]> git.pld-linux.org Git - packages/ruby-gnome2.git/commitdiff
- fixed ruby 1.9 encoding issues
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 31 Jul 2010 21:30:42 +0000 (21:30 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fixed ruby-rcairo header location problem

Changed files:
    ruby-gnome2-ruby19.patch -> 1.1
    ruby-gnome2.spec -> 1.51

ruby-gnome2-ruby19.patch [new file with mode: 0644]
ruby-gnome2.spec

diff --git a/ruby-gnome2-ruby19.patch b/ruby-gnome2-ruby19.patch
new file mode 100644 (file)
index 0000000..f7751b7
--- /dev/null
@@ -0,0 +1,11 @@
+--- ruby-gnome2-all-0.19.4/glib/src/lib/glib-mkenums.rb.orig   2010-07-31 23:18:04.303915210 +0200
++++ ruby-gnome2-all-0.19.4/glib/src/lib/glib-mkenums.rb        2010-07-31 23:28:22.970166438 +0200
+@@ -145,7 +145,7 @@
+       @targets = []
+       files.each do |path|
+         data = ""
+-        File.open(path) do |i|
++        File.open(path, "r:ASCII-8BIT") do |i|
+           data = i.read
+         end
+         @targets << [path, EnumDefinition.parse(data, g_type_prefix, options)]
index 2121061ca32fe0c9c326a82c82692c57b5b5397f..c7d91c696d74b4b61caba566baaf46640ce55832 100644 (file)
@@ -9,6 +9,7 @@ Source0:        http://dl.sourceforge.net/ruby-gnome2/%{name}-all-%{version}.tar.gz
 # Source0-md5: 40451e4173e2c8bcd5046aea7e499ef9
 Patch0:                %{name}-libxul.patch
 Patch1:                %{name}-libgnomeui.patch
+Patch2:                %{name}-ruby19.patch
 URL:           http://ruby-gnome2.sourceforge.jp/
 BuildRequires: GConf2-devel >= 2.0
 BuildRequires: glib2-devel >= 2.0
@@ -34,7 +35,7 @@ BuildRequires:        pkgconfig
 BuildRequires: poppler-glib-devel >= 0.5.2
 BuildRequires: rpmbuild(macros) >= 1.277
 BuildRequires: ruby-devel
-BuildRequires: ruby-rcairo
+BuildRequires: ruby-rcairo >= 1.8.1-3
 BuildRequires: sed >= 4.0
 BuildRequires: vte-devel >= 0.12.1
 BuildRequires: xulrunner-devel >= 1.9-5
@@ -89,6 +90,7 @@ Przykłady do Ruby-GNOME2.
 %setup -q -n %{name}-all-%{version}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 find . -name '*.rb' | xargs sed -i -e '1s,#.*local/bin/ruby,#!%{_bindir}/ruby,'
 
 %build
This page took 0.171751 seconds and 4 git commands to generate.