]> git.pld-linux.org Git - packages/ruby-gnome2.git/blob - ruby-gnome2.spec
e0fbb229b0409d0d5954d9aefc7e232fae5f67ad
[packages/ruby-gnome2.git] / ruby-gnome2.spec
1 # TODO
2 # - update to 2.2.0
3 # - gtk3 packages (or create separate ruby-gtk2, ruby-gtk3 packages besides ruby-gnome2?)
4 # - cairo-gobject
5 # - gobject-introspection
6 #        /usr/lib/ruby/2.0/cairo_gobject.so
7 #        /usr/lib/ruby/2.0/gobject_introspection.so
8 #        /usr/lib/ruby/2.0/rbgio2.h
9 #        /usr/lib/ruby/2.0/rbgio2conversions.h
10 #        /usr/share/ruby/2.0/cairo-gobject.rb
11 #        /usr/share/ruby/2.0/gobject-introspection
12 #        /usr/share/ruby/2.0/gobject-introspection.rb
13 #
14 # Conditional build:
15 %bcond_with     gtk3            # build GTK+3
16
17 Summary:        GNOME 2 libraries for Ruby
18 Summary(pl.UTF-8):      Biblioteki GNOME 2 dla języka Ruby
19 Name:           ruby-gnome2
20 Version:        1.1.9
21 Release:        1
22 License:        LGPL v2.1
23 Group:          Development/Languages
24 Source0:        http://downloads.sourceforge.net/ruby-gnome2/%{name}-all-%{version}.tar.gz
25 # Source0-md5:  852a528f8e58ca2729dada994c938be0
26 Patch0:         parse-error.patch
27 URL:            http://ruby-gnome2.sourceforge.jp/
28 BuildRequires:  atk-devel >= 1.0
29 BuildRequires:  cairo-devel >= 1.10.0
30 BuildRequires:  gdk-pixbuf2-devel >= 2
31 BuildRequires:  glib2-devel >= 1:2.16.0
32 BuildRequires:  goocanvas-devel >= 0.8
33 BuildRequires:  gstreamer0.10-devel >= 0.10.35
34 BuildRequires:  gstreamer0.10-plugins-base-devel >= 0.10.35
35 BuildRequires:  gtk+2-devel >= 2:2.12.0
36 BuildRequires:  gtksourceview2-devel
37 BuildRequires:  librsvg-devel >= 2.8
38 BuildRequires:  pango-devel >= 1:1.0
39 BuildRequires:  pkgconfig
40 BuildRequires:  poppler-glib-devel >= 0.8.0
41 BuildRequires:  rpmbuild(macros) >= 1.277
42 BuildRequires:  ruby-devel >= 1.8.5
43 BuildRequires:  ruby-pkg-config
44 BuildRequires:  ruby-rcairo-devel
45 BuildRequires:  ruby-rubygems
46 BuildRequires:  sed >= 4.0
47 BuildRequires:  vte0-devel >= 0.12.1
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 GNOME 2 libraries for Ruby.
52
53 %description -l pl.UTF-8
54 Biblioteki GNOME 2 dla języka Ruby.
55
56 %package -n ruby-glib2
57 Summary:        Ruby/Glib2, Ruby/GIO2 - Ruby bindings of GLib 2.x
58 Summary(pl.UTF-8):      Ruby/Glib2, Ruby/GIO2 - wiązania języka Ruby do bibliotek GLib 2.x
59 Group:          Development/Languages
60 Requires:       glib2 >= 1:2.16.0
61 Requires:       ruby >= 1.8.5
62 Obsoletes:      ruby-gnome2
63
64 %description -n ruby-glib2
65 Ruby/Glib2 is a Ruby binding of GLib 2.x. Ruby/GIO2 is a Ruby binding
66 of gio 2.x.
67
68 %description -n ruby-glib2 -l pl.UTF-8
69 Ruby/Glib2 to wiązanie języka Ruby do biblioteki GLib 2.x. Ruby/GIO2
70 to wiązanie języka Ruby do biblioteki gio 2.x.
71
72 %package -n ruby-glib2-devel
73 Summary:        Header files for Ruby/GLib2 and Ruby/GIO2 libraries
74 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Ruby/GLib2 i Ruby/GIO2
75 Group:          Development/Libraries
76 Requires:       glib2-devel >= 1:2.16.0
77 Requires:       ruby-devel >= 1.8.5
78 Requires:       ruby-glib2 = %{version}-%{release}
79 Obsoletes:      ruby-gnome2-devel
80
81 %description -n ruby-glib2-devel
82 Header files for Ruby/GLib2 and Ruby/GIO2 libraries.
83
84 %description -n ruby-glib2-devel -l pl.UTF-8
85 Pliki nagłówkowe bibliotek Ruby/GLib2 i Ruby/GIO2.
86
87 %package -n ruby-atk
88 Summary:        Ruby/ATK - Ruby binding of ATK
89 Summary(pl.UTF-8):      Ruby/ATK - wiązanie języka Ruby do biblioteki ATK
90 Group:          Development/Languages
91 Requires:       atk >= 1.0
92 Requires:       ruby-glib2 = %{version}-%{release}
93
94 %description -n ruby-atk
95 Ruby/ATK is a Ruby binding of ATK.
96
97 %description -n ruby-atk -l pl.UTF-8
98 Ruby/ATK to wiązanie języka Ruby do biblioteki ATK.
99
100 %package -n ruby-atk-devel
101 Summary:        Header files for Ruby/ATK library
102 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/ATK
103 Group:          Development/Libraries
104 Requires:       atk-devel >= 1.0
105 Requires:       ruby-atk = %{version}-%{release}
106 Requires:       ruby-glib2-devel = %{version}-%{release}
107
108 %description -n ruby-atk-devel
109 Header files for Ruby/ATK library.
110
111 %description -n ruby-atk-devel -l pl.UTF-8
112 Pliki nagłówkowe biblioteki Ruby/ATK.
113
114 %package -n ruby-pango
115 Summary:        Ruby/Pango - Ruby binding of pango 1.x
116 Summary(pl.UTF-8):      Ruby/Pango - wiązanie języka Ruby do biblioteki pango 1.x
117 Group:          Development/Languages
118 Requires:       cairo >= 1.10.0
119 Requires:       pango >= 1:1.0
120 Requires:       ruby-glib2 = %{version}-%{release}
121 Requires:       ruby-rcairo
122
123 %description -n ruby-pango
124 Ruby/Pango is a Ruby binding of pango 1.x.
125
126 %description -n ruby-pango -l pl.UTF-8
127 Ruby/Pango to wiązanie języka Ruby do biblioteki pango 1.x.
128
129 %package -n ruby-pango-devel
130 Summary:        Header files for Ruby/Pango library
131 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/Pango
132 Group:          Development/Libraries
133 Requires:       cairo-devel >= 1.10.0
134 Requires:       pango-devel >= 1.0
135 Requires:       ruby-glib2-devel = %{version}-%{release}
136 Requires:       ruby-pango = %{version}-%{release}
137
138 %description -n ruby-pango-devel
139 Header files for Ruby/Pango library.
140
141 %description -n ruby-pango-devel -l pl.UTF-8
142 Pliki nagłówkowe biblioteki Ruby/Pango.
143
144 %package -n ruby-gdk_pixbuf2
145 Summary:        Ruby/GdkPixbuf2 - Ruby binding of GdkPixbuf 2.x
146 Summary(pl.UTF-8):      Ruby/GdkPixbuf2 - wiązanie języka Ruby do biblioteki GdkPixbuf 2.x
147 Group:          Development/Languages
148 Requires:       gdk-pixbuf2 >= 2
149 Requires:       ruby-glib2 = %{version}-%{release}
150
151 %description -n ruby-gdk_pixbuf2
152 Ruby/GdkPixbuf2 is a Ruby binding of GdkPixbuf 2.x.
153
154 %description -n ruby-gdk_pixbuf2 -l pl.UTF-8
155 Ruby/GdkPixbuf2 to wiązanie języka Ruby do biblioteki GdkPixbuf 2.x.
156
157 %package -n ruby-gdk_pixbuf2-devel
158 Summary:        Header files for Ruby/GdkPixbuf2 library
159 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GdkPixbuf2
160 Group:          Development/Libraries
161 Requires:       gdk-pixbuf2-devel >= 2
162 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
163 Requires:       ruby-glib2-devel = %{version}-%{release}
164
165 %description -n ruby-gdk_pixbuf2-devel
166 Header files for Ruby/GdkPixbuf2 library.
167
168 %description -n ruby-gdk_pixbuf2-devel -l pl.UTF-8
169 Pliki nagłówkowe biblioteki Ruby/GdkPixbuf2.
170
171 %package -n ruby-gtk2
172 Summary:        Ruby/GTK2 - Ruby binding of GTK+ 2.x
173 Summary(pl.UTF-8):      Ruby/GTK2 - wiązanie języka Ruby do biblioteki GTK+ 2.x
174 Group:          Development/Languages
175 Requires:       gtk+2 >= 2:2.12.0
176 Requires:       ruby-atk = %{version}-%{release}
177 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
178 Requires:       ruby-glib2 = %{version}-%{release}
179 Requires:       ruby-pango = %{version}-%{release}
180
181 %description -n ruby-gtk2
182 Ruby/GTK2 is a Ruby binding of GTK+ 2.x.
183
184 %description -n ruby-gtk2 -l pl.UTF-8
185 Ruby/GTK2 to wiązanie języka Ruby do biblioteki GTK+ 2.x.
186
187 %package -n ruby-gtk2-devel
188 Summary:        Header files for Ruby/GTK2 library
189 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GTK2
190 Group:          Development/Libraries
191 Requires:       gtk+2-devel >= 2:2.12.0
192 Requires:       ruby-atk-devel = %{version}-%{release}
193 Requires:       ruby-gdk_pixbuf2-devel = %{version}-%{release}
194 Requires:       ruby-glib2-devel = %{version}-%{release}
195 Requires:       ruby-gtk2 = %{version}-%{release}
196 Requires:       ruby-pango-devel = %{version}-%{release}
197
198 %description -n ruby-gtk2-devel
199 Header files for Ruby/GTK2 library.
200
201 %description -n ruby-gtk2-devel -l pl.UTF-8
202 Pliki nagłówkowe biblioteki Ruby/GTK2.
203
204 %package -n ruby-goocanvas
205 Summary:        Ruby/GooCanvas - Ruby binding of GooCanvas
206 Summary(pl.UTF-8):      Ruby/GooCanvas - wiązanie języka Ruby do biblioteki GooCanvas
207 Group:          Development/Languages
208 Requires:       goocanvas >= 0.8
209 Requires:       ruby-gtk2 = %{version}-%{release}
210 Requires:       ruby-rcairo
211
212 %description -n ruby-goocanvas
213 Ruby/GooCanvas is a Ruby binding of GooCanvas.
214
215 %description -n ruby-goocanvas -l pl.UTF-8
216 Ruby/GooCanvas to wiązanie języka Ruby do biblioteki GooCanvas.
217
218 %package -n ruby-goocanvas-devel
219 Summary:        Header files for Ruby/GooCanvas library
220 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GooCanvas
221 Group:          Development/Libraries
222 Requires:       goocanvas-devel >= 0.8
223 Requires:       ruby-gtk2-devel = %{version}-%{release}
224 Requires:       ruby-rcairo-devel
225
226 %description -n ruby-goocanvas-devel
227 Header files for Ruby/GooCanvas library.
228
229 %description -n ruby-goocanvas-devel -l pl.UTF-8
230 Pliki nagłówkowe biblioteki Ruby/GooCanvas.
231
232 %package -n ruby-gstreamer
233 Summary:        Ruby/GStreamer - Ruby binding of GStreamer
234 Summary(pl.UTF-8):      Ruby/GStreamer - wiązanie języka Ruby do biblioteki GStreamer
235 Group:          Development/Languages
236 Requires:       gstreamer0.10 >= 0.10.35
237 Requires:       gstreamer0.10-plugins-base >= 0.10.35
238 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
239 Requires:       ruby-glib2 = %{version}-%{release}
240 Requires:       ruby-pango = %{version}-%{release}
241
242 %description -n ruby-gstreamer
243 Ruby/GStreamer is a Ruby binding of GStreamer.
244
245 %description -n ruby-gstreamer -l pl.UTF-8
246 Ruby/GStreamer to wiązanie języka Ruby do biblioteki GStreamer.
247
248 %package -n ruby-gstreamer-devel
249 Summary:        Header files for Ruby/GStreamer library
250 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GStreamer
251 Group:          Development/Libraries
252 Requires:       gstreamer0.10-devel >= 0.10.35
253 Requires:       gstreamer0.10-plugins-base-devel >= 0.10.35
254 Requires:       ruby-gdk_pixbuf2-devel = %{version}-%{release}
255 Requires:       ruby-glib2-devel = %{version}-%{release}
256 Requires:       ruby-pango-devel = %{version}-%{release}
257
258 %description -n ruby-gstreamer-devel
259 Header files for Ruby/GStreamer library.
260
261 %description -n ruby-gstreamer-devel -l pl.UTF-8
262 Pliki nagłówkowe biblioteki Ruby/GStreamer.
263
264 %package -n ruby-gtksourceview2
265 Summary:        Ruby/GtkSourceView2 - Ruby binding of gtksourceview 2.x
266 Summary(pl.UTF-8):      Ruby/GtkSourceView2 - wiązanie języka Ruby do biblioteki gtksourceview 2.x
267 Group:          Development/Languages
268 Requires:       gtksourceview2 >= 2.0.0
269 Requires:       ruby-gtk2 = %{version}-%{release}
270
271 %description -n ruby-gtksourceview2
272 Ruby/GtkSourceView2 is a Ruby binding of gtksourceview 2.x.
273
274 %description -n ruby-gtksourceview2 -l pl.UTF-8
275 Ruby/GtkSourceView2 to wiązanie języka Ruby do biblioteki
276 gtksourceview 2.x.
277
278 %package -n ruby-gtksourceview2-devel
279 Summary:        Header files for Ruby/GtkSourceView2 library
280 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GtkSourceView2
281 Group:          Development/Libraries
282 Requires:       gtksourceview2-devel >= 2.0.0
283 Requires:       ruby-gtk2-devel = %{version}-%{release}
284
285 %description -n ruby-gtksourceview2-devel
286 Header files for Ruby/GtkSourceView2 library.
287
288 %description -n ruby-gtksourceview2-devel -l pl.UTF-8
289 Pliki nagłówkowe biblioteki Ruby/GtkSourceView2.
290
291 %package -n ruby-poppler
292 Summary:        Ruby/Poppler - Ruby binding of poppler-glib
293 Summary(pl.UTF-8):      Ruby/Poppler - wiązanie języka Ruby do biblioteki poppler-glib
294 Group:          Development/Languages
295 Requires:       poppler-glib >= 0.8.0
296 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
297 Requires:       ruby-glib2 = %{version}-%{release}
298 Requires:       ruby-gtk2 = %{version}-%{release}
299
300 %description -n ruby-poppler
301 Ruby/Poppler is a Ruby binding of poppler-glib.
302
303 %description -n ruby-poppler -l pl.UTF-8
304 Ruby/Poppler to wiązanie języka Ruby do biblioteki poppler-glib.
305
306 %package -n ruby-poppler-devel
307 Summary:        Header files for Ruby/Poppler library
308 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/Poppler
309 Group:          Development/Libraries
310 Requires:       poppler-glib-devel >= 0.8.0
311 Requires:       ruby-gdk_pixbuf2-devel = %{version}-%{release}
312 Requires:       ruby-glib2-devel = %{version}-%{release}
313 Requires:       ruby-gtk2-devel = %{version}-%{release}
314
315 %description -n ruby-poppler-devel
316 Header files for Ruby/Poppler library.
317
318 %description -n ruby-poppler-devel -l pl.UTF-8
319 Pliki nagłówkowe biblioteki Ruby/Poppler.
320
321 %package -n ruby-rsvg2
322 Summary:        Ruby/RSVG - Ruby binding of librsvg
323 Summary(pl.UTF-8):      Ruby/RSVG - wiązanie języka Ruby do biblioteki librsvg
324 Group:          Development/Languages
325 Requires:       librsvg >= 2.8
326 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
327 Requires:       ruby-glib2 = %{version}-%{release}
328 Requires:       ruby-rcairo
329
330 %description -n ruby-rsvg2
331 Ruby/RSVG is a Ruby binding of librsvg.
332
333 %description -n ruby-rsvg2 -l pl.UTF-8
334 Ruby/RSVG to wiązanie języka Ruby do biblioteki librsvg.
335
336 %package -n ruby-rsvg2-devel
337 Summary:        Header files for Ruby/RSVG library
338 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/RSVG
339 Group:          Development/Libraries
340 Requires:       librsvg-devel >= 2.8
341 Requires:       ruby-gdk_pixbuf2-devel = %{version}-%{release}
342 Requires:       ruby-glib2-devel = %{version}-%{release}
343
344 %description -n ruby-rsvg2-devel
345 Header files for Ruby/RSVG library.
346
347 %description -n ruby-rsvg2-devel -l pl.UTF-8
348 Pliki nagłówkowe biblioteki Ruby/RSVG.
349
350 %package -n ruby-vte
351 Summary:        Ruby/VTE - Ruby binding of VTE
352 Summary(pl.UTF-8):      Ruby/VTE - wiązanie języka Ruby do biblioteki VTE
353 Group:          Development/Languages
354 Requires:       ruby-gtk2 = %{version}-%{release}
355 Requires:       vte0 >= 0.12.1
356
357 %description -n ruby-vte
358 Ruby/VTE is a Ruby binding of VTE.
359
360 %description -n ruby-vte -l pl.UTF-8
361 Ruby/VTE to wiązanie języka Ruby do biblioteki VTE.
362
363 %package -n ruby-vte-devel
364 Summary:        Header files for Ruby/VTE library
365 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/VTE
366 Group:          Development/Libraries
367 Requires:       ruby-gtk2-devel = %{version}-%{release}
368 Requires:       vte0-devel >= 0.12.1
369
370 %description -n ruby-vte-devel
371 Header files for Ruby/VTE library.
372
373 %description -n ruby-vte-devel -l pl.UTF-8
374 Pliki nagłówkowe biblioteki Ruby/VTE.
375
376 %package doc-ri
377 Summary:        Ruby-GNOME2 ri documentation
378 Summary(pl.UTF-8):      Dokumentacja dla Ruby-GNOME2 w formacie ri
379 Group:          Documentation
380 Requires:       ruby
381
382 %description doc-ri
383 Ruby-GNOME2 ri documentation.
384
385 %description doc-ri -l pl.UTF-8
386 Dokumentacja dla Ruby-GNOME2 w formacie ri.
387
388 %package doc-html
389 Summary:        Ruby-GNOME2 HTML documentation
390 Summary(pl.UTF-8):      Dokumentacja dla Ruby-GNOME2 w formacie HTML
391 Group:          Documentation
392
393 %description doc-html
394 Ruby-GNOME2 HTML documentation.
395
396 %description doc-html -l pl.UTF-8
397 Dokumentacja dla Ruby-GNOME2 w formacie HTML.
398
399 %package examples
400 Summary:        Ruby-GNOME2 examples
401 Summary(pl.UTF-8):      Przykłady do Ruby-GNOME2
402 Group:          Development/Libraries
403
404 %description examples
405 Ruby-GNOME2 examples.
406
407 %description examples -l pl.UTF-8
408 Przykłady do Ruby-GNOME2.
409
410 %prep
411 %setup -q -n %{name}-all-%{version}
412 find . -name '*.rb' | xargs sed -i -e '1s,#.*local/bin/ruby,#!%{_bindir}/ruby,'
413 %patch0 -p1
414
415 cp -p glib2/README README.glib2
416 cp -p glib2/TODO TODO.glib2
417 cp -p gio2/README README.gio2
418 cp -p gio2/TODO TODO.gio2
419
420 %build
421 # echo */extconf.rb | xargs -l1 dirname
422
423 comps="
424         atk
425         cairo-gobject
426         gdk_pixbuf2
427         gio2
428         glib2
429         gobject-introspection
430         goocanvas
431         gstreamer
432         gtk2
433         gtksourceview2
434         pango
435         poppler
436         rsvg2
437         vte
438 %if %{with gtk3}
439         gdk3
440         gtk3
441         gtksourceview3
442         vte3
443 %endif
444 "
445
446 ruby extconf.rb \
447         --vendor \
448         --enable-glib-experimental \
449         $comps
450 %{__make}
451
452 rdoc -o rdoc
453 rdoc --ri -o ri
454
455 %install
456 rm -rf $RPM_BUILD_ROOT
457 install -d $RPM_BUILD_ROOT{%{ruby_archdir},%{ruby_rubylibdir},%{ruby_ridir}} \
458         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
459
460 %{__make} install \
461         DESTDIR=$RPM_BUILD_ROOT \
462         RUBYLIBDIR=$RPM_BUILD_ROOT%{ruby_rubylibdir} \
463         sitearchdir=$RPM_BUILD_ROOT%{ruby_archdir} \
464         pkgconfigdir=$RPM_BUILD_ROOT%{_pkgconfigdir} \
465         RUBYARCHDIR=$RPM_BUILD_ROOT%{ruby_archdir}
466
467 cp -a gdk_pixbuf2/sample \
468         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/gdk_pixbuf2
469
470 cp -a glib2/sample \
471         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/glib2
472
473 cp -a goocanvas/sample \
474         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/goocanvas
475
476 cp -a gstreamer/sample \
477         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/gstreamer
478
479 cp -a gtk2/sample \
480         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/gtk2
481
482 cp -a gtksourceview2/sample \
483         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/gtksourceview2
484
485 cp -a pango/sample \
486         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/pango
487
488 cp -a poppler/sample \
489         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/poppler
490
491 cp -a rsvg2/sample \
492         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/rsvg2
493
494 cp -a vte/sample \
495         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/vte
496
497 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
498 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/{Object,TC_*,Test*}
499 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/{cache.ri,created.rid}
500
501 %clean
502 rm -rf $RPM_BUILD_ROOT
503
504 %files -n ruby-glib2
505 %defattr(644,root,root,755)
506 %doc AUTHORS NEWS README README.glib2 TODO.glib2 README.gio2 TODO.gio2
507 %attr(755,root,root) %{ruby_archdir}/gio2.so
508 %attr(755,root,root) %{ruby_archdir}/glib2.so
509 %{ruby_rubylibdir}/gio2.rb
510 %{ruby_rubylibdir}/glib-mkenums.rb
511 %{ruby_rubylibdir}/glib2.rb
512 %{ruby_rubylibdir}/gnome2-raketask.rb
513 # these files are expected to exist not only on Win32
514 %{ruby_rubylibdir}/gnome2-win32-binary-build-task.rb
515 %{ruby_rubylibdir}/gnome2-win32-binary-download-task.rb
516 %{ruby_rubylibdir}/mkmf-gnome2.rb
517 %{ruby_rubylibdir}/gio2
518 %{ruby_rubylibdir}/glib2
519
520 %files -n ruby-glib2-devel
521 %defattr(644,root,root,755)
522 %{ruby_archdir}/glib-enum-types.h
523 %{ruby_archdir}/rbgcompat.h
524 %{ruby_archdir}/rbglib.h
525 %{ruby_archdir}/rbglib2conversions.h
526 %{ruby_archdir}/rbglibdeprecated.h
527 %{ruby_archdir}/rbgobject.h
528 %{ruby_archdir}/rbgutil.h
529 %{ruby_archdir}/rbgutil_list.h
530 %{ruby_archdir}/rbgutildeprecated.h
531 %{_pkgconfigdir}/ruby-gio2.pc
532 %{_pkgconfigdir}/ruby-glib2.pc
533
534 %files -n ruby-atk
535 %defattr(644,root,root,755)
536 %doc atk/README
537 %attr(755,root,root) %{ruby_archdir}/atk.so
538 %{ruby_rubylibdir}/atk.rb
539
540 %files -n ruby-atk-devel
541 %defattr(644,root,root,755)
542 %{ruby_archdir}/rbatk.h
543 %{ruby_archdir}/rbatkversion.h
544 %{_pkgconfigdir}/ruby-atk.pc
545
546 %files -n ruby-pango
547 %defattr(644,root,root,755)
548 %doc pango/README
549 %attr(755,root,root) %{ruby_archdir}/pango.so
550 %{ruby_rubylibdir}/pango.rb
551
552 %files -n ruby-pango-devel
553 %defattr(644,root,root,755)
554 %{ruby_archdir}/rbpango.h
555 %{ruby_archdir}/rbpangoconversions.h
556 %{ruby_archdir}/rbpangoversion.h
557 %{_pkgconfigdir}/ruby-pango.pc
558
559 %files -n ruby-gdk_pixbuf2
560 %defattr(644,root,root,755)
561 %doc gdk_pixbuf2/README
562 %attr(755,root,root) %{ruby_archdir}/gdk_pixbuf2.so
563 %{ruby_rubylibdir}/gdk_pixbuf2.rb
564
565 %files -n ruby-gdk_pixbuf2-devel
566 %defattr(644,root,root,755)
567 %{ruby_archdir}/rbgdk-pixbuf.h
568 %{ruby_archdir}/rbgdk-pixbuf2conversions.h
569 %{_pkgconfigdir}/ruby-gdk-pixbuf2.pc
570
571 %files -n ruby-gtk2
572 %defattr(644,root,root,755)
573 %doc gtk2/README
574 %attr(755,root,root) %{ruby_archdir}/gtk2.so
575 %{ruby_rubylibdir}/gtk2.rb
576 %{ruby_rubylibdir}/gtk2
577
578 %files -n ruby-gtk2-devel
579 %defattr(644,root,root,755)
580 %{ruby_archdir}/rbgdk.h
581 %{ruby_archdir}/rbgdkconversions.h
582 %{ruby_archdir}/rbgtk.h
583 %{ruby_archdir}/rbgtkconversions.h
584 %{ruby_archdir}/rbgtkmacros.h
585 %{_pkgconfigdir}/ruby-gtk2.pc
586
587 %files -n ruby-goocanvas
588 %defattr(644,root,root,755)
589 %doc goocanvas/README
590 %attr(755,root,root) %{ruby_archdir}/goocanvas.so
591 %{ruby_rubylibdir}/goocanvas.rb
592
593 %files -n ruby-goocanvas-devel
594 %defattr(644,root,root,755)
595 %{_pkgconfigdir}/ruby-goocanvas.pc
596
597 %files -n ruby-gstreamer
598 %defattr(644,root,root,755)
599 %doc gstreamer/README
600 %attr(755,root,root) %{ruby_archdir}/gstreamer.so
601 %{ruby_rubylibdir}/gst.rb
602
603 %files -n ruby-gstreamer-devel
604 %defattr(644,root,root,755)
605 %{_pkgconfigdir}/ruby-gstreamer.pc
606
607 %files -n ruby-gtksourceview2
608 %defattr(644,root,root,755)
609 %doc gtksourceview2/README
610 %attr(755,root,root) %{ruby_archdir}/gtksourceview2.so
611 %{ruby_rubylibdir}/gtksourceview2.rb
612
613 %files -n ruby-gtksourceview2-devel
614 %defattr(644,root,root,755)
615 %{_pkgconfigdir}/ruby-gtksourceview2.pc
616
617 %files -n ruby-poppler
618 %defattr(644,root,root,755)
619 %doc poppler/README
620 %attr(755,root,root) %{ruby_archdir}/poppler.so
621 %{ruby_rubylibdir}/poppler.rb
622
623 %files -n ruby-poppler-devel
624 %defattr(644,root,root,755)
625 %{_pkgconfigdir}/ruby-poppler.pc
626
627 %files -n ruby-rsvg2
628 %defattr(644,root,root,755)
629 %doc rsvg2/README
630 %attr(755,root,root) %{ruby_archdir}/rsvg2.so
631 %{ruby_rubylibdir}/rsvg2.rb
632
633 %files -n ruby-rsvg2-devel
634 %defattr(644,root,root,755)
635 %{_pkgconfigdir}/ruby-rsvg2.pc
636
637 %files -n ruby-vte
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{ruby_archdir}/vte.so
640 %{ruby_rubylibdir}/vte.rb
641 %{ruby_rubylibdir}/vte
642
643 %files -n ruby-vte-devel
644 %defattr(644,root,root,755)
645 %{_pkgconfigdir}/ruby-vte.pc
646
647 %files doc-html
648 %defattr(644,root,root,755)
649 %doc rdoc/*
650
651 %files doc-ri
652 %defattr(644,root,root,755)
653 %{ruby_ridir}/A
654 %{ruby_ridir}/AlphaDemo
655 %{ruby_ridir}/AssistantRunner
656 %{ruby_ridir}/Atk
657 %{ruby_ridir}/ButtonBoxSample
658 %{ruby_ridir}/ButtonSample
659 %{ruby_ridir}/Cairo
660 %{ruby_ridir}/Canvas
661 %{ruby_ridir}/CanvasSampleArrowhead
662 %{ruby_ridir}/CanvasSampleFifteen
663 %{ruby_ridir}/CheckButtonSample
664 %{ruby_ridir}/ColorSelectionSample
665 %{ruby_ridir}/Demo
666 %{ruby_ridir}/DestWindow
667 %{ruby_ridir}/DialogSample
668 %{ruby_ridir}/DraggableWidget
669 %{ruby_ridir}/EntrySample
670 %{ruby_ridir}/FileSelectionSample
671 %{ruby_ridir}/FontSelectionSample
672 %{ruby_ridir}/GLib
673 %{ruby_ridir}/GLibTestUtils
674 %{ruby_ridir}/GNOME2Package
675 %{ruby_ridir}/GNOME2Win32BinaryBuildTask
676 %{ruby_ridir}/GNOME2Win32BinaryDownloadTask
677 %{ruby_ridir}/GammaCurveSample
678 %{ruby_ridir}/Gdk
679 %{ruby_ridir}/Gesture
680 %{ruby_ridir}/GestureProcessor
681 %{ruby_ridir}/GesturedWidget
682 %{ruby_ridir}/Gio
683 %{ruby_ridir}/Goo
684 %{ruby_ridir}/GooCanvasSample
685 %{ruby_ridir}/Gst
686 %{ruby_ridir}/GstTestUtils
687 %{ruby_ridir}/Gtk
688 %{ruby_ridir}/GtkTestUtils
689 %{ruby_ridir}/Inspector
690 %{ruby_ridir}/Layout
691 %{ruby_ridir}/LayoutSample
692 %{ruby_ridir}/MediaInfo
693 %{ruby_ridir}/MediaInfoStream
694 %{ruby_ridir}/MediaInfoTrack
695 %{ruby_ridir}/MenuSample
696 %{ruby_ridir}/MultiTerm
697 %{ruby_ridir}/MyButton
698 %{ruby_ridir}/MyButton2
699 %{ruby_ridir}/MyGtkPlug
700 %{ruby_ridir}/MyGtkSocket
701 %{ruby_ridir}/NotebookSample
702 %{ruby_ridir}/Pager
703 %{ruby_ridir}/Pango
704 %{ruby_ridir}/PangoTestUtils
705 %{ruby_ridir}/PixmapSample
706 %{ruby_ridir}/Pong
707 %{ruby_ridir}/Poppler
708 %{ruby_ridir}/PopplerTestUtils
709 %{ruby_ridir}/Print
710 %{ruby_ridir}/ProgressBarSample
711 %{ruby_ridir}/RSVG
712 %{ruby_ridir}/RadioButtonSample
713 %{ruby_ridir}/RangeSample
714 %{ruby_ridir}/ReparentSample
715 %{ruby_ridir}/RulerSample
716 %{ruby_ridir}/Sample
717 %{ruby_ridir}/SampleClass
718 %{ruby_ridir}/SampleDialog
719 %{ruby_ridir}/SampleWindow
720 %{ruby_ridir}/SavedPositionSample
721 %{ruby_ridir}/ScrolledWindowSample
722 %{ruby_ridir}/ShapeSampleBasic
723 %{ruby_ridir}/ShapeSampleModeller
724 %{ruby_ridir}/ShapeSampleRings
725 %{ruby_ridir}/ShapeSampleSheets
726 %{ruby_ridir}/ShapesSample
727 %{ruby_ridir}/SpinButtonSample
728 %{ruby_ridir}/SrcWindow
729 %{ruby_ridir}/StatusIconSample
730 %{ruby_ridir}/StatusbarSample
731 %{ruby_ridir}/ToggleButtonSample
732 %{ruby_ridir}/ToolbarSample
733 %{ruby_ridir}/TooltipsSample
734 %{ruby_ridir}/Vte
735 %{ruby_ridir}/WMHintsSample
736 %{ruby_ridir}/Window
737
738 %files examples
739 %defattr(644,root,root,755)
740 %{_examplesdir}/%{name}-%{version}
This page took 0.264057 seconds and 3 git commands to generate.