]> git.pld-linux.org Git - packages/ruby-gnome2.git/blob - ruby-gnome2.spec
d92411b748da408e7b40a02ca4938ee0efebe689
[packages/ruby-gnome2.git] / ruby-gnome2.spec
1 # TODO
2 # - actually build clutter, clutter-gtk, clutter-gstreamer, webkit-gtk, webkit-gtk2 modules
3 #
4 # Conditional build:
5 %bcond_without  gtk3            # GTK+ 3.x based packages too
6
7 Summary:        GNOME 2 libraries for Ruby
8 Summary(pl.UTF-8):      Biblioteki GNOME 2 dla języka Ruby
9 Name:           ruby-gnome2
10 Version:        2.2.0
11 Release:        1
12 License:        LGPL v2.1
13 Group:          Development/Languages
14 Source0:        http://downloads.sourceforge.net/ruby-gnome2/%{name}-all-%{version}.tar.gz
15 # Source0-md5:  5addc6fde34061387ab7b5c16a0075e5
16 URL:            http://ruby-gnome2.sourceforge.jp/
17 BuildRequires:  atk-devel >= 1:1.12.0
18 BuildRequires:  cairo-devel >= 1.10.0
19 BuildRequires:  cairo-gobject-devel >= 1.12.10
20 #BuildRequires: clutter-devel >= 1.12.0
21 #%{?with_gtk3:BuildRequires:    clutter-gtk-devel >= 1.2.0}
22 BuildRequires:  gdk-pixbuf2-devel >= 2
23 BuildRequires:  glib2-devel >= 1:2.16.0
24 BuildRequires:  gobject-introspection-devel >= 1.35.4
25 BuildRequires:  goocanvas-devel >= 0.8
26 BuildRequires:  gstreamer0.10-devel >= 0.10.35
27 BuildRequires:  gstreamer0.10-plugins-base-devel >= 0.10.35
28 BuildRequires:  gtk+2-devel >= 2:2.12.0
29 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.4.2}
30 BuildRequires:  gtksourceview2-devel >= 2
31 %{?with_gtk3:BuildRequires:     gtksourceview3-devel >= 3.4.2}
32 BuildRequires:  librsvg-devel >= 2.8
33 BuildRequires:  pango-devel >= 1:1.14.0
34 BuildRequires:  pkgconfig
35 BuildRequires:  poppler-glib-devel >= 0.12.0
36 BuildRequires:  rpmbuild(macros) >= 1.277
37 BuildRequires:  ruby-devel >= 1.9
38 %{?with_gtk3:BuildRequires:     ruby-devel >= 1.9.2}
39 BuildRequires:  ruby-pkg-config
40 BuildRequires:  ruby-rcairo-devel
41 BuildRequires:  ruby-rubygems
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  vte0-devel >= 0.12.1
44 %{?with_gtk3:BuildRequires:     vte-devel >= 0.32.2}
45 #BuildRequires: gtk-webkit-devel >= 1.8.1
46 #%{?with_gtk3:BuildRequires:    gtk-webkit3-devel >= 1.8.1}
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 GNOME 2 libraries for Ruby.
51
52 %description -l pl.UTF-8
53 Biblioteki GNOME 2 dla języka Ruby.
54
55 %package -n ruby-glib2
56 Summary:        Ruby/Glib2 - Ruby binding of GLib 2.x
57 Summary(pl.UTF-8):      Ruby/Glib2 - wiązanie języka Ruby do biblioteki GLib 2.x
58 Group:          Development/Languages
59 Requires:       glib2 >= 1:2.16.0
60 Requires:       ruby >= 1.9
61 Obsoletes:      ruby-gnome2
62
63 %description -n ruby-glib2
64 Ruby/Glib2 is a Ruby binding of GLib 2.x.
65
66 %description -n ruby-glib2 -l pl.UTF-8
67 Ruby/Glib2 to wiązanie języka Ruby do biblioteki GLib 2.x.
68
69 %package -n ruby-glib2-devel
70 Summary:        Header files for Ruby/GLib2 library
71 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GLib2
72 Group:          Development/Libraries
73 Requires:       glib2-devel >= 1:2.16.0
74 Requires:       ruby-devel >= 1.9
75 Requires:       ruby-glib2 = %{version}-%{release}
76 Obsoletes:      ruby-gnome2-devel
77
78 %description -n ruby-glib2-devel
79 Header files for Ruby/GLib2 library.
80
81 %description -n ruby-glib2-devel -l pl.UTF-8
82 Pliki nagłówkowe biblioteki Ruby/GLib2.
83
84 %package -n ruby-gobject-introspection
85 Summary:        Ruby/GObjectIntrospection - Ruby binding of GObject Introspection
86 Summary(pl.UTF-8):      Ruby/GObjectIntrospection - wiązania języka Ruby do biblioteki GObject Introspection
87 Group:          Development/Languages
88 Requires:       gobject-introspection >= 1.35.4
89 Requires:       ruby-glib2 = %{version}-%{release}
90
91 %description -n ruby-gobject-introspection
92 Ruby/GObjectIntrospection is a Ruby binding of GObject Introspection.
93
94 %description -n ruby-gobject-introspection -l pl.UTF-8
95 Ruby/GObjectIntrospection to wiązanie języka Ruby do biblioteki
96 GObject Introspection.
97
98 %package -n ruby-gobject-introspection-devel
99 Summary:        Header files for Ruby/GObjectIntrospection library
100 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GObjectIntrospection
101 Group:          Development/Languages
102 Requires:       ruby-glib2-devel = %{version}-%{release}
103 Requires:       ruby-gobject-introspection = %{version}-%{release}
104
105 %description -n ruby-gobject-introspection-devel
106 Header files for Ruby/GObjectIntrospection library.
107
108 %description -n ruby-gobject-introspection-devel -l pl.UTF-8
109 Pliki nagłówkowe biblioteki Ruby/GObjectIntrospection.
110
111 %package -n ruby-gio2
112 Summary:        Ruby/GIO2 - Ruby binding of GIO 2.x library
113 Summary(pl.UTF-8):      Ruby/GIO2 - wiązanie języka Ruby do biblioteki GIO 2.x
114 Group:          Development/Languages
115 Requires:       glib2 >= 1:2.16.0
116 Requires:       ruby-gobject-introspection = %{version}-%{release}
117
118 %description -n ruby-gio2
119 Ruby/GIO2 is a Ruby binding of GIO 2.x library.
120
121 %description -n ruby-gio2 -l pl.UTF-8
122 Ruby/GIO2 to wiązanie języka Ruby do biblioteki GIO 2.x.
123
124 %package -n ruby-atk
125 Summary:        Ruby/ATK - Ruby binding of ATK
126 Summary(pl.UTF-8):      Ruby/ATK - wiązanie języka Ruby do biblioteki ATK
127 Group:          Development/Languages
128 Requires:       atk >= 1:1.12.0
129 Requires:       ruby-glib2 = %{version}-%{release}
130
131 %description -n ruby-atk
132 Ruby/ATK is a Ruby binding of ATK.
133
134 %description -n ruby-atk -l pl.UTF-8
135 Ruby/ATK to wiązanie języka Ruby do biblioteki ATK.
136
137 %package -n ruby-atk-devel
138 Summary:        Header files for Ruby/ATK library
139 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/ATK
140 Group:          Development/Libraries
141 Requires:       atk-devel >= 1:1.12.0
142 Requires:       ruby-atk = %{version}-%{release}
143 Requires:       ruby-glib2-devel = %{version}-%{release}
144
145 %description -n ruby-atk-devel
146 Header files for Ruby/ATK library.
147
148 %description -n ruby-atk-devel -l pl.UTF-8
149 Pliki nagłówkowe biblioteki Ruby/ATK.
150
151 %package -n ruby-cairo-gobject
152 Summary:        Ruby/CairoGObject - Ruby binding of cairo-gobject library
153 Summary(pl.UTF-8):      Ruby/CairoGObject - wiązania języka Ruby do biblioteki cairo-gobject
154 Group:          Development/Languages
155 Requires:       cairo-gobject >= 1.12.10
156 Requires:       ruby-glib2 = %{version}-%{release}
157 Requires:       ruby-rcairo
158
159 %description -n ruby-cairo-gobject
160 Ruby/CairoGObject is a Ruby binding of cairo-gobject library.
161
162 %description -n ruby-cairo-gobject -l pl.UTF-8
163 Ruby/CairoGObject to wiązanie języka Ruby do biblioteki cairo-gobject.
164
165 %package -n ruby-pango
166 Summary:        Ruby/Pango - Ruby binding of pango 1.x
167 Summary(pl.UTF-8):      Ruby/Pango - wiązanie języka Ruby do biblioteki pango 1.x
168 Group:          Development/Languages
169 Requires:       cairo >= 1.10.0
170 Requires:       pango >= 1:1.14.0
171 Requires:       ruby-glib2 = %{version}-%{release}
172 Requires:       ruby-rcairo
173
174 %description -n ruby-pango
175 Ruby/Pango is a Ruby binding of pango 1.x.
176
177 %description -n ruby-pango -l pl.UTF-8
178 Ruby/Pango to wiązanie języka Ruby do biblioteki pango 1.x.
179
180 %package -n ruby-pango-devel
181 Summary:        Header files for Ruby/Pango library
182 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/Pango
183 Group:          Development/Libraries
184 Requires:       cairo-devel >= 1.10.0
185 Requires:       pango-devel >= 1:1.14.0
186 Requires:       ruby-glib2-devel = %{version}-%{release}
187 Requires:       ruby-pango = %{version}-%{release}
188
189 %description -n ruby-pango-devel
190 Header files for Ruby/Pango library.
191
192 %description -n ruby-pango-devel -l pl.UTF-8
193 Pliki nagłówkowe biblioteki Ruby/Pango.
194
195 %package -n ruby-gdk_pixbuf2
196 Summary:        Ruby/GdkPixbuf2 - Ruby binding of GdkPixbuf 2.x
197 Summary(pl.UTF-8):      Ruby/GdkPixbuf2 - wiązanie języka Ruby do biblioteki GdkPixbuf 2.x
198 Group:          Development/Languages
199 Requires:       gdk-pixbuf2 >= 2
200 Requires:       ruby-glib2 = %{version}-%{release}
201
202 %description -n ruby-gdk_pixbuf2
203 Ruby/GdkPixbuf2 is a Ruby binding of GdkPixbuf 2.x.
204
205 %description -n ruby-gdk_pixbuf2 -l pl.UTF-8
206 Ruby/GdkPixbuf2 to wiązanie języka Ruby do biblioteki GdkPixbuf 2.x.
207
208 %package -n ruby-gdk_pixbuf2-devel
209 Summary:        Header files for Ruby/GdkPixbuf2 library
210 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GdkPixbuf2
211 Group:          Development/Libraries
212 Requires:       gdk-pixbuf2-devel >= 2
213 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
214 Requires:       ruby-glib2-devel = %{version}-%{release}
215
216 %description -n ruby-gdk_pixbuf2-devel
217 Header files for Ruby/GdkPixbuf2 library.
218
219 %description -n ruby-gdk_pixbuf2-devel -l pl.UTF-8
220 Pliki nagłówkowe biblioteki Ruby/GdkPixbuf2.
221
222 %package -n ruby-gtk2
223 Summary:        Ruby/GTK2 - Ruby binding of GTK+ 2.x
224 Summary(pl.UTF-8):      Ruby/GTK2 - wiązanie języka Ruby do biblioteki GTK+ 2.x
225 Group:          Development/Languages
226 Requires:       gtk+2 >= 2:2.12.0
227 Requires:       ruby-atk = %{version}-%{release}
228 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
229 Requires:       ruby-glib2 = %{version}-%{release}
230 Requires:       ruby-pango = %{version}-%{release}
231
232 %description -n ruby-gtk2
233 Ruby/GTK2 is a Ruby binding of GTK+ 2.x.
234
235 %description -n ruby-gtk2 -l pl.UTF-8
236 Ruby/GTK2 to wiązanie języka Ruby do biblioteki GTK+ 2.x.
237
238 %package -n ruby-gtk2-devel
239 Summary:        Header files for Ruby/GTK2 library
240 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GTK2
241 Group:          Development/Libraries
242 Requires:       gtk+2-devel >= 2:2.12.0
243 Requires:       ruby-atk-devel = %{version}-%{release}
244 Requires:       ruby-gdk_pixbuf2-devel = %{version}-%{release}
245 Requires:       ruby-glib2-devel = %{version}-%{release}
246 Requires:       ruby-gtk2 = %{version}-%{release}
247 Requires:       ruby-pango-devel = %{version}-%{release}
248
249 %description -n ruby-gtk2-devel
250 Header files for Ruby/GTK2 library.
251
252 %description -n ruby-gtk2-devel -l pl.UTF-8
253 Pliki nagłówkowe biblioteki Ruby/GTK2.
254
255 %package -n ruby-goocanvas
256 Summary:        Ruby/GooCanvas - Ruby binding of GooCanvas
257 Summary(pl.UTF-8):      Ruby/GooCanvas - wiązanie języka Ruby do biblioteki GooCanvas
258 Group:          Development/Languages
259 Requires:       goocanvas >= 0.8
260 Requires:       ruby-gtk2 = %{version}-%{release}
261 Requires:       ruby-rcairo
262
263 %description -n ruby-goocanvas
264 Ruby/GooCanvas is a Ruby binding of GooCanvas.
265
266 %description -n ruby-goocanvas -l pl.UTF-8
267 Ruby/GooCanvas to wiązanie języka Ruby do biblioteki GooCanvas.
268
269 %package -n ruby-goocanvas-devel
270 Summary:        Header files for Ruby/GooCanvas library
271 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GooCanvas
272 Group:          Development/Libraries
273 Requires:       goocanvas-devel >= 0.8
274 Requires:       ruby-gtk2-devel = %{version}-%{release}
275 Requires:       ruby-rcairo-devel
276
277 %description -n ruby-goocanvas-devel
278 Header files for Ruby/GooCanvas library.
279
280 %description -n ruby-goocanvas-devel -l pl.UTF-8
281 Pliki nagłówkowe biblioteki Ruby/GooCanvas.
282
283 %package -n ruby-gstreamer
284 Summary:        Ruby/GStreamer - Ruby binding of GStreamer
285 Summary(pl.UTF-8):      Ruby/GStreamer - wiązanie języka Ruby do biblioteki GStreamer
286 Group:          Development/Languages
287 Requires:       gstreamer0.10 >= 0.10.35
288 Requires:       gstreamer0.10-plugins-base >= 0.10.35
289 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
290 Requires:       ruby-glib2 = %{version}-%{release}
291 Requires:       ruby-pango = %{version}-%{release}
292
293 %description -n ruby-gstreamer
294 Ruby/GStreamer is a Ruby binding of GStreamer.
295
296 %description -n ruby-gstreamer -l pl.UTF-8
297 Ruby/GStreamer to wiązanie języka Ruby do biblioteki GStreamer.
298
299 %package -n ruby-gstreamer-devel
300 Summary:        Header files for Ruby/GStreamer library
301 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GStreamer
302 Group:          Development/Libraries
303 Requires:       gstreamer0.10-devel >= 0.10.35
304 Requires:       gstreamer0.10-plugins-base-devel >= 0.10.35
305 Requires:       ruby-gdk_pixbuf2-devel = %{version}-%{release}
306 Requires:       ruby-glib2-devel = %{version}-%{release}
307 Requires:       ruby-pango-devel = %{version}-%{release}
308
309 %description -n ruby-gstreamer-devel
310 Header files for Ruby/GStreamer library.
311
312 %description -n ruby-gstreamer-devel -l pl.UTF-8
313 Pliki nagłówkowe biblioteki Ruby/GStreamer.
314
315 %package -n ruby-gtksourceview2
316 Summary:        Ruby/GtkSourceView2 - Ruby binding of gtksourceview 2.x
317 Summary(pl.UTF-8):      Ruby/GtkSourceView2 - wiązanie języka Ruby do biblioteki gtksourceview 2.x
318 Group:          Development/Languages
319 Requires:       gtksourceview2 >= 2.0.0
320 Requires:       ruby-gtk2 = %{version}-%{release}
321
322 %description -n ruby-gtksourceview2
323 Ruby/GtkSourceView2 is a Ruby binding of gtksourceview 2.x.
324
325 %description -n ruby-gtksourceview2 -l pl.UTF-8
326 Ruby/GtkSourceView2 to wiązanie języka Ruby do biblioteki
327 gtksourceview 2.x.
328
329 %package -n ruby-gtksourceview2-devel
330 Summary:        Header files for Ruby/GtkSourceView2 library
331 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GtkSourceView2
332 Group:          Development/Libraries
333 Requires:       gtksourceview2-devel >= 2.0.0
334 Requires:       ruby-gtk2-devel = %{version}-%{release}
335 Requires:       ruby-gtksourceview2 = %{version}-%{release}
336
337 %description -n ruby-gtksourceview2-devel
338 Header files for Ruby/GtkSourceView2 library.
339
340 %description -n ruby-gtksourceview2-devel -l pl.UTF-8
341 Pliki nagłówkowe biblioteki Ruby/GtkSourceView2.
342
343 %package -n ruby-poppler
344 Summary:        Ruby/Poppler - Ruby binding of poppler-glib
345 Summary(pl.UTF-8):      Ruby/Poppler - wiązanie języka Ruby do biblioteki poppler-glib
346 Group:          Development/Languages
347 Requires:       poppler-glib >= 0.12.0
348 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
349 Requires:       ruby-glib2 = %{version}-%{release}
350 Requires:       ruby-gtk2 = %{version}-%{release}
351
352 %description -n ruby-poppler
353 Ruby/Poppler is a Ruby binding of poppler-glib.
354
355 %description -n ruby-poppler -l pl.UTF-8
356 Ruby/Poppler to wiązanie języka Ruby do biblioteki poppler-glib.
357
358 %package -n ruby-poppler-devel
359 Summary:        Header files for Ruby/Poppler library
360 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/Poppler
361 Group:          Development/Libraries
362 Requires:       poppler-glib-devel >= 0.12.0
363 Requires:       ruby-gdk_pixbuf2-devel = %{version}-%{release}
364 Requires:       ruby-glib2-devel = %{version}-%{release}
365 Requires:       ruby-gtk2-devel = %{version}-%{release}
366
367 %description -n ruby-poppler-devel
368 Header files for Ruby/Poppler library.
369
370 %description -n ruby-poppler-devel -l pl.UTF-8
371 Pliki nagłówkowe biblioteki Ruby/Poppler.
372
373 %package -n ruby-rsvg2
374 Summary:        Ruby/RSVG - Ruby binding of librsvg
375 Summary(pl.UTF-8):      Ruby/RSVG - wiązanie języka Ruby do biblioteki librsvg
376 Group:          Development/Languages
377 Requires:       librsvg >= 2.8
378 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
379 Requires:       ruby-glib2 = %{version}-%{release}
380 Requires:       ruby-rcairo
381
382 %description -n ruby-rsvg2
383 Ruby/RSVG is a Ruby binding of librsvg.
384
385 %description -n ruby-rsvg2 -l pl.UTF-8
386 Ruby/RSVG to wiązanie języka Ruby do biblioteki librsvg.
387
388 %package -n ruby-rsvg2-devel
389 Summary:        Header files for Ruby/RSVG library
390 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/RSVG
391 Group:          Development/Libraries
392 Requires:       librsvg-devel >= 2.8
393 Requires:       ruby-gdk_pixbuf2-devel = %{version}-%{release}
394 Requires:       ruby-glib2-devel = %{version}-%{release}
395
396 %description -n ruby-rsvg2-devel
397 Header files for Ruby/RSVG library.
398
399 %description -n ruby-rsvg2-devel -l pl.UTF-8
400 Pliki nagłówkowe biblioteki Ruby/RSVG.
401
402 %package -n ruby-vte
403 Summary:        Ruby/VTE - Ruby binding of VTE
404 Summary(pl.UTF-8):      Ruby/VTE - wiązanie języka Ruby do biblioteki VTE
405 Group:          Development/Languages
406 Requires:       ruby-gtk2 = %{version}-%{release}
407 Requires:       vte0 >= 0.12.1
408
409 %description -n ruby-vte
410 Ruby/VTE is a Ruby binding of VTE.
411
412 %description -n ruby-vte -l pl.UTF-8
413 Ruby/VTE to wiązanie języka Ruby do biblioteki VTE.
414
415 %package -n ruby-vte-devel
416 Summary:        Header files for Ruby/VTE library
417 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/VTE
418 Group:          Development/Libraries
419 Requires:       ruby-gtk2-devel = %{version}-%{release}
420 Requires:       ruby-vte = %{version}-%{release}
421 Requires:       vte0-devel >= 0.12.1
422
423 %description -n ruby-vte-devel
424 Header files for Ruby/VTE library.
425
426 %description -n ruby-vte-devel -l pl.UTF-8
427 Pliki nagłówkowe biblioteki Ruby/VTE.
428
429 %package -n ruby-gtk3
430 Summary:        Ruby/GTK3 - Ruby binding of GTK+ 3.x
431 Summary(pl.UTF-8):      Ruby/GTK3 - wiązanie języka Ruby do bibliotek GTK+ 3.x
432 Group:          Development/Languages
433 Requires:       gtk+3 >= 3.4.2
434 Requires:       ruby >= 1.9.2
435 Requires:       ruby-atk = %{version}-%{release}
436 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
437 Requires:       ruby-glib2 = %{version}-%{release}
438 Requires:       ruby-pango = %{version}-%{release}
439
440 %description -n ruby-gtk3
441 Ruby/GTK3 is a Ruby binding of GTK+ 3.x.
442
443 %description -n ruby-gtk3 -l pl.UTF-8
444 Ruby/GTK3 to wiązanie języka Ruby do bibliotek GTK+ 3.x.
445
446 %package -n ruby-gtk3-devel
447 Summary:        Header files for Ruby/GTK3 library
448 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GTK3
449 Group:          Development/Libraries
450 Requires:       gtk+3-devel >= 3.4.2
451 Requires:       ruby-atk-devel = %{version}-%{release}
452 Requires:       ruby-devel >= 1.9.2
453 Requires:       ruby-gdk_pixbuf2-devel = %{version}-%{release}
454 Requires:       ruby-glib2-devel = %{version}-%{release}
455 Requires:       ruby-gtk3 = %{version}-%{release}
456 Requires:       ruby-pango-devel = %{version}-%{release}
457
458 %description -n ruby-gtk3-devel
459 Header files for Ruby/GTK3 library.
460
461 %description -n ruby-gtk3-devel -l pl.UTF-8
462 Pliki nagłówkowe biblioteki Ruby/GTK3.
463
464 %package -n ruby-gtksourceview3
465 Summary:        Ruby/GtkSourceView3 - Ruby binding of gtksourceview 3.x
466 Summary(pl.UTF-8):      Ruby/GtkSourceView3 - wiązanie języka Ruby do biblioteki gtksourceview 3.x
467 Group:          Development/Languages
468 Requires:       gtksourceview3 >= 3.4.2
469 Requires:       ruby-gtk3 = %{version}-%{release}
470
471 %description -n ruby-gtksourceview3
472 Ruby/GtkSourceView3 is a Ruby binding of gtksourceview 3.x.
473
474 %description -n ruby-gtksourceview3 -l pl.UTF-8
475 Ruby/GtkSourceView3 to wiązanie języka Ruby do biblioteki
476 gtksourceview 3.x.
477
478 %package -n ruby-gtksourceview3-devel
479 Summary:        Header files for Ruby/GtkSourceView3 library
480 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GtkSourceView3
481 Group:          Development/Libraries
482 Requires:       gtksourceview3-devel >= 3.4.2
483 Requires:       ruby-gtk3-devel = %{version}-%{release}
484 Requires:       ruby-gtksourceview3 = %{version}-%{release}
485
486 %description -n ruby-gtksourceview3-devel
487 Header files for Ruby/GtkSourceView3 library.
488
489 %description -n ruby-gtksourceview3-devel -l pl.UTF-8
490 Pliki nagłówkowe biblioteki Ruby/GtkSourceView3.
491
492 %package -n ruby-vte3
493 Summary:        Ruby/VTE3 - Ruby binding of VTE on GTK+ 3.x
494 Summary(pl.UTF-8):      Ruby/VTE3 - wiązanie języka Ruby do biblioteki VTE na GTK+ 3.x
495 Group:          Development/Languages
496 Requires:       ruby-gtk3 = %{version}-%{release}
497 Requires:       vte >= 0.32.2
498
499 %description -n ruby-vte3
500 Ruby/VTE3 is a Ruby binding of VTE on GTK+ 3.x.
501
502 %description -n ruby-vte3 -l pl.UTF-8
503 Ruby/VTE3 to wiązanie języka Ruby do biblioteki VTE opartej na GTK+
504 3.x.
505
506 %package -n ruby-vte3-devel
507 Summary:        Header files for Ruby/VTE3 library
508 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/VTE3
509 Group:          Development/Libraries
510 Requires:       ruby-gtk3-devel = %{version}-%{release}
511 Requires:       ruby-vte3 = %{version}-%{release}
512 Requires:       vte-devel >= 0.32.2
513
514 %description -n ruby-vte3-devel
515 Header files for Ruby/VTE3 library.
516
517 %description -n ruby-vte3-devel -l pl.UTF-8
518 Pliki nagłówkowe biblioteki Ruby/VTE3.
519
520 %package doc-ri
521 Summary:        Ruby-GNOME2 ri documentation
522 Summary(pl.UTF-8):      Dokumentacja dla Ruby-GNOME2 w formacie ri
523 Group:          Documentation
524 Requires:       ruby
525
526 %description doc-ri
527 Ruby-GNOME2 ri documentation.
528
529 %description doc-ri -l pl.UTF-8
530 Dokumentacja dla Ruby-GNOME2 w formacie ri.
531
532 %package doc-html
533 Summary:        Ruby-GNOME2 HTML documentation
534 Summary(pl.UTF-8):      Dokumentacja dla Ruby-GNOME2 w formacie HTML
535 Group:          Documentation
536
537 %description doc-html
538 Ruby-GNOME2 HTML documentation.
539
540 %description doc-html -l pl.UTF-8
541 Dokumentacja dla Ruby-GNOME2 w formacie HTML.
542
543 %package examples
544 Summary:        Ruby-GNOME2 examples
545 Summary(pl.UTF-8):      Przykłady do Ruby-GNOME2
546 Group:          Development/Libraries
547
548 %description examples
549 Ruby-GNOME2 examples.
550
551 %description examples -l pl.UTF-8
552 Przykłady do Ruby-GNOME2.
553
554 %prep
555 %setup -q -n %{name}-all-%{version}
556 find . -name '*.rb' | xargs sed -i -e '1s,#.*local/bin/ruby,#!%{_bindir}/ruby,'
557
558 cp -p glib2/README README.glib2
559 cp -p glib2/TODO TODO.glib2
560 cp -p gdk3/README.md README.gdk3.md
561 cp -p gtk3/README.md README.gtk3.md
562
563 %build
564 # echo */extconf.rb | xargs -l1 dirname
565
566 comps="
567         atk
568         clutter
569         clutter-gstreamer
570         cairo-gobject
571         gdk_pixbuf2
572         gio2
573         glib2
574         gobject-introspection
575         goocanvas
576         gstreamer
577         gtk2
578         gtksourceview2
579         pango
580         poppler
581         rsvg2
582         vte
583         webkit-gtk2
584 %if %{with gtk3}
585         clutter-gtk
586         gdk3
587         gtk3
588         gtksourceview3
589         vte3
590         webkit-gtk
591 %endif
592 "
593
594 ruby extconf.rb \
595         --vendor \
596         --enable-glib-experimental \
597         $comps
598 %{__make}
599
600 rdoc -o rdoc
601 rdoc --ri -o ri
602
603 %install
604 rm -rf $RPM_BUILD_ROOT
605 install -d $RPM_BUILD_ROOT{%{ruby_archdir},%{ruby_rubylibdir},%{ruby_ridir}} \
606         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
607
608 %{__make} install \
609         DESTDIR=$RPM_BUILD_ROOT \
610         RUBYLIBDIR=$RPM_BUILD_ROOT%{ruby_rubylibdir} \
611         sitearchdir=$RPM_BUILD_ROOT%{ruby_archdir} \
612         pkgconfigdir=$RPM_BUILD_ROOT%{_pkgconfigdir} \
613         RUBYARCHDIR=$RPM_BUILD_ROOT%{ruby_archdir}
614
615 cp -a gdk_pixbuf2/sample \
616         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/gdk_pixbuf2
617
618 cp -a glib2/sample \
619         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/glib2
620
621 cp -a goocanvas/sample \
622         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/goocanvas
623
624 cp -a gstreamer/sample \
625         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/gstreamer
626
627 cp -a gtk2/sample \
628         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/gtk2
629
630 cp -a gtksourceview2/sample \
631         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/gtksourceview2
632
633 cp -a pango/sample \
634         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/pango
635
636 cp -a poppler/sample \
637         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/poppler
638
639 cp -a rsvg2/sample \
640         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/rsvg2
641
642 cp -a vte/sample \
643         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/vte
644
645 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
646 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/{Math,Object,REXML,RbConfig,Test*,page-*,rdoc,ri}
647 %if %{without gtk3}
648 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/{ClutterGtk*,WebKitGtk,clutter-gtk,gdk3,gtk3,gtksourceview3,vte3,webkit-gtk}
649 %endif
650 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/{cache.ri,created.rid}
651
652 %clean
653 rm -rf $RPM_BUILD_ROOT
654
655 %files -n ruby-glib2
656 %defattr(644,root,root,755)
657 %doc AUTHORS NEWS README README.glib2 TODO.glib2
658 %attr(755,root,root) %{ruby_archdir}/glib2.so
659 %{ruby_rubylibdir}/glib-mkenums.rb
660 %{ruby_rubylibdir}/glib2.rb
661 %{ruby_rubylibdir}/gnome2-raketask.rb
662 %dir %{ruby_rubylibdir}/gnome2
663 %{ruby_rubylibdir}/gnome2/rake
664 %{ruby_rubylibdir}/mkmf-gnome2.rb
665 %{ruby_rubylibdir}/glib2
666
667 %files -n ruby-glib2-devel
668 %defattr(644,root,root,755)
669 %{ruby_archdir}/glib-enum-types.h
670 %{ruby_archdir}/rbgcompat.h
671 %{ruby_archdir}/rbglib.h
672 %{ruby_archdir}/rbglib2conversions.h
673 %{ruby_archdir}/rbglibdeprecated.h
674 %{ruby_archdir}/rbgobject.h
675 %{ruby_archdir}/rbgutil.h
676 %{ruby_archdir}/rbgutil_list.h
677 %{ruby_archdir}/rbgutildeprecated.h
678 %{_pkgconfigdir}/ruby-glib2.pc
679
680 %files -n ruby-gobject-introspection
681 %defattr(644,root,root,755)
682 %doc gobject-introspection/README.md
683 %attr(755,root,root) %{ruby_archdir}/gobject_introspection.so
684 %{ruby_rubylibdir}/gobject-introspection.rb
685 %{ruby_rubylibdir}/gobject-introspection
686
687 %files -n ruby-gobject-introspection-devel
688 %defattr(644,root,root,755)
689 %{ruby_archdir}/rb-gobject-introspection.h
690 %{_pkgconfigdir}/ruby-gobject-introspection.pc
691
692 %files -n ruby-gio2
693 %defattr(644,root,root,755)
694 %doc gio2/README.md
695 %attr(755,root,root) %{ruby_archdir}/gio2.so
696 %{ruby_rubylibdir}/gio2.rb
697 %{ruby_rubylibdir}/gio2
698
699 %files -n ruby-atk
700 %defattr(644,root,root,755)
701 %doc atk/README
702 %attr(755,root,root) %{ruby_archdir}/atk.so
703 %{ruby_rubylibdir}/atk.rb
704
705 %files -n ruby-atk-devel
706 %defattr(644,root,root,755)
707 %{ruby_archdir}/rbatk.h
708 %{ruby_archdir}/rbatkversion.h
709 %{_pkgconfigdir}/ruby-atk.pc
710
711 %files -n ruby-cairo-gobject
712 %defattr(644,root,root,755)
713 %doc cairo-gobject/README.md
714 %attr(755,root,root) %{ruby_archdir}/cairo_gobject.so
715 %{ruby_rubylibdir}/cairo-gobject.rb
716
717 %files -n ruby-pango
718 %defattr(644,root,root,755)
719 %doc pango/README
720 %attr(755,root,root) %{ruby_archdir}/pango.so
721 %{ruby_rubylibdir}/pango.rb
722
723 %files -n ruby-pango-devel
724 %defattr(644,root,root,755)
725 %{ruby_archdir}/rbpango.h
726 %{ruby_archdir}/rbpangoconversions.h
727 %{ruby_archdir}/rbpangoversion.h
728 %{_pkgconfigdir}/ruby-pango.pc
729
730 %files -n ruby-gdk_pixbuf2
731 %defattr(644,root,root,755)
732 %doc gdk_pixbuf2/README
733 %attr(755,root,root) %{ruby_archdir}/gdk_pixbuf2.so
734 %{ruby_rubylibdir}/gdk_pixbuf2.rb
735
736 %files -n ruby-gdk_pixbuf2-devel
737 %defattr(644,root,root,755)
738 %{ruby_archdir}/rbgdk-pixbuf.h
739 %{ruby_archdir}/rbgdk-pixbuf2conversions.h
740 %{_pkgconfigdir}/ruby-gdk-pixbuf2.pc
741
742 %files -n ruby-gtk2
743 %defattr(644,root,root,755)
744 %doc gtk2/README
745 %attr(755,root,root) %{ruby_archdir}/gtk2.so
746 %{ruby_rubylibdir}/gtk2.rb
747 %{ruby_rubylibdir}/gtk2
748
749 %files -n ruby-gtk2-devel
750 %defattr(644,root,root,755)
751 %{ruby_archdir}/rbgdk.h
752 %{ruby_archdir}/rbgdkconversions.h
753 %{ruby_archdir}/rbgtk.h
754 %{ruby_archdir}/rbgtkconversions.h
755 %{ruby_archdir}/rbgtkmacros.h
756 %{_pkgconfigdir}/ruby-gtk2.pc
757
758 %files -n ruby-goocanvas
759 %defattr(644,root,root,755)
760 %doc goocanvas/README
761 %attr(755,root,root) %{ruby_archdir}/goocanvas.so
762 %{ruby_rubylibdir}/goocanvas.rb
763 %{ruby_rubylibdir}/goo
764
765 %files -n ruby-goocanvas-devel
766 %defattr(644,root,root,755)
767 %{_pkgconfigdir}/ruby-goocanvas.pc
768
769 %files -n ruby-gstreamer
770 %defattr(644,root,root,755)
771 %doc gstreamer/README.md
772 %attr(755,root,root) %{ruby_archdir}/gstreamer.so
773 %{ruby_rubylibdir}/gst.rb
774 %{ruby_rubylibdir}/gst
775
776 %files -n ruby-gstreamer-devel
777 %defattr(644,root,root,755)
778 %{_pkgconfigdir}/ruby-gstreamer.pc
779
780 %files -n ruby-gtksourceview2
781 %defattr(644,root,root,755)
782 %doc gtksourceview2/README
783 %attr(755,root,root) %{ruby_archdir}/gtksourceview2.so
784 %{ruby_rubylibdir}/gtksourceview2.rb
785
786 %files -n ruby-gtksourceview2-devel
787 %defattr(644,root,root,755)
788 %{_pkgconfigdir}/ruby-gtksourceview2.pc
789
790 %files -n ruby-poppler
791 %defattr(644,root,root,755)
792 %doc poppler/README
793 %attr(755,root,root) %{ruby_archdir}/poppler.so
794 %{ruby_rubylibdir}/poppler.rb
795
796 %files -n ruby-poppler-devel
797 %defattr(644,root,root,755)
798 %{_pkgconfigdir}/ruby-poppler.pc
799
800 %files -n ruby-rsvg2
801 %defattr(644,root,root,755)
802 %doc rsvg2/README
803 %attr(755,root,root) %{ruby_archdir}/rsvg2.so
804 %{ruby_rubylibdir}/rsvg2.rb
805
806 %files -n ruby-rsvg2-devel
807 %defattr(644,root,root,755)
808 %{_pkgconfigdir}/ruby-rsvg2.pc
809
810 %files -n ruby-vte
811 %defattr(644,root,root,755)
812 %doc vte/README
813 %attr(755,root,root) %{ruby_archdir}/vte.so
814 %{ruby_rubylibdir}/vte.rb
815 %{ruby_rubylibdir}/vte
816
817 %files -n ruby-vte-devel
818 %defattr(644,root,root,755)
819 %{_pkgconfigdir}/ruby-vte.pc
820
821 %if %{with gtk3}
822 %files -n ruby-gtk3
823 %defattr(644,root,root,755)
824 %doc README.gdk3.md README.gtk3.md
825 %attr(755,root,root) %{ruby_archdir}/gdk3.so
826 %attr(755,root,root) %{ruby_archdir}/gtk3.so
827 %{ruby_rubylibdir}/gdk3.rb
828 %{ruby_rubylibdir}/gdk3
829 %{ruby_rubylibdir}/gtk3.rb
830 %{ruby_rubylibdir}/gtk3
831
832 %files -n ruby-gtk3-devel
833 %defattr(644,root,root,755)
834 %{ruby_archdir}/rbgdk3.h
835 %{ruby_archdir}/rbgdk3conversions.h
836 %{ruby_archdir}/rbgtk3.h
837 %{ruby_archdir}/rbgtk3conversions.h
838 %{_pkgconfigdir}/ruby-gdk3.pc
839 %{_pkgconfigdir}/ruby-gtk3.pc
840
841 %files -n ruby-gtksourceview3
842 %defattr(644,root,root,755)
843 %doc gtksourceview3/README.md
844 %attr(755,root,root) %{ruby_archdir}/gtksourceview3.so
845 %{ruby_rubylibdir}/gtksourceview3.rb
846 %{ruby_rubylibdir}/gtksourceview3
847
848 %files -n ruby-gtksourceview3-devel
849 %defattr(644,root,root,755)
850 %{_pkgconfigdir}/ruby-gtksourceview3.pc
851
852 %files -n ruby-vte3
853 %defattr(644,root,root,755)
854 %doc vte3/README.md
855 %attr(755,root,root) %{ruby_archdir}/vte3.so
856 %{ruby_rubylibdir}/vte3.rb
857 %{ruby_rubylibdir}/vte3
858
859 %files -n ruby-vte3-devel
860 %defattr(644,root,root,755)
861 %{_pkgconfigdir}/ruby-vte3.pc
862 %endif
863
864 %files doc-html
865 %defattr(644,root,root,755)
866 %doc rdoc/*
867
868 %files doc-ri
869 %defattr(644,root,root,755)
870 %{ruby_ridir}/A
871 %{ruby_ridir}/AlphaDemo
872 %{ruby_ridir}/AssistantRunner
873 %{ruby_ridir}/Atk
874 %{ruby_ridir}/AtkTestUtils
875 %{ruby_ridir}/ButtonBoxSample
876 %{ruby_ridir}/ButtonSample
877 %{ruby_ridir}/Cairo
878 %{ruby_ridir}/CairoGObject
879 %{ruby_ridir}/CairoGObjectTestUtils
880 %{ruby_ridir}/Canvas
881 %{ruby_ridir}/CanvasSampleAnimation
882 %{ruby_ridir}/CanvasSampleArrowhead
883 %{ruby_ridir}/CanvasSampleEvents
884 %{ruby_ridir}/CanvasSampleFeatures
885 %{ruby_ridir}/CanvasSampleFifteen
886 %{ruby_ridir}/CanvasSampleFocus
887 %{ruby_ridir}/CanvasSamplePrimitives
888 %{ruby_ridir}/CheckButtonSample
889 %{ruby_ridir}/Clutter
890 %{ruby_ridir}/ClutterColorTest
891 %{ruby_ridir}/ClutterGStreamerTestUtils
892 %{ruby_ridir}/ClutterGst
893 %{ruby_ridir}/ClutterGstTest
894 %{ruby_ridir}/ClutterTestUtils
895 %{ruby_ridir}/ColorSelectionSample
896 %{ruby_ridir}/Demo
897 %{ruby_ridir}/DestWindow
898 %{ruby_ridir}/DialogSample
899 %{ruby_ridir}/DraggableWidget
900 %{ruby_ridir}/EntrySample
901 %{ruby_ridir}/FileChooserSample
902 %{ruby_ridir}/FileSelectionSample
903 %{ruby_ridir}/FontSelectionSample
904 %{ruby_ridir}/GLib
905 %{ruby_ridir}/GLibTestUtils
906 %{ruby_ridir}/GNOME2
907 %{ruby_ridir}/GNOME2Win32BinaryBuildTask
908 %{ruby_ridir}/GNOME2Win32BinaryDownloadTask
909 %{ruby_ridir}/GObjectIntrospection
910 %{ruby_ridir}/GObjectIntrospectionTestUtils
911 %{ruby_ridir}/GammaCurveSample
912 %{ruby_ridir}/Gdk
913 %{ruby_ridir}/GdkTestUtils
914 %{ruby_ridir}/GdkX11
915 %{ruby_ridir}/Gesture
916 %{ruby_ridir}/GestureProcessor
917 %{ruby_ridir}/GesturedWidget
918 %{ruby_ridir}/Gio
919 %{ruby_ridir}/GioTestUtils
920 %{ruby_ridir}/Goo
921 %{ruby_ridir}/GooCanvasSample
922 %{ruby_ridir}/Gst
923 %{ruby_ridir}/Gtk
924 %{ruby_ridir}/GtkSource
925 %{ruby_ridir}/GtkTestUtils
926 %{ruby_ridir}/Inspector
927 %{ruby_ridir}/LabelSample
928 %{ruby_ridir}/Layout
929 %{ruby_ridir}/LayoutSample
930 %{ruby_ridir}/MenuSample
931 %{ruby_ridir}/MultiTerm
932 %{ruby_ridir}/MyButton
933 %{ruby_ridir}/MyButton2
934 %{ruby_ridir}/MyGtkPlug
935 %{ruby_ridir}/MyGtkSocket
936 %{ruby_ridir}/NotebookSample
937 %{ruby_ridir}/Pager
938 %{ruby_ridir}/Pango
939 %{ruby_ridir}/PangoTestUtils
940 %{ruby_ridir}/PixmapSample
941 %{ruby_ridir}/Pong
942 %{ruby_ridir}/Poppler
943 %{ruby_ridir}/PopplerTestUtils
944 %{ruby_ridir}/Print
945 %{ruby_ridir}/ProgressBarSample
946 %{ruby_ridir}/RSVG
947 %{ruby_ridir}/RadioButtonSample
948 %{ruby_ridir}/RangeSample
949 %{ruby_ridir}/ReparentSample
950 %{ruby_ridir}/RulerSample
951 %{ruby_ridir}/Sample
952 %{ruby_ridir}/SampleClass
953 %{ruby_ridir}/SampleDialog
954 %{ruby_ridir}/SampleWindow
955 %{ruby_ridir}/SavedPositionSample
956 %{ruby_ridir}/ScrolledWindowSample
957 %{ruby_ridir}/ShapeSampleBasic
958 %{ruby_ridir}/ShapeSampleModeller
959 %{ruby_ridir}/ShapeSampleRings
960 %{ruby_ridir}/ShapeSampleSheets
961 %{ruby_ridir}/ShapesSample
962 %{ruby_ridir}/SpinButtonSample
963 %{ruby_ridir}/SrcWindow
964 %{ruby_ridir}/StatusIconSample
965 %{ruby_ridir}/StatusbarSample
966 %{ruby_ridir}/ToggleButtonSample
967 %{ruby_ridir}/ToolbarSample
968 %{ruby_ridir}/TooltipsSample
969 %{ruby_ridir}/VideoApp
970 %{ruby_ridir}/Vte
971 %{ruby_ridir}/WMHintsSample
972 %{ruby_ridir}/WebKitGtk2
973 %{ruby_ridir}/WebKitGtkTestUtils
974 %{ruby_ridir}/Window
975 %{ruby_ridir}/atk
976 %{ruby_ridir}/cairo-gobject
977 %{ruby_ridir}/clutter
978 %{ruby_ridir}/clutter-gstreamer
979 %{ruby_ridir}/gdk_pixbuf2
980 %{ruby_ridir}/gio2
981 %{ruby_ridir}/glib2
982 %{ruby_ridir}/gobject-introspection
983 %{ruby_ridir}/goocanvas
984 %{ruby_ridir}/gstreamer
985 %{ruby_ridir}/gtk2
986 %{ruby_ridir}/gtksourceview2
987 %{ruby_ridir}/pango
988 %{ruby_ridir}/poppler
989 %{ruby_ridir}/rsvg2
990 %{ruby_ridir}/vte
991 %{ruby_ridir}/webkit-gtk2
992 %if %{with gtk3}
993 %{ruby_ridir}/ClutterGtk
994 %{ruby_ridir}/ClutterGtkEmbedTest
995 %{ruby_ridir}/ClutterGtkTestUtils
996 %{ruby_ridir}/WebKitGtk
997 %{ruby_ridir}/clutter-gtk
998 %{ruby_ridir}/gdk3
999 %{ruby_ridir}/gtk3
1000 %{ruby_ridir}/gtksourceview3
1001 %{ruby_ridir}/vte3
1002 %{ruby_ridir}/webkit-gtk
1003 %endif
1004
1005 %files examples
1006 %defattr(644,root,root,755)
1007 %{_examplesdir}/%{name}-%{version}
This page took 0.079523 seconds and 2 git commands to generate.