]> git.pld-linux.org Git - packages/ruby-gnome2.git/blob - ruby-gnome2.spec
- package cairo-gobject and gobject-introspection bindings + more ri docs
[packages/ruby-gnome2.git] / ruby-gnome2.spec
1 # TODO
2 # - update to 2.2.0
3 # - gtk3 packages (or create separate ruby-gtk2, ruby-gtk3 packages besides ruby-gnome2?)
4 #
5 # Conditional build:
6 %bcond_with     gtk3            # build GTK+3
7
8 Summary:        GNOME 2 libraries for Ruby
9 Summary(pl.UTF-8):      Biblioteki GNOME 2 dla języka Ruby
10 Name:           ruby-gnome2
11 Version:        1.1.9
12 Release:        1
13 License:        LGPL v2.1
14 Group:          Development/Languages
15 Source0:        http://downloads.sourceforge.net/ruby-gnome2/%{name}-all-%{version}.tar.gz
16 # Source0-md5:  852a528f8e58ca2729dada994c938be0
17 Patch0:         parse-error.patch
18 URL:            http://ruby-gnome2.sourceforge.jp/
19 BuildRequires:  atk-devel >= 1.0
20 BuildRequires:  cairo-devel >= 1.10.0
21 BuildRequires:  gdk-pixbuf2-devel >= 2
22 BuildRequires:  glib2-devel >= 1:2.16.0
23 BuildRequires:  gobject-introspection-devel >= 1.35.4
24 BuildRequires:  goocanvas-devel >= 0.8
25 BuildRequires:  gstreamer0.10-devel >= 0.10.35
26 BuildRequires:  gstreamer0.10-plugins-base-devel >= 0.10.35
27 BuildRequires:  gtk+2-devel >= 2:2.12.0
28 BuildRequires:  gtksourceview2-devel
29 BuildRequires:  librsvg-devel >= 2.8
30 BuildRequires:  pango-devel >= 1:1.0
31 BuildRequires:  pkgconfig
32 BuildRequires:  poppler-glib-devel >= 0.8.0
33 BuildRequires:  rpmbuild(macros) >= 1.277
34 BuildRequires:  ruby-devel >= 1.8.5
35 BuildRequires:  ruby-pkg-config
36 BuildRequires:  ruby-rcairo-devel
37 BuildRequires:  ruby-rubygems
38 BuildRequires:  sed >= 4.0
39 BuildRequires:  vte0-devel >= 0.12.1
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 GNOME 2 libraries for Ruby.
44
45 %description -l pl.UTF-8
46 Biblioteki GNOME 2 dla języka Ruby.
47
48 %package -n ruby-glib2
49 Summary:        Ruby/Glib2, Ruby/GIO2 - Ruby bindings of GLib 2.x
50 Summary(pl.UTF-8):      Ruby/Glib2, Ruby/GIO2 - wiązania języka Ruby do bibliotek GLib 2.x
51 Group:          Development/Languages
52 Requires:       glib2 >= 1:2.16.0
53 Requires:       ruby >= 1.8.5
54 Obsoletes:      ruby-gnome2
55
56 %description -n ruby-glib2
57 Ruby/Glib2 is a Ruby binding of GLib 2.x. Ruby/GIO2 is a Ruby binding
58 of gio 2.x.
59
60 %description -n ruby-glib2 -l pl.UTF-8
61 Ruby/Glib2 to wiązanie języka Ruby do biblioteki GLib 2.x. Ruby/GIO2
62 to wiązanie języka Ruby do biblioteki gio 2.x.
63
64 %package -n ruby-glib2-devel
65 Summary:        Header files for Ruby/GLib2 and Ruby/GIO2 libraries
66 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Ruby/GLib2 i Ruby/GIO2
67 Group:          Development/Libraries
68 Requires:       glib2-devel >= 1:2.16.0
69 Requires:       ruby-devel >= 1.8.5
70 Requires:       ruby-glib2 = %{version}-%{release}
71 Obsoletes:      ruby-gnome2-devel
72
73 %description -n ruby-glib2-devel
74 Header files for Ruby/GLib2 and Ruby/GIO2 libraries.
75
76 %description -n ruby-glib2-devel -l pl.UTF-8
77 Pliki nagłówkowe bibliotek Ruby/GLib2 i Ruby/GIO2.
78
79 %package -n ruby-gobject-introspection
80 Summary:        Ruby/GObjectIntrospection - Ruby binding of GObject Introspection
81 Summary(pl.UTF-8):      Ruby/GObjectIntrospection - wiązania języka Ruby do biblioteki GObject Introspection
82 Group:          Development/Languages
83 Requires:       gobject-introspection >= 1.35.4
84 Requires:       ruby-glib2 = %{version}-%{release}
85
86 %description -n ruby-gobject-introspection
87 Ruby/GObjectIntrospection is a Ruby binding of GObject Introspection.
88
89 %description -n ruby-gobject-introspection -l pl.UTF-8
90 Ruby/GObjectIntrospection to wiązanie języka Ruby do biblioteki
91 GObject Introspection.
92
93 %package -n ruby-atk
94 Summary:        Ruby/ATK - Ruby binding of ATK
95 Summary(pl.UTF-8):      Ruby/ATK - wiązanie języka Ruby do biblioteki ATK
96 Group:          Development/Languages
97 Requires:       atk >= 1.0
98 Requires:       ruby-glib2 = %{version}-%{release}
99
100 %description -n ruby-atk
101 Ruby/ATK is a Ruby binding of ATK.
102
103 %description -n ruby-atk -l pl.UTF-8
104 Ruby/ATK to wiązanie języka Ruby do biblioteki ATK.
105
106 %package -n ruby-atk-devel
107 Summary:        Header files for Ruby/ATK library
108 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/ATK
109 Group:          Development/Libraries
110 Requires:       atk-devel >= 1.0
111 Requires:       ruby-atk = %{version}-%{release}
112 Requires:       ruby-glib2-devel = %{version}-%{release}
113
114 %description -n ruby-atk-devel
115 Header files for Ruby/ATK library.
116
117 %description -n ruby-atk-devel -l pl.UTF-8
118 Pliki nagłówkowe biblioteki Ruby/ATK.
119
120 %package -n ruby-cairo-gobject
121 Summary:        Ruby/CairoGObject - Ruby binding of cairo-gobject library
122 Summary(pl.UTF-8):      Ruby/CairoGObject - wiązania języka Ruby do biblioteki cairo-gobject
123 Group:          Development/Languages
124 Requires:       ruby-glib2 = %{version}-%{release}
125 Requires:       ruby-rcairo
126
127 %description -n ruby-cairo-gobject
128 Ruby/CairoGObject is a Ruby binding of cairo-gobject library.
129
130 %description -n ruby-cairo-gobject -l pl.UTF-8
131 Ruby/CairoGObject to wiązanie języka Ruby do biblioteki cairo-gobject.
132
133 %package -n ruby-pango
134 Summary:        Ruby/Pango - Ruby binding of pango 1.x
135 Summary(pl.UTF-8):      Ruby/Pango - wiązanie języka Ruby do biblioteki pango 1.x
136 Group:          Development/Languages
137 Requires:       cairo >= 1.10.0
138 Requires:       pango >= 1:1.0
139 Requires:       ruby-glib2 = %{version}-%{release}
140 Requires:       ruby-rcairo
141
142 %description -n ruby-pango
143 Ruby/Pango is a Ruby binding of pango 1.x.
144
145 %description -n ruby-pango -l pl.UTF-8
146 Ruby/Pango to wiązanie języka Ruby do biblioteki pango 1.x.
147
148 %package -n ruby-pango-devel
149 Summary:        Header files for Ruby/Pango library
150 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/Pango
151 Group:          Development/Libraries
152 Requires:       cairo-devel >= 1.10.0
153 Requires:       pango-devel >= 1.0
154 Requires:       ruby-glib2-devel = %{version}-%{release}
155 Requires:       ruby-pango = %{version}-%{release}
156
157 %description -n ruby-pango-devel
158 Header files for Ruby/Pango library.
159
160 %description -n ruby-pango-devel -l pl.UTF-8
161 Pliki nagłówkowe biblioteki Ruby/Pango.
162
163 %package -n ruby-gdk_pixbuf2
164 Summary:        Ruby/GdkPixbuf2 - Ruby binding of GdkPixbuf 2.x
165 Summary(pl.UTF-8):      Ruby/GdkPixbuf2 - wiązanie języka Ruby do biblioteki GdkPixbuf 2.x
166 Group:          Development/Languages
167 Requires:       gdk-pixbuf2 >= 2
168 Requires:       ruby-glib2 = %{version}-%{release}
169
170 %description -n ruby-gdk_pixbuf2
171 Ruby/GdkPixbuf2 is a Ruby binding of GdkPixbuf 2.x.
172
173 %description -n ruby-gdk_pixbuf2 -l pl.UTF-8
174 Ruby/GdkPixbuf2 to wiązanie języka Ruby do biblioteki GdkPixbuf 2.x.
175
176 %package -n ruby-gdk_pixbuf2-devel
177 Summary:        Header files for Ruby/GdkPixbuf2 library
178 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GdkPixbuf2
179 Group:          Development/Libraries
180 Requires:       gdk-pixbuf2-devel >= 2
181 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
182 Requires:       ruby-glib2-devel = %{version}-%{release}
183
184 %description -n ruby-gdk_pixbuf2-devel
185 Header files for Ruby/GdkPixbuf2 library.
186
187 %description -n ruby-gdk_pixbuf2-devel -l pl.UTF-8
188 Pliki nagłówkowe biblioteki Ruby/GdkPixbuf2.
189
190 %package -n ruby-gtk2
191 Summary:        Ruby/GTK2 - Ruby binding of GTK+ 2.x
192 Summary(pl.UTF-8):      Ruby/GTK2 - wiązanie języka Ruby do biblioteki GTK+ 2.x
193 Group:          Development/Languages
194 Requires:       gtk+2 >= 2:2.12.0
195 Requires:       ruby-atk = %{version}-%{release}
196 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
197 Requires:       ruby-glib2 = %{version}-%{release}
198 Requires:       ruby-pango = %{version}-%{release}
199
200 %description -n ruby-gtk2
201 Ruby/GTK2 is a Ruby binding of GTK+ 2.x.
202
203 %description -n ruby-gtk2 -l pl.UTF-8
204 Ruby/GTK2 to wiązanie języka Ruby do biblioteki GTK+ 2.x.
205
206 %package -n ruby-gtk2-devel
207 Summary:        Header files for Ruby/GTK2 library
208 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GTK2
209 Group:          Development/Libraries
210 Requires:       gtk+2-devel >= 2:2.12.0
211 Requires:       ruby-atk-devel = %{version}-%{release}
212 Requires:       ruby-gdk_pixbuf2-devel = %{version}-%{release}
213 Requires:       ruby-glib2-devel = %{version}-%{release}
214 Requires:       ruby-gtk2 = %{version}-%{release}
215 Requires:       ruby-pango-devel = %{version}-%{release}
216
217 %description -n ruby-gtk2-devel
218 Header files for Ruby/GTK2 library.
219
220 %description -n ruby-gtk2-devel -l pl.UTF-8
221 Pliki nagłówkowe biblioteki Ruby/GTK2.
222
223 %package -n ruby-goocanvas
224 Summary:        Ruby/GooCanvas - Ruby binding of GooCanvas
225 Summary(pl.UTF-8):      Ruby/GooCanvas - wiązanie języka Ruby do biblioteki GooCanvas
226 Group:          Development/Languages
227 Requires:       goocanvas >= 0.8
228 Requires:       ruby-gtk2 = %{version}-%{release}
229 Requires:       ruby-rcairo
230
231 %description -n ruby-goocanvas
232 Ruby/GooCanvas is a Ruby binding of GooCanvas.
233
234 %description -n ruby-goocanvas -l pl.UTF-8
235 Ruby/GooCanvas to wiązanie języka Ruby do biblioteki GooCanvas.
236
237 %package -n ruby-goocanvas-devel
238 Summary:        Header files for Ruby/GooCanvas library
239 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GooCanvas
240 Group:          Development/Libraries
241 Requires:       goocanvas-devel >= 0.8
242 Requires:       ruby-gtk2-devel = %{version}-%{release}
243 Requires:       ruby-rcairo-devel
244
245 %description -n ruby-goocanvas-devel
246 Header files for Ruby/GooCanvas library.
247
248 %description -n ruby-goocanvas-devel -l pl.UTF-8
249 Pliki nagłówkowe biblioteki Ruby/GooCanvas.
250
251 %package -n ruby-gstreamer
252 Summary:        Ruby/GStreamer - Ruby binding of GStreamer
253 Summary(pl.UTF-8):      Ruby/GStreamer - wiązanie języka Ruby do biblioteki GStreamer
254 Group:          Development/Languages
255 Requires:       gstreamer0.10 >= 0.10.35
256 Requires:       gstreamer0.10-plugins-base >= 0.10.35
257 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
258 Requires:       ruby-glib2 = %{version}-%{release}
259 Requires:       ruby-pango = %{version}-%{release}
260
261 %description -n ruby-gstreamer
262 Ruby/GStreamer is a Ruby binding of GStreamer.
263
264 %description -n ruby-gstreamer -l pl.UTF-8
265 Ruby/GStreamer to wiązanie języka Ruby do biblioteki GStreamer.
266
267 %package -n ruby-gstreamer-devel
268 Summary:        Header files for Ruby/GStreamer library
269 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GStreamer
270 Group:          Development/Libraries
271 Requires:       gstreamer0.10-devel >= 0.10.35
272 Requires:       gstreamer0.10-plugins-base-devel >= 0.10.35
273 Requires:       ruby-gdk_pixbuf2-devel = %{version}-%{release}
274 Requires:       ruby-glib2-devel = %{version}-%{release}
275 Requires:       ruby-pango-devel = %{version}-%{release}
276
277 %description -n ruby-gstreamer-devel
278 Header files for Ruby/GStreamer library.
279
280 %description -n ruby-gstreamer-devel -l pl.UTF-8
281 Pliki nagłówkowe biblioteki Ruby/GStreamer.
282
283 %package -n ruby-gtksourceview2
284 Summary:        Ruby/GtkSourceView2 - Ruby binding of gtksourceview 2.x
285 Summary(pl.UTF-8):      Ruby/GtkSourceView2 - wiązanie języka Ruby do biblioteki gtksourceview 2.x
286 Group:          Development/Languages
287 Requires:       gtksourceview2 >= 2.0.0
288 Requires:       ruby-gtk2 = %{version}-%{release}
289
290 %description -n ruby-gtksourceview2
291 Ruby/GtkSourceView2 is a Ruby binding of gtksourceview 2.x.
292
293 %description -n ruby-gtksourceview2 -l pl.UTF-8
294 Ruby/GtkSourceView2 to wiązanie języka Ruby do biblioteki
295 gtksourceview 2.x.
296
297 %package -n ruby-gtksourceview2-devel
298 Summary:        Header files for Ruby/GtkSourceView2 library
299 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/GtkSourceView2
300 Group:          Development/Libraries
301 Requires:       gtksourceview2-devel >= 2.0.0
302 Requires:       ruby-gtk2-devel = %{version}-%{release}
303
304 %description -n ruby-gtksourceview2-devel
305 Header files for Ruby/GtkSourceView2 library.
306
307 %description -n ruby-gtksourceview2-devel -l pl.UTF-8
308 Pliki nagłówkowe biblioteki Ruby/GtkSourceView2.
309
310 %package -n ruby-poppler
311 Summary:        Ruby/Poppler - Ruby binding of poppler-glib
312 Summary(pl.UTF-8):      Ruby/Poppler - wiązanie języka Ruby do biblioteki poppler-glib
313 Group:          Development/Languages
314 Requires:       poppler-glib >= 0.8.0
315 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
316 Requires:       ruby-glib2 = %{version}-%{release}
317 Requires:       ruby-gtk2 = %{version}-%{release}
318
319 %description -n ruby-poppler
320 Ruby/Poppler is a Ruby binding of poppler-glib.
321
322 %description -n ruby-poppler -l pl.UTF-8
323 Ruby/Poppler to wiązanie języka Ruby do biblioteki poppler-glib.
324
325 %package -n ruby-poppler-devel
326 Summary:        Header files for Ruby/Poppler library
327 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/Poppler
328 Group:          Development/Libraries
329 Requires:       poppler-glib-devel >= 0.8.0
330 Requires:       ruby-gdk_pixbuf2-devel = %{version}-%{release}
331 Requires:       ruby-glib2-devel = %{version}-%{release}
332 Requires:       ruby-gtk2-devel = %{version}-%{release}
333
334 %description -n ruby-poppler-devel
335 Header files for Ruby/Poppler library.
336
337 %description -n ruby-poppler-devel -l pl.UTF-8
338 Pliki nagłówkowe biblioteki Ruby/Poppler.
339
340 %package -n ruby-rsvg2
341 Summary:        Ruby/RSVG - Ruby binding of librsvg
342 Summary(pl.UTF-8):      Ruby/RSVG - wiązanie języka Ruby do biblioteki librsvg
343 Group:          Development/Languages
344 Requires:       librsvg >= 2.8
345 Requires:       ruby-gdk_pixbuf2 = %{version}-%{release}
346 Requires:       ruby-glib2 = %{version}-%{release}
347 Requires:       ruby-rcairo
348
349 %description -n ruby-rsvg2
350 Ruby/RSVG is a Ruby binding of librsvg.
351
352 %description -n ruby-rsvg2 -l pl.UTF-8
353 Ruby/RSVG to wiązanie języka Ruby do biblioteki librsvg.
354
355 %package -n ruby-rsvg2-devel
356 Summary:        Header files for Ruby/RSVG library
357 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/RSVG
358 Group:          Development/Libraries
359 Requires:       librsvg-devel >= 2.8
360 Requires:       ruby-gdk_pixbuf2-devel = %{version}-%{release}
361 Requires:       ruby-glib2-devel = %{version}-%{release}
362
363 %description -n ruby-rsvg2-devel
364 Header files for Ruby/RSVG library.
365
366 %description -n ruby-rsvg2-devel -l pl.UTF-8
367 Pliki nagłówkowe biblioteki Ruby/RSVG.
368
369 %package -n ruby-vte
370 Summary:        Ruby/VTE - Ruby binding of VTE
371 Summary(pl.UTF-8):      Ruby/VTE - wiązanie języka Ruby do biblioteki VTE
372 Group:          Development/Languages
373 Requires:       ruby-gtk2 = %{version}-%{release}
374 Requires:       vte0 >= 0.12.1
375
376 %description -n ruby-vte
377 Ruby/VTE is a Ruby binding of VTE.
378
379 %description -n ruby-vte -l pl.UTF-8
380 Ruby/VTE to wiązanie języka Ruby do biblioteki VTE.
381
382 %package -n ruby-vte-devel
383 Summary:        Header files for Ruby/VTE library
384 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Ruby/VTE
385 Group:          Development/Libraries
386 Requires:       ruby-gtk2-devel = %{version}-%{release}
387 Requires:       vte0-devel >= 0.12.1
388
389 %description -n ruby-vte-devel
390 Header files for Ruby/VTE library.
391
392 %description -n ruby-vte-devel -l pl.UTF-8
393 Pliki nagłówkowe biblioteki Ruby/VTE.
394
395 %package doc-ri
396 Summary:        Ruby-GNOME2 ri documentation
397 Summary(pl.UTF-8):      Dokumentacja dla Ruby-GNOME2 w formacie ri
398 Group:          Documentation
399 Requires:       ruby
400
401 %description doc-ri
402 Ruby-GNOME2 ri documentation.
403
404 %description doc-ri -l pl.UTF-8
405 Dokumentacja dla Ruby-GNOME2 w formacie ri.
406
407 %package doc-html
408 Summary:        Ruby-GNOME2 HTML documentation
409 Summary(pl.UTF-8):      Dokumentacja dla Ruby-GNOME2 w formacie HTML
410 Group:          Documentation
411
412 %description doc-html
413 Ruby-GNOME2 HTML documentation.
414
415 %description doc-html -l pl.UTF-8
416 Dokumentacja dla Ruby-GNOME2 w formacie HTML.
417
418 %package examples
419 Summary:        Ruby-GNOME2 examples
420 Summary(pl.UTF-8):      Przykłady do Ruby-GNOME2
421 Group:          Development/Libraries
422
423 %description examples
424 Ruby-GNOME2 examples.
425
426 %description examples -l pl.UTF-8
427 Przykłady do Ruby-GNOME2.
428
429 %prep
430 %setup -q -n %{name}-all-%{version}
431 find . -name '*.rb' | xargs sed -i -e '1s,#.*local/bin/ruby,#!%{_bindir}/ruby,'
432 %patch0 -p1
433
434 cp -p glib2/README README.glib2
435 cp -p glib2/TODO TODO.glib2
436 cp -p gio2/README README.gio2
437 cp -p gio2/TODO TODO.gio2
438
439 %build
440 # echo */extconf.rb | xargs -l1 dirname
441
442 comps="
443         atk
444         cairo-gobject
445         gdk_pixbuf2
446         gio2
447         glib2
448         gobject-introspection
449         goocanvas
450         gstreamer
451         gtk2
452         gtksourceview2
453         pango
454         poppler
455         rsvg2
456         vte
457 %if %{with gtk3}
458         gdk3
459         gtk3
460         gtksourceview3
461         vte3
462 %endif
463 "
464
465 ruby extconf.rb \
466         --vendor \
467         --enable-glib-experimental \
468         $comps
469 %{__make}
470
471 rdoc -o rdoc
472 rdoc --ri -o ri
473
474 %install
475 rm -rf $RPM_BUILD_ROOT
476 install -d $RPM_BUILD_ROOT{%{ruby_archdir},%{ruby_rubylibdir},%{ruby_ridir}} \
477         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
478
479 %{__make} install \
480         DESTDIR=$RPM_BUILD_ROOT \
481         RUBYLIBDIR=$RPM_BUILD_ROOT%{ruby_rubylibdir} \
482         sitearchdir=$RPM_BUILD_ROOT%{ruby_archdir} \
483         pkgconfigdir=$RPM_BUILD_ROOT%{_pkgconfigdir} \
484         RUBYARCHDIR=$RPM_BUILD_ROOT%{ruby_archdir}
485
486 cp -a gdk_pixbuf2/sample \
487         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/gdk_pixbuf2
488
489 cp -a glib2/sample \
490         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/glib2
491
492 cp -a goocanvas/sample \
493         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/goocanvas
494
495 cp -a gstreamer/sample \
496         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/gstreamer
497
498 cp -a gtk2/sample \
499         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/gtk2
500
501 cp -a gtksourceview2/sample \
502         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/gtksourceview2
503
504 cp -a pango/sample \
505         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/pango
506
507 cp -a poppler/sample \
508         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/poppler
509
510 cp -a rsvg2/sample \
511         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/rsvg2
512
513 cp -a vte/sample \
514         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/vte
515
516 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
517 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/{Object,RbConfig,TC_*,Test*,page-*,rdoc,ri}
518 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/{cache.ri,created.rid}
519
520 %clean
521 rm -rf $RPM_BUILD_ROOT
522
523 %files -n ruby-glib2
524 %defattr(644,root,root,755)
525 %doc AUTHORS NEWS README README.glib2 TODO.glib2 README.gio2 TODO.gio2
526 %attr(755,root,root) %{ruby_archdir}/gio2.so
527 %attr(755,root,root) %{ruby_archdir}/glib2.so
528 %{ruby_rubylibdir}/gio2.rb
529 %{ruby_rubylibdir}/glib-mkenums.rb
530 %{ruby_rubylibdir}/glib2.rb
531 %{ruby_rubylibdir}/gnome2-raketask.rb
532 # these files are expected to exist not only on Win32
533 %{ruby_rubylibdir}/gnome2-win32-binary-build-task.rb
534 %{ruby_rubylibdir}/gnome2-win32-binary-download-task.rb
535 %{ruby_rubylibdir}/mkmf-gnome2.rb
536 %{ruby_rubylibdir}/gio2
537 %{ruby_rubylibdir}/glib2
538
539 %files -n ruby-glib2-devel
540 %defattr(644,root,root,755)
541 %{ruby_archdir}/glib-enum-types.h
542 %{ruby_archdir}/rbgcompat.h
543 %{ruby_archdir}/rbgio2.h
544 %{ruby_archdir}/rbgio2conversions.h
545 %{ruby_archdir}/rbglib.h
546 %{ruby_archdir}/rbglib2conversions.h
547 %{ruby_archdir}/rbglibdeprecated.h
548 %{ruby_archdir}/rbgobject.h
549 %{ruby_archdir}/rbgutil.h
550 %{ruby_archdir}/rbgutil_list.h
551 %{ruby_archdir}/rbgutildeprecated.h
552 %{_pkgconfigdir}/ruby-gio2.pc
553 %{_pkgconfigdir}/ruby-glib2.pc
554
555 %files -n ruby-gobject-introspection
556 %defattr(644,root,root,755)
557 %doc gobject-introspection/README.md
558 %attr(755,root,root) %{ruby_archdir}/gobject_introspection.so
559 %{ruby_rubylibdir}/gobject-introspection.rb
560 %{ruby_rubylibdir}/gobject-introspection
561
562 %files -n ruby-atk
563 %defattr(644,root,root,755)
564 %doc atk/README
565 %attr(755,root,root) %{ruby_archdir}/atk.so
566 %{ruby_rubylibdir}/atk.rb
567
568 %files -n ruby-atk-devel
569 %defattr(644,root,root,755)
570 %{ruby_archdir}/rbatk.h
571 %{ruby_archdir}/rbatkversion.h
572 %{_pkgconfigdir}/ruby-atk.pc
573
574 %files -n ruby-cairo-gobject
575 %defattr(644,root,root,755)
576 %doc cairo-gobject/README.md
577 %attr(755,root,root) %{ruby_archdir}/cairo_gobject.so
578 %{ruby_rubylibdir}/cairo-gobject.rb
579
580 %files -n ruby-pango
581 %defattr(644,root,root,755)
582 %doc pango/README
583 %attr(755,root,root) %{ruby_archdir}/pango.so
584 %{ruby_rubylibdir}/pango.rb
585
586 %files -n ruby-pango-devel
587 %defattr(644,root,root,755)
588 %{ruby_archdir}/rbpango.h
589 %{ruby_archdir}/rbpangoconversions.h
590 %{ruby_archdir}/rbpangoversion.h
591 %{_pkgconfigdir}/ruby-pango.pc
592
593 %files -n ruby-gdk_pixbuf2
594 %defattr(644,root,root,755)
595 %doc gdk_pixbuf2/README
596 %attr(755,root,root) %{ruby_archdir}/gdk_pixbuf2.so
597 %{ruby_rubylibdir}/gdk_pixbuf2.rb
598
599 %files -n ruby-gdk_pixbuf2-devel
600 %defattr(644,root,root,755)
601 %{ruby_archdir}/rbgdk-pixbuf.h
602 %{ruby_archdir}/rbgdk-pixbuf2conversions.h
603 %{_pkgconfigdir}/ruby-gdk-pixbuf2.pc
604
605 %files -n ruby-gtk2
606 %defattr(644,root,root,755)
607 %doc gtk2/README
608 %attr(755,root,root) %{ruby_archdir}/gtk2.so
609 %{ruby_rubylibdir}/gtk2.rb
610 %{ruby_rubylibdir}/gtk2
611
612 %files -n ruby-gtk2-devel
613 %defattr(644,root,root,755)
614 %{ruby_archdir}/rbgdk.h
615 %{ruby_archdir}/rbgdkconversions.h
616 %{ruby_archdir}/rbgtk.h
617 %{ruby_archdir}/rbgtkconversions.h
618 %{ruby_archdir}/rbgtkmacros.h
619 %{_pkgconfigdir}/ruby-gtk2.pc
620
621 %files -n ruby-goocanvas
622 %defattr(644,root,root,755)
623 %doc goocanvas/README
624 %attr(755,root,root) %{ruby_archdir}/goocanvas.so
625 %{ruby_rubylibdir}/goocanvas.rb
626
627 %files -n ruby-goocanvas-devel
628 %defattr(644,root,root,755)
629 %{_pkgconfigdir}/ruby-goocanvas.pc
630
631 %files -n ruby-gstreamer
632 %defattr(644,root,root,755)
633 %doc gstreamer/README
634 %attr(755,root,root) %{ruby_archdir}/gstreamer.so
635 %{ruby_rubylibdir}/gst.rb
636
637 %files -n ruby-gstreamer-devel
638 %defattr(644,root,root,755)
639 %{_pkgconfigdir}/ruby-gstreamer.pc
640
641 %files -n ruby-gtksourceview2
642 %defattr(644,root,root,755)
643 %doc gtksourceview2/README
644 %attr(755,root,root) %{ruby_archdir}/gtksourceview2.so
645 %{ruby_rubylibdir}/gtksourceview2.rb
646
647 %files -n ruby-gtksourceview2-devel
648 %defattr(644,root,root,755)
649 %{_pkgconfigdir}/ruby-gtksourceview2.pc
650
651 %files -n ruby-poppler
652 %defattr(644,root,root,755)
653 %doc poppler/README
654 %attr(755,root,root) %{ruby_archdir}/poppler.so
655 %{ruby_rubylibdir}/poppler.rb
656
657 %files -n ruby-poppler-devel
658 %defattr(644,root,root,755)
659 %{_pkgconfigdir}/ruby-poppler.pc
660
661 %files -n ruby-rsvg2
662 %defattr(644,root,root,755)
663 %doc rsvg2/README
664 %attr(755,root,root) %{ruby_archdir}/rsvg2.so
665 %{ruby_rubylibdir}/rsvg2.rb
666
667 %files -n ruby-rsvg2-devel
668 %defattr(644,root,root,755)
669 %{_pkgconfigdir}/ruby-rsvg2.pc
670
671 %files -n ruby-vte
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{ruby_archdir}/vte.so
674 %{ruby_rubylibdir}/vte.rb
675 %{ruby_rubylibdir}/vte
676
677 %files -n ruby-vte-devel
678 %defattr(644,root,root,755)
679 %{_pkgconfigdir}/ruby-vte.pc
680
681 %files doc-html
682 %defattr(644,root,root,755)
683 %doc rdoc/*
684
685 %files doc-ri
686 %defattr(644,root,root,755)
687 %{ruby_ridir}/A
688 %{ruby_ridir}/AlphaDemo
689 %{ruby_ridir}/AssistantRunner
690 %{ruby_ridir}/Atk
691 %{ruby_ridir}/ButtonBoxSample
692 %{ruby_ridir}/ButtonSample
693 %{ruby_ridir}/Cairo
694 %{ruby_ridir}/CairoGObject
695 %{ruby_ridir}/CairoGObjectTestUtils
696 %{ruby_ridir}/Canvas
697 %{ruby_ridir}/CanvasSampleArrowhead
698 %{ruby_ridir}/CanvasSampleFifteen
699 %{ruby_ridir}/CanvasSamplePrimitives
700 %{ruby_ridir}/CheckButtonSample
701 %{ruby_ridir}/ColorSelectionSample
702 %{ruby_ridir}/Demo
703 %{ruby_ridir}/DestWindow
704 %{ruby_ridir}/DialogSample
705 %{ruby_ridir}/DraggableWidget
706 %{ruby_ridir}/EntrySample
707 %{ruby_ridir}/FileChooserSample
708 %{ruby_ridir}/FileSelectionSample
709 %{ruby_ridir}/FontSelectionSample
710 %{ruby_ridir}/GLib
711 %{ruby_ridir}/GLibTestUtils
712 %{ruby_ridir}/GNOME2Package
713 %{ruby_ridir}/GNOME2Win32BinaryBuildTask
714 %{ruby_ridir}/GNOME2Win32BinaryDownloadTask
715 %{ruby_ridir}/GObjectIntrospection
716 %{ruby_ridir}/GObjectIntrospectionTestUtils
717 %{ruby_ridir}/GammaCurveSample
718 %{ruby_ridir}/Gdk
719 %{ruby_ridir}/GdkX11
720 %{ruby_ridir}/Gesture
721 %{ruby_ridir}/GestureProcessor
722 %{ruby_ridir}/GesturedWidget
723 %{ruby_ridir}/Gio
724 %{ruby_ridir}/Goo
725 %{ruby_ridir}/GooCanvasSample
726 %{ruby_ridir}/Gst
727 %{ruby_ridir}/GstTestUtils
728 %{ruby_ridir}/Gtk
729 %{ruby_ridir}/GtkSource
730 %{ruby_ridir}/GtkTestUtils
731 %{ruby_ridir}/Inspector
732 %{ruby_ridir}/LabelSample
733 %{ruby_ridir}/Layout
734 %{ruby_ridir}/LayoutSample
735 %{ruby_ridir}/MediaInfo
736 %{ruby_ridir}/MediaInfoStream
737 %{ruby_ridir}/MediaInfoTrack
738 %{ruby_ridir}/MenuSample
739 %{ruby_ridir}/MultiTerm
740 %{ruby_ridir}/MyButton
741 %{ruby_ridir}/MyButton2
742 %{ruby_ridir}/MyGtkPlug
743 %{ruby_ridir}/MyGtkSocket
744 %{ruby_ridir}/NotebookSample
745 %{ruby_ridir}/Pager
746 %{ruby_ridir}/Pango
747 %{ruby_ridir}/PangoTestUtils
748 %{ruby_ridir}/PixmapSample
749 %{ruby_ridir}/Pong
750 %{ruby_ridir}/Poppler
751 %{ruby_ridir}/PopplerTestUtils
752 %{ruby_ridir}/Print
753 %{ruby_ridir}/ProgressBarSample
754 %{ruby_ridir}/RSVG
755 %{ruby_ridir}/RadioButtonSample
756 %{ruby_ridir}/RangeSample
757 %{ruby_ridir}/ReparentSample
758 %{ruby_ridir}/RulerSample
759 %{ruby_ridir}/Sample
760 %{ruby_ridir}/SampleClass
761 %{ruby_ridir}/SampleDialog
762 %{ruby_ridir}/SampleWindow
763 %{ruby_ridir}/SavedPositionSample
764 %{ruby_ridir}/ScrolledWindowSample
765 %{ruby_ridir}/ShapeSampleBasic
766 %{ruby_ridir}/ShapeSampleModeller
767 %{ruby_ridir}/ShapeSampleRings
768 %{ruby_ridir}/ShapeSampleSheets
769 %{ruby_ridir}/ShapesSample
770 %{ruby_ridir}/SpinButtonSample
771 %{ruby_ridir}/SrcWindow
772 %{ruby_ridir}/StatusIconSample
773 %{ruby_ridir}/StatusbarSample
774 %{ruby_ridir}/ToggleButtonSample
775 %{ruby_ridir}/ToolbarSample
776 %{ruby_ridir}/TooltipsSample
777 %{ruby_ridir}/Vte
778 %{ruby_ridir}/WMHintsSample
779 %{ruby_ridir}/Window
780 %{ruby_ridir}/atk
781 %{ruby_ridir}/cairo-gobject
782 %{ruby_ridir}/gdk3
783 %{ruby_ridir}/gdk_pixbuf2
784 %{ruby_ridir}/gio2
785 %{ruby_ridir}/glib2
786 %{ruby_ridir}/gobject-introspection
787 %{ruby_ridir}/goocanvas
788 %{ruby_ridir}/gstreamer
789 %{ruby_ridir}/gtk2
790 %{ruby_ridir}/gtk3
791 %{ruby_ridir}/gtksourceview2
792 %{ruby_ridir}/gtksourceview3
793 %{ruby_ridir}/pango
794 %{ruby_ridir}/poppler
795 %{ruby_ridir}/rsvg2
796 %{ruby_ridir}/vte
797 %{ruby_ridir}/vte3
798
799 %files examples
800 %defattr(644,root,root,755)
801 %{_examplesdir}/%{name}-%{version}
This page took 0.136067 seconds and 3 git commands to generate.