]> git.pld-linux.org Git - packages/ruby-facter.git/blob - ruby-facter.spec
a1de45b29f76b6df30d75c55ab5e9fffd6fd2927
[packages/ruby-facter.git] / ruby-facter.spec
1 %define         pkgname facter
2 Summary:        Ruby module for collecting simple facts about a host operating system
3 Name:           ruby-%{pkgname}
4 Version:        2.4.4
5 Release:        1
6 License:        GPL v2+
7 Group:          Development/Languages
8 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
9 # Source0-md5:  0e8806dbfaa5b9b0b7b7f19c725aab1d
10 URL:            https://puppetlabs.com/facter
11 BuildRequires:  docutils
12 BuildRequires:  rpm-rubyprov
13 BuildRequires:  rpmbuild(macros) >= 1.656
14 Requires:       net-tools
15 Requires:       which
16 # dmidecode and pciutils are not available on all arches
17 %ifarch %{ix86} %{x8664} ia64
18 Requires:       dmidecode
19 Requires:       pciutils
20 %endif
21 Obsoletes:      facter < 1.5.9
22 # due arch specific dependencies
23 #BuildArch:     noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 # nothing to be placed there. we're not noarch only because of arch dependant requires
27 %define         _enable_debug_packages  0
28
29 %description
30 Facter is a lightweight program that gathers basic node information
31 about the hardware and operating system. Facter is especially useful
32 for retrieving things like operating system names, hardware
33 characteristics, IP addresses, MAC addresses, and SSH keys.
34
35 Facter is extensible and allows gathering of node information that may
36 be custom or site specific. It is easy to extend by including your own
37 custom facts. Facter can also be used to create conditional
38 expressions in Puppet that key off the values returned by facts.
39
40 %prep
41 %setup -q -n %{pkgname}-%{version}
42
43 %build
44 # write .gemspec
45 %__gem_helper spec
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir}}
50 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
51 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
52 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc README.md etc/facter.conf
60 %attr(755,root,root) %{_bindir}/facter
61 %{ruby_vendorlibdir}/%{pkgname}
62 %{ruby_vendorlibdir}/%{pkgname}.rb
63 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.136359 seconds and 2 git commands to generate.