]> git.pld-linux.org Git - packages/ruby-facter.git/blob - ruby-facter.spec
disable debuginfo subpackage
[packages/ruby-facter.git] / ruby-facter.spec
1 %define         pkgname facter
2 Summary:        Ruby module for collecting simple facts about a host operating system
3 Name:           ruby-%{pkgname}
4 Version:        1.6.18
5 Release:        2
6 License:        GPL v2+
7 Group:          Development/Languages
8 Source0:        http://downloads.puppetlabs.com/%{pkgname}/%{pkgname}-%{version}.tar.gz
9 # Source0-md5:  c209df5909ccd4112c19cf4b535027a7
10 URL:            http://puppetlabs.com/puppet/related-projects/facter/
11 BuildRequires:  docutils
12 BuildRequires:  rpm-rubyprov
13 BuildRequires:  rpmbuild(macros) >= 1.656
14 Requires:       net-tools
15 Requires:       which
16 # dmidecode and pciutils are not available on all arches
17 %ifarch %{ix86} %{x8664} ia64
18 Requires:       dmidecode
19 Requires:       pciutils
20 %endif
21 Obsoletes:      facter < 1.5.9
22 # due arch specific dependencies
23 #BuildArch:     noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 # nothing to be placed there. we're not noarch only because of arch dependant requires
27 %define         _enable_debug_packages  0
28
29 %description
30 Facter is a lightweight program that gathers basic node information
31 about the hardware and operating system. Facter is especially useful
32 for retrieving things like operating system names, hardware
33 characteristics, IP addresses, MAC addresses, and SSH keys.
34
35 Facter is extensible and allows gathering of node information that may
36 be custom or site specific. It is easy to extend by including your own
37 custom facts. Facter can also be used to create conditional
38 expressions in Puppet that key off the values returned by facts.
39
40 %prep
41 %setup -q -n %{pkgname}-%{version}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{ruby_sitelibdir}
46 %{__ruby} install.rb \
47         --quick \
48         --no-man \
49         --no-rdoc \
50         --sitelibdir=%{ruby_vendorlibdir} \
51         --destdir=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc README.md etc/facter.conf
59 %attr(755,root,root) %{_bindir}/facter
60 %{ruby_vendorlibdir}/facter
61 %{ruby_vendorlibdir}/facter.rb
This page took 0.067022 seconds and 3 git commands to generate.