]> git.pld-linux.org Git - packages/ruby-facter.git/blob - ruby-facter.spec
- up to 1.6.18
[packages/ruby-facter.git] / ruby-facter.spec
1 %define         pkgname facter
2 Summary:        Ruby module for collecting simple facts about a host operating system
3 Name:           ruby-%{pkgname}
4 Version:        1.6.18
5 Release:        1
6 License:        GPL v2+
7 Group:          Networking/Admin
8 Source0:        http://downloads.puppetlabs.com/%{pkgname}/%{pkgname}-%{version}.tar.gz
9 # Source0-md5:  c209df5909ccd4112c19cf4b535027a7
10 URL:            http://www.puppetlabs.com/puppet/related-projects/facter/
11 BuildRequires:  docutils
12 BuildRequires:  rpmbuild(macros) >= 1.484
13 BuildRequires:  ruby >= 1:1.8.6
14 BuildRequires:  ruby-modules
15 Requires:       net-tools
16 Requires:       which
17 # dmidecode and pciutils are not available on all arches
18 %ifarch %{ix86} %{x8664} ia64
19 Requires:       dmidecode
20 Requires:       pciutils
21 %endif
22 Obsoletes:      facter
23 %{?ruby_mod_ver_requires_eq}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 # nothing to be placed there. we're not noarch only because of ruby packaging
27 %define         _enable_debug_packages  0
28
29 %description
30 Facter is a lightweight program that gathers basic node information
31 about the hardware and operating system. Facter is especially useful
32 for retrieving things like operating system names, hardware
33 characteristics, IP addresses, MAC addresses, and SSH keys.
34
35 Facter is extensible and allows gathering of node information that may
36 be custom or site specific. It is easy to extend by including your own
37 custom facts. Facter can also be used to create conditional
38 expressions in Puppet that key off the values returned by facts.
39
40 %prep
41 %setup -q -n %{pkgname}-%{version}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{ruby_sitelibdir}
46 %{__ruby} install.rb \
47         --quick \
48         --no-man \
49         --no-rdoc \
50         --destdir=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc README.md etc/facter.conf
58 %attr(755,root,root) %{_bindir}/facter
59 %{ruby_sitelibdir}/facter
60 %{ruby_sitelibdir}/facter.rb
This page took 0.19209 seconds and 3 git commands to generate.