]> git.pld-linux.org Git - packages/rubberband.git/blob - rubberband.spec
fce7c8c473f345b6d8f1bbf41667fb10b8139e09
[packages/rubberband.git] / rubberband.spec
1 #
2 # Conditional build:
3 %bcond_without  java    # JNI library
4
5 Summary:        An audio time-stretching and pitch-shifting library and utility program
6 Summary(pl.UTF-8):      Biblioteka i narzędzie do rozciągania i harmonizowania dźwięku
7 Name:           rubberband
8 Version:        1.8.2
9 Release:        1
10 License:        GPL v2+
11 Group:          Applications/Sound
12 Source0:        https://breakfastquay.com/files/releases/%{name}-%{version}.tar.bz2
13 # Source0-md5:  db0ecb4f1a647bdaf7e43ef2ca2f7883
14 Patch0:         %{name}-pc.patch
15 Patch1:         %{name}-jni.patch
16 URL:            http://www.breakfastquay.com/rubberband/
17 BuildRequires:  fftw3-devel >= 3
18 %{?with_jni:BuildRequires:      jdk}
19 BuildRequires:  ladspa-devel
20 BuildRequires:  libsamplerate-devel
21 BuildRequires:  libsndfile-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  pkgconfig
24 BuildRequires:  vamp-devel
25 Requires:       %{name}-libs = %{version}-%{release}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Rubber Band is a library and utility program that permits you to
30 change the tempo and pitch of an audio recording independently of one
31 another.
32
33 %description -l pl.UTF-8
34 Rubber Band to biblioteka i program narzędziowy, który pozwala na
35 zmianę tempa i wysokości tonu nagrywanego dźwięku niezależnie.
36
37 %package libs
38 Summary:        Shared rubberband library
39 Summary(pl.UTF-8):      Biblioteka współdzielona rubberband
40 Group:          Libraries
41
42 %description libs
43 Shared rubberband library.
44
45 %description libs -l pl.UTF-8
46 Biblioteka współdzielona rubberband.
47
48 %package devel
49 Summary:        Header files for rubberband library
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki rubberband
51 Group:          Development/Libraries
52 Requires:       %{name}-libs = %{version}-%{release}
53
54 %description devel
55 Header files for rubberband library.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe biblioteki rubberband.
59
60 %package static
61 Summary:        Static rubberband library
62 Summary(pl.UTF-8):      Statyczna biblioteka rubberband
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static rubberband library.
68
69 %description static -l pl.UTF-8
70 Statyczna biblioteka rubberband.
71
72 %package -n java-rubberband
73 Summary:        Java JNI interface for rubberband
74 Summary(pl.UTF-8):      Interfejs Javy JNI do rubberband
75 Group:          Libraries/Java
76 Requires:       jre
77
78 %description -n java-rubberband
79 Java JNI interface for rubberband.
80
81 %description -n java-rubberband -l pl.UTF-8
82 Interfejs Javy JNI do rubberband.
83
84 %package -n ladspa-rubberband-plugins
85 Summary:        rubberband LADSPA plugin
86 Summary(pl.UTF-8):      Wtyczka LADSPA rubberband
87 Group:          Applications/Sound
88 Requires:       ladspa-common
89
90 %description -n ladspa-rubberband-plugins
91 rubberband LADSPA plugin.
92
93 %description -n ladspa-rubberband-plugins -l pl.UTF-8
94 Wtyczka LADSPA rubberband.
95
96 %package -n vamp-plugins-rubberband
97 Summary:        rubberband Vamp plugin
98 Summary(pl.UTF-8):      Wtyczka Vamp rubberband
99 Group:          Applications/Sound
100 Requires:       vamp
101
102 %description -n vamp-plugins-rubberband
103 rubberband Vamp plugin.
104
105 %description -n vamp-plugins-rubberband -l pl.UTF-8
106 Wtyczka Vamp rubberband.
107
108 %prep
109 %setup -q
110 %patch0 -p1
111 %patch1 -p1
112
113 %build
114 %configure
115 %{__make} all %{?with_java:jni} \
116         INSTALL_LIBDIR="%{_libdir}" \
117         INSTALL_VAMPDIR="%{_libdir}/vamp" \
118         INSTALL_LADSPADIR="%{_libdir}/ladspa"
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT \
125         INSTALL_LIBDIR="%{_libdir}" \
126         INSTALL_VAMPDIR="%{_libdir}/vamp" \
127         INSTALL_LADSPADIR="%{_libdir}/ladspa" \
128         INSTALL_PKGDIR="%{_pkgconfigdir}"
129
130 %if %{with java}
131 install -d $RPM_BUILD_ROOT%{_javadir}
132 cp -p lib/rubberband.jar $RPM_BUILD_ROOT%{_javadir}
133 %endif
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post   libs -p /sbin/ldconfig
139 %postun libs -p /sbin/ldconfig
140
141 %post   -n java-rubberband -p /sbin/ldconfig
142 %postun -n java-rubberband -p /sbin/ldconfig
143
144 %files
145 %defattr(644,root,root,755)
146 %doc CHANGELOG README.txt
147 %attr(755,root,root) %{_bindir}/rubberband
148
149 %files libs
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/librubberband.so.*.*.*
152 %attr(755,root,root) %ghost %{_libdir}/librubberband.so.2
153
154 %files devel
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_libdir}/librubberband.so
157 %{_includedir}/%{name}
158 %{_pkgconfigdir}/rubberband.pc
159
160 %files static
161 %defattr(644,root,root,755)
162 %{_libdir}/librubberband.a
163
164 %if %{with java}
165 %files -n java-rubberband
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/librubberband-jni.so
168 %{_javadir}/rubberband.jar
169 %endif
170
171 %files -n ladspa-rubberband-plugins
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libdir}/ladspa/ladspa-rubberband.so
174 %{_libdir}/ladspa/ladspa-rubberband.cat
175 %{_datadir}/ladspa/rdf/ladspa-rubberband.rdf
176
177 %files -n vamp-plugins-rubberband
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/vamp/vamp-rubberband.so
180 %{_libdir}/vamp/vamp-rubberband.cat
This page took 0.044686 seconds and 2 git commands to generate.