]> git.pld-linux.org Git - packages/rtl8812au.git/commitdiff
- fix build on kernels using gcc 4.9 features auto/th/rtl8812au-4.3.2_11100.20140411-0.20140901.4
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 11 Dec 2014 20:43:32 +0000 (21:43 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 11 Dec 2014 20:43:32 +0000 (21:43 +0100)
- rel 4

gcc-4.9.patch [new file with mode: 0644]
rtl8812au.spec

diff --git a/gcc-4.9.patch b/gcc-4.9.patch
new file mode 100644 (file)
index 0000000..19dfc2c
--- /dev/null
@@ -0,0 +1,18 @@
+--- rtl8812au_linux-master/core/rtw_debug.c~   2014-07-21 15:06:45.000000000 +0200
++++ rtl8812au_linux-master/core/rtw_debug.c    2014-12-11 21:38:17.142784499 +0100
+@@ -62,8 +62,15 @@
+ void dump_drv_version(void *sel)
+ {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 14, 0)
++#pragma GCC diagnostic push
++#pragma GCC diagnostic ignored "-Wdate-time"
++#endif
+       DBG_871X_SEL_NL(sel, "%s %s\n", DRV_NAME, DRIVERVERSION);
+       DBG_871X_SEL_NL(sel, "build time: %s %s\n", __DATE__, __TIME__);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 14, 0)
++#pragma GCC diagnostic pop
++#endif
+ }
+ void dump_log_level(void *sel)
index c613e3a24b7aae0736c9bed29a00889adc4296d6..4dc3ae796cb6205073a15a15655ddad1bceafeb0 100644 (file)
@@ -19,7 +19,7 @@ exit 1
 %define                kpkg    %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%kernel_pkg ; done)
 %define                bkpkg   %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%build_kernel_pkg ; done)
 
-%define                rel     3
+%define                rel     4
 %define                snap    20140901
 %define                pname   rtl8812au
 Summary:       Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter
@@ -39,6 +39,7 @@ Patch1:               disable-debug.patch
 Patch2:                enable-cfg80211-support.patch
 Patch3:                update-cfg80211-support.patch
 Patch4:                warnings.patch
+Patch5:                gcc-4.9.patch
 BuildRequires: rpmbuild(macros) >= 1.678
 %{?with_dist_kernel:%{expand:%kbrs}}
 BuildRoot:     %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
@@ -87,6 +88,7 @@ Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %build
 %{expand:%bkpkg}
This page took 0.115854 seconds and 4 git commands to generate.