]> git.pld-linux.org Git - packages/rtl8812au.git/blob - rtl8812au.spec
- updates and fixes for 4.1 and 4.2 kernels
[packages/rtl8812au.git] / rtl8812au.spec
1 # Conditional build:
2 %bcond_with     verbose         # verbose build (V=1)
3
4 # nothing to be placed to debuginfo package
5 %define         _enable_debug_packages  0
6
7 %define         rel     9
8 %define         snap    20140901
9 %define         pname   rtl8812au
10 Summary:        Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter
11 Name:           %{pname}%{_alt_kernel}
12 Version:        4.3.2_11100.20140411
13 Release:        0.%{snap}.%{rel}%{?_pld_builder:@%{_kernel_ver_str}}
14 License:        GPL
15 Group:          Base/Kernel
16 #Source0:       https://github.com/abperiasamy/rtl8812AU_8821AU_linux/archive/master/%{name}-%{version}-%{snap}.tar.gz
17 Source0:        https://github.com/austinmarton/rtl8812au_linux/archive/master/%{pname}-%{version}-%{snap}.tar.gz
18 # Source0-md5:  693825ab344b68a1217f20ab8dd98b82
19 # good luck finding this chip on Realtek website :/
20 #URL:           http://www.realtek.com.tw/
21 URL:            https://github.com/austinmarton/rtl8812au_linux
22 Patch0:         linux-3.11.patch
23 Patch1:         disable-debug.patch
24 Patch2:         enable-cfg80211-support.patch
25 Patch3:         update-cfg80211-support.patch
26 Patch4:         warnings.patch
27 Patch5:         gcc-4.9.patch
28 Patch6:         linux-3.18.patch
29 Patch7:         linux-4.0.patch
30 Patch8:         linux-4.1.patch
31 Patch9:         linux-4.2.patch
32 BuildRequires:  rpmbuild(macros) >= 1.701
33 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
34 BuildRoot:      %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
35
36 %description
37 Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter.
38
39 %define kernel_pkg()\
40 %package -n kernel%{_alt_kernel}-net-rtl8812au\
41 Summary:        Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
42 Release:        %{rel}@%{_kernel_ver_str}\
43 Group:          Base/Kernel\
44 Requires(post,postun):  /sbin/depmod\
45 %requires_releq_kernel\
46 Requires(postun):       %releq_kernel\
47 \
48 %description -n kernel%{_alt_kernel}-net-rtl8812au\
49 Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
50 \
51 %files -n kernel%{_alt_kernel}-net-rtl8812au\
52 %defattr(644,root,root,755)\
53 /lib/modules/%{_kernel_ver}/kernel/drivers/net/wireless/*.ko*\
54 \
55 %post   -n kernel%{_alt_kernel}-net-rtl8812au\
56 %depmod %{_kernel_ver}\
57 \
58 %postun -n kernel%{_alt_kernel}-net-rtl8812au\
59 %depmod %{_kernel_ver}\
60 %{nil}
61
62 %define build_kernel_pkg()\
63 %{__make} clean KVER=%{_kernel_ver} KSRC=%{_kernelsrcdir}\
64 %{__make} modules KVER=%{_kernel_ver} KSRC=%{_kernelsrcdir}\
65 %install_kernel_modules -D installed -m 8812au -d kernel/drivers/net/wireless\
66 %{nil}
67
68 %{expand:%create_kernel_packages}
69
70 %prep
71 #%setup -q -n %{pname}-%{version}
72 %setup -q -n rtl8812au_linux-master
73 %patch0 -p1
74 %patch1 -p1
75 %patch2 -p1
76 %patch3 -p1
77 %patch4 -p1
78 %patch5 -p1
79 %patch6 -p1
80 %patch7 -p1
81 %patch8 -p1
82 %patch9 -p1
83
84 %build
85 %{expand:%build_kernel_packages}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT
90
91 cp -a installed/* $RPM_BUILD_ROOT
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
This page took 0.170167 seconds and 4 git commands to generate.