]> git.pld-linux.org Git - packages/rtl8812au.git/blob - rtl8812au.spec
- rel 16
[packages/rtl8812au.git] / rtl8812au.spec
1 # TODO: consider migrating to https://github.com/zebulon2/rtl8812au / https://aur.archlinux.org/packages/rtl8812au-v5-dkms-git/
2 #
3 # Conditional build:
4 %bcond_with     verbose         # verbose build (V=1)
5
6 # nothing to be placed to debuginfo package
7 %define         _enable_debug_packages  0
8
9 %define         rel     16
10 %define         snap    20140901
11 %define         pname   rtl8812au
12 Summary:        Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter
13 Name:           %{pname}%{_alt_kernel}
14 Version:        4.3.2_11100.20140411
15 Release:        0.%{snap}.%{rel}%{?_pld_builder:@%{_kernel_ver_str}}
16 License:        GPL
17 Group:          Base/Kernel
18 #Source0:       https://github.com/abperiasamy/rtl8812AU_8821AU_linux/archive/master/%{name}-%{version}-%{snap}.tar.gz
19 Source0:        https://github.com/austinmarton/rtl8812au_linux/archive/master/%{pname}-%{version}-%{snap}.tar.gz
20 # Source0-md5:  693825ab344b68a1217f20ab8dd98b82
21 # good luck finding this chip on Realtek website :/
22 #URL:           http://www.realtek.com.tw/
23 URL:            https://github.com/austinmarton/rtl8812au_linux
24 Patch0:         linux-3.11.patch
25 Patch1:         disable-debug.patch
26 Patch2:         enable-cfg80211-support.patch
27 Patch3:         update-cfg80211-support.patch
28 Patch4:         warnings.patch
29 Patch5:         gcc-4.9.patch
30 Patch6:         linux-3.18.patch
31 Patch7:         linux-4.0.patch
32 Patch8:         linux-4.1.patch
33 Patch9:         linux-4.2.patch
34 Patch10:        linux-4.3.patch
35 Patch11:        linux-4.6.patch
36 Patch12:        linux-4.7.patch
37 Patch13:        linux-4.8.patch
38 Patch14:        linux-4.11.patch
39 Patch15:        linux-4.11.9.patch
40 Patch16:        linux-4.12.patch
41 BuildRequires:  rpmbuild(macros) >= 1.701
42 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
43 BuildRoot:      %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
44
45 %description
46 Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter.
47
48 %define kernel_pkg()\
49 %package -n kernel%{_alt_kernel}-net-rtl8812au\
50 Summary:        Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
51 Release:        %{rel}@%{_kernel_ver_str}\
52 Group:          Base/Kernel\
53 Requires(post,postun):  /sbin/depmod\
54 %requires_releq_kernel\
55 Requires(postun):       %releq_kernel\
56 \
57 %description -n kernel%{_alt_kernel}-net-rtl8812au\
58 Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
59 \
60 %files -n kernel%{_alt_kernel}-net-rtl8812au\
61 %defattr(644,root,root,755)\
62 /lib/modules/%{_kernel_ver}/kernel/drivers/net/wireless/*.ko*\
63 \
64 %post   -n kernel%{_alt_kernel}-net-rtl8812au\
65 %depmod %{_kernel_ver}\
66 \
67 %postun -n kernel%{_alt_kernel}-net-rtl8812au\
68 %depmod %{_kernel_ver}\
69 %{nil}
70
71 %define build_kernel_pkg()\
72 %{__make} clean KVER=%{_kernel_ver} KSRC=%{_kernelsrcdir}\
73 %{__make} modules KVER=%{_kernel_ver} KSRC=%{_kernelsrcdir}\
74 %install_kernel_modules -D installed -m 8812au -d kernel/drivers/net/wireless\
75 %{nil}
76
77 %{expand:%create_kernel_packages}
78
79 %prep
80 #%setup -q -n %{pname}-%{version}
81 %setup -q -n rtl8812au_linux-master
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p1
85 %patch3 -p1
86 %patch4 -p1
87 %patch5 -p1
88 %patch6 -p1
89 %patch7 -p1
90 %patch8 -p1
91 %patch9 -p1
92 %patch10 -p1
93 %patch11 -p1
94 %patch12 -p1
95 %patch13 -p1
96 %patch14 -p1
97 %patch15 -p1
98 %patch16 -p1
99
100 %build
101 %{expand:%build_kernel_packages}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT
106
107 cp -a installed/* $RPM_BUILD_ROOT
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
This page took 0.091552 seconds and 4 git commands to generate.