]> git.pld-linux.org Git - packages/rtl8812au.git/blob - rtl8812au.spec
- uppdated kernel modules build system
[packages/rtl8812au.git] / rtl8812au.spec
1 # Conditional build:
2 %bcond_with     verbose         # verbose build (V=1)
3
4 # nothing to be placed to debuginfo package
5 %define         _enable_debug_packages  0
6
7 %define         rel     5
8 %define         snap    20140901
9 %define         pname   rtl8812au
10 Summary:        Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter
11 Name:           %{pname}%{_alt_kernel}
12 Version:        4.3.2_11100.20140411
13 Release:        0.%{snap}.%{rel}%{?_pld_builder:@%{_kernel_ver_str}}
14 License:        GPL
15 Group:          Base/Kernel
16 #Source0:       https://github.com/abperiasamy/rtl8812AU_8821AU_linux/archive/master/%{name}-%{version}-%{snap}.tar.gz
17 Source0:        https://github.com/austinmarton/rtl8812au_linux/archive/master/%{name}-%{version}-%{snap}.tar.gz
18 # Source0-md5:  693825ab344b68a1217f20ab8dd98b82
19 # good luck finding this chip on Realtek website :/
20 #URL:           http://www.realtek.com.tw/
21 URL:            https://github.com/austinmarton/rtl8812au_linux
22 Patch0:         linux-3.11.patch
23 Patch1:         disable-debug.patch
24 Patch2:         enable-cfg80211-support.patch
25 Patch3:         update-cfg80211-support.patch
26 Patch4:         warnings.patch
27 Patch5:         gcc-4.9.patch
28 Patch6:         linux-3.18.patch
29 BuildRequires:  rpmbuild(macros) >= 1.701
30 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
31 BuildRoot:      %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
32
33 %description
34 Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter.
35
36 %define kernel_pkg()\
37 %package -n kernel%{_alt_kernel}-net-rtl8812au\
38 Summary:        Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
39 Release:        %{rel}@%{_kernel_ver_str}\
40 Group:          Base/Kernel\
41 Requires(post,postun):  /sbin/depmod\
42 %requires_releq_kernel\
43 Requires(postun):       %releq_kernel\
44 \
45 %description -n kernel%{_alt_kernel}-net-rtl8812au\
46 Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
47 \
48 %files -n kernel%{_alt_kernel}-net-rtl8812au\
49 %defattr(644,root,root,755)\
50 /lib/modules/%{_kernel_ver}/kernel/drivers/net/wireless/*.ko*\
51 \
52 %post   -n kernel%{_alt_kernel}-net-rtl8812au\
53 %depmod %{_kernel_ver}\
54 \
55 %postun -n kernel%{_alt_kernel}-net-rtl8812au\
56 %depmod %{_kernel_ver}\
57 %{nil}
58
59 %define build_kernel_pkg()\
60 %{__make} clean KVER=%{_kernel_ver} KSRC=%{_kernelsrcdir}\
61 %{__make} modules KVER=%{_kernel_ver} KSRC=%{_kernelsrcdir}\
62 %install_kernel_modules -D installed -m 8812au -d kernel/drivers/net/wireless\
63 %{nil}
64
65 %{expand:%create_kernel_packages}
66
67 %prep
68 #%setup -q -n %{pname}-%{version}
69 %setup -q -n rtl8812au_linux-master
70 %patch0 -p1
71 %patch1 -p1
72 %patch2 -p1
73 %patch3 -p1
74 %patch4 -p1
75 %patch5 -p1
76 %patch6 -p1
77
78 %build
79 %{expand:%build_kernel_packages}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT
84
85 cp -a installed/* $RPM_BUILD_ROOT
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
This page took 0.093519 seconds and 4 git commands to generate.