]> git.pld-linux.org Git - packages/rtl8812au.git/blob - rtl8812au.spec
96928cfd24662fbd4d606bab400499c406a2d048
[packages/rtl8812au.git] / rtl8812au.spec
1 # Conditional build:
2 %bcond_with     verbose         # verbose build (V=1)
3
4 # nothing to be placed to debuginfo package
5 %define         _enable_debug_packages  0
6
7 %define         rel     12
8 %define         snap    20140901
9 %define         pname   rtl8812au
10 Summary:        Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter
11 Name:           %{pname}%{_alt_kernel}
12 Version:        4.3.2_11100.20140411
13 Release:        0.%{snap}.%{rel}%{?_pld_builder:@%{_kernel_ver_str}}
14 License:        GPL
15 Group:          Base/Kernel
16 #Source0:       https://github.com/abperiasamy/rtl8812AU_8821AU_linux/archive/master/%{name}-%{version}-%{snap}.tar.gz
17 Source0:        https://github.com/austinmarton/rtl8812au_linux/archive/master/%{pname}-%{version}-%{snap}.tar.gz
18 # Source0-md5:  693825ab344b68a1217f20ab8dd98b82
19 # good luck finding this chip on Realtek website :/
20 #URL:           http://www.realtek.com.tw/
21 URL:            https://github.com/austinmarton/rtl8812au_linux
22 Patch0:         linux-3.11.patch
23 Patch1:         disable-debug.patch
24 Patch2:         enable-cfg80211-support.patch
25 Patch3:         update-cfg80211-support.patch
26 Patch4:         warnings.patch
27 Patch5:         gcc-4.9.patch
28 Patch6:         linux-3.18.patch
29 Patch7:         linux-4.0.patch
30 Patch8:         linux-4.1.patch
31 Patch9:         linux-4.2.patch
32 Patch10:        linux-4.3.patch
33 Patch11:        linux-4.6.patch
34 Patch12:        linux-4.7.patch
35 BuildRequires:  rpmbuild(macros) >= 1.701
36 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
37 BuildRoot:      %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
38
39 %description
40 Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter.
41
42 %define kernel_pkg()\
43 %package -n kernel%{_alt_kernel}-net-rtl8812au\
44 Summary:        Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
45 Release:        %{rel}@%{_kernel_ver_str}\
46 Group:          Base/Kernel\
47 Requires(post,postun):  /sbin/depmod\
48 %requires_releq_kernel\
49 Requires(postun):       %releq_kernel\
50 \
51 %description -n kernel%{_alt_kernel}-net-rtl8812au\
52 Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
53 \
54 %files -n kernel%{_alt_kernel}-net-rtl8812au\
55 %defattr(644,root,root,755)\
56 /lib/modules/%{_kernel_ver}/kernel/drivers/net/wireless/*.ko*\
57 \
58 %post   -n kernel%{_alt_kernel}-net-rtl8812au\
59 %depmod %{_kernel_ver}\
60 \
61 %postun -n kernel%{_alt_kernel}-net-rtl8812au\
62 %depmod %{_kernel_ver}\
63 %{nil}
64
65 %define build_kernel_pkg()\
66 %{__make} clean KVER=%{_kernel_ver} KSRC=%{_kernelsrcdir}\
67 %{__make} modules KVER=%{_kernel_ver} KSRC=%{_kernelsrcdir}\
68 %install_kernel_modules -D installed -m 8812au -d kernel/drivers/net/wireless\
69 %{nil}
70
71 %{expand:%create_kernel_packages}
72
73 %prep
74 #%setup -q -n %{pname}-%{version}
75 %setup -q -n rtl8812au_linux-master
76 %patch0 -p1
77 %patch1 -p1
78 %patch2 -p1
79 %patch3 -p1
80 %patch4 -p1
81 %patch5 -p1
82 %patch6 -p1
83 %patch7 -p1
84 %patch8 -p1
85 %patch9 -p1
86 %patch10 -p1
87 %patch11 -p1
88 %patch12 -p1
89
90 %build
91 %{expand:%build_kernel_packages}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT
96
97 cp -a installed/* $RPM_BUILD_ROOT
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
This page took 0.036475 seconds and 2 git commands to generate.