]> git.pld-linux.org Git - packages/rsync.git/commitdiff
- removed requires rsh - this is optional feature, but rsync complains
authorPaweł Gołaszewski <blues@pld-linux.org>
Thu, 16 Jan 2003 09:28:22 +0000 (09:28 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  about missing rsh - to be fixed
- added rsyncd-standalone package

Changed files:
    rsync.spec -> 1.62

rsync.spec

index ab34837685455139f860d0296ccccacf18d61088..4323b11bf7af7c3bd00d9d7365507258c3df3e7e 100644 (file)
@@ -13,11 +13,12 @@ License:    GPL
 Group:         Daemons
 Source0:       http://rsync.samba.org/ftp/rsync/%{name}-%{version}.tar.gz
 Source1:       %{name}.inet
+Source2:       %{name}.init
+Source3:       %{name}.sysconfig
 Patch0:                %{name}-config.patch
 Patch1:                %{name}-man.patch
 BuildRequires: autoconf
 BuildRequires: popt-devel
-Requires:      rsh
 URL:           http://samba.anu.edu.au/rsync/
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -74,14 +75,17 @@ rsync - 
 × ËÏÍÐÒÅÓÏ×ÁÎÏÍÕ ×ÉĦ. ðÒÉ ÃØÏÍÕ ÚÏ×Ӧ͠ÎÅ ÏÂÏ×'ÑÚËÏ×Ï, ÝÏ ÏÄÎÁ
 ÍÁÛÉÎÁ ÍÁÌÁ × ÓÅÂÅ ËÏЦÀ ÔÏÇÏ, ÝÏ ¤ ÎÁ ¦ÎۦʠÍÁÛÉΦ.
 
-%package -n rsyncd
+%package -n rsyncd-inetd
 Summary:       Files necessary to run rsync in daemon mode
 Summary(pl):   Pliki niezbêdne do uruchomienia rsynca w trybie serwera
 Group:         Daemons
 Requires:      %{name}
 Requires:      rc-inetd
+Provides:      rsyncd
+Obsoletes:     rsyncd
+Obsoletes:     rsyncd-standalone
 
-%description -n rsyncd
+%description -n rsyncd-inetd
 rsync is a replacement for rcp that has many more features.
 
 rsync uses the "rsync algorithm" which provides a very fast method for
@@ -92,7 +96,32 @@ sets of files are present at one of the ends of the link beforehand.
 A technical report describing the rsync algorithm is included with
 this package.
 
-%description -n rsyncd -l pl
+%description -n rsyncd-inetd -l pl
+Rsync jest zamiennikiem programu rcp z bardziej rozbudowan± sk³adni±
+poleceñ. Program ten u¿ywa efektywnego algorytmu "rsync" w czasie
+komunikacji i transportu plików do systemu zdalnego. Dokumentacja
+techniczna nowego algorytmu zosta³a równie¿ do³±czona do pakietu.
+
+%package -n rsyncd-standalone
+Summary:       Files necessary to run rsync in daemon mode
+Summary(pl):   Pliki niezbêdne do uruchomienia rsynca w trybie serwera
+Group:         Daemons
+Requires:      %{name}
+Provides:      rsyncd
+Obsoletes:     rsyncd-inetd
+
+%description -n rsyncd-standalone
+rsync is a replacement for rcp that has many more features.
+
+rsync uses the "rsync algorithm" which provides a very fast method for
+bringing remote files into sync. It does this by sending just the
+differences in the files across the link, without requiring that both
+sets of files are present at one of the ends of the link beforehand.
+
+A technical report describing the rsync algorithm is included with
+this package.
+
+%description -n rsyncd-standalone -l pl
 Rsync jest zamiennikiem programu rcp z bardziej rozbudowan± sk³adni±
 poleceñ. Program ten u¿ywa efektywnego algorytmu "rsync" w czasie
 komunikacji i transportu plików do systemu zdalnego. Dokumentacja
@@ -118,25 +147,43 @@ rm -rf $RPM_BUILD_ROOT
        mandir=$RPM_BUILD_ROOT%{_mandir} \
        bindir=$RPM_BUILD_ROOT%{_bindir}
 
-install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/sysconfig/rc-inetd}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{sysconfig/rc-inetd,rc.d/init.d}}
 
 :> $RPM_BUILD_ROOT%{_sysconfdir}/rsyncd.conf
 :> $RPM_BUILD_ROOT%{_sysconfdir}/rsyncd.secrets
 
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/rsyncd
+install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rsyncd
+install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/rsyncd
 
-%post -n rsyncd
+%post -n rsyncd-inetd
 if [ -f /var/lock/subsys/rc-inetd ]; then
         /etc/rc.d/init.d/rc-inetd restart 1>&2
 else
         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
 fi
 
-%postun -n rsyncd
+%postun -n rsyncd-inetd
 if [ "$1" = "0" -a -f /var/lock/subsys/rc-inetd ]; then
        /etc/rc.d/init.d/rc-inetd reload 1>&2
 fi
 
+%post -n rsyncd-standalone
+/sbin/chkconfig --add rsyncd
+if [ -f /var/lock/subsys/rsyncd ]; then
+       /etc/rc.d/init.d/rsyncd restart 1>&2
+else
+       echo "Type \"/etc/rc.d/init.d/rsyncd start\" to start rsync server" 1>&2
+fi
+
+%postun -n rsyncd-standalone
+if [ "$1" = "0" ]; then
+       if [ -f /var/lock/subsys/rsyncd ]; then
+               /etc/rc.d/init.d/rsyncd stop 1>&2
+       fi
+       /sbin/chkconfig --del rsyncd
+fi
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -146,10 +193,19 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/*
 %{_mandir}/man1/*
 
-%files -n rsyncd
+%files -n rsyncd-inetd
 %defattr(644,root,root,755)
 %dir %{_sysconfdir}
 %attr(640,root,root) %config(noreplace) %{_sysconfdir}/rsyncd.conf
 %attr(640,root,root) %config(noreplace) %{_sysconfdir}/rsyncd.secrets
 %attr(640,root,root) /etc/sysconfig/rc-inetd/rsyncd
 %{_mandir}/man5/*
+
+%files -n rsyncd-standalone
+%defattr(644,root,root,755)
+%dir %{_sysconfdir}
+%attr(640,root,root) %config(noreplace) %{_sysconfdir}/rsyncd.conf
+%attr(640,root,root) %config(noreplace) %{_sysconfdir}/rsyncd.secrets
+%attr(640,root,root) %config(noreplace) /etc/sysconfig/rsyncd
+%attr(755,root,root) /etc/rc.d/init.d/rsyncd
+%{_mandir}/man5/*
This page took 0.041777 seconds and 4 git commands to generate.