]> git.pld-linux.org Git - packages/rstudio.git/blob - rstudio.spec
abecf7f75e58acceb967348a1f7c4857edbc960c
[packages/rstudio.git] / rstudio.spec
1 Summary:        IDE for R
2 Summary(pl.UTF-8):      IDE dla R
3 Name:           rstudio
4 Version:        1.1.142
5 Release:        0.1
6 License:        AGPLv3
7 Group:          Applications
8 Source0:        https://github.com/rstudio/rstudio/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
9 # Source0-md5:  4209bf5cfa815416aaab54b2afc528cc
10 Source1:        https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip
11 # Source1-md5:  0e03798b8e53096c4a906bde05e32378
12 Source2:        https://s3.amazonaws.com/rstudio-buildtools/gwt-2.7.0.zip
13 # Source2-md5:  a8f3704a597b392910ea060284f21a03
14 Source3:        https://s3.amazonaws.com/rstudio-buildtools/gin-1.5.zip
15 # Source3-md5:  2409168cc18bf5f341e107e6887fe359
16 Source4:        https://s3.amazonaws.com/rstudio-buildtools/mathjax-26.zip
17 # Source4-md5:  94fcab0aead8f730cd21e26dcb5a330d
18 Source5:        https://s3.amazonaws.com/rstudio-buildtools/pandoc-1.12.4.2.zip
19 # Source5-md5:  d0f7e3d23b42cb9d26d2783d659040cf
20 Source6:        https://s3.amazonaws.com/rstudio-buildtools/libclang-3.5.zip
21 # Source6-md5:  cf1a43d2d6203a765ef16d7b12382c8a
22 Source7:        https://s3.amazonaws.com/rstudio-buildtools/libclang-builtin-headers.zip
23 # Source7-md5:  e6790a3ee6c371968eba865fc0a84daf
24 Source8:        packrat_0.4.1.24_bbdab984134678db91b8f372e2550e59f266de37.tar.xz
25 # Source8-md5:  7607927c4adf507d67d2ba18d38c7bb0
26 Source9:        rmarkdown_1.4.0.9001_b7434dcc5abe87cb27f01cbffb9ca94e1539d322.tar.xz
27 # Source9-md5:  3555af924d08fa900789c61eaa837087
28 Source10:       shinyapps_0.3.61_d3ab9e1cdd02f0067d69fe6fc816a61c8a5f2218.tar.xz
29 # Source10-md5: 3f5ce12f86b00a2e77067d7769fffe08
30 Source11:       rsconnect_0.7.0-2_fa486121f8f75701e2044f33d2901e610160322f.tar.xz
31 # Source11-md5: 938ca5efbed1ead619de42488ed30760
32 Patch0:         boost-moc.patch
33 URL:            http://rstudio.org/
34 BuildRequires:  Qt5WebKit-devel
35 BuildRequires:  Qt5XmlPatterns-devel
36 BuildRequires:  R >= 2.11.1
37 BuildRequires:  boost-devel >= 1.50
38 BuildRequires:  clang-devel >= 3.5.0
39 BuildRequires:  cmake >= 2.8.0
40 BuildRequires:  java-junit
41 BuildRequires:  openssl-devel
42 BuildRequires:  pam-devel
43 BuildRequires:  pandoc
44 BuildRequires:  pango-devel
45 Requires:       R >= 2.11.1
46 Requires:       pandoc
47 Requires:       clang >= 3.5.0
48 ExclusiveArch:  %{ix86} %{x8664}
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 RStudio(tm) is a free and open source integrated development
53 environment (IDE) for R. You can run it on your desktop (Windows, Mac,
54 or Linux) or even over the web using RStudio Server.
55
56 %prep
57 %setup -q
58 mkdir -p dependencies/common/dictionaries
59 unzip -qq %{SOURCE1} -d dependencies/common/dictionaries
60 mkdir -p src/gwt/lib/gwt
61 mkdir -p src/gwt/lib/gin/1.5
62 unzip -qq %{SOURCE2} -d src/gwt/lib/gwt
63 unzip -qq %{SOURCE3} -d src/gwt/lib/gin/1.5
64 %{__mv} src/gwt/lib/gwt/gwt-2.7.0 src/gwt/lib/gwt/2.7.0
65 unzip -qq %{SOURCE4} -d dependencies/common
66
67 xz -dc %{SOURCE8} | tar xf - -C dependencies/common/
68 xz -dc %{SOURCE9} | tar xf - -C dependencies/common/
69 xz -dc %{SOURCE10} | tar xf - -C dependencies/common/
70 xz -dc %{SOURCE11} | tar xf - -C dependencies/common/
71
72 # fix building with boost 1.56
73 # specify that namespace core is in the global namespace and not
74 # relative to some other namespace (like its ::core not ::boost::core)
75 find . \( -name *.cpp -or -name *.hpp \) -exec sed \
76         -e 's@<core::@< ::core::@g' -e 's@\([^:]\)core::@\1::core::@g' -i {} \;
77
78 # rstudio wants 1.12.4.2, let it think that
79 mkdir -p dependencies/common/pandoc/1.12.4.2
80 ln -s %{_bindir}/pandoc dependencies/common/pandoc/1.12.4.2/pandoc
81 ln -s %{_bindir}/pandoc dependencies/common/pandoc/1.12.4.2/pandoc-static
82
83 mkdir -p dependencies/common/libclang/3.5/include/
84 ln -s /usr/include/clang-c dependencies/common/libclang/3.5/include/
85 mkdir -p dependencies/common/libclang/builtin-headers
86 ln -s /usr/lib64/clang/3.5.0/include dependencies/common/libclang/builtin-headers/3.5
87 #dependencies/common/libclang/builtin-headers/libc++/3.5
88 %ifarch %{ix86}
89 mkdir -p dependencies/common/libclang/3.5/linux/x86
90 ln -s %{_libdir}/libclang.so dependencies/common/libclang/3.5/linux/x86/libclang.so
91 %endif
92 %ifarch %{x8664}
93 mkdir -p dependencies/common/libclang/3.5/linux/x86_64
94 ln -s %{_libdir}/libclang.so dependencies/common/libclang/3.5/linux/x86_64/libclang.so
95 %endif
96
97 %patch0 -p1
98
99 %build
100 install -d build
101 cd build
102 %cmake \
103         -DQT_QMAKE_EXECUTABLE=/usr/bin/qt5-qmake \
104         -DCMAKE_CXX_FLAGS_RELEASE="${CXXFLAGS:-%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG}" \
105         -DCMAKE_C_FLAGS_RELEASE="${CFLAGS:-%{rpmcflags} -DNDEBUG -DQT_NO_DEBUG}" \
106         -DRSTUDIO_TARGET=Desktop \
107         -DCMAKE_BUILD_TYPE=Release \
108         -DCMAKE_INSTALL_PREFIX=%{_libdir}/%{name} \
109         ../
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT%{_bindir}
116
117 %{__make} -C build install/fast \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 ln -s %{_libdir}/%{name}/bin/rstudio $RPM_BUILD_ROOT%{_bindir}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(644,root,root,755)
127 %doc COPYING NOTICE README.md
128 %attr(755,root,root) %{_bindir}/*
129 %dir %{_libdir}/%{name}
130 %{_libdir}/%{name}/R
131 %dir %{_libdir}/%{name}/bin
132 %attr(755,root,root) %{_libdir}/%{name}/bin/diagnostics
133 %attr(755,root,root) %{_libdir}/%{name}/bin/r*
134 %dir %{_libdir}/%{name}/bin/postback
135 %attr(755,root,root) %{_libdir}/%{name}/bin/postback/*
136 %attr(755,root,root) %{_libdir}/%{name}/bin/pandoc*
137 %{_libdir}/%{name}/resources
138 %{_libdir}/%{name}/www
139 %{_libdir}/%{name}/www-symbolmaps
140 %{_libdir}/%{name}/rstudio.png
141 %{_desktopdir}/rstudio.desktop
142 %{_iconsdir}/hicolor/*x*/apps/*
143 %{_iconsdir}/hicolor/*x*/mimetypes/*
144 %{_datadir}/mime/packages/*.xml
145 %{_pixmapsdir}/rstudio.png
This page took 0.128884 seconds and 2 git commands to generate.