]> git.pld-linux.org Git - packages/rstudio.git/blob - rstudio.spec
- disable build on on x86 archs
[packages/rstudio.git] / rstudio.spec
1 Summary:        IDE for R
2 Summary(pl.UTF-8):      IDE dla R
3 Name:           rstudio
4 Version:        0.99.39
5 Release:        5
6 License:        AGPLv3
7 Group:          Applications
8 Source0:        https://github.com/rstudio/rstudio/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
9 # Source0-md5:  8b340edf12a40806daafffad9e3849f0
10 Source1:        https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip
11 # Source1-md5:  0e03798b8e53096c4a906bde05e32378
12 Source2:        https://s3.amazonaws.com/rstudio-buildtools/gwt-2.6.0.zip
13 # Source2-md5:  b08b2b0c50ef2249703aa8422388d5db
14 Source3:        https://s3.amazonaws.com/rstudio-buildtools/gin-1.5.zip
15 # Source3-md5:  2409168cc18bf5f341e107e6887fe359
16 Source4:        https://s3.amazonaws.com/rstudio-buildtools/mathjax-23.zip
17 # Source4-md5:  5853c0494c6b28557d6b7cecaa790019
18 Source5:        https://s3.amazonaws.com/rstudio-buildtools/pandoc-1.12.4.2.zip
19 # Source5-md5:  d0f7e3d23b42cb9d26d2783d659040cf
20 Source6:        https://s3.amazonaws.com/rstudio-buildtools/libclang-3.5.zip
21 # Source6-md5:  cf1a43d2d6203a765ef16d7b12382c8a
22 Source7:        https://s3.amazonaws.com/rstudio-buildtools/libclang-builtin-headers.zip
23 # Source7-md5:  e6790a3ee6c371968eba865fc0a84daf
24 Source8:        packrat_0.4.1.24_bbdab984134678db91b8f372e2550e59f266de37.tar.xz
25 # Source8-md5:  7607927c4adf507d67d2ba18d38c7bb0
26 Source9:        rmarkdown_0.3.12_8a78f712202263200f2110ec8aa24a55c2726e37.tar.xz
27 # Source9-md5:  358f9f4bf2f35dd58d4771f6b24d252e
28 Source10:       shinyapps_0.3.61_d3ab9e1cdd02f0067d69fe6fc816a61c8a5f2218.tar.xz
29 # Source10-md5: 3f5ce12f86b00a2e77067d7769fffe08
30 Patch0:         boost-moc.patch
31 URL:            http://rstudio.org/
32 BuildRequires:  QtWebKit-devel
33 BuildRequires:  QtXmlPatterns-devel
34 BuildRequires:  R >= 2.11.1
35 BuildRequires:  boost-devel >= 1.50
36 BuildRequires:  clang-devel >= 3.5.0
37 BuildRequires:  cmake >= 2.8.0
38 BuildRequires:  java-junit
39 BuildRequires:  openssl-devel
40 BuildRequires:  pam-devel
41 BuildRequires:  pandoc
42 BuildRequires:  pango-devel
43 Requires:       R >= 2.11.1
44 Requires:       pandoc
45 Requires:       clang >= 3.5.0
46 ExclusiveArch:  %{ix86} %{x8664}
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 RStudio(tm) is a free and open source integrated development
51 environment (IDE) for R. You can run it on your desktop (Windows, Mac,
52 or Linux) or even over the web using RStudio Server.
53
54 %prep
55 %setup -q
56 mkdir -p dependencies/common/dictionaries
57 unzip -qq %{SOURCE1} -d dependencies/common/dictionaries
58 mkdir -p src/gwt/lib/gwt
59 mkdir -p src/gwt/lib/gin/1.5
60 unzip -qq %{SOURCE2} -d src/gwt/lib/gwt
61 unzip -qq %{SOURCE3} -d src/gwt/lib/gin/1.5
62 %{__mv} src/gwt/lib/gwt/gwt-2.6.0 src/gwt/lib/gwt/2.6.0
63 unzip -qq %{SOURCE4} -d dependencies/common
64
65 xz -dc %{SOURCE8} | tar xf - -C dependencies/common/
66 xz -dc %{SOURCE9} | tar xf - -C dependencies/common/
67 xz -dc %{SOURCE10} | tar xf - -C dependencies/common/
68
69 # fix building with boost 1.56
70 # specify that namespace core is in the global namespace and not
71 # relative to some other namespace (like its ::core not ::boost::core)
72 find . \( -name *.cpp -or -name *.hpp \) -exec sed \
73         -e 's@<core::@< ::core::@g' -e 's@\([^:]\)core::@\1::core::@g' -i {} \;
74
75 # rstudio wants 1.12.4.2, let it think that
76 mkdir -p dependencies/common/pandoc/1.12.4.2
77 ln -s %{_bindir}/pandoc dependencies/common/pandoc/1.12.4.2/pandoc
78 ln -s %{_bindir}/pandoc dependencies/common/pandoc/1.12.4.2/pandoc-static
79
80 mkdir -p dependencies/common/libclang/3.5/include/
81 ln -s /usr/include/clang-c dependencies/common/libclang/3.5/include/
82 mkdir -p dependencies/common/libclang/builtin-headers
83 ln -s /usr/lib64/clang/3.5.0/include dependencies/common/libclang/builtin-headers/3.5
84 #dependencies/common/libclang/builtin-headers/libc++/3.5
85 %ifarch %{ix86}
86 mkdir -p dependencies/common/libclang/3.5/linux/x86
87 ln -s %{_libdir}/libclang.so dependencies/common/libclang/3.5/linux/x86/libclang.so
88 %endif
89 %ifarch %{x8664}
90 mkdir -p dependencies/common/libclang/3.5/linux/x86_64
91 ln -s %{_libdir}/libclang.so dependencies/common/libclang/3.5/linux/x86_64/libclang.so
92 %endif
93
94 %patch0 -p1
95
96 %build
97 install -d build
98 cd build
99 %cmake \
100         -DCMAKE_CXX_FLAGS_RELEASE="${CXXFLAGS:-%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG}" \
101         -DCMAKE_C_FLAGS_RELEASE="${CFLAGS:-%{rpmcflags} -DNDEBUG -DQT_NO_DEBUG}" \
102         -DRSTUDIO_TARGET=Desktop \
103         -DCMAKE_BUILD_TYPE=Release \
104         -DCMAKE_INSTALL_PREFIX=%{_libdir}/%{name} \
105         ../
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT%{_bindir}
112
113 %{__make} -C build install/fast \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 ln -s %{_libdir}/%{name}/bin/rstudio $RPM_BUILD_ROOT%{_bindir}
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files
122 %defattr(644,root,root,755)
123 %doc COPYING NOTICE README.md
124 %attr(755,root,root) %{_bindir}/*
125 %dir %{_libdir}/%{name}
126 %{_libdir}/%{name}/R
127 %dir %{_libdir}/%{name}/bin
128 %attr(755,root,root) %{_libdir}/%{name}/bin/diagnostics
129 %attr(755,root,root) %{_libdir}/%{name}/bin/r*
130 %dir %{_libdir}/%{name}/bin/postback
131 %attr(755,root,root) %{_libdir}/%{name}/bin/postback/*
132 %attr(755,root,root) %{_libdir}/%{name}/bin/pandoc*
133 %{_libdir}/%{name}/resources
134 %{_libdir}/%{name}/www
135 %{_libdir}/%{name}/www-symbolmaps
136 %{_libdir}/%{name}/rstudio.png
137 %{_desktopdir}/rstudio.desktop
138 %{_iconsdir}/hicolor/*x*/apps/*
139 %{_iconsdir}/hicolor/*x*/mimetypes/*
140 %{_datadir}/mime/packages/*.xml
141 %{_pixmapsdir}/rstudio.png
This page took 0.384211 seconds and 3 git commands to generate.