]> git.pld-linux.org Git - packages/rstudio.git/blob - rstudio.spec
- up to 1.1.143
[packages/rstudio.git] / rstudio.spec
1 Summary:        IDE for R
2 Summary(pl.UTF-8):      IDE dla R
3 Name:           rstudio
4 Version:        1.1.143
5 Release:        1
6 License:        AGPLv3
7 Group:          Applications
8 Source0:        https://github.com/rstudio/rstudio/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
9 # Source0-md5:  ae531eed17e70a6d4f2d8560696b466e
10 Source1:        https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip
11 # Source1-md5:  0e03798b8e53096c4a906bde05e32378
12 Source2:        https://s3.amazonaws.com/rstudio-buildtools/gwt-2.7.0.zip
13 # Source2-md5:  a8f3704a597b392910ea060284f21a03
14 Source3:        https://s3.amazonaws.com/rstudio-buildtools/gin-1.5.zip
15 # Source3-md5:  2409168cc18bf5f341e107e6887fe359
16 Source4:        https://s3.amazonaws.com/rstudio-buildtools/mathjax-26.zip
17 # Source4-md5:  94fcab0aead8f730cd21e26dcb5a330d
18 Source5:        https://s3.amazonaws.com/rstudio-buildtools/pandoc-1.12.4.2.zip
19 # Source5-md5:  d0f7e3d23b42cb9d26d2783d659040cf
20 Source6:        https://s3.amazonaws.com/rstudio-buildtools/libclang-3.5.zip
21 # Source6-md5:  cf1a43d2d6203a765ef16d7b12382c8a
22 Source7:        https://s3.amazonaws.com/rstudio-buildtools/libclang-builtin-headers.zip
23 # Source7-md5:  e6790a3ee6c371968eba865fc0a84daf
24 Source8:        packrat_0.4.1.24_bbdab984134678db91b8f372e2550e59f266de37.tar.xz
25 # Source8-md5:  7607927c4adf507d67d2ba18d38c7bb0
26 Source9:        rmarkdown_1.4.0.9001_b7434dcc5abe87cb27f01cbffb9ca94e1539d322.tar.xz
27 # Source9-md5:  3555af924d08fa900789c61eaa837087
28 Source10:       shinyapps_0.3.61_d3ab9e1cdd02f0067d69fe6fc816a61c8a5f2218.tar.xz
29 # Source10-md5: 3f5ce12f86b00a2e77067d7769fffe08
30 Source11:       rsconnect_0.7.0-2_fa486121f8f75701e2044f33d2901e610160322f.tar.xz
31 # Source11-md5: 938ca5efbed1ead619de42488ed30760
32 URL:            http://rstudio.org/
33 BuildRequires:  Qt5WebKit-devel
34 BuildRequires:  Qt5XmlPatterns-devel
35 BuildRequires:  R >= 2.11.1
36 BuildRequires:  boost-devel >= 1.50
37 BuildRequires:  clang-devel >= 3.5.0
38 BuildRequires:  cmake >= 2.8.0
39 BuildRequires:  java-junit
40 BuildRequires:  openssl-devel
41 BuildRequires:  pam-devel
42 BuildRequires:  pandoc
43 BuildRequires:  pango-devel
44 Requires:       R >= 2.11.1
45 Requires:       pandoc
46 Requires:       clang >= 3.5.0
47 ExclusiveArch:  %{ix86} %{x8664}
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 RStudio(tm) is a free and open source integrated development
52 environment (IDE) for R. You can run it on your desktop (Windows, Mac,
53 or Linux) or even over the web using RStudio Server.
54
55 %prep
56 %setup -q
57 mkdir -p dependencies/common/dictionaries
58 unzip -qq %{SOURCE1} -d dependencies/common/dictionaries
59 mkdir -p src/gwt/lib/gwt
60 mkdir -p src/gwt/lib/gin/1.5
61 unzip -qq %{SOURCE2} -d src/gwt/lib/gwt
62 unzip -qq %{SOURCE3} -d src/gwt/lib/gin/1.5
63 %{__mv} src/gwt/lib/gwt/gwt-2.7.0 src/gwt/lib/gwt/2.7.0
64 unzip -qq %{SOURCE4} -d dependencies/common
65
66 xz -dc %{SOURCE8} | tar xf - -C dependencies/common/
67 xz -dc %{SOURCE9} | tar xf - -C dependencies/common/
68 xz -dc %{SOURCE10} | tar xf - -C dependencies/common/
69 xz -dc %{SOURCE11} | tar xf - -C dependencies/common/
70
71 # rstudio wants 1.12.4.2, let it think that
72 mkdir -p dependencies/common/pandoc/1.12.4.2
73 ln -s %{_bindir}/pandoc dependencies/common/pandoc/1.12.4.2/pandoc
74 ln -s %{_bindir}/pandoc dependencies/common/pandoc/1.12.4.2/pandoc-static
75
76 mkdir -p dependencies/common/libclang/3.5/include/
77 ln -s /usr/include/clang-c dependencies/common/libclang/3.5/include/
78 mkdir -p dependencies/common/libclang/builtin-headers
79 ln -s /usr/lib64/clang/3.5.0/include dependencies/common/libclang/builtin-headers/3.5
80 #dependencies/common/libclang/builtin-headers/libc++/3.5
81 %ifarch %{ix86}
82 mkdir -p dependencies/common/libclang/3.5/linux/x86
83 ln -s %{_libdir}/libclang.so dependencies/common/libclang/3.5/linux/x86/libclang.so
84 %endif
85 %ifarch %{x8664}
86 mkdir -p dependencies/common/libclang/3.5/linux/x86_64
87 ln -s %{_libdir}/libclang.so dependencies/common/libclang/3.5/linux/x86_64/libclang.so
88 %endif
89
90 %build
91 install -d build
92 cd build
93 %cmake \
94         -DQT_QMAKE_EXECUTABLE=/usr/bin/qt5-qmake \
95         -DCMAKE_CXX_FLAGS_RELEASE="${CXXFLAGS:-%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG}" \
96         -DCMAKE_C_FLAGS_RELEASE="${CFLAGS:-%{rpmcflags} -DNDEBUG -DQT_NO_DEBUG}" \
97         -DRSTUDIO_TARGET=Desktop \
98         -DCMAKE_BUILD_TYPE=Release \
99         -DCMAKE_INSTALL_PREFIX=%{_libdir}/%{name} \
100         ../
101
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT%{_bindir}
107
108 %{__make} -C build install/fast \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 ln -s %{_libdir}/%{name}/bin/rstudio $RPM_BUILD_ROOT%{_bindir}
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(644,root,root,755)
118 %doc COPYING NOTICE README.md
119 %attr(755,root,root) %{_bindir}/*
120 %dir %{_libdir}/%{name}
121 %{_libdir}/%{name}/R
122 %dir %{_libdir}/%{name}/bin
123 %attr(755,root,root) %{_libdir}/%{name}/bin/diagnostics
124 %attr(755,root,root) %{_libdir}/%{name}/bin/r*
125 %dir %{_libdir}/%{name}/bin/postback
126 %attr(755,root,root) %{_libdir}/%{name}/bin/postback/*
127 %{_libdir}/%{name}/resources
128 %{_libdir}/%{name}/www
129 %{_libdir}/%{name}/www-symbolmaps
130 %{_libdir}/%{name}/rstudio.png
131 %{_desktopdir}/rstudio.desktop
132 %{_iconsdir}/hicolor/*x*/apps/*
133 %{_iconsdir}/hicolor/*x*/mimetypes/*
134 %{_datadir}/mime/packages/*.xml
135 %{_pixmapsdir}/rstudio.png
This page took 0.071446 seconds and 3 git commands to generate.