]> git.pld-linux.org Git - packages/rssh.git/commitdiff
- updated to 2.3.4
authorAdam Gołębiowski <adamg@pld-linux.org>
Tue, 9 Oct 2018 18:05:45 +0000 (20:05 +0200)
committerAdam Gołębiowski <adamg@pld-linux.org>
Tue, 9 Oct 2018 18:05:45 +0000 (20:05 +0200)
rssh-rsync-protocol.patch
rssh-userbuild.patch
rssh.spec

index dcd175bf8ab14b49d12c1b92147a0c9444cf6a3e..98096d9c6a2cf3699aeb812ab0be7315a5711c97 100644 (file)
@@ -62,17 +62,16 @@ index e576755..50a63e2 100644
   * check_command_line() - take the command line passed to rssh, and verify
   *                      that the specified command is one the user is
   *                      allowed to run.  Return the path of the command
-@@ -230,9 +258,9 @@ char *check_command_line( char *cl, ShellOptions_t *opts )
+@@ -258,7 +258,11 @@ char *check_command_line( char **cl, ShellOptions_t *opts )
  
-       if ( check_command(cl, opts, PATH_RSYNC, RSSH_ALLOW_RSYNC) ){
+       if ( check_command(*cl, opts, PATH_RSYNC, RSSH_ALLOW_RSYNC) ){
                /* filter -e option */
--              if ( opt_exist(cl, 'e') ){
-+              if ( opt_exist(cl, 'e') && !check_rsync_e(cl) ){
-                       fprintf(stderr, "\ninsecure -e option not allowed.");
--                      log_msg("insecure -e option in rdist command line!");
-+                      log_msg("insecure -e option in rsync command line!");
-                       return NULL;
-               }
-               
--- 
-tg: (05d6ee0..) fixes/rsync-protocol (depends on: upstream)
+-              if ( opt_filter(cl, 'e') ) return NULL;
++              if ( opt_filter(cl, 'e') && !check_rsync_e(cl) ) {
++                      fprintf(stderr, "\ninsecure -e without --server not allowed.");
++                      log_msg("insecure -e option without --server in rsync command line!");
++                      return NULL;
++              }
+               while (cl && *cl){
+                       if ( strstr(*cl, "--rsh" ) ){
+                               fprintf(stderr, "\ninsecure --rsh= not allowed.");
index 73764253fac63ec78215d39be8954e0d87bd6dcb..3871afb4039bf47177bd3c0795e19a6d6fd8d4b7 100644 (file)
@@ -1,14 +1,5 @@
 --- rssh-2.1.1/Makefile.am.orig        2003-09-15 07:49:52.000000000 +0200
 +++ rssh-2.1.1/Makefile.am     2003-09-15 07:55:22.000000000 +0200
-@@ -1,7 +1,7 @@
- ## Process this file with automake to produce Makefile.in
- AUTOMAKE_OPTIONS = nostdinc
- ourdefs = -DPATH_RSSH_CONFIG=\"@sysconfdir@/rssh.conf\" -DPATH_CHROOT_HELPER=\"@libexecdir@/rssh_chroot_helper\"
--CFLAGS = @defcflags@ @static@ 
-+AM_CFLAGS = @defcflags@ @static@ 
- bin_PROGRAMS = rssh
- libexec_PROGRAMS = rssh_chroot_helper
- nodist_rssh_SOURCES = main.c pathnames.h config.h
 @@ -15,9 +15,6 @@
  .c.o:
        $(CC) -c $(DEFS) $(ourdefs) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $<
index 1c92241e95bd03e7d75785f19860a476b4f002ec..5f7c267c2045b7502bfadc87694e2aceb39240c3 100644 (file)
--- a/rssh.spec
+++ b/rssh.spec
@@ -1,12 +1,12 @@
 Summary:       A restricted shell for assigning scp- or sftp-only access
 Summary(pl.UTF-8):     Okrojona powłoka dająca dostęp tylko do scp i/lub sftp
 Name:          rssh
-Version:       2.3.3
-Release:       4
+Version:       2.3.4
+Release:       1
 License:       BSD-like
 Group:         Applications/Shells
 Source0:       http://dl.sourceforge.net/rssh/%{name}-%{version}.tar.gz
-# Source0-md5: b0c147602fcc95737ed50573b92fc468
+# Source0-md5: 5211f5fe206704f813a3cec61f487042
 Patch0:                %{name}-userbuild.patch
 Patch1:                %{name}-mkchroot.patch
 Patch2:                %{name}-rsync-protocol.patch
@@ -53,6 +53,7 @@ install -d $RPM_BUILD_ROOT/bin
 %{__make} install \
         DESTDIR=$RPM_BUILD_ROOT
 
+mv -f $RPM_BUILD_ROOT%{_sysconfdir}/rssh.conf{.default,}
 ln -sf rssh $RPM_BUILD_ROOT%{_bindir}/scpsh
 ln -sf rssh $RPM_BUILD_ROOT%{_bindir}/sftpsh
 
@@ -61,6 +62,7 @@ ln -s %{_bindir}/%{name} $RPM_BUILD_ROOT/bin/%{name}
 ln -s %{_bindir}/scpsh $RPM_BUILD_ROOT/bin/scpsh
 ln -s %{_bindir}/sftpsh $RPM_BUILD_ROOT/bin/sftpsh
 
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -100,7 +102,7 @@ ln -sf %{_bindir}/sftpsh /bin/sftpsh
 %attr(755,root,root) %{_bindir}/%{name}
 %attr(755,root,root) %{_bindir}/scpsh
 %attr(755,root,root) %{_bindir}/sftpsh
-%attr(4755,root,root) %{_libdir}/rssh_chroot_helper
+%attr(4755,root,root) %{_libexecdir}/rssh_chroot_helper
 %{_mandir}/man?/*
 # legacy
 %ghost /bin/%{name}
This page took 0.098527 seconds and 4 git commands to generate.