]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- rpm4.1
authorMariusz Mazur <mmazur@pld-linux.org>
Fri, 18 Oct 2002 12:55:18 +0000 (12:55 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    rpm-bb-and-short-circuit.patch -> 1.2
    rpm-lt14d.patch -> 1.2

rpm-bb-and-short-circuit.patch [new file with mode: 0644]
rpm-lt14d.patch [new file with mode: 0644]

diff --git a/rpm-bb-and-short-circuit.patch b/rpm-bb-and-short-circuit.patch
new file mode 100644 (file)
index 0000000..7a40391
--- /dev/null
@@ -0,0 +1,11 @@
+--- rpm-4.1/rpmqv.c.sc Thu Sep 19 11:32:08 2002
++++ rpm-4.1/rpmqv.c    Thu Sep 19 11:38:45 2002
+@@ -685,6 +685,8 @@
+       case 'b':
+           ba->buildAmount |= RPMBUILD_PACKAGEBINARY;
+           ba->buildAmount |= RPMBUILD_CLEAN;
++          if ((ba->buildChar == 'b') && ba->shortCircuit)
++              /*@innerbreak@*/ break;
+           /*@fallthrough@*/
+       case 'i':
+           ba->buildAmount |= RPMBUILD_INSTALL;
diff --git a/rpm-lt14d.patch b/rpm-lt14d.patch
new file mode 100644 (file)
index 0000000..fed5f96
--- /dev/null
@@ -0,0 +1,23 @@
+--- rpm-4.0.4/rpmio/Makefile.am.orig   Tue May 21 19:07:54 2002
++++ rpm-4.0.4/rpmio/Makefile.am        Tue May 21 19:26:14 2002
+@@ -24,6 +24,7 @@
+ LIBS =        @LIBS@ @WITH_ZLIB_LIB@ -lrt -lpthread
+ BEECRYPTLOBJS = $(shell cat $(top_builddir)/beecrypt/listobjs)
++BEECRYPTOBJS = $(BEECRYPTLOBJS:%.lo=%.o)
+ lib_LTLIBRARIES = librpmio.la
+ librpmio_la_SOURCES = digest.c macro.c rpmio.c rpmlog.c rpmmalloc.c \
+@@ -45,6 +46,12 @@
+       for lo in $(BEECRYPTLOBJS); do \
+         [ -f $$lo ] || $(LN_S) $(top_builddir)/beecrypt/$$lo $$lo ; \
+       done
++      for lo in $(BEECRYPTOBJS) ; do \
++        [ ! -f $$lo -a -f $(top_builddir)/beecrypt/$$lo ] && $(LN_S) \
++              $(top_builddir)/beecrypt/$$lo $$lo ; \
++        [ ! -f .libs/$$lo -a -f $(top_builddir)/beecrypt/.libs/$$lo ] && $(LN_S) \
++              ../$(top_builddir)/beecrypt/.libs/$$lo .libs/$$lo ; \
++      done
+       touch $@
+ clean-local:
This page took 0.052861 seconds and 4 git commands to generate.