]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- removed namespace check in rpmal.c, it was unneccessary as the db52 auto/th/rpm-5.4.10-35.5
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 2 Dec 2012 13:58:56 +0000 (14:58 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 2 Dec 2012 13:58:56 +0000 (14:58 +0100)
  comparison was on unparsed names and broke name-to-provides check
  during upgrades
- rel .5

rpm-namespace-compare.patch
rpm.spec

index eeb38c891df0408ab2a76bcc1ea4d4c500d0aaa4..e38d8ddd3ae97fc6639d735a16cab0429164a7de 100644 (file)
@@ -196,40 +196,3 @@ diff -ur rpm-5.4.10/lib/depends.c rpm-5.4.10.nstype/lib/depends.c
      }
      if (rc && (ourrc = rc) >= terminate)
        goto exit;
-diff -ur rpm-5.4.10/lib/rpmal.c rpm-5.4.10.nstype/lib/rpmal.c
---- rpm-5.4.10/lib/rpmal.c     2012-04-15 23:20:57.000000000 +0200
-+++ rpm-5.4.10.nstype/lib/rpmal.c      2012-11-30 12:57:52.579432191 +0100
-@@ -61,6 +65,7 @@
-     alKey pkgKey;             /*!< Containing package. */
- /*@observer@*/
-     const char * entry;               /*!< Dependency name. */
-+    nsType entryNS;           /*!< Dependency namesapce. */
-     unsigned short entryLen;  /*!< No. of bytes in name. */
-     unsigned short entryIx;   /*!< Dependency index. */
-     indexEntryType_e type;    /*!< Type of available item. */
-@@ -271,6 +276,9 @@
-     if (lenchk)
-       return lenchk;
-+    if (a->entryNS != b->entryNS)
-+      return -1;
-+
-     return strcmp(a->entry, b->entry);
- }
-@@ -305,6 +313,7 @@
-       aie->pkgKey = pkgKey;
- /*@-assignexpose@*/
-       aie->entry = Name;
-+      aie->entryNS = rpmdsNSType(provides);
- /*@=assignexpose@*/
-       aie->entryLen = (unsigned short)strlen(Name);
-       ix = rpmdsIx(provides);
-@@ -421,6 +431,7 @@
-       memset(alloca(sizeof(*needle)), 0, sizeof(*needle));
-     /*@-assignexpose -temptrans@*/
-     needle->entry = KName;
-+    needle->entryNS = rpmdsNSType(ds);
-     /*@=assignexpose =temptrans@*/
-     needle->entryLen = (unsigned short)strlen(needle->entry);
index bfa3c756a5805c46621dccd9477d4d087e94cd6d..1fbf4f9640b6446d172f1c885f3805b3e82a91b7 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -52,7 +52,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       5.4.10
-Release:       35.4
+Release:       35.5
 License:       LGPL
 Group:         Base
 # http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.10-0.20120706.src.rpm
This page took 0.049094 seconds and 4 git commands to generate.