]> git.pld-linux.org Git - packages/rpm.git/commitdiff
removed patch lua-exit-chroot-correctly, applied upstream
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 22 Aug 2012 11:53:25 +0000 (13:53 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 22 Aug 2012 11:53:25 +0000 (13:53 +0200)
rpm-lua-exit-chroot-correctly.patch [deleted file]
rpm.spec

diff --git a/rpm-lua-exit-chroot-correctly.patch b/rpm-lua-exit-chroot-correctly.patch
deleted file mode 100644 (file)
index 8f90b16..0000000
+++ /dev/null
@@ -1,74 +0,0 @@
---- rpm-5.2.0/lib/psm.c        2009-07-07 23:12:33.000000000 +0200
-+++ rpm-5.2.0/lib/psm.c        2010-05-08 15:17:24.063904813 +0200
-@@ -576,17 +576,21 @@
- #endif        /* WITH_LUA */
- #if defined(WITH_LUA) || defined(WITH_FICL) || defined(WITH_JS) || defined(WITH_PERLEMBED) || defined(WITH_PYTHONEMBED) || defined(WITH_RUBYEMBED) || defined(WITH_TCL)
--static int enterChroot(rpmpsm psm, int * fdnop)
-+static int enterChroot(rpmpsm psm, int * pwdFdnop, int * rootFdnop)
-       /*@globals fileSystem, internalState @*/
--      /*@modifies *fdnop, fileSystem, internalState @*/
-+      /*@modifies *pwdFdnop, *rootFdnop, fileSystem, internalState @*/
- {
-     const rpmts ts = psm->ts;
-     int inChroot;
-     int xx;
-     /* Save the current working directory. */
--    if (fdnop)
--      (*fdnop) = open(".", O_RDONLY, 0);
-+    if (pwdFdnop)
-+      (*pwdFdnop) = open(".", O_RDONLY, 0);
-+
-+    /* Save the current root directory. */
-+    if (rootFdnop)
-+      (*rootFdnop) = open("/", O_RDONLY, 0);
-     /* Get into the chroot. */
-     if (!rpmtsChrootDone(ts)) {
-@@ -607,7 +611,7 @@
-     return inChroot;
- }
--static int exitChroot(rpmpsm psm, int inChroot, int rootFdno)
-+static int exitChroot(rpmpsm psm, int inChroot, int pwdFdno, int rootFdno)
-       /*@globals fileSystem, internalState @*/
-       /*@modifies fileSystem, internalState @*/
- {
-@@ -623,10 +627,12 @@
- /*@=modobserver@*/
-           xx = rpmtsSetChrootDone(ts, 0);
-       }
-+      xx = fchdir(pwdFdno);
-     } else
--      xx = fchdir(rootFdno);
-+      xx = fchdir(pwdFdno);
-     xx = close(rootFdno);
-+    xx = close(pwdFdno);
-     return 0;
- }
-@@ -648,11 +654,12 @@
-       /*@modifies psm, fileSystem, internalState @*/
- {
-     char * av[] = { NULL, NULL, NULL, NULL };
-+    int pwdFdno = -1;
-     int rootFdno = -1;
-     rpmRC rc = RPMRC_OK;
-     int xx = 0;
-     int * ssp = NULL;
--    int inChroot = enterChroot(psm, &rootFdno);
-+    int inChroot = enterChroot(psm, &pwdFdno, &rootFdno);
-     if (psm->sstates != NULL)
-       ssp = psm->sstates + tag2slx(psm->scriptTag);
-@@ -726,7 +733,7 @@
-       *ssp |= RPMSCRIPT_STATE_REAPED;
-     }
--    xx = exitChroot(psm, inChroot, rootFdno);
-+    xx = exitChroot(psm, inChroot, pwdFdno, rootFdno);
-     return rc;
- }
index 66b83266811647f27de55c8d1047dd89c6745f83..168596455a045388b7aced49b36062c1c39b4ec6 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -147,7 +147,6 @@ Patch59:    %{name}-libtool-deps.patch
 Patch60:       %{name}-mimetype.patch
 Patch61:       %{name}-sparc64.patch
 Patch62:       %{name}-gendiff.patch
-Patch63:       %{name}-lua-exit-chroot-correctly.patch
 Patch70:       %{name}-configure-autoconf.patch
 Patch72:       openmp.patch
 Patch73:       rpm-URPM-build-fix.patch
@@ -717,7 +716,6 @@ install %{SOURCE12} scripts/perl.prov
 %patch61 -p1
 %endif
 %patch62 -p1
-#patch63 -p1 applied upstream
 %patch70 -p1
 %patch72 -p1 -b .wiget
 %patch73 -p1
This page took 0.03901 seconds and 4 git commands to generate.