]> git.pld-linux.org Git - packages/rpm.git/commitdiff
fix autoreq for elf without exe bit during %install
authorJan Palus <atler@pld-linux.org>
Wed, 23 Mar 2022 10:52:33 +0000 (11:52 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 23 May 2022 15:29:23 +0000 (17:29 +0200)
no-exe-for-elf-req.patch [new file with mode: 0644]
rpm.spec

diff --git a/no-exe-for-elf-req.patch b/no-exe-for-elf-req.patch
new file mode 100644 (file)
index 0000000..3aa7b0f
--- /dev/null
@@ -0,0 +1,12 @@
+--- rpm-4.16.1.3/tools/elfdeps.c.orig  2020-05-28 12:04:25.084136944 +0200
++++ rpm-4.16.1.3/tools/elfdeps.c       2022-03-23 11:19:01.656202339 +0100
+@@ -300,7 +300,8 @@
+     if (ehdr->e_type == ET_DYN || ehdr->e_type == ET_EXEC) {
+       ei->marker = mkmarker(ehdr);
+       ei->isDSO = (ehdr->e_type == ET_DYN);
+-      ei->isExec = (st.st_mode & (S_IXUSR|S_IXGRP|S_IXOTH));
++      //ei->isExec = (st.st_mode & (S_IXUSR|S_IXGRP|S_IXOTH));
++      ei->isExec = 1;
+       processProgHeaders(ei, ehdr);
+       processSections(ei);
index 1884b7cd7d52a84bf7a999d544e9d4f427eec8d7..ccc0aa7c3f9faaa022914946087a74cf4ab4629f 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -92,6 +92,7 @@ Patch32:      noexpand.patch
 Patch34:       skip-symlinks.patch
 Patch35:       pl-po.patch
 Patch36:       build-locale.patch
+Patch37:       no-exe-for-elf-req.patch
 URL:           https://rpm.org/
 BuildRequires: acl-devel
 %{?with_audit:BuildRequires:   audit-libs-devel}
@@ -639,6 +640,7 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch34 -p1
 %patch35 -p1
 %patch36 -p1
+%patch37 -p1
 
 %{__rm} po/*.gmo
 
This page took 0.067611 seconds and 4 git commands to generate.