]> git.pld-linux.org Git - packages/rpm.git/commitdiff
GNUconfigure macro removed, prepare to integration with oryginal rpm
authorArtur Frysiak <artur@frysiak.net>
Mon, 27 Aug 2001 15:37:30 +0000 (15:37 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    rpm.macros -> 1.60

rpm.macros

index b6f613aeb2cac9266f2ca33a97c1ca875cf4bbad..fb7214925ccce4d8a0521195c39453a3bf04ba03 100644 (file)
@@ -1,3 +1,23 @@
+# PLD rpm macros
+
+%_defaultdocdir  %{_usr}/share/doc
+%_fixowner       [ `%{__id_u}` = '0' ] && %{__chown_Rhf} root.@ROOT_GROUP@
+%_fixgroup       true
+%_topdir         %(echo $HOME)/rpm
+%_exec_prefix    %{_prefix}
+%_bindir         %{_exec_prefix}/bin
+%_sbindir        %{_exec_prefix}/sbin
+%_libexecdir     %{_exec_prefix}/lib
+%_datadir        %{_prefix}/share
+%_sharedstatedir %{_prefix}/com
+%_lib            lib
+%_libdir         %{_exec_prefix}/%{_lib}
+%_includedir     %{_prefix}/include
+%_oldincludedir  /usr/include
+%_sysconfdir     /etc
+%_localstatedir  /var
+%_infodir        /usr/share/info
+%_mandir         %{_prefix}/share/man
 #-----------------------------------------------------------------
 # CFLAGS and LDFLAGS used to build
 
        --infodir=%{_infodir} \
 }
 
-#------------------------------------------------------------------------------
-# The GNUconfigure macro does the following:
-#       update config.guess and config.sub.
-#       regenerate all autoconf/automake files
-#       optionally change to a directory (make the directory if requested).
-#       run configure with correct prefix, platform, and CFLAGS.
-#       optionally restore current directory.
-#
-# Based on autogen.sh from GNOME and orginal GNUconfigure
-#
-%GNUconfigure(MCs:)      \
-  %{-C:_mydir="`pwd`"; %{-M: %{__mkdir} -p %{-C*};} cd %{-C*}} \
-  dirs="`find ${_mydir} -name configure.in -print`"; export dirs; \
-    for coin in `echo ${dirs}` \
-do \
-  dr=`dirname ${coin}`; \
-if test -f ${dr}/NO-AUTO-GEN; then \
- : \
-else \
-     macrodirs=`sed -n -e 's,AM_ACLOCAL_INCLUDE(\(.*\)),\1,gp' < ${coin}`; \
-    ( cd ${dr}; \
-      aclocalinclude="${ACLOCAL_FLAGS}"; \
-      for k in ${macrodirs}; do \
-        if test -d ${k}; then \
-          aclocalinclude="${aclocalinclude} -I ${k}"; \
-        ##else \
-        ##  echo "**Warning**: No such directory \`${k}'.  Ignored." \
-        fi \
-      done \
-      if grep "^AM_GNU_GETTEXT" configure.in >/dev/null; then \
-        if grep "sed.*POTFILES" configure.in >/dev/null; then \
-          : do nothing -- we still have an old unmodified configure.in \
-        else \
-          test -r ${dr}/aclocal.m4 || touch ${dr}/aclocal.m4; \
-          echo "no" | gettextize --force --copy; \
-          test -r ${dr}/aclocal.m4 && %{__chmod} u+w ${dr}/aclocal.m4; \
-        fi \
-      fi \
-      if grep "^AM_PROG_LIBTOOL" configure.in >/dev/null; then \
-        %{__libtoolize} --force --copy; \
-      fi \
-      aclocal ${aclocalinclude}; \
-      if grep "^AM_CONFIG_HEADER" configure.in >/dev/null; then \
-        %{__autoheader}; \
-      fi \
-      echo "Running automake --gnu ${am_opt} ..."; \
-      %{__automake} --add-missing --gnu ${am_opt}; \
-      %{__autoconf}; \
-    ); \
-  fi \
-done \
-  %{-C:${_mydir}}%{!-C:.}/%{configure} \
-  %{-C:cd ${_mydir}; unset _mydir}
-
 # Location of autoconf macros
 %_aclocaldir   %(aclocal --print-ac-dir)
 
This page took 0.138808 seconds and 4 git commands to generate.