]> git.pld-linux.org Git - packages/rpm.git/commitdiff
make -lib depend on elfutils-libs instead of elfutils; rel 7 master auto/th/rpm-4.17.1.1-7
authorJan Palus <atler@pld-linux.org>
Thu, 18 Apr 2024 12:19:45 +0000 (14:19 +0200)
committerJan Palus <atler@pld-linux.org>
Thu, 18 Apr 2024 12:19:45 +0000 (14:19 +0200)
perl-heredoc-matching.patch [new file with mode: 0644]
rpm.spec

diff --git a/perl-heredoc-matching.patch b/perl-heredoc-matching.patch
new file mode 100644 (file)
index 0000000..8ad0160
--- /dev/null
@@ -0,0 +1,39 @@
+From 73419594af15e94e77bae413d9754d3775cf0280 Mon Sep 17 00:00:00 2001
+From: Jan Palus <jpalus@fastmail.com>
+Date: Tue, 12 Dec 2023 19:45:54 +0100
+Subject: [PATCH] perl.req: make heredoc block matching more generic
+
+match any <<MARKER providing:
+
+- it is not in comment (not preceded by #)
+- it can't be string literal (not preceded by ' or ")
+- as a sanity check it must be preceded by either whitespace, comma or
+  equals sign
+
+adds support for
+
+   return <<"EOS";
+
+   fun(arg, <<"EOS");
+---
+ scripts/perl.req | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/scripts/perl.req b/scripts/perl.req
+index 1b50c50847..8bfa38771e 100755
+--- a/scripts/perl.req
++++ b/scripts/perl.req
+@@ -102,10 +102,10 @@ sub process_file {
+   while (<FILE>) {
+-    # skip the "= <<" block
++    # skip the heredoc block
+-    if (m/^\s*(?:my\s*)?\$(?:.*)\s*=\s*<<\s*(["'`])(.+?)\1/ ||
+-        m/^\s*(?:my\s*)?\$(.*)\s*=\s*<<(\w+)\s*;/) {
++    if (m/^[^'"#]+[\s,=(]<<\s*(["'`])(.+?)\1/ ||
++        m/^[^'"#]+[\s,=(](<<)(\w+)\s*;/) {
+       $tag = $2;
+       while (<FILE>) {
+         chomp;
index a986e7623ddee08419f3bee959b2f6e66e737d1a..4ebca67171db31f2dc25967808a5c42105df38b3 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -34,7 +34,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       4.17.1.1
-Release:       5
+Release:       7
 Epoch:         1
 License:       GPL v2 / LGPL v2.1
 Group:         Base
@@ -95,6 +95,7 @@ Patch36:      build-locale.patch
 Patch37:       no-exe-for-elf-req.patch
 Patch38:       gem-in-package-builddir.patch
 Patch39:       sqlite-log-crash.patch
+Patch40:       perl-heredoc-matching.patch
 URL:           https://rpm.org/
 BuildRequires: acl-devel
 %{?with_audit:BuildRequires:   audit-libs-devel}
@@ -243,8 +244,7 @@ Zawiera on:
 Summary:       RPMs library
 Summary(pl.UTF-8):     Biblioteki RPM-a
 Group:         Libraries
-Requires:      elfutils >= 0.159
-Requires:      elfutils-libelf >= 0.159
+Requires:      elfutils-libs >= 0.159
 Requires:      libmagic >= 1.15-2
 Requires:      popt >= %{popt_ver}
 Requires:      sqlite3-libs >= 3.22.0
@@ -675,6 +675,7 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch37 -p1
 %patch38 -p1
 %patch39 -p1
+%patch40 -p1
 
 %{__rm} po/*.gmo
 
This page took 0.075909 seconds and 4 git commands to generate.