]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- make triggerin behaviour (args values) comaptible with rpm4,
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 1 Dec 2012 20:08:13 +0000 (21:08 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 1 Dec 2012 20:08:13 +0000 (21:08 +0100)
  fixes problem with webapp triggers not being run by rpm5

rpm-triggerin-compat.patch [new file with mode: 0644]
rpm.spec

diff --git a/rpm-triggerin-compat.patch b/rpm-triggerin-compat.patch
new file mode 100644 (file)
index 0000000..6d4320c
--- /dev/null
@@ -0,0 +1,38 @@
+More detailed explanation:
+
+http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2012-December/023356.html
+
+On Dec 1, 2012, at 10:55 AM, Jeffrey Johnson <n3npq@me.com> wrote:
+
+> 
+> I'm inclined atm to prefer the above actual behavior to "fudging" an
+> extra +1 for "legacy compatible" behavior; I'm sure we disagree here.
+> 
+> Short answer: patch in an extra +1 (there will be two code paths in need
+> of patching, check for symmetry as above) if you wish "legacy compatible" behavior.
+> 
+
+This is likely all that is needed (untested):
+
+cvs diff rpm/lib/psm.c
+Index: rpm/lib/psm.c
+===================================================================
+RCS file: /v/rpm/cvs/rpm/lib/psm.c,v
+retrieving revision 2.399.2.5
+diff -p -u -w -r2.399.2.5 rpm/lib/psm.c
+--- rpm/lib/psm.c      19 Apr 2012 17:26:06 -0000      2.399.2.5
++++ rpm/lib/psm.c      1 Dec 2012 16:02:48 -0000
+@@ -2755,7 +2755,7 @@ assert(psm->te != NULL);
+           psm->scriptTag = RPMTAG_POSTIN;
+           psm->progTag = RPMTAG_POSTINPROG;
+           psm->sense = RPMSENSE_TRIGGERIN;
+-          psm->countCorrection = 0;
++          psm->countCorrection = 1;
+           if (!(rpmtsFlags(ts) & RPMTRANS_FLAG_NOPOST)) {
+               rc = (rpmRC) rpmpsmNext(psm, PSM_SCRIPT);
+
+_______________________________________________
+pld-devel-en mailing list
+pld-devel-en@lists.pld-linux.org
+http://lists.pld-linux.org/mailman/listinfo/pld-devel-en
index e5053e41608d11f61bdde282438a69eca936911c..32fc2c3d3e7812862610dbd002cb92973af19f20 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -150,6 +150,7 @@ Patch55:    %{name}-disable-hmac-verify.patch
 Patch56:       rpm-macros.patch
 Patch57:       %{name}-db5.2.patch
 Patch58:       %{name}-preserve-iterator.patch
+Patch59:       %{name}-triggerin-compat.patch
 
 # Patches imported from Mandriva
 
@@ -848,6 +849,7 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch56 -p1
 %patch57 -p1
 %patch58 -p1
+%patch59 -p1
 
 %patch1000 -p1
 %patch1001 -p1
This page took 0.063425 seconds and 4 git commands to generate.