]> git.pld-linux.org Git - packages/rpm.git/commitdiff
add field byKey tp dependencyConflict structure rpm-4_0_2-19
authorpawelk <pawelk@pld-linux.org>
Sun, 17 Jun 2001 18:22:55 +0000 (18:22 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
rel: 19
stbr

Changed files:
    rpm-byKey.patch -> 1.1
    rpm.spec -> 1.208

rpm-byKey.patch [new file with mode: 0644]
rpm.spec

diff --git a/rpm-byKey.patch b/rpm-byKey.patch
new file mode 100644 (file)
index 0000000..b143d01
--- /dev/null
@@ -0,0 +1,47 @@
+--- ./lib/rpmlib.h.org Sun Jun 17 13:38:45 2001
++++ ./lib/rpmlib.h     Sun Jun 17 13:37:38 2001
+@@ -764,6 +764,7 @@
+     const char * byName;
+     const char * byVersion;
+     const char * byRelease;
++    const void * byKey;
+     Header byHeader;
+     /* these needs fields are misnamed -- they are used for the package
+        which isn't needed as well */
+--- ./lib/depends.c.org        Sun Jun 17 13:38:59 2001
++++ ./lib/depends.c    Sun Jun 17 13:36:56 2001
+@@ -1250,7 +1250,7 @@
+ }
+ static int checkPackageDeps(rpmTransactionSet ts, struct problemsSet * psp,
+-              Header h, const char * keyName, uint_32 multiLib)
++              Header h, const char * keyName, uint_32 multiLib, void *key)
+ {
+     const char * name, * version, * release;
+     const char ** requires;
+@@ -1311,6 +1311,7 @@
+           psp->problems[psp->num].byName = xstrdup(name);
+           psp->problems[psp->num].byVersion = xstrdup(version);
+           psp->problems[psp->num].byRelease = xstrdup(release);
++          psp->problems[psp->num].byKey = key;
+           psp->problems[psp->num].needsName = xstrdup(requires[i]);
+           psp->problems[psp->num].needsVersion = xstrdup(requiresEVR[i]);
+           psp->problems[psp->num].needsFlags = requireFlags[i];
+@@ -1431,7 +1432,7 @@
+     rpmdbPruneIterator(mi, ts->removedPackages, ts->numRemovedPackages, 1);
+     while ((h = rpmdbNextIterator(mi)) != NULL) {
+-      if (checkPackageDeps(ts, psp, h, key, 0)) {
++      if (checkPackageDeps(ts, psp, h, key, 0,NULL)) {
+           rc = 1;
+           break;
+       }
+@@ -1995,7 +1996,7 @@
+     for (i = 0, p = ts->addedPackages.list; i < npkgs; i++, p++)
+     {
+-      rc = checkPackageDeps(ts, &ps, p->h, NULL, p->multiLib);
++      rc = checkPackageDeps(ts, &ps, p->h, NULL, p->multiLib,p->key);
+       if (rc)
+           goto exit;
index 2590e7f78a83f99f2eecd7ee5dcfb0e3bbc808ea..49b09a04bc7f886aadec61c06488b1fedbe10112 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -3,7 +3,7 @@ Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
 Summary(pl):   Aplikacja do zarz±dzania pakietami
 Name:          rpm
 Version:       4.0.2
 Summary(pl):   Aplikacja do zarz±dzania pakietami
 Name:          rpm
 Version:       4.0.2
-Release:       18
+Release:       19
 License:       GPL
 Group:         Base
 Group(de):     Gründsätzlich
 License:       GPL
 Group:         Base
 Group(de):     Gründsätzlich
@@ -36,6 +36,7 @@ Patch12:      %{name}-rh-lame.patch
 Patch13:       %{name}-glob.patch
 Patch14:       %{name}-header_h.patch  
 Patch15:       %{name}-fast-alAddPackage.patch
 Patch13:       %{name}-glob.patch
 Patch14:       %{name}-header_h.patch  
 Patch15:       %{name}-fast-alAddPackage.patch
+Patch16:       %{name}-byKey.patch
 Patch37:        %{name}-short_circuit.patch
 Patch38:        %{name}-section_test.patch
 BuildRequires: gettext-devel
 Patch37:        %{name}-short_circuit.patch
 Patch38:        %{name}-section_test.patch
 BuildRequires: gettext-devel
@@ -217,6 +218,7 @@ construir pacotes usando o RPM.
 %patch11 -p0
 %patch12 -p0
 %patch15 -p0
 %patch11 -p0
 %patch12 -p0
 %patch15 -p0
+%patch16 -p0
 %patch31 -p1
 install %{SOURCE2} macros.pld.in
 %patch38 -p1
 %patch31 -p1
 install %{SOURCE2} macros.pld.in
 %patch38 -p1
This page took 0.053656 seconds and 4 git commands to generate.