]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- clean up patches, rpm4 uses fuzz=0 for patching
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 13 Oct 2020 06:22:01 +0000 (08:22 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 13 Oct 2020 06:22:01 +0000 (08:22 +0200)
python-internal-build.patch
rpm-changelog_order_check_nonfatal.patch
rpm-man_pl.patch
rpm-perl-macros.patch
rpm-perl-magic.patch
rpm-perl_req-INC_dirs.patch

index b33976920f7cf7dabc736d0235a7405c23532b3c..ce66a3553f43fc59f8ed80384e8a9d285397ee98 100644 (file)
@@ -21,7 +21,7 @@
  rpmmod = Extension('rpm._rpm',
                     sources = ['header-py.c', 'rpmds-py.c', 'rpmfd-py.c',
 @@ -33,11 +24,9 @@
-                               'rpmte-py.c', 'rpmts-py.c',
+                               'rpmte-py.c', 'rpmts-py.c', 'rpmver-py.c',
                                'spec-py.c',
                                'rpmmodule.c'],
 -                   include_dirs = pkgconfig('--cflags'),
index 4fca83fb300c2d80e93eb8a7a6152c30733faaa9..ae75fa4e712177f0aa8da433156f14dbefcf666e 100644 (file)
@@ -1,7 +1,7 @@
 --- rpm-4.5/build/parseChangelog.c.orig        2012-07-24 14:46:12.856158625 +0200
 +++ rpm-4.5/build/parseChangelog.c     2012-07-24 14:47:55.293158624 +0200
 @@ -181,9 +181,8 @@
-           goto exit;
+               trimtime = firstTime - trimage;
        }
        if (lastTime && lastTime < time) {
 -          rpmlog(RPMLOG_ERR,
index db61324351d934bf389ffc5cbbd5d3115b1837b6..c9e03eaab88aceaf4e1d7c71695d25d1c4ceb7d1 100644 (file)
@@ -1,7 +1,7 @@
---- rpm/doc/pl/rpm.8~  2007-11-24 23:21:26.000000000 +0100
-+++ rpm/doc/pl/rpm.8   2007-11-24 23:21:26.000000000 +0100
-@@ -325,6 +325,7 @@
- Instaluje pakiety nawet je¶li niektóre z nich s± ju¿ zainstalowane na tym
+--- rpm-4.16.0/doc/pl/rpm.8.orig       2020-05-28 12:04:25.022136604 +0200
++++ rpm-4.16.0/doc/pl/rpm.8    2020-10-13 08:06:11.442087617 +0200
+@@ -318,6 +318,7 @@
+ Instaluje pakiety nawet jeśli niektóre z nich są już zainstalowane na tym
  systemie.
  .TP
 +\fB--test\fR
index a486444e4de3ad3e116469d730d84cd118bbfcc1..1d09638388873b813cebea16cf0c88c90b1798ad 100644 (file)
@@ -11,7 +11,7 @@
        python/Makefile
 --- rpm-5.3.1/scripts/perl.req.wiget   2008-10-26 10:50:53.000000000 +0100
 +++ rpm-5.3.1/scripts/perl.req 2010-05-30 16:35:36.999438206 +0200
-@@ -41,7 +41,11 @@
+@@ -45,7 +45,11 @@
  
  if ("@ARGV") {
    foreach (@ARGV) {
@@ -24,7 +24,7 @@
    }
  } else {
  
-@@ -49,7 +53,11 @@ if ("@ARGV") {
+@@ -53,7 +57,11 @@
    # contents of the file.
  
    foreach (<>) {
@@ -37,7 +37,7 @@
    }
  }
  
-@@ -215,19 +223,41 @@ sub process_file {
+@@ -261,19 +269,41 @@
  
        $module =~ s/\(\s*\)$//;
  
@@ -89,8 +89,8 @@
  
        };
  
-@@ -244,7 +274,31 @@ sub process_file {
-       #  will be included with the name sys/systeminfo.ph so only use the
+@@ -290,7 +320,31 @@
+       # will be included with the name sys/systeminfo.ph so only use the
        # basename of *.ph files
  
 -      ($module =~ m/\.ph$/) && next;
index 29e27a2a738bd4abc42b920a0fe9eb83317d22ed..1faacf3d57b6a9be2a022269403c24a546c931c5 100644 (file)
@@ -1,7 +1,6 @@
 --- rpm/build/rpmfc.c.orig     2014-10-07 15:53:03.185631053 +0100
 +++ rpm/build/rpmfc.c  2014-10-07 16:02:32.487591097 +0100
-@@ -593,7 +593,8 @@
-   { "troff or preprocessor input",    RPMFC_INCLUDE },
+@@ -593,6 +593,7 @@
    { "GNU Info",                       RPMFC_INCLUDE },
  
    { "perl ",                  RPMFC_INCLUDE },
index f6276f421bb6ff2c9d4789e3cb5caaef1a8aa52e..f15d4010c867505cf5ef90b0668adc6c64962479 100644 (file)
@@ -1,6 +1,6 @@
 --- scripts/perl.req~  2004-04-16 13:27:10.000000000 +0200
 +++ scripts/perl.req   2004-04-26 23:54:42.128568344 +0200
-@@ -39,8 +39,17 @@
+@@ -39,9 +39,18 @@
  eval { require version; $HAVE_VERSION = 1; };
  
  
@@ -20,6 +20,7 @@
 +    if (m=/usr/(sbin|bin|lib|lib64|libx32|share|X11R6/(lib|lib64|libx32|bin))/=) {
        if (! m=(/(doc|man|info|usr/src)/|\.(so|ph|h|html|pod)$)=) {
          process_file($_) if -f;
+       }
 @@ -53,7 +64,9 @@
  foreach $perlver (sort keys %perlreq) {
    print "perl >= $perlver\n";
This page took 0.048833 seconds and 4 git commands to generate.