]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- force initial __cc,__cxx,__cpp to stabilize build env. and avoid poisoning
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 13 Mar 2003 23:09:02 +0000 (23:09 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  (I had __cc=gcc and __cxx=g++ propagated for over 2 years on my machine,
   hiding some problems found on official builders, which I couldn't repeat)
- release 15.1 (works for me on athlon - check on other archs, esp. !x86)

Changed files:
    rpm.spec -> 1.396

rpm.spec

index 26256a6adad912f396da744dca686484221a1ab1..cc98362bd4d655638bf760ca735333052d183266 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -3,6 +3,12 @@
 # - learn find-perl-provides to use the __perl macro instead
 #   of /usr/bin/perl
 #
+# Conditional build:
+# _without_static      - build shared /bin/rpm (doesn't work at the moment)
+# force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
+# force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
+# force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
+#
 %include        /usr/lib/rpm/macros.python
 %define        beecrypt_ver    2.2.0
 %define        beecrypt_rel    2
@@ -18,7 +24,7 @@ Summary(ru):  
 Summary(uk):   íÅÎÅÄÖÅÒ ÐÁËÅԦנצĠRPM
 Name:          rpm
 Version:       4.1
-Release:       15
+Release:       15.1
 License:       GPL
 Group:         Base
 Source0:       ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/%{name}-%{version}.tar.gz
@@ -110,6 +116,11 @@ Conflicts: glibc < 2.2.92
 # don't require very fresh rpm.macros to build
 %define                __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
 
+# stabilize new build environment
+%define                __cc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
+%define                __cxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
+%define                __cpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
+
 %description
 RPM is a powerful package manager, which can be used to build,
 install, query, verify, update, and uninstall individual software
@@ -588,7 +599,9 @@ sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|'  \
        -e 's|@host_cpu@|%{_target_cpu}|'  macros.in  > macros.tmp
 mv -f macros.tmp macros.in
 
+# pass CC and CXX too in case of building with some older configure macro
 %configure \
+       CC="%{__cc}" CXX="%{__cxx}" CPP="%{__cpp}" \
        --enable-shared \
        --enable-static \
        --with-apidocs \
This page took 0.043186 seconds and 4 git commands to generate.