]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- rpmpopt patch updates: merged drop-legacy-CLI patch, added pl.po update,
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 10 Jun 2003 22:34:09 +0000 (22:34 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  added --bcond alias back to rpmb/rpmbuild, disabled RH's --buildpolicy
- etc_dir patch updates: s/ETC_DIR/HOME_ETC/, added pl.po update

Changed files:
    rpm-drop-legacy-CLI.patch -> 1.4
    rpm-etc_dir.patch -> 1.2
    rpm-rpmpopt.patch -> 1.15
    rpm.spec -> 1.433

rpm-drop-legacy-CLI.patch [deleted file]
rpm-etc_dir.patch
rpm-rpmpopt.patch
rpm.spec

diff --git a/rpm-drop-legacy-CLI.patch b/rpm-drop-legacy-CLI.patch
deleted file mode 100644 (file)
index e3c0c95..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
---- rpm-4.2/rpmpopt.in.wiget   Thu Mar 27 19:07:35 2003
-+++ rpm-4.2/rpmpopt.in Thu Mar 27 19:07:36 2003
-@@ -105,31 +105,31 @@
-       --POPTdesc=$"find package name that contains a required capability (needs rpmdb-redhat package installed)"
- # colon separated i18n domains to use as PO catalogue lookaside for
--* retrieving header group/description/summary.
-+# retrieving header group/description/summary.
- #
- # For Red Hat, value should be "redhat-dist:redhat-powertools".
- rpm alias --i18ndomains --define '_i18ndomains !#:+'
- # Build policies enabled from command line. Last policy applies.
--rpm alias --buildpolicy --define '__os_install_post @RPMCONFIGDIR@/brp-!#:+' \
--      --POPTdesc=$"set buildroot <policy> (e.g. compress man pages)" \
--      --POPTargs=$"<policy>"
-+#rpm alias --buildpolicy --define '__os_install_post @RPMCONFIGDIR@/brp-!#:+' \
-+#     --POPTdesc=$"set buildroot <policy> (e.g. compress man pages)" \
-+#     --POPTargs=$"<policy>"
- # Make RPM build tree
--rpm exec --install-build-tree install-build-tree \
-+rpmbuild exec --install-build-tree install-build-tree \
-       --POPTdesc=$"make all needed dirs for building binary rpms"
- # Compiling with debuginfo may be enabled by --debug
--rpm alias --debug --define 'debug 1' \
--      --POPTdesc=$"build packages with debug informations"
-+#rpm alias --debug --define 'debug 1' \
-+#     --POPTdesc=$"build packages with debug informations"
- rpmb alias --debug --define 'debug 1' \
-       --POPTdesc=$"build packages with debug informations"
- rpmbuild alias --debug --define 'debug 1' \
-       --POPTdesc=$"build packages with debug informations"
- # Conditional building 
--rpm exec  --bcond   find-spec-bcond \
--      --POPTdesc=$"find all --with/--without values"
-+#rpm exec  --bcond   find-spec-bcond \
-+#     --POPTdesc=$"find all --with/--without values"
- # Choose db interface:
- #     0       same as 1
- #     1       native db1 interface (e.g. linux glibc libdb1 routines).
-@@ -247,6 +247,11 @@
- rpmbuild alias --without      --define "_without_!#:+  --without-!#:+" \
-       --POPTdesc=$"disable configure <option> for build" \
-       --POPTargs=$"<option>"
-+# Build policies enabled from command line. Last policy applies.
-+rpmbuild alias --buildpolicy --define '__os_install_post @RPMCONFIGDIR@/brp-!#:+' \
-+      --POPTdesc=$"set buildroot <policy> (e.g. compress man pages)" \
-+      --POPTargs=$"<policy>"
-+
- #==============================================================================
- rpmd  alias --dbpath          --define '_dbpath !#:+' \
-       --POPTdesc=$"use database in DIRECTORY" \
index 5b789a446f88f6eee3a6a49a0b2e80b34f05f950..7437042ae7a8090cf7d0ba5795b5b846c94da889 100644 (file)
@@ -5,12 +5,12 @@ diff -Nru rpm-4.1/lib/rpmrc.c rpm-4.1.new/lib/rpmrc.c
        /* Expand ~/ to $HOME/ */
        fn[0] = '\0';
        if (r[0] == '~' && r[1] == '/') {
-+                      const char * etc_dir = getenv("ETC_DIR");
++                      const char * etc_dir = getenv("HOME_ETC");
            const char * home = getenv("HOME");
 -          if (home == NULL) {
 +                      if (etc_dir) {
 +              if (strlen(etc_dir) > (sizeof(fn) - strlen(r))) {
-+                                      rpmError(RPMERR_RPMRC, _("Cannot read %s, ETC_DIR is too large.\n"),r);
++                                      rpmError(RPMERR_RPMRC, _("Cannot read %s, HOME_ETC is too large.\n"),r);
 +                                      rc = 1;
 +                                      break;
 +              }
@@ -71,7 +71,7 @@ diff -Nru rpm-4.1/rpmio/macro.c rpm-4.1.new/rpmio/macro.c
 -              mfile += 2;
 -              strncpy(buf, home, sizeof(buf));
 -              strncat(buf, "/", sizeof(buf) - strlen(buf));
-+                      char *etc_dir = getenv("ETC_DIR");
++                      char *etc_dir = getenv("HOME_ETC");
 +
 +                      if (etc_dir) {
 +                              mfile += 2;
@@ -92,3 +92,16 @@ diff -Nru rpm-4.1/rpmio/macro.c rpm-4.1.new/rpmio/macro.c
        fd = Fopen(buf, "r.fpio");
        if (fd == NULL || Ferror(fd)) {
            if (fd) (void) Fclose(fd);
+--- rpm-4.3/po/pl.po.orig      2003-06-10 23:59:11.000000000 +0200
++++ rpm-4.3/po/pl.po   2003-06-11 00:06:16.000000000 +0200
+@@ -2834,6 +2834,10 @@
+ msgid "Please contact rpm-list@redhat.com\n"
+ msgstr "Proszê skontaktowaæ siê z rpm-list@redhat.com\n"
++#: lib/rpmrc.c:1764
++msgid "Cannot read %s, HOME_ETC is too large.\n"
++msgstr "Nie mo¿na odczytaæ %s, HOME_ETC jest zbyt du¿e.\n"
++
+ #: lib/rpmrc.c:1765
+ #, c-format
+ msgid "Cannot expand %s\n"
index b2933d9740a1fea7ba6bbc1ab82f4496051875cf..d965c27d40335714bdbff2a59fdc8bd203b3377a 100644 (file)
@@ -1,25 +1,77 @@
-diff -Nru rpm-4.0/rpmpopt.in rpm-4.0.new/rpmpopt.in
---- rpm-4.0/rpmpopt.in Wed Nov 15 19:18:35 2000
-+++ rpm-4.0.new/rpmpopt.in     Wed Nov 15 19:18:15 2000
-@@ -80,6 +80,21 @@
- # Build policies enabled from command line. Last policy applies.
- rpm alias --buildpolicy --define '__os_install_post @RPMCONFIGDIR@/brp-!#:+'
+--- rpm-4.3/rpmpopt.in.orig    2003-02-06 19:02:50.000000000 +0100
++++ rpm-4.3/rpmpopt.in 2003-06-10 23:55:22.000000000 +0200
+@@ -105,16 +105,11 @@
+       --POPTdesc=$"find package name that contains a required capability (needs rpmdb-redhat package installed)"
  
-+# Make RPM build tree
-+rpm exec --install-build-tree install-build-tree \
-+      --POPTdesc=$"make all needed dirs for building binary rpms"
-+
-+# Compiling with debuginfo may be enabled by --debug
-+rpm alias --debug --define 'debug 1' \
-+      --POPTdesc=$"build packages with debug informations"
-+rpmb alias --debug --define 'debug 1' \
-+      --POPTdesc=$"build packages with debug informations"
-+rpmbuild alias --debug --define 'debug 1' \
-+      --POPTdesc=$"build packages with debug informations"
-+
-+# Conditional building 
-+rpm exec  --bcond   find-spec-bcond \
-+      --POPTdesc=$"find all --with/--without values"
+ # colon separated i18n domains to use as PO catalogue lookaside for
+-* retrieving header group/description/summary.
++# retrieving header group/description/summary.
+ #
+ # For Red Hat, value should be "redhat-dist:redhat-powertools".
+ rpm alias --i18ndomains --define '_i18ndomains !#:+'
+-# Build policies enabled from command line. Last policy applies.
+-rpm alias --buildpolicy --define '__os_install_post @RPMCONFIGDIR@/brp-!#:+' \
+-      --POPTdesc=$"set buildroot <policy> (e.g. compress man pages)" \
+-      --POPTargs=$"<policy>"
+-
  # Choose db interface:
  #     0       same as 1
  #     1       native db1 interface (e.g. linux glibc libdb1 routines).
+@@ -217,6 +212,15 @@
+ rpmb  alias --without         --define "_without_!#:+    --without-!#:+" \
+       --POPTdesc=$"disable configure <option> for build" \
+       --POPTargs=$"<option>"
++# (PLD-specific) Make RPM build tree
++rpmb  exec --install-build-tree install-build-tree \
++      --POPTdesc=$"make all needed dirs for building binary rpms"
++# (PLD-specific) Compiling with debuginfo may be enabled by --debug
++rpmb  alias --debug --define 'debug 1' \
++      --POPTdesc=$"build packages with debug information"
++# (PLD-specific) Conditional building
++rpmb  exec  --bcond find-spec-bcond \
++      --POPTdesc=$"find all --with/--without values"
+ #==============================================================================
+ rpmbuild      alias --dbpath          --define '_dbpath !#:+' \
+       --POPTdesc=$"use database in DIRECTORY" \
+@@ -232,6 +236,19 @@
+ rpmbuild alias --without      --define "_without_!#:+  --without-!#:+" \
+       --POPTdesc=$"disable configure <option> for build" \
+       --POPTargs=$"<option>"
++# (PLD-specific) Make RPM build tree
++rpmbuild exec --install-build-tree install-build-tree \
++      --POPTdesc=$"make all needed dirs for building binary rpms"
++# (PLD-specific) Compiling with debuginfo may be enabled by --debug
++rpmbuild alias --debug --define 'debug 1' \
++      --POPTdesc=$"build packages with debug information"
++# (PLD-specific) Conditional building
++rpmbuild exec  --bcond find-spec-bcond \
++      --POPTdesc=$"find all --with/--without values"
++# Build policies enabled from command line. Last policy applies.
++#rpmbuild alias --buildpolicy --define '__os_install_post @RPMCONFIGDIR@/brp-!#:+' \
++#     --POPTdesc=$"set buildroot <policy> (e.g. compress man pages)" \
++#     --POPTargs=$"<policy>"
+ #==============================================================================
+ rpmd  alias --dbpath          --define '_dbpath !#:+' \
+       --POPTdesc=$"use database in DIRECTORY" \
+--- rpm-4.3/po/pl.po.orig      2003-06-10 23:48:19.000000000 +0200
++++ rpm-4.3/po/pl.po   2003-06-10 23:59:11.000000000 +0200
+@@ -3791,6 +3791,18 @@
+ msgid "disable configure <option> for build"
+ msgstr "wy³±cz <opcjê> konfiguracji przy budowaniu"
++#: ../rpmpopt:217
++msgid "make all needed dirs for building binary rpms"
++msgstr "utwórz wszystkie katalogi potrzebne do budowania binarnych RPM-ów"
++
++#: ../rpmpopt:220
++msgid "build packages with debug information"
++msgstr "buduj pakiety z informacjami do odpluskwiania"
++
++#: ../rpmpopt:223
++msgid "find all --with/--without values"
++msgstr "znajd¼ wszystkie warto¶ci --with/--without"
++
+ #: ../rpmpopt:186 ../rpmpopt:201 ../rpmpopt:216 ../rpmpopt:224 ../rpmpopt:232
+ #: ../rpmpopt:240 ../rpmpopt:248 ../rpmpopt:256 ../rpmpopt:264 ../rpmpopt:337
+ #: ../rpmpopt:409 ../rpmpopt:417
index dc6a6f550ff5b0b7b3aab179df7693f3e7ea832e..2ede830b1164e43c9c1ec0637e5e612c246f9830 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -61,7 +61,7 @@ Patch7:               %{name}-glob.patch
 Patch11:       %{name}-noexpand.patch
 Patch12:       %{name}-scripts-closefds.patch
 Patch13:       %{name}-python-macros.patch
-Patch16:       %{name}-drop-legacy-CLI.patch
+#Patch16:      %{name}-drop-legacy-CLI.patch
 Patch18:       %{name}-gettext-in-header.patch
 Patch19:       %{name}-compress-doc.patch
 Patch20:       %{name}-lt14d.patch
@@ -498,8 +498,6 @@ construir pacotes usando o RPM.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-# find-spec-bcond need update
-# po/pl.po need update
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
@@ -507,7 +505,6 @@ construir pacotes usando o RPM.
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
-%patch16 -p1
 %patch18 -p1
 %patch19 -p1
 %patch20 -p1
This page took 0.05544 seconds and 4 git commands to generate.