]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- remove scripts and config that's been moved to rpm-build-macros
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 6 Jan 2020 08:20:37 +0000 (17:20 +0900)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 6 Jan 2020 08:20:37 +0000 (17:20 +0900)
rpm-compress-doc [deleted file]
rpm-find-spec-bcond [deleted file]
rpm-mimetype.patch
rpm-mimetypedeps [deleted file]
rpm.spec

diff --git a/rpm-compress-doc b/rpm-compress-doc
deleted file mode 100644 (file)
index 3c5ff93..0000000
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/bin/sh
-#
-# Compress documentation files found in $DOCDIR. Omit some files we don't
-# want to get compressed.
-#
-# /etc/rpm/noautocompressdoc and --noautocompressdoc= option can contain
-# whitespace delimated list of patters to omit.
-#
-
-#set -x
-
-COMPRESS_CMD="gzip -9nf"
-EXCLUDE_SUFFIXES="htm html jpg jpeg png gif pdf css dia js abw HTM JPG PNG GIF PDF CSS JS"
-EXCLUDE_MASKS=
-RECOMPRESS_BZIP2=yes
-
-nocompressdoc=''
-while [ $# -gt 0 ]; do
-       case "$1" in
-         --noautocompressdoc=*)
-               EXCLUDE_MASKS=`echo "${1#--noautocompressdoc=}" | sed -e 's/^ *//;s/ *$//;s/ \+/|/g'`
-       esac
-       shift
-done
-
-if [ -r /etc/rpm/noautocompressdoc ]; then
-       exclude=$(cat /etc/rpm/noautocompressdoc | grep -v '^#' | xargs echo | sed -e 's/^ *//;s/ *$//;s/ \+/|/g')
-       if [ -n "${exclude}" ]; then
-               if [ -n "${EXCLUDE_MASKS}" ]; then
-                       EXCLUDE_MASKS="${EXCLUDE_MASKS}|${exclude}"
-               else
-                       EXCLUDE_MASKS="${exclude}"
-               fi
-       fi
-fi
-
-if [ "$DOCDIR" = "" ] ; then
-       echo '$DOCDIR not set; exiting.'
-       exit 1
-fi
-
-cd $DOCDIR
-
-echo "Compressing documentation in $DOCDIR..."
-
-if test "$EXCLUDE_MASKS" ; then
-       echo "Excluding pattern '$EXCLUDE_MASKS'"
-fi
-
-FIND_CMD="find . -type f "
-for SUF in $EXCLUDE_SUFFIXES ; do
-       FIND_CMD="$FIND_CMD -a -not -name '*.$SUF'"
-done
-
-eval $FIND_CMD | while read FILENAME ; do
-       if test -n "$EXCLUDE_MASKS" ; then
-               if eval "case \$(basename \"$FILENAME\") in
-                        $EXCLUDE_MASKS ) true ;;
-                        * ) false ;;
-                        esac" ; then
-                       continue
-               fi
-       fi
-       case "$FILENAME" in
-       *.gz | *.Z)
-               gzip -d "$FILENAME"
-               FILENAME=$(echo "$FILENAME" | sed -e 's/\.gz$//; s/\.Z$//')
-               ;;
-       *.bz2)
-               if [ "$RECOMPRESS_BZIP2" = yes ] ; then
-                       bzip2 -d "$FILENAME"
-                       FILENAME=$(echo "$FILENAME" | sed -e 's/\.bz2$//')
-               else
-                       continue
-               fi
-               ;;
-       esac
-
-       $COMPRESS_CMD "$FILENAME"
-
-       echo -n "$FILENAME "
-done
-
-echo
-echo "Documentation compressed."
diff --git a/rpm-find-spec-bcond b/rpm-find-spec-bcond
deleted file mode 100644 (file)
index a11dece..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-#!/bin/sh
-# Display bcond (_with_*, _without_*) macros from given spec 
-# $Id$
-
-if [ "$#" = 0 ]; then
-    echo "Usage: $0 SPEC"
-    exit 1
-fi
-
-SPEC=$1
-if [ $SPEC = "--" ]; then
-    if [ "$#" -lt 2 ]; then
-       echo "Usage: rpmbuild --bcond SPEC"
-       exit 1
-    fi
-    SPEC=$2
-fi
-
-if [ ! -f $SPEC ]; then
-    echo "rpmbuild: $SPEC: no such file"
-    exit 1
-fi
-
-bconds=`awk -F"\n" 'BEGIN { chlog=0 }
-               /^%changelog/ { chlog=1 }
-               /_with(out)?_[_a-zA-Z0-9]+/ && chlog == 0 {
-                       match($0, /_with(out)?_[_a-zA-Z0-9]+/);
-                       print substr($0, RSTART, RLENGTH)                       
-               }
-               /^%bcond_with/ && chlog == 0 {
-                       match($0, /bcond_with(out)?[ \t]+[_a-zA-Z0-9]+/);
-                                bcond = substr($0, RSTART +5 , RLENGTH -5);
-                                gsub(/[ \t]+/,"_",bcond);
-                                print bcond
-                       }' $SPEC | sort -u`
-
-for c in $bconds; do
-    echo -n "$c"
-
-    if ! echo `rpm --eval "%$c"` | grep $c >/dev/null; then
-       echo " (on)"
-    else 
-       echo ""
-    fi
-done
-
-
-for bcond in $bconds; do
-    isset=`awk -F"\n" "BEGIN { val=0 }
-                   /^%define[\t ]+$bcond/ {
-                     if (match(\\$0, /$bcond[\t ]+0[\t ]*$/)) {
-                        val = 0
-                     } else if (match(\\$0, /$bcond[\t ]+1[\t ]*$/)) {
-                        val = 1
-                     } else {
-                        print \"couldn't determine $bcond value from \", \\$0
-                     }
-                  } END { print val }" $SPEC`;
-
-    if [ x"$isset" = x"1" ]; then
-       echo "WARN: $bcond defined in spec";
-    fi
-done
-        
index ed51d83e12ff0f393cfa9a685d3997df2dc26170..b9bd54d9dbca8b6afcfd10811f522966ae9f059f 100644 (file)
@@ -51,23 +51,3 @@ diff -urN rpm-5.1.4/lib/rpmfc.h rpm-5.1.4.new/lib/rpmfc.h
      RPMFC_TYPELIB             = (1 <<  5),
      RPMFC_HASKELL             = (1 <<  6),
      RPMFC_RUBY                        = (1 <<  7),
-diff -urN rpm-5.1.4/macros/macros.in rpm-5.1.4.new/macros/macros.in
---- rpm-5.1.4/macros/macros.in 2008-07-29 19:36:38.000000000 +0200
-+++ rpm-5.1.4.new/macros/macros.in     2008-07-29 19:45:45.000000000 +0200
-@@ -1617,6 +1617,16 @@
- #}1}%{rpm_license_check}
- #------------------------------------------------------------------------
-+# mimetype(...) configuration.
-+#
-+# Path to script to autogenerate mimetype(foo) provides, based on MimeType
-+# key from desktop files.
-+#
-+# Note: Used if _use_internal_dependency_generator is non-zero. The
-+# helper is also used by %{_uselibrpm}/rpmdeps --provides
-+%__mimetype_provides %{_usrlibrpm}/mimetypedeps.sh --provides
-+
-+#------------------------------------------------------------------------
- # executable(...) configuration.
- #
- # Path to scripts to autogenerate executable(foo) script dependencies,
diff --git a/rpm-mimetypedeps b/rpm-mimetypedeps
deleted file mode 100644 (file)
index 6c0176d..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh
-
-case $1 in
--P|--provides)
-       while read filename; do
-       case "$filename" in
-       *.desktop)
-               mime=$(awk -F= '/^MimeType=/{print $2}' "$filename")
-               IFS=';'
-               for type in $mime; do
-                       if [ -n "$type" ]; then
-                               echo "mimetype($type)"
-                       fi
-               done
-               ;;
-       esac
-       done
-       ;;
-esac
-
-exit 0
index ef7ffdbe2221a476778db67f223b69f15aa3dc56..adcc50dbc109d193fc9171c6902ca2c699b58ca7 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -59,10 +59,8 @@ Source101:   README.cpu-os-macros
 Source1:       %{name}.groups
 Source2:       macros.pld.in
 Source3:       %{name}-install-tree
-Source4:       %{name}-find-spec-bcond
 Source5:       %{name}-hrmib-cache
 Source6:       %{name}-groups-po.awk
-Source7:       %{name}-compress-doc
 Source10:      %{name}.sysinfo
 Source11:      perl.prov
 Source12:      %{name}-user_group.sh
@@ -71,7 +69,6 @@ Source13:     %{name}.sysconfig
 Source15:      banner.sh
 Source16:      ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
 # Source16-md5:        23914bb49fafe7153cee87126d966461
-Source17:      %{name}-mimetypedeps
 Source18:      macros.local
 Source19:      %{name}.noautocompressdoc
 Source20:      %{name}.noautoprov
@@ -1205,10 +1202,7 @@ install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
 
 install %{SOURCE1} doc/manual/groups
 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
-install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
-install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
 install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
-install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
 install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
 install %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
 
@@ -1494,15 +1488,12 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
 %attr(755,root,root) %{_rpmlibdir}/brp-*
 %attr(755,root,root) %{_rpmlibdir}/check-files
-%attr(755,root,root) %{_rpmlibdir}/compress-doc
 %attr(755,root,root) %{_rpmlibdir}/cross-build
-%attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
-%attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
 # needs hacked pkg-config to return anything
 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
 %attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
This page took 0.046005 seconds and 4 git commands to generate.