]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- fix ___build_pre macro breakage that caused undefined RPM_SOURCE_DIR
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 15 Sep 2012 17:34:32 +0000 (19:34 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 15 Sep 2012 17:34:32 +0000 (19:34 +0200)
rpm-fix-___build_pre-macro.patch [new file with mode: 0644]
rpm.spec

diff --git a/rpm-fix-___build_pre-macro.patch b/rpm-fix-___build_pre-macro.patch
new file mode 100644 (file)
index 0000000..235c94d
--- /dev/null
@@ -0,0 +1,22 @@
+--- rpm-5.4.10/macros/macros.rpmbuild.in.old   2012-09-15 19:31:55.178325519 +0200
++++ rpm-5.4.10/macros/macros.rpmbuild.in       2012-09-15 19:32:37.158324039 +0200
+@@ -324,9 +324,18 @@
+ %___build_args                -e
+ %___build_cmd         %{?_sudo:%{_sudo} }%{?_remsh:%{_remsh} %{_remhost} }%{?_remsudo:%{_remsudo} }%{?_remchroot:%{_remchroot} %{_remroot} }%{___build_shell} %{___build_args}
+ %___build_pre \
++  RPM_SOURCE_DIR=\"%{u2p:%{_sourcedir}}\"\
+   RPM_BUILD_DIR=\"%{u2p:%{_builddir}}\"\
+   RPM_OPT_FLAGS=\"%{optflags}\"\
+-  export RPM_BUILD_DIR RPM_OPT_FLAGS\
++  RPM_ARCH=\"%{_arch}\"\
++  RPM_OS=\"%{_os}\"\
++  export RPM_SOURCE_DIR RPM_BUILD_DIR RPM_OPT_FLAGS RPM_ARCH RPM_OS\
++  RPM_DOC_DIR=\"%{_docdir}\"\
++  export RPM_DOC_DIR\
++  RPM_PACKAGE_NAME=\"%{name}\"\
++  RPM_PACKAGE_VERSION=\"%{version}\"\
++  RPM_PACKAGE_RELEASE=\"%{release}\"\
++  export RPM_PACKAGE_NAME RPM_PACKAGE_VERSION RPM_PACKAGE_RELEASE\
+   %{?buildroot:RPM_BUILD_ROOT=\"%{u2p:%{buildroot}}\"\
+   export RPM_BUILD_ROOT}\
+   %{?_javaclasspath:CLASSPATH=\"%{_javaclasspath}\"\
index 25b4b3419cefadb0e16fa79625f69944efac67ab..d39d0cff7ff41cce26e4d0a9206ab8f9ed072a1a 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -4,10 +4,6 @@
 # - add macros for some ppc, mipsel, alpha and sparc
 # - make %%patch not multiline, so plain comment char could still work:
 #   http://git.pld-linux.org/gitweb.cgi/packages/kernel.git/commitdiff/5d3a3ea257d7f88e59d0ad93c20cc8448fb42f3d
-# - why $RPM_SOURCE_DIR missing, needs macro?
-#      # for rpm 5.3
-#      [ -z "$RPM_SOURCE_DIR" ] && export RPM_SOURCE_DIR=$(dirname %{SOURCE6})
-#   http://git.pld-linux.org/gitweb.cgi/packages/kernel.git/commitdiff/5d3a3ea257d7f88e59d0ad93c20cc8448fb42f3d
 #
 # - http://rpm5.org/cvs/tktview?tn=41&_submit=Show
 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
@@ -130,6 +126,7 @@ Patch42:    %{name}-disable-ldconfig-optimization.patch
 Patch43:       %{name}-fix--p-interpreter-and-empty-script.patch
 Patch44:       %{name}-db_buffer_small.patch
 Patch45:       %{name}-pattern_Release.patch
+Patch46:       %{name}-fix-___build_pre-macro.patch
 
 # Patches imported from Mandriva
 
@@ -796,6 +793,7 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch43 -p1
 %patch44 -p1
 %patch45 -p1
+%patch46 -p1
 
 %patch1000 -p1
 %patch1001 -p1
This page took 0.048086 seconds and 4 git commands to generate.