]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- mono deps
authorwolf <wolf@pld-linux.org>
Thu, 11 Aug 2005 16:54:56 +0000 (16:54 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
[18:52 wolf@bajzel:~/rpm/RPMS]% rpm -qp --requires monotheka-0.0.5-1.athlon.rpm
/bin/sh
dotnet-gtk-sharp-gnome >= 1.0.4
mono >= 1.0.6
mono(Mono.Data.SqliteClient) = 1.0.5000.0
mono(MovieDatabase) = 0.0.0.0
mono(PluginLib) = 0.0.0.0
mono(System) = 1.0.5000.0
mono(System.Data) = 1.0.5000.0
mono(Util) = 0.0.0.0
mono(gconf-sharp) = 1.0.0.0
mono(gdk-sharp) = 1.0.0.0
mono(glade-sharp) = 1.0.0.0
mono(glib-sharp) = 1.0.0.0
mono(gnome-sharp) = 1.0.0.0
mono(gtk-sharp) = 1.0.0.0
mono(gtkhtml-sharp) = 1.0.0.0
mono(mscorlib) = 1.0.5000.0
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
sqlite >= 2.8
rpmlib(PayloadIsBzip2) <= 3.0.5-1

Changed files:
    rpm-mono.patch -> 1.1
    rpm.macros -> 1.233

rpm-mono.patch [new file with mode: 0644]
rpm.macros

diff --git a/rpm-mono.patch b/rpm-mono.patch
new file mode 100644 (file)
index 0000000..b6b771d
--- /dev/null
@@ -0,0 +1,132 @@
+diff -ruN rpm-4.4.2./build/rpmfc.c rpm-4.4.2/build/rpmfc.c
+--- rpm-4.4.2./build/rpmfc.c   2005-08-11 13:11:54.000000000 +0200
++++ rpm-4.4.2/build/rpmfc.c    2005-08-11 15:33:47.000000000 +0200
+@@ -534,6 +534,9 @@
+   /* XXX "python 2.3 byte-compiled" */
+   { "python ",                        RPMFC_PYTHON|RPMFC_INCLUDE },
++  /* .NET executables and libraries. file(1) cannot differ it from native win32 executables unfortunatelly */
++  { "PE executable",          RPMFC_MONO|RPMFC_INCLUDE },
++
+   { "current ar archive",     RPMFC_STATIC|RPMFC_LIBRARY|RPMFC_ARCHIVE|RPMFC_INCLUDE },
+   { "Zip archive data",               RPMFC_COMPRESSED|RPMFC_ARCHIVE|RPMFC_INCLUDE },
+@@ -827,6 +830,42 @@
+ }
+ /**
++ * Extract .NET dependencies.
++ * @param fc          file classifier
++ * @param findprov    1 to enable provides
++ * @param findreq     1 to enable requires
++ * @param noautoprov  _noautoprov regexps
++ * @param noautoprov_c        # of _noautoprov regexps
++ * @param noautoreq   _noautoreq regexps
++ * @param noautoreq_c # of _noautoreq regexps
++ * @return            0 on success
++ */
++static int rpmfcMONO(rpmfc fc, int findprov, int findreq,
++    regex_t *noautoprov, int noautoprov_c, regex_t *noautoreq, int noautoreq_c)
++      /*@globals rpmGlobalMacroContext, h_errno, fileSystem, internalState @*/
++      /*@modifies fc, rpmGlobalMacroContext, fileSystem, internalState @*/
++{
++    const char * fn = fc->fn[fc->ix];
++    FILE * fp;
++    int xx;
++
++    fp = fopen(fn, "r");
++    if (fp == NULL || ferror(fp)) {
++      if (fp) (void) fclose(fp);
++      return -1;
++    }
++
++    (void) fclose(fp);
++
++    if (findprov)
++      xx = rpmfcHelper(fc, 'P', "mono", noautoprov, noautoprov_c);
++    if (findreq)
++      xx = rpmfcHelper(fc, 'R', "mono", noautoreq, noautoreq_c);
++
++    return 0;
++}
++
++/**
+  * Extract Elf dependencies.
+  * @param fc          file classifier
+  * @param findprov    1 to enable provides
+@@ -1179,6 +1218,7 @@
+     { rpmfcSCRIPT,    (RPMFC_SCRIPT|RPMFC_PERL) },
+     { rpmfcSCRIPT,    (RPMFC_SCRIPT|RPMFC_PYTHON) },
+     { rpmfcSCRIPT,    (RPMFC_SCRIPT|RPMFC_PHP) },
++    { rpmfcMONO,      RPMFC_MONO },
+     { NULL, 0 }
+ };
+diff -ruN rpm-4.4.2./build/rpmfc.h rpm-4.4.2/build/rpmfc.h
+--- rpm-4.4.2./build/rpmfc.h   2005-08-11 13:11:54.000000000 +0200
++++ rpm-4.4.2/build/rpmfc.h    2005-08-11 14:10:33.000000000 +0200
+@@ -78,6 +78,7 @@
+     RPMFC_PYTHON              = (1 << 26),
+     RPMFC_PHP                 = (1 << 27),
+     RPMFC_TCL                 = (1 << 28),
++    RPMFC_MONO                        = (1 <<  6),
+     RPMFC_WHITE                       = (1 << 29),
+     RPMFC_INCLUDE             = (1 << 30),
+diff -ruN rpm-4.4.2./macros.in rpm-4.4.2/macros.in
+--- rpm-4.4.2./macros.in       2005-08-11 13:11:54.000000000 +0200
++++ rpm-4.4.2/macros.in        2005-08-11 17:20:46.276790376 +0200
+@@ -443,6 +443,9 @@
+ %__python_provides    @RPMCONFIGDIR@/pythondeps.sh --provides
+ %__python_requires    @RPMCONFIGDIR@/pythondeps.sh --requires
++%__mono_provides      @RPMCONFIGDIR@/monodeps.sh --provides
++%__mono_requires      @RPMCONFIGDIR@/monodeps.sh --requires
++
+ #
+ # fixowner, fixgroup, and fixperms are run at the end of hardcoded setup
+ # These macros are necessary only for legacy compatibility, and have moved
+diff -ruN rpm-4.4.2./configure.ac rpm-4.4.2/configure.ac
+--- rpm-4.4.2./configure.ac    2005-08-11 17:36:01.000000000 +0200
++++ rpm-4.4.2/configure.ac     2005-08-11 18:11:15.449385328 +0200
+@@ -1355,7 +1355,7 @@
+       scripts/php.req scripts/php.prov
+       rpmio/Makefile rpmdb/Makefile lib/Makefile build/Makefile
+       scripts/Makefile scripts/brp-redhat
+-      scripts/macros.perl scripts/macros.php scripts/macros.python
++      scripts/macros.perl scripts/macros.php scripts/macros.python scripts/macros.mono
+       tools/Makefile
+       tests/Makefile tests/rpmrc tests/macros tests/hello-test/Makefile
+       misc/Makefile intl/Makefile po/Makefile.in
+diff -ruN rpm-4.4.2./scripts/macros.mono rpm-4.4.2/scripts/macros.mono
+--- rpm-4.4.2./scripts/macros.mono     1970-01-01 01:00:00.000000000 +0100
++++ rpm-4.4.2/scripts/macros.mono      2005-08-11 18:14:44.387621888 +0200
+@@ -0,0 +1,6 @@
++# Mono specific macro definitions.
++# To make use of these macros insert the following line into your spec file:
++# %include /usr/lib/rpm/macros.mono
++
++%define               __find_requires /usr/bin/mono-find-requires
++%define               __find_provides /usr/bin/mono-find-provides
+diff -ruN rpm-4.4.2./scripts/macros.mono.in rpm-4.4.2/scripts/macros.mono.in
+--- rpm-4.4.2./scripts/macros.mono.in  1970-01-01 01:00:00.000000000 +0100
++++ rpm-4.4.2/scripts/macros.mono.in   2005-08-11 18:15:49.420735352 +0200
+@@ -0,0 +1,6 @@
++# Mono specific macro definitions.
++# To make use of these macros insert the following line into your spec file:
++# %include @RPMCONFIGDIR@/macros.mono
++
++%define               __find_requires /usr/bin/mono-find-requires
++%define               __find_provides /usr/bin/mono-find-provides
+diff -ruN rpm-4.4.2./scripts/Makefile.am rpm-4.4.2/scripts/Makefile.am
+--- rpm-4.4.2./scripts/Makefile.am     2005-07-13 14:19:13.000000000 +0200
++++ rpm-4.4.2/scripts/Makefile.am      2005-08-11 18:13:19.998450992 +0200
+@@ -16,7 +16,7 @@
+       rpm.daily rpm.log rpm.xinetd rpm2cpio.sh \
+       sql.prov sql.req tcl.req tgpg trpm u_pkg.sh \
+       vpkg-provides.sh vpkg-provides2.sh \
+-      macros.perl* macros.python* \
++      macros.perl* macros.python* macros.mono* \
+       macros.php* find-*.php find-php-*
+ installprefix = $(DESTDIR)
index 6bd9b27d8fec43a1933fcd6a5da3a600b7a7723e..1ec9bcc683e52ba6124224f9251ab95949ccfc80 100644 (file)
@@ -458,6 +458,8 @@ fi \
 %__php_requires %{nil}
 %__perl_provides %{nil}
 %__perl_requires %{nil}
+%__mono_provides %{nil}
+%__mono_requires %{nil}
 
 # Perl specific macro definitions.
 %perl_privlib  %(eval "`%{__perl} -V:installprivlib`"; echo $installprivlib)
This page took 0.064274 seconds and 4 git commands to generate.