]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- add %scons
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 5 Dec 2006 17:28:07 +0000 (17:28 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- unify %cmake vs %__cmake

Changed files:
    rpm.macros -> 1.337

rpm.macros

index 3dfbcc14043d5fd876fa7c1f80984036567db8a6..90f2bd5ffa4c0affd2dbb3a15007dbd84cc8b8ec 100644 (file)
@@ -134,16 +134,24 @@ fi; \
        %{dependencytracking} \
 }
 
+# override __cmake to add -j4 in your ~/.rpmmacros for parallel make
+%__cmake       /usr/bin/cmake
 %cmake { \
 CC="%{__cc}" \
 CXX="%{__cxx}" \
 CFLAGS="%{rpmcflags}" \
 CXXFLAGS="%{rpmcxxflags}" \
-cmake \
+%{__cmake} \
+}
+
+# override __scons to add -j4 in your ~/.rpmmacros for parallel make
+%__scons       /usr/bin/scons
+%scons { \
+%{__scons} \
 }
 
 # waf. see waf.spec
-# override __waf to add -j1 in your ~/.rpmmacros
+# override __waf to add -j4 in your ~/.rpmmacros for parallel make
 %__waf /usr/bin/waf
 %waf { \
 CC="%{__cc}" \
This page took 0.040216 seconds and 4 git commands to generate.