]> git.pld-linux.org Git - packages/rpm.git/commitdiff
removed perl.req patches applied upstream
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 22 Aug 2012 11:45:10 +0000 (13:45 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 22 Aug 2012 11:45:10 +0000 (13:45 +0200)
rpm-perl_req-heredocs_pod.patch [deleted file]
rpm-perl_req-skip_multiline.patch [deleted file]
rpm-perl_req-use_base.patch [deleted file]
rpm.spec

diff --git a/rpm-perl_req-heredocs_pod.patch b/rpm-perl_req-heredocs_pod.patch
deleted file mode 100644 (file)
index 5d7d9f2..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
---- rpm-5.1.4/scripts/perl.req.in.orig 2008-10-26 10:26:43.622757203 +0100
-+++ rpm-5.1.4/scripts/perl.req 2008-10-26 10:26:48.452756609 +0100
-@@ -140,15 +140,22 @@
-   return if (!is_perlfile($file, \*FILE));
-   while (<FILE>) {
--    
--    # skip the "= <<" block
--    if ( ( m/^\s*\$(.*)\s*=\s*<<\s*["'](.*)['"]/) ||
--         ( m/^\s*\$(.*)\s*=\s*<<\s*(.*);/) ) {
--      $tag = $2;
--      while (<FILE>) {
--        ( $_ =~ /^$tag/) && last;
--      }
-+    # skip the documentation
-+    if ( /^ = (?: head\d | pod | item | over | back | (?: begin|end|for ) \s+\S+ ) \b/x ) {
-+        $_ = <FILE> until /^=cut/ or eof;
-+        next;
-+    }
-+
-+    # naively strip some comments... will screw m/\#/, m##, q##, qw##, qr##, etc, but these don't really matter for us 
-+    s/(?<! \\ ) # \b .+ //x;
-+
-+    # skip the "= <<label", "print <<", "warn <<", "foo(<<label) blocks
-+    # note: watch out for the binary << operator and comments
-+    if ( m/ (?: = | \b[a-z][a-z_]+\(? ) \s* << \s* (?: q{0,2}(["']) (.+) \1 | ([a-zA-Z][a-zA-Z\d_]*) ) [\s;\)]* $/x ) {
-+        my $tag = defined $2 ? $2 : $3;
-+        $_ = <FILE> until m/^\Q$tag\E\s*$/ or eof;
-+        next;
-     }
-     # skip q{} quoted sections - just hope we don't have curly brackets
-@@ -157,21 +164,7 @@
-     if ( m/^.*\Wq[qxwr]?\s*([\{\(\[#|\/])[^})\]#|\/]*$/ && ! m/^\s*(require|use)\s/ ) {
-       $tag = $1;
-       $tag =~ tr/{([/})]/;
--      $_ = <FILE> until m/\Q$tag\E/;
--    }
--
--    # skip the documentation
--
--    # we should not need to have item in this if statement (it
--    # properly belongs in the over/back section) but people do not
--    # read the perldoc.
--
--    if ( (m/^=(head[1-4]|pod|item)/) .. (m/^=(cut)/) ) {
--      next;
--    }
--
--    if ( (m/^=(over)/) .. (m/^=(back)/) ) {
--      next;
-+      $_ = <FILE> until m/\Q$tag\E/ or eof;
-     }
-     
-     # skip the data section
diff --git a/rpm-perl_req-skip_multiline.patch b/rpm-perl_req-skip_multiline.patch
deleted file mode 100644 (file)
index e94feb3..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
---- rpm-5.1.4/scripts/perl.req~        2008-08-20 21:34:42.000000000 +0200
-+++ rpm-5.1.4/scripts/perl.req 2008-08-28 12:45:14.820174910 +0200
-@@ -156,10 +156,8 @@
-     # marker, such as occurs right here. Draw the line somewhere.
-     if ( m/^.*\Wq[qxwr]?\s*([\{\(\[#|\/])[^})\]#|\/]*$/ && ! m/^\s*(require|use)\s/ ) {
-       $tag = $1;
--      $tag =~ tr/{\(\[\#|\//})]#|\//;
--      while (<FILE>) {
--        ( $_ =~ m/\}/ ) && last;
--      }
-+      $tag =~ tr/{([/})]/;
-+      $_ = <FILE> until m/\Q$tag\E/;
-     }
-     # skip the documentation
diff --git a/rpm-perl_req-use_base.patch b/rpm-perl_req-use_base.patch
deleted file mode 100644 (file)
index cdb0a7c..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
---- rpm-5.1.4/scripts/perl.req 2008-08-20 21:27:09.929116479 +0200
-+++ rpm-5.1.4/scripts/perl.req 2008-10-26 10:48:31.529709016 +0100
-@@ -196,7 +196,28 @@
-       }
-     }
--    if ( 
-+    # handle "use base qw/ foo::bar baz::blah /;" and variations
-+    if (
-+        m/^ \s* use \s+ base
-+           (?:  \s+ q[wq]? \s* ( [!@#\$%^&*'"\/+=`~,.?-] ) \s* ( [\w:]+? (?: \s+[\w:]+? )*? ) \s* \1
-+               |
-+                \s* ( ["'] ) ( [\w:]+? ) \3
-+               |
-+                # qw[], qw(), qw<>, qw{} are handled here; lax, but who gives
-+                \s+ q[wq]? \s* [\[({<] \s* ( [\w:]+? (?: \s+[\w:]+? )*? ) \s* [\])}>]
-+           )
-+           \s* ;
-+       /x
-+      )
-+    {
-+        my @deps = ( $1 ? split /\s+/, $2 : $3 ? $4 : split /\s+/, $5 );
-+        for my $mod ( grep !exists $require{$_}, @deps ) {
-+            $require{$mod} = '';
-+            $line{$mod}    = $_;
-+        }
-+    }
-+
-+    elsif ( 
- # ouch could be in a eval, perhaps we do not want these since we catch
- # an exception they must not be required
index 826fe45151182c234c6ecf504ed6f27d5d4e79b6..c8fe149524d3b64f5ee00c0bc7f37bca31059435 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -133,9 +133,6 @@ Patch34:    %{name}-epoch0.patch
 Patch35:       %{name}-perl_req-INC_dirs.patch
 Patch36:       %{name}-debuginfo.patch
 Patch37:       %{name}-doxygen_hack.patch
-Patch38:       %{name}-perl_req-use_base.patch
-Patch39:       %{name}-perl_req-skip_multiline.patch
-Patch40:       %{name}-perl_req-heredocs_pod.patch
 
 Patch41:       vendor-pld.patch
 
@@ -705,9 +702,6 @@ install %{SOURCE12} scripts/perl.prov
 # needs update to 5.4
 #%patch36 -p1
 %patch37 -p1
-#patch38 -p1 applied
-#patch39 -p1 applied
-#patch40 -p1 applied
 %patch41 -p1
 %patch42 -p1
 %patch46 -p1
This page took 0.119005 seconds and 4 git commands to generate.