]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- updated for 20040107 auto/ac/rpm-4_3-0_20040107_1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 7 Jan 2004 01:58:29 +0000 (01:58 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    rpm-magic-usesystem.patch -> 1.2
    rpm-perl-macros.patch -> 1.30
    rpm-po.patch -> 1.6
    rpm-system_libs.patch -> 1.10

rpm-magic-usesystem.patch
rpm-perl-macros.patch
rpm-po.patch
rpm-system_libs.patch

index ebeb437befa797a640124f1798f707fd83a4b50c..973ebd3b9dd7263f66057c4e8686a47e15321b87 100644 (file)
@@ -1,14 +1,15 @@
---- rpm-4.3/file/Makefile.am.orig      2003-04-16 18:37:23.000000000 +0200
-+++ rpm-4.3/file/Makefile.am   2003-06-08 21:37:17.000000000 +0200
-@@ -2,4 +2,4 @@
+diff -urN rpm-4.3.org/file/Makefile.am rpm-4.3/file/Makefile.am
+--- rpm-4.3.org/file/Makefile.am       2004-01-07 02:01:53.050779393 +0100
++++ rpm-4.3/file/Makefile.am   2004-01-07 02:10:07.851944923 +0100
+@@ -1,3 +1,3 @@
  EXTRA_DIST = LEGAL.NOTICE MAINT Makefile.std
  
 -SUBDIRS = src magic doc
-+SUBDIRS = src doc
---- rpm-4.3/file/src/Makefile.am.orig  2003-04-17 18:44:59.000000000 +0200
-+++ rpm-4.3/file/src/Makefile.am       2003-06-08 21:36:44.000000000 +0200
-@@ -26,7 +26,7 @@
++SUBDIRS = src magic
+diff -urN rpm-4.3.org/file/src/Makefile.am rpm-4.3/file/src/Makefile.am
+--- rpm-4.3.org/file/src/Makefile.am   2004-01-07 02:01:54.159548970 +0100
++++ rpm-4.3/file/src/Makefile.am       2004-01-07 02:09:30.670672672 +0100
+@@ -24,7 +24,7 @@
  file_LDADD =  libfmagic.la
  
  pkglibdir =  @prefix@/lib/rpm
@@ -17,3 +18,4 @@
  CPPFLAGS = -DMAGIC='"$(MAGIC)"'
  
  listobjs:
+
index c8a084331a7f265806aed5a9d267467f69fdbadc..847592e50c53e98d985dfc9ec6377c4170a696be 100644 (file)
@@ -1,5 +1,17 @@
---- rpm-4.1/scripts/perl.req.wiget     Mon Jun  3 22:56:33 2002
-+++ rpm-4.1/scripts/perl.req   Wed Sep 18 23:50:15 2002
+diff -urN rpm-4.3.org/configure.ac rpm-4.3/configure.ac
+--- rpm-4.3.org/configure.ac   2004-01-07 01:51:35.251160244 +0100
++++ rpm-4.3/configure.ac       2004-01-07 01:55:53.198560246 +0100
+@@ -1196,6 +1196,7 @@
+ AC_CONFIG_SUBDIRS(popt beecrypt zlib elfutils file db3)
+ AC_CONFIG_FILES([ Doxyfile Makefile rpmrc macros platform rpmpopt rpm.spec
++      scripts/perl.req scripts/perl.prov
+       rpmio/Makefile rpmdb/Makefile lib/Makefile build/Makefile
+       scripts/Makefile scripts/brp-redhat
+       scripts/macros.perl scripts/macros.php scripts/macros.python
+diff -urN rpm-4.3.org/scripts/perl.req rpm-4.3/scripts/perl.req
+--- rpm-4.3.org/scripts/perl.req       2004-01-07 01:51:04.911464416 +0100
++++ rpm-4.3/scripts/perl.req   2004-01-07 01:55:17.030076058 +0100
 @@ -1,4 +1,4 @@
 -#!/usr/bin/perl
 +#!@__PERL@
@@ -44,7 +56,7 @@
    } else {
  
      # I am not using rpm3.0 so I do not want spaces arround my
-@@ -209,7 +221,31 @@
+@@ -219,7 +231,31 @@
        # will be included with the name sys/systeminfo.ph so only use the
        # basename of *.ph files
  
  
        $require{$module}=$version;
        $line{$module}=$_;
---- rpm-4.1/configure.ac.wiget Thu Aug 22 19:01:34 2002
-+++ rpm-4.1/configure.ac       Wed Sep 18 23:50:46 2002
-@@ -1194,6 +1194,7 @@
- AC_CONFIG_SUBDIRS(popt beecrypt zlib libelf db3)
- AC_OUTPUT([ Doxyfile Makefile rpmrc macros platform rpmpopt rpm.spec
-+      scripts/perl.req scripts/perl.prov
-       rpmio/Makefile rpmdb/Makefile lib/Makefile build/Makefile
-       scripts/Makefile scripts/brp-redhat
-       scripts/macros.perl scripts/macros.php scripts/macros.python
+diff -urN rpm-4.3.org/scripts/perl.req.orig rpm-4.3/scripts/perl.req.orig
+--- rpm-4.3.org/scripts/perl.req.orig  1970-01-01 01:00:00.000000000 +0100
++++ rpm-4.3/scripts/perl.req.orig      2004-01-04 03:13:09.000000000 +0100
+@@ -0,0 +1,234 @@
++#!/usr/bin/perl
++
++# RPM (and it's source code) is covered under two separate licenses. 
++
++# The entire code base may be distributed under the terms of the GNU
++# General Public License (GPL), which appears immediately below.
++# Alternatively, all of the source code in the lib subdirectory of the
++# RPM source code distribution as well as any code derived from that
++# code may instead be distributed under the GNU Library General Public
++# License (LGPL), at the choice of the distributor. The complete text
++# of the LGPL appears at the bottom of this file.
++
++# This alternatively is allowed to enable applications to be linked
++# against the RPM library (commonly called librpm) without forcing
++# such applications to be distributed under the GPL.
++
++# Any questions regarding the licensing of RPM should be addressed to
++# Erik Troan <ewt@redhat.com>.
++
++# a simple makedepends like script for perl.
++ 
++# To save development time I do not parse the perl grammmar but
++# instead just lex it looking for what I want.  I take special care to
++# ignore comments and pod's.
++
++# It would be much better if perl could tell us the dependencies of a
++# given script.
++
++# The filenames to scan are either passed on the command line or if
++# that is empty they are passed via stdin.
++
++# If there are strings in the file which match the pattern
++#     m/^\s*\$RPM_Requires\s*=\s*["'](.*)['"]/i
++# then these are treated as additional names which are required by the
++# file and are printed as well.
++
++# I plan to rewrite this in C so that perl is not required by RPM at
++# build time.
++
++# by Ken Estes Mail.com kestes@staff.mail.com
++
++if ("@ARGV") {
++  foreach (@ARGV) {
++    process_file($_);
++  }
++} else {
++  
++  # notice we are passed a list of filenames NOT as common in unix the
++  # contents of the file.
++  
++  foreach (<>) {
++    process_file($_);
++  }
++}
++
++
++foreach $module (sort keys %require) {
++  if (length($require{$module}) == 0) {
++    print "perl($module)\n";
++  } else {
++
++    # I am not using rpm3.0 so I do not want spaces arround my
++    # operators. Also I will need to change the processing of the
++    # $RPM_* vairable when I upgrage.
++
++    print "perl($module) >= $require{$module}\n";
++  }
++}
++
++exit 0;
++
++
++
++sub process_file {
++  
++  my ($file) = @_;
++  chomp $file;
++  
++  open(FILE, "<$file") || return;
++  
++  while (<FILE>) {
++    
++    # skip the "= <<" block
++
++    if ( ( m/^\s*\$(.*)\s*=\s*<<\s*["'](.*)['"]/i) ||
++         ( m/^\s*\$(.*)\s*=\s*<<\s*(.*);/i) ) {
++      $tag = $2;
++      while (<FILE>) {
++        ( $_ =~ /^$tag/) && last;
++      }
++    }
++
++    # skip the documentation
++
++    # we should not need to have item in this if statement (it
++    # properly belongs in the over/back section) but people do not
++    # read the perldoc.
++
++    if ( (m/^=(head1|head2|pod|item)/) .. (m/^=(cut)/) ) {
++      next;
++    }
++
++    if ( (m/^=(over)/) .. (m/^=(back)/) ) {
++      next;
++    }
++    
++    # skip the data section
++    if (m/^__(DATA|END)__$/) {
++      last;
++    }
++
++    # Each keyword can appear multiple times.  Don't
++    #  bother with datastructures to store these strings,
++    #  if we need to print it print it now.
++    
++    if ( m/^\s*\$RPM_Requires\s*=\s*["'](.*)['"]/i) {
++      foreach $_ (split(/\s+/, $1)) {
++      print "$_\n";
++      }
++    }
++
++    if ( 
++
++# ouch could be in a eval, perhaps we do not want these since we catch
++# an exception they must not be required
++
++#   eval { require Term::ReadLine } or die $@;
++#   eval "require Term::Rendezvous;" or die $@;
++#   eval { require Carp } if defined $^S; # If error/warning during compilation,
++
++
++      (m/^(\s*)         # we hope the inclusion starts the line
++       (require|use)\s+(?!\{)     # do not want 'do {' loops
++       # quotes around name are always legal
++       [\'\"]?([^\;\ \'\"\t]*)[\'\"]?[\t\;\ ]
++       # the syntax for 'use' allows version requirements
++       \s*([.0-9]*)
++       /x)
++       ) {
++      my ($whitespace, $statement, $module, $version) = ($1, $2, $3,$4);
++
++      # we only consider require statements that are flush against
++      # the left edge. any other require statements give too many
++      # false positives, as they are usually inside of an if statement
++      # as a fallback module or a rarely used option
++
++      ($whitespace ne "" && $statement eq "require") && next;
++
++      # if there is some interpolation of variables just skip this
++      # dependency, we do not want
++      #        do "$ENV{LOGDIR}/$rcfile";
++   
++      ($module =~ m/\$/) && next;
++
++      # skip if the phrase was "use of" -- shows up in gimp-perl, et al
++      next if $module eq 'of';
++
++      # if the module ends in a comma we probaly caught some
++      # documentation of the form 'check stuff,\n do stuff, clean
++      # stuff.' there are several of these in the perl distribution
++
++      ($module  =~ m/[,>]$/) && next;
++
++      # if the module name starts in a dot it is not a module name.
++      # Is this necessary?  Please give me an example if you turn this
++      # back on.
++
++      #      ($module =~ m/^\./) && next;
++
++      # if the module ends with .pm strip it to leave only basename.
++      # starts with /, which means its an absolute path to a file
++      if ($module =~ m(^/)) {
++        print "$module\n";
++        next;
++      }
++
++      # sometimes people do use POSIX qw(foo), or use POSIX(qw(foo)) etc
++      # we can strip qw.*$, as well as (.*$:
++      $module =~ s/qw.*$//;
++      $module =~ s/\(.*$//;
++
++      $module =~ s/\.pm$//;
++
++      # some perl programmers write 'require URI/URL;' when 
++      # they mean 'require URI::URL;'
++
++      $module =~ s/\//::/;
++
++      # trim off trailing parenthesis if any.  Sometimes people pass
++      # the module an empty list.
++
++      $module =~ s/\(\s*\)$//;
++
++      if ( $module =~ m/^[0-9._]+$/ ) {
++      # if module is a number then both require and use interpret that
++      # to mean that a particular version of perl is specified
++
++      if ($module =~ /5.00/) {
++        print "perl >= 0:$module\n";
++        next;
++      }
++      else {
++        print "perl >= 1:$module\n";
++        next;
++      }
++
++      };
++
++      # ph files do not use the package name inside the file.
++      # perlmodlib  documentation says:
++      
++      #       the .ph files made by h2ph will probably end up as
++      #       extension modules made by h2xs.
++      
++      # so do not expend much effort on these.
++
++
++      # there is no easy way to find out if a file named systeminfo.ph
++      # will be included with the name sys/systeminfo.ph so only use the
++      # basename of *.ph files
++
++      ($module  =~ m/\.ph$/) && next;
++
++      $require{$module}=$version;
++      $line{$module}=$_;
++    }
++    
++  }
++
++  close(FILE) ||
++    die("$0: Could not close file: '$file' : $!\n");
++  
++  return ; 
++}
index 551ffc0986dce9f7f985f04c853440f8f322e0e7..7c699c85d74a6c9e5ce1ef79ef5b07c2a4ad4ebd 100644 (file)
@@ -147,7 +147,7 @@ diff -urN rpm-4.3.org/po/pt_BR.po rpm-4.3/po/pt_BR.po
 @@ -6,6 +6,9 @@
  "Project-Id-Version: rpm 4.0.3\n"
  "Report-Msgid-Bugs-To: \n"
- "POT-Creation-Date: 2003-12-07 15:11-0500\n"
+ "POT-Creation-Date: 2004-01-05 17:24+0000\n"
 +"PO-Revision-Date: 2002-02-14 10:51+0000\n"
 +"Last-Translator: José Nuno Coelho Sanarra Pires <jncp@rnl.ist.utl.pt>\n"
 +"Language-Team: pt <morais@kde.org\n"
@@ -160,7 +160,7 @@ diff -urN rpm-4.3.org/po/sr.po rpm-4.3/po/sr.po
 @@ -3,6 +3,9 @@
  "Project-Id-Version: rpm 4.0.3\n"
  "Report-Msgid-Bugs-To: \n"
- "POT-Creation-Date: 2003-12-07 15:11-0500\n"
+ "POT-Creation-Date: 2004-01-05 17:24+0000\n"
 +"PO-Revision-Date: 2002-02-14 10:51+0000\n"
 +"Last-Translator: ?\n"
 +"Language-Team: ?\n"
index 1f747144e88b156534862aea6efd69fa388e7cd8..32812e92c20eab75a78d1115abf3b5edef6310ec 100644 (file)
@@ -1,7 +1,7 @@
 diff -urN rpm-4.3.org/configure.ac rpm-4.3/configure.ac
---- rpm-4.3.org/configure.ac   2003-12-28 02:08:42.969753832 +0100
-+++ rpm-4.3/configure.ac       2003-12-28 02:09:04.576469112 +0100
-@@ -431,6 +431,18 @@
+--- rpm-4.3.org/configure.ac   2004-01-07 02:28:38.420706689 +0100
++++ rpm-4.3/configure.ac       2004-01-07 02:29:17.078719715 +0100
+@@ -425,6 +425,18 @@
  AC_SUBST(WITH_BEECRYPT_INCLUDE)
  AC_SUBST(WITH_BEECRYPT_LIB)
  
@@ -20,78 +20,39 @@ diff -urN rpm-4.3.org/configure.ac rpm-4.3/configure.ac
  AC_CHECK_FUNC(setreuid, [], [
      AC_CHECK_LIB(ucb, setreuid, [if echo $LIBS | grep -- -lucb >/dev/null ;then :; else LIBS="$LIBS -lc -lucb" USEUCB=y;fi])
  ])
-@@ -1218,7 +1230,7 @@
+@@ -1193,7 +1205,7 @@
  dnl # XXX Propagate -lucb to popt ...
  dnl export LIBS INCPATH CONFIG_SITE
  
 -AC_CONFIG_SUBDIRS(popt beecrypt zlib elfutils file db3)
 +AC_CONFIG_SUBDIRS(file)
  
- AC_OUTPUT([ Doxyfile Makefile rpmrc macros platform rpmpopt rpm.spec
+ AC_CONFIG_FILES([ Doxyfile Makefile rpmrc macros platform rpmpopt rpm.spec
        scripts/perl.req scripts/perl.prov
-@@ -1240,7 +1252,7 @@
-       python/Makefile
+@@ -1216,7 +1228,7 @@
        python/rpmdb/Makefile
        python/rpmdb/test/Makefile
--  ], [        echo timestamp > popt/stamp-h.in
-+  ], [
+   ])
+-AC_CONFIG_COMMANDS([default],[[       echo timestamp > popt/stamp-h.in
++AC_CONFIG_COMMANDS([default],[[       
        echo timestamp > stamp-h.in
-   ]
- )
-diff -urN rpm-4.3.org/configure.ac.orig rpm-4.3/configure.ac.orig
---- rpm-4.3.org/configure.ac.orig      2003-12-28 02:08:50.057676304 +0100
-+++ rpm-4.3/configure.ac.orig  2003-12-28 02:08:04.494602944 +0100
-@@ -1222,6 +1222,7 @@
- AC_OUTPUT([ Doxyfile Makefile rpmrc macros platform rpmpopt rpm.spec
-       scripts/perl.req scripts/perl.prov
-+      scripts/php.req scripts/php.prov
-       rpmio/Makefile rpmdb/Makefile lib/Makefile build/Makefile
-       scripts/Makefile scripts/brp-redhat
-       scripts/macros.perl scripts/macros.php scripts/macros.python
+   
+ ]],[[]])
 diff -urN rpm-4.3.org/lib/Makefile.am rpm-4.3/lib/Makefile.am
---- rpm-4.3.org/lib/Makefile.am        2003-12-28 02:08:42.972753376 +0100
-+++ rpm-4.3/lib/Makefile.am    2003-12-28 02:10:03.310540176 +0100
-@@ -10,7 +10,6 @@
-       -I$(top_srcdir)/rpmdb \
-       -I$(top_srcdir)/rpmio \
-       @WITH_BEECRYPT_INCLUDE@ \
--      -I$(top_srcdir)/popt \
-       @INCPATH@
- EXTRA_DIST = getdate.y
-@@ -40,7 +39,7 @@
+--- rpm-4.3.org/lib/Makefile.am        2004-01-07 02:27:38.909001150 +0100
++++ rpm-4.3/lib/Makefile.am    2004-01-07 02:29:44.348085397 +0100
+@@ -40,7 +40,7 @@
  librpm_la_LDFLAGS = -release 4.3 $(LDFLAGS) \
        $(top_builddir)/rpmdb/librpmdb.la \
        $(top_builddir)/rpmio/librpmio.la \
 -      $(top_builddir)/popt/libpopt.la \
-+      @WITH_POPT_LIB@ \
-       -lselinux
++      -lpopt \
+       @WITH_SELINUX_LIB@
  
  getdate.c: getdate.y
-@@ -93,7 +92,7 @@
-       $(LINK) @LDFLAGS_STATIC@ $(CFLAGS) $(DEFS) $(INCLUDES) -o $@ $< \
-       -lselinux \
-       $(top_builddir)/rpmio/librpmio.la \
--      $(top_builddir)/popt/libpopt.la
-+      -lpopt
-       
- #tds: tds.c librpm.la
- #     $(CC) $(CFLAGS) $(DEFS) $(INCLUDES) -o $@ $< $(mylibs)
-@@ -104,8 +103,8 @@
- tthread: tthread.o librpm.la
-       $(LINK) $(CFLAGS) $(DEFS) $(INCLUDES) -o $@ $< $(mylibs) @WITH_LIBELF_LIB@
--tsystem: tsystem.o $(top_builddir)/popt/libpopt.la
--      $(LINK) $(CFLAGS) $(DEFS) $(INCLUDES) -o $@ $< $(top_builddir)/rpmio/librpmio.la $(top_builddir)/popt/libpopt.la
-+tsystem: tsystem.o
-+      $(LINK) $(CFLAGS) $(DEFS) $(INCLUDES) -o $@ $< $(top_builddir)/rpmio/librpmio.la -lpopt
- tre: tre.o librpm.la
-       $(LINK) $(CFLAGS) $(DEFS) $(INCLUDES) -o $@ $< \
 diff -urN rpm-4.3.org/Makefile.am rpm-4.3/Makefile.am
---- rpm-4.3.org/Makefile.am    2003-12-28 02:08:42.937758696 +0100
-+++ rpm-4.3/Makefile.am        2003-12-28 02:09:04.580468504 +0100
+--- rpm-4.3.org/Makefile.am    2004-01-07 02:27:37.031389024 +0100
++++ rpm-4.3/Makefile.am        2004-01-07 02:29:17.082718889 +0100
 @@ -14,7 +14,7 @@
        po/*.in po/*.po po/rpm.pot \
        rpm.magic rpmpopt-$(VERSION) rpmqv.c rpm.c
@@ -138,8 +99,8 @@ diff -urN rpm-4.3.org/Makefile.am rpm-4.3/Makefile.am
  CVSTAG = r$(subst .,-,$(VERSION))
  
 diff -urN rpm-4.3.org/rpmdb/Makefile.am rpm-4.3/rpmdb/Makefile.am
---- rpm-4.3.org/rpmdb/Makefile.am      2003-12-28 02:08:53.054220760 +0100
-+++ rpm-4.3/rpmdb/Makefile.am  2003-12-28 02:09:04.581468352 +0100
+--- rpm-4.3.org/rpmdb/Makefile.am      2004-01-07 02:28:11.926180317 +0100
++++ rpm-4.3/rpmdb/Makefile.am  2004-01-07 02:29:17.087717856 +0100
 @@ -9,7 +9,6 @@
        -I$(top_srcdir)/lib \
        -I$(top_srcdir)/rpmio \
@@ -158,8 +119,8 @@ diff -urN rpm-4.3.org/rpmdb/Makefile.am rpm-4.3/rpmdb/Makefile.am
  librpmdb_la_LIBADD = $(DBLIBOBJS) $(libdb_la)
  librpmdb_la_DEPENDENCIES = $(DBLIBOBJS) $(libdb_la)
 diff -urN rpm-4.3.org/rpmio/Makefile.am rpm-4.3/rpmio/Makefile.am
---- rpm-4.3.org/rpmio/Makefile.am      2003-12-28 02:08:42.988750944 +0100
-+++ rpm-4.3/rpmio/Makefile.am  2003-12-28 02:09:04.582468200 +0100
+--- rpm-4.3.org/rpmio/Makefile.am      2004-01-07 02:27:43.915966813 +0100
++++ rpm-4.3/rpmio/Makefile.am  2004-01-07 02:29:17.090717237 +0100
 @@ -11,7 +11,6 @@
  INCLUDES = -I. \
        -I$(top_srcdir) \
@@ -212,8 +173,8 @@ diff -urN rpm-4.3.org/rpmio/Makefile.am rpm-4.3/rpmio/Makefile.am
  tsw_SOURCES = tsw.c
  tsw_LDFLAGS = librpmio.la
 diff -urN rpm-4.3.org/tools/Makefile.am rpm-4.3/tools/Makefile.am
---- rpm-4.3.org/tools/Makefile.am      2003-12-28 02:08:42.852771616 +0100
-+++ rpm-4.3/tools/Makefile.am  2003-12-28 02:09:26.913073432 +0100
+--- rpm-4.3.org/tools/Makefile.am      2004-01-07 02:27:44.830777831 +0100
++++ rpm-4.3/tools/Makefile.am  2004-01-07 02:29:17.096715997 +0100
 @@ -9,7 +9,6 @@
        -I$(top_srcdir)/rpmdb \
        -I$(top_srcdir)/rpmio \
This page took 0.059387 seconds and 4 git commands to generate.