]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- scripts-closefds patch: prevent from passing open file descriptors to
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 8 Sep 2001 23:40:29 +0000 (23:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  pre/post scripts (one fd (12?) was terminal, second (11?) .rpm file)
- python-amfix patch: fixes automake problems in python subdir
- release 34

Changed files:
    rpm-python-amfix.patch -> 1.1
    rpm-scripts-closefds.patch -> 1.1
    rpm.spec -> 1.239

rpm-python-amfix.patch [new file with mode: 0644]
rpm-scripts-closefds.patch [new file with mode: 0644]
rpm.spec

diff --git a/rpm-python-amfix.patch b/rpm-python-amfix.patch
new file mode 100644 (file)
index 0000000..2bead41
--- /dev/null
@@ -0,0 +1,9 @@
+--- rpm-4.0.2/python/Makefile.am.orig  Mon Jun 19 01:26:50 2000
++++ rpm-4.0.2/python/Makefile.am       Sun Sep  9 00:41:37 2001
+@@ -25,5 +25,5 @@
+ noinst_LTLIBRARIES = librpmmodule.la
+ librpmmodule_la_SOURCES = rpmmodule.c hash.c upgrade.c
+-rpmmodule.so: $(librpmmodule_la_OBJECTS)
++rpmmodule.so$(EXEEXT): $(librpmmodule_la_OBJECTS)
+       $(LINK) -o $@ $^ $(rpmmodule_so_LDFLAGS)
diff --git a/rpm-scripts-closefds.patch b/rpm-scripts-closefds.patch
new file mode 100644 (file)
index 0000000..da005da
--- /dev/null
@@ -0,0 +1,30 @@
+diff -Nur rpm-4.0.2.orig/lib/rpminstall.c rpm-4.0.2/lib/rpminstall.c
+--- rpm-4.0.2.orig/lib/rpminstall.c    Sat Feb 10 15:07:16 2001
++++ rpm-4.0.2/lib/rpminstall.c Sun Sep  9 00:33:52 2001
+@@ -87,6 +87,13 @@
+       case RPMCALLBACK_INST_OPEN_FILE:
+       fd = Fopen(filename, "r.ufdio");
+       fd = fdLink(fd, "persist (showProgress)");
++      {
++          int oldfl=Fcntl(fd, F_GETFD, 0);
++          if(oldfl >= 0) {
++              oldfl |= FD_CLOEXEC; /* scripts shouldn't inherit rpm file descriptor */
++              Fcntl(fd, F_SETFD, oldfl);
++          }
++      }
+       return fd;
+       case RPMCALLBACK_INST_CLOSE_FILE:
+diff -Nur rpm-4.0.2.orig/lib/uninstall.c rpm-4.0.2/lib/uninstall.c
+--- rpm-4.0.2.orig/lib/uninstall.c     Mon Jan 22 16:59:13 2001
++++ rpm-4.0.2/lib/uninstall.c  Sat Sep  8 23:58:22 2001
+@@ -388,6 +388,9 @@
+           if (Fileno(ts->scriptFd) > STDERR_FILENO) {
+               Fclose (ts->scriptFd);
+           }
++      } else {
++          if (Fileno(out) > STDERR_FILENO)
++              Fclose (out);
+       }
+       {   const char *ipath = rpmExpand("PATH=%{_install_script_path}", NULL);
index 2bdb397bd5aad6e1cafdeccbaca241ed977fc0bf..59a93f676d8fc475ff63800fc99d1174dfcd006c 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -3,7 +3,7 @@ Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
 Summary(pl):   Aplikacja do zarz±dzania pakietami
 Name:          rpm
 Version:       4.0.2
-Release:       33
+Release:       34
 License:       GPL
 Group:         Base
 Group(de):     Gründsätzlich
@@ -41,6 +41,8 @@ Patch17:      %{name}-perlprov.patch
 Patch18:       %{name}-noperldir.patch
 Patch19:       popt-cvs20010530.patch
 Patch20:       %{name}-noexpand.patch
+Patch21:       %{name}-scripts-closefds.patch
+Patch22:       %{name}-python-amfix.patch
 Patch37:        %{name}-short_circuit.patch
 Patch38:        %{name}-section_test.patch
 BuildRequires: gettext-devel >= 0.10.38-3
@@ -249,6 +251,8 @@ construir pacotes usando o RPM.
 %patch16 -p0
 %patch17 -p1
 %patch18 -p1
+%patch19 -p1
+%patch22 -p1
 %patch31 -p1
 %patch36 -p1
 cp platform.in macros.pld.in
This page took 0.047456 seconds and 4 git commands to generate.