- package/own /usr/lib/.build-id directory
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 24 Jan 2021 08:43:54 +0000 (09:43 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 24 Jan 2021 08:43:54 +0000 (09:43 +0100)
This should force poldek and rpm5 to upgrade the rpm package when trying
to install any package built with rpm 4.

rpm.spec

index b3bb33e5f4328d740f307682a3d6dd1a1c0186bd..bd91c6f4a6d6dc091c781ac2daf8756c5d3d98db 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -638,7 +638,7 @@ cd python
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/{rpm,pki/rpm-gpg}} \
-       $RPM_BUILD_ROOT/var/lib/{banner,rpm}
+       $RPM_BUILD_ROOT{/var/lib/{banner,rpm},/usr/lib/.build-id}
 
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
 
@@ -869,6 +869,8 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 # valgrind suppression file for rpm
 %{_rpmlibdir}/rpm.supp
 
+%dir /usr/lib/.build-id
+
 %files base
 %defattr(644,root,root,755)
 %dir %{_sysconfdir}/rpm
This page took 1.215213 seconds and 4 git commands to generate.