]> git.pld-linux.org Git - packages/rpm.git/commitdiff
trivial patches update dev-5.4.18
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 18 Jul 2017 17:08:38 +0000 (20:08 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Tue, 18 Jul 2017 17:08:38 +0000 (20:08 +0300)
complex patches need review

19 files changed:
openmp.patch
rpm-5.4.10-duplicate_files_terminate_build.patch
rpm-5.4.10-files-listed-twice-terminates-build.patch
rpm-5.4.10-unpackaged_subdirs_terminate_build.patch
rpm-5.4.7-hdrfmt-fix-unitialized-argv-element.patch
rpm-5.4.9-fix-rpm_qa-pattern.patch
rpm-5.4.9-strip-buildroot-away-from-duplicate-files-list.patch
rpm-double_check_file_deps.patch
rpm-double_check_unpackaged_subdirs.patch
rpm-file-magic-can-be-mixed-case.patch
rpm-fix-compress-doc.patch
rpm-fix-filedigests-verify.patch
rpm-lua-expat.patch
rpm-repackage-dont-force-max-compression.patch
rpm-semanage.patch
rpm-unglobal.patch
rpm.spec
vendor-pld.patch
x32.patch

index 78b02eaec837e10834420e3c57a246cadfb2e562..1caaca13a4ba7c23b05dd20bad86c64c995784eb 100644 (file)
@@ -1,11 +1,15 @@
---- rpm-5.3.1/rpmio/Makefile.am.wiget  2010-05-24 17:23:09.000000000 +0200
-+++ rpm-5.3.1/rpmio/Makefile.am        2010-06-01 21:29:20.521227268 +0200
-@@ -102,7 +102,7 @@ librpmio_la_SOURCES = \
-       xzdio.c \
-       yarn.c
+
+outdated? there's already in rpmio/Makefile.am:
+AM_CFLAGS = $(OPENMP_CFLAGS)
+
+--- rpm-5.4.18/rpmio/Makefile.am~      2017-07-16 22:47:06.000000000 +0300
++++ rpm-5.4.18/rpmio/Makefile.am       2017-07-18 16:16:56.558291408 +0300
+@@ -274,7 +274,7 @@
+       yarn.c \
+       zstdio.c
  
--librpmio_la_LDFLAGS = -release $(LT_CURRENT).$(LT_REVISION)
-+librpmio_la_LDFLAGS = -release $(LT_CURRENT).$(LT_REVISION) $(OPENMP_CFLAGS)
+-librpmio_la_LDFLAGS = -no-undefined -release $(LT_CURRENT).$(LT_REVISION)
++librpmio_la_LDFLAGS = -no-undefined -release $(LT_CURRENT).$(LT_REVISION) $(OPENMP_CFLAGS)
  if HAVE_LD_VERSION_SCRIPT
  librpmio_la_LDFLAGS += -Wl,@LD_VERSION_SCRIPT_FLAG@,@top_srcdir@/rpmio/librpmio.vers
  endif
index 8f4574b13a42c1f6290e0ba8dfaae3dc74cfd5ac..ce16ad2f23faaf30f5b0214e10ea776010a78a80 100644 (file)
@@ -1,15 +1,14 @@
---- rpm-5.4.10/build/files.c.dups_terminate~   2012-07-10 20:09:01.125249185 +0200
-+++ rpm-5.4.10/build/files.c   2012-07-10 20:09:01.135249061 +0200
-@@ -2917,7 +2917,8 @@ exit:
+--- rpm-5.4.18/build/files.c~  2017-07-18 19:57:37.000000000 +0300
++++ rpm-5.4.18/build/files.c   2017-07-18 19:58:47.210448958 +0300
+@@ -2873,7 +2873,7 @@
  
  /* auxiliary function for checkDuplicateFiles() */
  /* XXX need to pass Header because fi->h is NULL */
--static int fiIntersect(/*@null@*/ rpmfi fi1, /*@null@*/ rpmfi fi2, size_t buildrootL)
-+static int fiIntersect(/*@null@*/ rpmfi fi1, /*@null@*/ rpmfi fi2,
-+      size_t buildrootL, int _duplicate_files_terminate_build)
-       /*@globals internalState @*/
-       /*@modifies fi1, fi2, internalState @*/
+-static int fiIntersect(rpmfi fi1, rpmfi fi2, size_t buildrootL)
++static int fiIntersect(rpmfi fi1, rpmfi fi2, size_t buildrootL, int _duplicate_files_terminate_build)
  {
+     int n = 0;
+     int i1, i2;
 @@ -2955,7 +2956,7 @@ static int fiIntersect(/*@null@*/ rpmfi
        he->tag = RPMTAG_NVRA;
        N2 = (headerGet(fi2->h, he, 0) ? he->p.str : NULL);
               _("File(s) packaged into both %s and %s:\n%s"),
               N1, N2, rpmiobStr(dups));
  
-@@ -2972,7 +2973,8 @@ static int fiIntersect(/*@null@*/ rpmfi
+@@ -2926,7 +2926,7 @@
   * @param spec                spec file control structure
   * @return            number of duplicate files
   */
 -static int checkDuplicateFiles(Spec spec, size_t buildrootL)
-+static int checkDuplicateFiles(Spec spec, size_t buildrootL,
-+      int _duplicate_files_terminate_build)
-       /*@globals rpmGlobalMacroContext, h_errno, fileSystem, internalState @*/
-       /*@modifies *spec->packages,
-               rpmGlobalMacroContext, fileSystem, internalState @*/
++static int checkDuplicateFiles(Spec spec, size_t buildrootL, int _duplicate_files_terminate_build)
+ {
+     int n = 0;
+     Package pkg1, pkg2;
 @@ -2997,7 +2999,7 @@ static int checkDuplicateFiles(Spec spec
  #endif
            if (fi2 == NULL) continue;
index 9fd555cd3952bc1a75cdfd004e1901ea66ee4d06..0e35c44dbfe662e10523d8239e70ce9b2903a57c 100644 (file)
@@ -1,14 +1,14 @@
---- rpm-5.4.10/build/files.c.twice_terminate~  2012-07-10 20:18:14.613329633 +0200
-+++ rpm-5.4.10/build/files.c   2012-07-10 20:18:14.677328833 +0200
-@@ -1329,7 +1329,7 @@ static rpmuint32_t getDigestAlgo(Header
-  * @param h
-  * @param isSrc
+--- rpm-5.4.18/build/files.c~  2017-07-18 20:02:53.000000000 +0300
++++ rpm-5.4.18/build/files.c   2017-07-18 20:03:43.702134699 +0300
+@@ -1353,7 +1353,7 @@
+  * @param h           h
+  * @param isSrc               isSrc
   */
--static void genCpioListAndHeader(/*@partial@*/ FileList fl,
-+static rpmRC genCpioListAndHeader(/*@partial@*/ FileList fl,
+-static void genCpioListAndHeader(FileList fl,
++static rpmRC genCpioListAndHeader(FileList fl,
                rpmfi * fip, Header h, int isSrc)
-       /*@globals rpmGlobalMacroContext, h_errno, fileSystem, internalState @*/
-       /*@modifies h, *fip, fl->processingFailed, fl->fileList,
+ {
+     HE_t he = (HE_t) memset(alloca(sizeof(*he)), 0, sizeof(*he));
 @@ -1349,6 +1349,7 @@ static void genCpioListAndHeader(/*@part
      rpmuint32_t dalgo = getDigestAlgo(h, isSrc);
      char buf[BUFSIZ];
index 2e7c5b88b8c729836a81ac754bd0474ceda582c1..59b2ba28b31a8a0ec440c4841608fc0e08d2b58c 100644 (file)
@@ -1,14 +1,14 @@
---- rpm-5.4.10/build/files.c.subdir_terminate~ 2012-07-10 20:14:36.357058212 +0200
-+++ rpm-5.4.10/build/files.c   2012-07-10 20:14:36.367058087 +0200
-@@ -3025,7 +3025,7 @@ static inline int packagedDir(Package pk
+--- rpm-5.4.18/build/files.c~  2017-07-18 20:01:13.000000000 +0300
++++ rpm-5.4.18/build/files.c   2017-07-18 20:02:01.770304167 +0300
+@@ -2987,7 +2987,7 @@
   *       /A/B/C/D
   * Now directories "/A/B" and "/A/B/C" should also be packaged.
   */
 -static int pkgUnpackagedSubdirs(Package pkg, size_t buildrootL)
 +static int pkgUnpackagedSubdirs(Package pkg, size_t buildrootL, int _unpackaged_subdirs_terminate_build)
-       /*@globals rpmGlobalMacroContext, h_errno, fileSystem, internalState @*/
-       /*@modifies pkg->header,
-               rpmGlobalMacroContext, fileSystem, internalState @*/
+ {
+     int n = 0;
+     int i, j;
 @@ -3103,7 +3103,7 @@ static int pkgUnpackagedSubdirs(Package
        }
        unpackaged = _free(unpackaged);
               _("Unpackaged subdir(s) in %s:\n%s"),
               N, rpmiobStr(list));
  
-@@ -3119,7 +3119,7 @@ static int pkgUnpackagedSubdirs(Package
+@@ -3080,7 +3080,7 @@
   * @param spec                spec file control structure
   * @return            number of unpackaged subdirectories
   */
 -static int checkUnpackagedSubdirs(Spec spec, size_t buildrootL)
 +static int checkUnpackagedSubdirs(Spec spec, size_t buildrootL, int _unpackaged_subdirs_terminate_build)
-       /*@globals rpmGlobalMacroContext, h_errno, fileSystem, internalState @*/
-       /*@modifies *spec->packages,
-               rpmGlobalMacroContext, fileSystem, internalState @*/
+ {
+     int n = 0;
+     Package pkg;
 @@ -3128,7 +3128,7 @@ static int checkUnpackagedSubdirs(Spec s
      Package pkg;
  
index 157a6eb4df9e0550cba42a21db91a0c5ce5bf29d..e62a73a7c7308ba59a0b220025cc0973d8504967 100644 (file)
@@ -1,13 +1,13 @@
---- rpm-5.4.7/rpmdb/hdrfmt.c.unitialized~      2012-03-19 14:21:14.907225418 +0100
-+++ rpm-5.4.7/rpmdb/hdrfmt.c   2012-03-19 14:21:17.327228582 +0100
-@@ -2048,8 +2048,10 @@ static int triggertypeTag(Header h, HE_t
+--- rpm-5.4.18/rpmdb/hdrfmt.c~ 2017-07-18 20:05:47.000000000 +0300
++++ rpm-5.4.18/rpmdb/hdrfmt.c  2017-07-18 20:06:11.192944908 +0300
+@@ -2092,8 +2092,10 @@
      he->p.argv = xmalloc(sizeof(*he->p.argv) * he->c);
      for (i = 0; i < (unsigned) he->c; i++) {
        for (j = 0; j < (unsigned) numNames; j++) {
 -          if (indices.ui32p[j] != i)
 +          if (indices.ui32p[j] != i) {
 +              he->p.argv[i] = NULL;
-               /*@innercontinue@*/ continue;
+               continue;
 +          }
  
            /* XXX FIXME: there's memory leaks here. */
index 76ce249b4aacced001402fd36b2b5625cd6c4807..9326befe5be8846c14a700765843481d96f25796 100644 (file)
@@ -1,11 +1,11 @@
---- rpm-5.4.9/lib/rpmgi.c.pattern~     2012-04-15 23:20:58.000000000 +0200
-+++ rpm-5.4.9/lib/rpmgi.c      2012-05-17 01:56:21.018481577 +0200
-@@ -473,7 +473,7 @@ fprintf(stderr, "*** gi %p key %p[%d]\tm
+--- rpm-5.4.18/lib/rpmgi.c~    2017-07-14 15:07:43.000000000 +0300
++++ rpm-5.4.18/lib/rpmgi.c     2017-07-18 20:07:54.541517378 +0300
+@@ -462,7 +462,7 @@
                pat = ae;
                got++;
            }
 -          if (got) {
 +          if (got >= 0) {
- if (_rpmgi_debug  < 0)
- fprintf(stderr, "\tav %p[%d]: \"%s\" -> %s ~= \"%s\"\n", gi->argv, (int)(av - gi->argv), *av, tagName((rpmTag)tag), pat);
+ SPEW("\tav %p[%d]: \"%s\" -> %s ~= \"%s\"\n", gi->argv, (int)(av - gi->argv), *av, tagName((rpmTag)tag), pat);
                got = rpmmiAddPattern(gi->mi, (rpmTag)tag, RPMMIRE_DEFAULT, pat);
+           }
index 8e48830b922eafb8f23731e65d8b26039d2e8760..0b6f175fe5015f5e7bece5cbcdb1ec2d48b3f757 100644 (file)
@@ -1,14 +1,14 @@
---- rpm-5.4.9/build/files.c.buildroot_dups~    2012-04-15 17:04:14.000000000 +0200
-+++ rpm-5.4.9/build/files.c    2012-05-15 02:11:03.734983519 +0200
-@@ -2917,7 +2917,7 @@ exit:
+--- rpm-5.4.18/build/files.c~  2017-07-18 19:55:03.000000000 +0300
++++ rpm-5.4.18/build/files.c   2017-07-18 19:56:17.522870262 +0300
+@@ -2873,7 +2873,7 @@
  
  /* auxiliary function for checkDuplicateFiles() */
  /* XXX need to pass Header because fi->h is NULL */
--static int fiIntersect(/*@null@*/ rpmfi fi1, /*@null@*/ rpmfi fi2)
-+static int fiIntersect(/*@null@*/ rpmfi fi1, /*@null@*/ rpmfi fi2, size_t buildrootL)
-       /*@globals internalState @*/
-       /*@modifies fi1, fi2, internalState @*/
+-static int fiIntersect(rpmfi fi1, rpmfi fi2)
++static int fiIntersect(rpmfi fi1, rpmfi fi2, size_t buildrootL)
  {
+     int n = 0;
+     int i1, i2;
 @@ -2941,7 +2941,7 @@ static int fiIntersect(/*@null@*/ rpmfi
            if (!dups)
                dups = rpmiobNew(0);
            n++;
        }
      }
-@@ -2972,7 +2972,7 @@ static int fiIntersect(/*@null@*/ rpmfi
+@@ -2926,7 +2926,7 @@
   * @param spec                spec file control structure
   * @return            number of duplicate files
   */
 -static int checkDuplicateFiles(Spec spec)
 +static int checkDuplicateFiles(Spec spec, size_t buildrootL)
-       /*@globals rpmGlobalMacroContext, h_errno, fileSystem, internalState @*/
-       /*@modifies *spec->packages,
-               rpmGlobalMacroContext, fileSystem, internalState @*/
+ {
+     int n = 0;
+     Package pkg1, pkg2;
 @@ -2997,7 +2997,7 @@ static int checkDuplicateFiles(Spec spec
  #endif
            if (fi2 == NULL) continue;
            (void) rpmfiSetHeader(fi2, NULL);
            fi2 = rpmfiFree(fi2);
        }
-@@ -3023,7 +3023,7 @@ static inline int packagedDir(Package pk
+@@ -2987,7 +2987,7 @@
   *       /A/B/C/D
   * Now directories "/A/B" and "/A/B/C" should also be packaged.
   */
 -static int pkgUnpackagedSubdirs(Package pkg)
 +static int pkgUnpackagedSubdirs(Package pkg, size_t buildrootL)
-       /*@globals rpmGlobalMacroContext, h_errno, fileSystem, internalState @*/
-       /*@modifies pkg->header,
-               rpmGlobalMacroContext, fileSystem, internalState @*/
+ {
+     int n = 0;
+     int i, j;
 @@ -3096,7 +3096,7 @@ static int pkgUnpackagedSubdirs(Package
  
        for (i = 0; i < n; i++) {
            unpackaged[i] = _free(unpackaged[i]);
        }
        unpackaged = _free(unpackaged);
-@@ -3117,7 +3117,7 @@ static int pkgUnpackagedSubdirs(Package
+@@ -3080,7 +3080,7 @@
   * @param spec                spec file control structure
   * @return            number of unpackaged subdirectories
   */
 -static int checkUnpackagedSubdirs(Spec spec)
 +static int checkUnpackagedSubdirs(Spec spec, size_t buildrootL)
-       /*@globals rpmGlobalMacroContext, h_errno, fileSystem, internalState @*/
-       /*@modifies *spec->packages,
-               rpmGlobalMacroContext, fileSystem, internalState @*/
+ {
+     int n = 0;
+     Package pkg;
 @@ -3126,7 +3126,7 @@ static int checkUnpackagedSubdirs(Spec s
      Package pkg;
  
index 58000a5f19a633717c790c103fa0dc8b20490be9..dc1bca49a94a16fe814c95f7086dfff446596e45 100644 (file)
@@ -1,6 +1,5 @@
-diff -dur rpm-5.4.12.orig/lib/rpmal.c rpm-5.4.12/lib/rpmal.c
---- rpm-5.4.12.orig/lib/rpmal.c        2012-04-15 23:20:57.000000000 +0200
-+++ rpm-5.4.12/lib/rpmal.c     2013-08-13 13:46:28.000000000 +0200
+--- rpm-5.4.18/lib/rpmal.c~    2017-07-18 19:41:25.000000000 +0300
++++ rpm-5.4.18/lib/rpmal.c     2017-07-18 19:42:21.707538362 +0300
 @@ -7,6 +7,10 @@
  #include <rpmio.h>
  #include <rpmiotypes.h>               /* XXX fnpyKey */
@@ -38,14 +37,14 @@ diff -dur rpm-5.4.12.orig/lib/rpmal.c rpm-5.4.12/lib/rpmal.c
  
      memset(alp, 0, sizeof(*alp));     /* XXX trash and burn */
      return;
-@@ -244,6 +253,7 @@
- /*@-assignexpose -castexpose @*/
+@@ -210,6 +210,7 @@
      alp->provides = rpmdsLink(provides, "Provides (rpmalAdd)");
      alp->bf = rpmbfLink(rpmfiFNBF(fi));
 +    alp->fi = rpmfiLink(fi, "file list (rpmalAdd)");
- /*@=assignexpose =castexpose @*/
  
      rpmalFreeIndex(al);
 @@ -350,17 +360,17 @@
  rpmalAllFileSatisfiesDepend(const rpmal al, const rpmds ds, alKey * keyp)
  {
index b83f7decc5d7f4a95a0109e5676c014493bcb198..92f0e58f7f3bef66c35432bf06390d143eb7b534 100644 (file)
@@ -4,32 +4,31 @@ for useless checks (note that before packagedDir() could succeed on
 some dir over buildroot, leading to log some junk, after the end of
 string shorter than buildrootL).
 
---- rpm-5.4.13/build/files.c.orig      2013-10-04 21:31:18.840898688 +0200
-+++ rpm-5.4.13/build/files.c   2013-10-13 09:09:23.406411763 +0200
-@@ -3032,12 +3032,26 @@
+--- rpm-5.4.18/build/files.c~  2017-07-18 19:46:18.000000000 +0300
++++ rpm-5.4.18/build/files.c   2017-07-18 19:46:29.723117424 +0300
+@@ -2959,9 +2959,25 @@
  }
  
  /* auxiliary function: check if directory d is packaged */
 -static inline int packagedDir(Package pkg, const char *d)
 +static int packagedDir(Package pkg, const char *d)
-       /*@globals rpmGlobalMacroContext, h_errno, fileSystem, internalState @*/
-       /*@modifies pkg->header,
-               rpmGlobalMacroContext, fileSystem, internalState @*/
  {
 -    return rpmbfChk(rpmfiFNBF(pkg->fi), d, strlen(d));
 +    if(!rpmbfChk(rpmfiFNBF(pkg->fi), d, strlen(d)))
-+      return 0;
++        return 0;
++
 +    char * fifn = (char *) xmalloc(pkg->fi->fnlen + 1);
 +    rpmuint32_t j;
 +    for(j = 0; j < pkg->fi->fc; j++) {
-+      const char * dn = NULL;
-+      (void) urlPath(pkg->fi->dnl[pkg->fi->dil[j]], &dn);
-+      strcpy(stpcpy(fifn, dn), pkg->fi->bnl[j]);
-+      if (!strcmp(d, fifn)) {
-+          free(fifn);
-+          return 1;
-+      }
++        const char * dn = NULL;
++        (void) urlPath(pkg->fi->dnl[pkg->fi->dil[j]], &dn);
++        strcpy(stpcpy(fifn, dn), pkg->fi->bnl[j]);
++        if (!strcmp(d, fifn)) {
++            free(fifn);
++            return 1;
++        }
 +    }
++
 +    free(fifn);
 +    return 0;
  }
index 0d566a487e3231ba66bab0a0a1939f24a2d2553a..d02a54ef976785478a0342c412a4fcecda64d386 100644 (file)
@@ -1,6 +1,6 @@
---- rpm-5.4.16/scripts/rpm2cpio~       2015-04-20 19:42:37.000000000 +0300
-+++ rpm-5.4.16/scripts/rpm2cpio        2016-03-16 00:23:31.243396707 +0200
-@@ -25,13 +25,13 @@
+--- rpm-5.4.18/scripts/rpm2cpio~       2017-07-16 07:42:40.000000000 +0300
++++ rpm-5.4.18/scripts/rpm2cpio        2017-07-18 17:50:00.490906514 +0300
+@@ -25,15 +25,15 @@
  EXTRACTOR="dd if=$pkg ibs=$o skip=1"
  
  COMPRESSION=$(($EXTRACTOR |file -) 2>/dev/null)
@@ -13,6 +13,9 @@
 -elif echo $COMPRESSION |grep -q xz; then
 +elif echo $COMPRESSION |grep -qi xz; then
        DECOMPRESSOR=unxz
+-elif echo $COMPRESSION |grep -q zstd; then
++elif echo $COMPRESSION |grep -qi zstd; then
+       DECOMPRESSOR=unxz
 -elif echo $COMPRESSION |grep -q cpio; then
 +elif echo $COMPRESSION |grep -qi cpio; then
        DECOMPRESSOR=cat
index a9256d30a2e9d422170156e69535adf39c931d65..073cc9cb0d338f5229432d8d893849ec9e7129ed 100644 (file)
@@ -1,5 +1,5 @@
---- rpm-5.4.10/build/files.c~  2013-01-25 13:14:36.692060288 +0100
-+++ rpm-5.4.10/build/files.c   2013-02-25 12:03:26.110910465 +0100
+--- rpm-5.4.18/build/files.c~  2017-07-18 18:00:51.000000000 +0300
++++ rpm-5.4.18/build/files.c   2017-07-18 18:01:41.326747116 +0300
 @@ -1041,7 +1041,6 @@
        /* XXX FIXME: this is easy to do as macro expansion */
  
@@ -8,7 +8,7 @@
                char *mkdir_p;
  
                pkg->specialDoc = rpmiobNew(0);
-@@ -1056,11 +1055,6 @@
+@@ -1064,11 +1064,6 @@
                mkdir_p = _free(mkdir_p);
                pkg->specialDoc = rpmiobAppend(pkg->specialDoc, " \"$DOCDIR\"", 1);
  
@@ -17,9 +17,9 @@
 -                  pkg->specialDoc = rpmiobAppend(pkg->specialDoc, compress_doc, 1);
 -              compress_doc = _free(compress_doc);
 -
-               /*@-temptrans@*/
                *fileName = buf;
-               /*@=temptrans@*/
+               fl->passedSpecialDoc = 1;
+               fl->isSpecialDoc = 1;
 @@ -1071,6 +1065,15 @@
            pkg->specialDoc = rpmiobAppend(pkg->specialDoc, "cp -pr ", 0);
            pkg->specialDoc = rpmiobAppend(pkg->specialDoc, specialDocBuf, 0);
index 755848f4f6832ca03957244529cf738d2854f49d..602a8c55968fbddbee4910878efcea802edb4bb4 100644 (file)
@@ -1,10 +1,10 @@
---- rpm-5.4.10.orig/build/files.c      2012-10-15 23:29:13.601832730 +0200
-+++ rpm-5.4.10/build/files.c   2012-10-15 23:29:50.264308164 +0200
-@@ -393,7 +393,6 @@
+--- rpm-5.4.18/build/files.c~  2017-07-18 17:50:47.000000000 +0300
++++ rpm-5.4.18/build/files.c   2017-07-18 17:57:03.435875760 +0300
+@@ -362,7 +362,6 @@
                if (strcmp(p, vfa->attribute))
-                   /*@innercontinue@*/ continue;
+                   continue;
                verifyFlags |= vfa->flag;
 -                  verifyFlags &= ~RPMVERIFY_FDIGEST;
-               /*@innerbreak@*/ break;
+               break;
            }
            if (vfa->attribute)
index ab55b638b6f8248664c0bb2e968e9c1c2b745524..66b4a66e17bd2a2d4780d2d5239ac59ce1ed7d77 100644 (file)
@@ -1,5 +1,5 @@
---- rpm-5.4.16/lua/Makefile.am~        2016-04-19 19:19:35.000000000 +0300
-+++ rpm-5.4.16/lua/Makefile.am 2016-04-20 16:51:20.574586445 +0300
+--- rpm-5.4.18/lua/Makefile.am~        2016-08-06 20:39:54.000000000 +0300
++++ rpm-5.4.18/lua/Makefile.am 2017-07-18 19:44:32.874014686 +0300
 @@ -326,7 +326,10 @@
        lzio.c
  
@@ -9,6 +9,6 @@
 +if USE_LUA_CRYPTO
 +liblua_la_LIBADD += -lexpat
 +endif
- liblua_la_LDFLAGS = $(LDFLAGS)
+ liblua_la_LDFLAGS = -no-undefined $(LDFLAGS)
  
  liblua.la: $(liblua_la_OBJECTS) $(liblua_la_DEPENDENCIES) 
index 7c2a25dc121c77febff5c09a8e45a86ab012e86c..2b6487364f2948753a81c65a04b16ce4a8ddc6c3 100644 (file)
@@ -1,11 +1,11 @@
---- rpm-5.4.10/lib/psm.c~      2013-03-17 13:34:31.534601434 +0100
-+++ rpm-5.4.10/lib/psm.c       2013-03-25 13:46:18.326658890 +0100
-@@ -3017,7 +3017,7 @@
+--- rpm-5.4.18/lib/psm.c~      2017-07-18 19:37:38.000000000 +0300
++++ rpm-5.4.18/lib/psm.c       2017-07-18 19:40:53.713076772 +0300
+@@ -2905,7 +2905,7 @@
  
-       psm->rpmio_flags = t = (char *) xmalloc(sizeof("w9.gzdio"));
-       *t = '\0';
--      t = stpcpy(t, ((psm->goal == PSM_PKGSAVE) ? "w9" : "r"));
-+      t = stpcpy(t, ((psm->goal == PSM_PKGSAVE) ? "w6" : "r"));
+       psm->rpmio_flags = te = (char *) xmalloc(sizeof("w9.zstdio")+32);
+       *te = '\0';
+-      te = stpcpy(te, ((psm->goal == PSM_PKGSAVE) ? "w9" : "r"));
++      te = stpcpy(te, ((psm->goal == PSM_PKGSAVE) ? "w6" : "r"));
        if (!strcmp(payload_compressor, "gzip"))
-           t = stpcpy(t, ".gzdio");
+           te = stpcpy(te, ".gzdio");
        if (!strcmp(payload_compressor, "bzip2"))
index 8d3de6dbc863f5b2e29728a060085b6fcf377640..721b28f23175c2a8bbc99692a2ac85e1744b8e70 100644 (file)
@@ -1,9 +1,9 @@
---- rpm-5.4.17/rpmio/macro.c.orig      2016-04-10 02:18:38.000000000 +0200
-+++ rpm-5.4.17/rpmio/macro.c   2017-02-25 00:03:03.071277546 +0100
-@@ -111,7 +111,7 @@
+--- rpm-5.4.18/rpmio/macro.c~  2017-07-13 20:09:20.000000000 +0300
++++ rpm-5.4.18/rpmio/macro.c   2017-07-18 16:18:28.893062010 +0300
+@@ -139,7 +139,7 @@
+ #define       WITH_MOZJS      1
  #endif
  
- /*@unchecked@*/
 -#if defined(WITH_AUGEAS) || defined(WITH_FICL) || defined(WITH_MOZJS) || defined(WITH_NIX) || defined(WITH_PERLEMBED) || defined(WITH_PYTHONEMBED) || defined(WITH_RUBYEMBED) || defined(WITH_SQLITE) || defined(WITH_SQUIRREL) || defined(WITH_TCL)
 +#if defined(WITH_AUGEAS) || defined(WITH_FICL) || defined(WITH_MOZJS) || defined(WITH_NIX) || defined(WITH_PERLEMBED) || defined(WITH_PYTHONEMBED) || defined(WITH_RUBYEMBED) || defined(WITH_SQLITE) || defined(WITH_SQUIRREL) || defined(WITH_TCL) || defined(WITH_SEMANAGE)
  static int _globalI = 0x80000000;
index ef777c57ce1801809b4d22f48e94fe30570b963a..1a6db8da772e9fac44f545527a7a438a0731fe73 100644 (file)
@@ -1,5 +1,5 @@
---- rpm-4.5/rpmio/macro.c.org  2009-08-08 15:42:25.574860247 +0200
-+++ rpm-4.5/rpmio/macro.c      2009-08-08 15:47:20.495455961 +0200
+--- rpm-5.4.18/rpmio/macro.c~  2017-07-18 16:19:04.000000000 +0300
++++ rpm-5.4.18/rpmio/macro.c   2017-07-18 16:30:30.419934771 +0300
 @@ -807,6 +807,43 @@
      return se;
  }
@@ -55,7 +55,7 @@
  
        if (STREQ("echo", f, fn) ||
            STREQ("warn", f, fn) ||
-@@ -1984,6 +2023,18 @@
+@@ -3207,6 +3207,18 @@
      }
  }
  
@@ -71,6 +71,6 @@
 +      }
 +}
 +
- /*@-mustmod@*/ /* LCL: mc is modified through mb->mc, mb is abstract */
  int
  rpmDefineMacro(MacroContext mc, const char * macro, int level)
+ {
index 309b8b4417f1c2ec964928374d2d6734d8736b14..53a18e54c898d6c9634326c2d028e27e662c94ce 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -877,7 +877,7 @@ cd -
 #patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
+#%patch3 -p1 do we still want to disable setproctitle
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
@@ -915,11 +915,11 @@ cd -
 %patch32 -p1
 %patch33 -p1
 %patch34 -p1
-%patch35 -p1
+#%patch35 -p1 rpm-namespace-compare.patch -- UPDATE!
 %patch36 -p1
 %patch37 -p1
 %patch38 -p1
-%patch39 -p1
+#%patch39 -p1 rpm-fix-missing-types-in-headers.patch - oudated?
 %patch40 -p1
 %if %{with db61} || %{with db62}
 %patch41 -p1
@@ -939,7 +939,7 @@ cd -
 %patch54 -p1
 %patch55 -p1
 %patch56 -p1
-%patch57 -p1
+#%patch57 -p1 rpm-headerChecks.patch - applied in 5.4.18 ?
 %patch58 -p1
 %patch60 -p1
 %patch61 -p1
@@ -955,12 +955,12 @@ cd -
 %patch75 -p1
 %patch77 -p1
 %patch78 -p1
-%patch79 -p1
+#%patch79 -p1 rpm-rpmspec.patch - update rpm.org port
 
 %patch81 -p0
 %patch82 -p1
 %patch84 -p1
-%patch85 -p1
+#%patch85 -p1 rpm-CVE-2013-6435.patch - solved differently upstream?
 %patch86 -p1
 %patch87 -p1
 %patch88 -p1
index cd775315ddb00b89bfcdd8afd9a4f698a2d3c643..69039f7a93e62e6ab084aeab0a1cdba71aaef6f3 100644 (file)
@@ -1,5 +1,5 @@
---- rpm-5.2.0/configure.ac.wig 2010-04-25 22:53:46.360198235 +0200
-+++ rpm-5.2.0/configure.ac     2010-04-25 22:54:14.100214966 +0200
+--- rpm-5.4.18/configure.ac~   2017-07-18 16:11:41.000000000 +0300
++++ rpm-5.4.18/configure.ac    2017-07-18 16:14:03.712760045 +0300
 @@ -1872,6 +1872,9 @@ AC_ARG_WITH(
            "fedora")
                    AC_DEFINE([RPM_VENDOR_FEDORA], 1, Vendor is Fedora)
            esac
            AC_MSG_RESULT([$withval])
      else
-@@ -2485,7 +2485,7 @@
+@@ -6264,6 +6264,7 @@
      rpmdb/DB_CONFIG
      macros/macros macros/macros.rpmbuild
      macros/cmake macros/gstreamer macros/java macros/kernel macros/libtool
--    macros/mandriva macros/suse macros/fedora macros/mono macros/perl macros/pkgconfig macros/php
-+    macros/pld macros/mandriva macros/suse macros/fedora macros/mono macros/perl macros/pkgconfig macros/php
++    macros/pld
+     macros/mandriva macros/suse macros/fedora macros/mono macros/mqtt
+     macros/perl macros/pkgconfig macros/php
      macros/python macros/ruby macros/selinux macros/tcl
-     doc/Makefile
-     doc/manual/Makefile doc/fr/Makefile doc/ja/Makefile doc/ko/Makefile
 --- rpm-5.4.10/Makefile.am~    2012-03-17 01:24:19.000000000 +0100
 +++ rpm-5.4.10/Makefile.am     2012-09-03 00:08:35.599623394 +0200
 @@ -117,7 +117,7 @@
index 900aa64ff2772dd4338e95d52126d3fbe7996d13..94c55428ff5eb75db2c009beb4a545300e242589 100644 (file)
--- a/x32.patch
+++ b/x32.patch
@@ -122,25 +122,21 @@ diff -ur rpm-5.4.15/autodeps/linux.req rpm-5.4.15.x32/autodeps/linux.req
      $OBJDUMP -p $f | awk 'BEGIN { START=0; LIBNAME=""; needed='$needed'; }
        /^$/ { START=0; }
        /^Dynamic Section:$/ { START=1; }
-diff -ur rpm-5.4.15/lib/rpmds.c rpm-5.4.15.x32/lib/rpmds.c
---- rpm-5.4.15/lib/rpmds.c     2014-12-20 19:35:31.114557975 +0100
-+++ rpm-5.4.15.x32/lib/rpmds.c 2014-12-20 19:34:54.958087185 +0100
-@@ -2922,19 +2922,26 @@
+--- rpm-5.4.18/lib/rpmds.c~    2017-07-18 19:50:07.000000000 +0300
++++ rpm-5.4.18/lib/rpmds.c     2017-07-18 19:51:31.551747419 +0300
+@@ -2825,9 +2825,10 @@
   * @retval t          soname dependency
   * @param s           elf string (NULL uses "")
   * @param isElf64     is this an ELF64 symbol?
 + * @param isX32               is this an X32 symbol?
   */
  #if defined(HAVE_GELF_H) && defined(HAVE_LIBELF) && !defined(__FreeBSD__)
--static char * sonameDep(/*@returned@*/ char * t, const char * s, int isElf64)
-+static char * sonameDep(/*@returned@*/ char * t, const char * s, int isElf64, int isX32)
-       /*@modifies t @*/
+-static char * sonameDep(char * t, const char * s, int isElf64)
++static char * sonameDep(char * t, const char * s, int isElf64, int isX32)
  {
      *t = '\0';
  #if !defined(__alpha__) && !defined(__sun)
-     if (isElf64) {
-       if (s[strlen(s)-1] != ')')
-       (void) stpcpy( stpcpy(t, s), "()(64bit)");
+@@ -2837,6 +2838,12 @@
      else
            (void) stpcpy( stpcpy(t, s), "(64bit)");
      }else
This page took 0.155792 seconds and 4 git commands to generate.