]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- merged some changes from AC-branch:
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 19 Jul 2005 17:47:57 +0000 (17:47 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  - libs deps to make rpm working without /usr
  - disable neon and sqlite dependencies (no-neon,no-sqlite patches)
  - readded home_etc support (etc_dir patch) - but with bcond
  - patch-quote patch
- added file-update patch (for compatibility with *.mgc generated by file 4.14)
- release 9.1

Changed files:
    rpm.spec -> 1.676

rpm.spec

index e2d937c4e5b9cb0d166d90b843812ad416da11a2..54399ce9bf547518b240b4115c3df7d3128154b6 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -9,8 +9,10 @@
 %bcond_with    static          # build static rpmi (not supported at the moment)
 %bcond_without apidocs         # don't generate documentation with doxygen
 %bcond_with    autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
+%bcond_without home_etc        # build without HOME_ETC support
 %bcond_without python          # don't build python bindings
 %bcond_without selinux         # build without selinux support
+%bcond_with    neon            # build with HTTP/WebDAV support (neon library)
 # force_cc             - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
 # force_cxx            - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
 # force_cpp            - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
@@ -18,7 +20,7 @@
 # versions of required libraries
 %define        reqdb_ver       4.3.27-1
 %define        reqpopt_ver     1.10.1
-%define        beecrypt_ver    2:4.1.0
+%define        beecrypt_ver    2:4.1.2-4
 %define        rpm_macros_rev  1.231
 Summary:       RPM Package Manager
 Summary(de):   RPM Packet-Manager
@@ -30,7 +32,7 @@ Summary(uk):  
 Name:          rpm
 %define        sover   4.4
 Version:       4.4.1
-Release:       1.99
+Release:       9.1
 License:       GPL
 Group:         Base
 Source0:       ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
@@ -97,24 +99,31 @@ Patch39:    %{name}-pythondeps.patch
 Patch40:       %{name}-print-requires.patch
 Patch41:       %{name}-reduce-stack-usage.patch
 Patch42:       %{name}-glob.patch
+Patch43:       %{name}-patch-quote.patch
+Patch44:       %{name}-no-neon.patch
+Patch45:       %{name}-no-sqlite.patch
+Patch46:       %{name}-file-update.patch
 URL:           http://www.rpm.org/
 Icon:          rpm.gif
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
 BuildRequires: beecrypt-devel >= %{beecrypt_ver}
-BuildRequires: bzip2-devel >= 1.0.1
+BuildRequires: bzip2-devel >= 1.0.2-17
 BuildRequires: db-devel >= %{reqdb_ver}
 %{?with_apidocs:BuildRequires: doxygen}
-BuildRequires: elfutils-devel
+BuildRequires: elfutils-devel >= 0.108
 BuildRequires: findutils
 BuildRequires: gettext-devel >= 0.11.4-2
+%{?with_home_etc:BuildRequires:        home-etc-devel >= 1:1.0.9-2}
 #BuildRequires:        libmagic-devel
 %{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
+%if %{with neon}
 BuildRequires: libxml2-devel
 BuildRequires: neon-devel >= 0.24.7-3
+%endif
 BuildRequires: patch >= 2.2
 BuildRequires: popt-devel >= %{reqpopt_ver}
 %{?with_python:BuildRequires:  python-devel >= 2.2}
@@ -125,7 +134,7 @@ BuildRequires:      zlib-devel
 %if %{with static}
 # Require static library only for static build
 BuildRequires: beecrypt-static >= %{beecrypt_ver}
-BuildRequires: bzip2-static >= 1.0.2-5
+BuildRequires: bzip2-static >= 1.0.2-17
 BuildRequires: db-static >= %{reqdb_ver}
 BuildRequires: glibc-static >= 2.2.94
 BuildRequires: elfutils-static
@@ -211,11 +220,17 @@ RPM - 
 Summary:       RPMs library
 Summary(pl):   Biblioteki RPM-a
 Group:         Libraries
+Requires:      beecrypt >= %{beecrypt_ver}
 Requires:      db >= %{reqdb_ver}
-%{?with_selinux:BuildRequires: libselinux >= 1.18}
+%{?with_selinux:Requires:      libselinux >= 1.18}
 Requires:      popt >= %{reqpopt_ver}
+Obsoletes:     rpm-libs
 # avoid SEGV caused by mixed db versions
 Conflicts:     poldek < 0.18.1-16
+%if %{with home_etc}
+# avoid linking to /usr/lib
+Conflicts:     home-etc < 1.0.9-2
+%endif
 
 %description lib
 RPMs library.
@@ -237,6 +252,7 @@ Requires:   beecrypt-devel >= %{beecrypt_ver}
 Requires:      bzip2-devel
 Requires:      db-devel >= %{reqdb_ver}
 Requires:      elfutils-devel
+%{?with_home_etc:Requires:     home-etc-devel >= 1:1.0.9-2}
 %{?with_selinux:Requires:      libselinux-devel}
 Requires:      popt-devel >= %{reqpopt_ver}
 Requires:      zlib-devel
@@ -582,8 +598,7 @@ ze 
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
-# home-etc FIXME
-#%patch14 -p1
+%patch14 -p1
 %patch15 -p1
 %patch16 -p1
 %patch17 -p1
@@ -624,6 +639,10 @@ cat %{SOURCE11} >> macros.in
 %patch40 -p1
 %patch41 -p1
 %patch42 -p1
+%patch43 -p1
+%{!?with_neon:%patch44 -p1}
+%patch45 -p1
+%patch46 -p1
 %patch0 -p1
 %patch3 -p1
 
@@ -635,7 +654,7 @@ cd ..
 mv -f po/{no,nb}.po
 mv -f po/{sr,sr@Latn}.po
 
-rm -rf neon zlib libelf db db3 popt rpmdb/db.h
+rm -rf sqlite zlib db db3 popt rpmdb/db.h
 
 # generate Group translations to *.po
 awk -f %{SOURCE6} %{SOURCE1}
@@ -675,10 +694,11 @@ CPPFLAGS="-Dglob=rpm_glob -Dglobfree=rpm_globfree"; export CPPFLAGS
        CC="%{__newcc}" \
        CXX="%{__newcxx}" \
        CPP="%{__newcpp}" \
+       %{?with_autoreqdep:--enable-adding-packages-names-in-autogenerated-dependancies} \
        --enable-shared \
        --enable-static \
-       %{?with_apidoc:--with-apidocs} \
-       %{?with_pkgnameinautoreq:--enable-adding-packages-names-in-autogenerated-dependancies} \
+       %{?with_apidocs:--with-apidocs} \
+       %{?with_home_etc:--with-home_etc} \
        %{?with_python:--with-python=auto} \
        %{!?with_python:--without-python} \
        %{!?with_selinux:--without-selinux} \
@@ -696,6 +716,7 @@ CPPFLAGS="-Dglob=rpm_glob -Dglobfree=rpm_globfree"; export CPPFLAGS
        debugedit_LDADD="\$(WITH_LIBELF_LIB) -lpopt"
 
 #      %{!?with_static:rpm_LDFLAGS="\$(myLDFLAGS)"} \
+
 %{?with_apidocs:%{__make} doxygen}
 
 %install
This page took 0.055242 seconds and 4 git commands to generate.