]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- partialy fixed /usr/lib/rpm/*-linux/macros by appending rpm.platform
authortwittner <twittner@pld-linux.org>
Sat, 23 Feb 2008 23:28:56 +0000 (23:28 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  contents (correct me if I did this in wrong way).
  Probably `Multilibs' and `Build policy macros.' sections should be added.
- rel. 0.7

Changed files:
    rpm.platform -> 1.8
    rpm.spec -> 1.882

rpm.platform
rpm.spec

index 36d574a4e1be3ccdd10f800b7a93f9745afbc19c..9853d3fe90d7426b7555dd0f245418f08b0b665e 100644 (file)
@@ -1,13 +1,13 @@
 # PLD rpm macros
 
-%__id          @__ID@
+%__id          /bin/id
 %__id_u                %{__id} -u
-%__chown_Rhf           @__CHOWN_RHF@
-%__chgrp_Rhf           @__CHGRP_RHF@
+%__chown_Rhf           %{__chown} -Rhf
+%__chgrp_Rhf           %{__chgrp} -Rhf
 
-%_fixowner       [ `%{__id_u}` = '0' ] && %{__chown_Rhf} root:@ROOT_GROUP@
+%_fixowner       [ `%{__id_u}` = '0' ] && %{__chown_Rhf} root:root
 %_fixgroup       true
-%_fixperms       %{__chmod} -Rf @FIXPERMS@
+%_fixperms       %{__chmod} -Rf -Rf a+rX,u+w,g-w,o-w
 
 %_exec_prefix    %{_prefix}
 %_bindir         %{_exec_prefix}/bin
index d0a07d89d7b5742e109dd3ecea1189faa2a71722..de0d702a38c259beba226a41ea28424ad6733c08 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -1,6 +1,5 @@
 #
 # TODO:
-# - manuals are not compressed
 # - %{_arch} = i686 not as used to be i386:
 #   5.0.2: rpm -E '%_target_base_arch %_arch'
 #          i386 i686
@@ -63,7 +62,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       5.0.2
-Release:       0.6
+Release:       0.7
 License:       LGPL
 Group:         Base
 Source0:       http://rpm5.org/files/rpm/rpm-5.0/%{name}-%{version}.tar.gz
@@ -1001,12 +1000,16 @@ for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuil
        ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
 done
 
+# Append rpm.platform contents to /usr/lib/rpm/${arch}-linux/macros
+for m in $RPM_BUILD_ROOT%{_rpmlibdir}/*/macros ; do
+       cat %{SOURCE2} | %{__sed} 's#@LIB@#%{_lib}#' >> $m
+done
 # remove arch dependant macros which have no use on noarch
-#%{__sed} -i -e '
-#/{__spec_install_post_strip}/d
-#/{__spec_install_post_chrpath}/d
-#/{__spec_install_post_compress_modules}/d
-#' $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
+%{__sed} -i -e '
+/{__spec_install_post_strip}/d
+/{__spec_install_post_chrpath}/d
+/{__spec_install_post_compress_modules}/d
+' $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
 
 # Bourne shell script vs ELF executable linked with rpm,rpmdb,rpmio
 mv $RPM_BUILD_ROOT{%{_rpmlibdir},%{_bindir}}/rpm2cpio
This page took 0.086195 seconds and 4 git commands to generate.