]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- find perl requires only in bin|lib|share dirs
authorArtur Frysiak <artur@frysiak.net>
Sat, 30 Oct 1999 09:59:56 +0000 (09:59 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    rpm-perl-macros.patch -> 1.4

rpm-perl-macros.patch

index 6a29e91872324b09b9f119d18b074bf645286691..3985ec63645ebe27d571e49a13d0068a26f3a7b8 100644 (file)
@@ -1,16 +1,6 @@
---- rpm-3.0.3.perl/configure.in        Fri Oct 22 14:23:17 1999
-+++ rpm-3.0.3/configure.in     Fri Oct 22 14:47:01 1999
-@@ -906,7 +906,7 @@
- export LIBS INCPATH CONFIG_SITE
- AC_CONFIG_SUBDIRS(popt)
--AC_OUTPUT([Makefile rpmrc macros macros.pld lib/Makefile
-+AC_OUTPUT([Makefile rpmrc macros macros.pld macros.perl lib/Makefile
-       build/Makefile tools/Makefile scripts/Makefile
-       tests/Makefile tests/rpmrc tests/macros tests/hello-test/Makefile
-       misc/Makefile po/Makefile.in intl/Makefile
---- rpm-3.0.3.perl/macros.in   Fri Oct 22 14:23:17 1999
-+++ rpm-3.0.3/macros.in        Fri Oct 22 14:59:08 1999
+diff -ruN rpm-3.0.3/macros.in rpm-3.0.3.new/macros.in
+--- rpm-3.0.3/macros.in        Sat Oct 30 11:59:36 1999
++++ rpm-3.0.3.new/macros.in    Sat Oct 30 11:24:39 1999
 @@ -248,6 +248,8 @@
  #     %{perl_sitearch}/Image
  #     %dir %{perl_sitearch}/auto/Image
@@ -22,8 +12,9 @@
  %requires_eq()        %(LC_ALL="C" rpm -q --queryformat 'Requires:%%{NAME} = %%{VERSION}' %1| grep -v "is not")
 -%perl_sitearch        %(eval "`perl -V:installsitearch`"; echo $installsitearch)
 -%perl_archlib %(eval "`perl -V:installarchlib`"; echo $installarchlib)
---- rpm-3.0.3.perl/macros.perl.in      Thu Jan  1 01:00:00 1970
-+++ rpm-3.0.3/macros.perl.in   Fri Oct 22 15:08:15 1999
+diff -ruN rpm-3.0.3/macros.perl.in rpm-3.0.3.new/macros.perl.in
+--- rpm-3.0.3/macros.perl.in   Thu Jan  1 01:00:00 1970
++++ rpm-3.0.3.new/macros.perl.in       Sat Oct 30 11:24:39 1999
 @@ -0,0 +1,11 @@
 +# Perl specific macro definitions.
 +# To make use of these macros insert the following line into your spec file:
@@ -36,8 +27,9 @@
 +%define               perl_sitearch   %(eval "`perl -V:installsitearch`"; echo $installsitearch)
 +%define               perl_archlib    %(eval "`perl -V:installarchlib`"; echo $installarchlib)
 +
---- rpm-3.0.3.perl/scripts/Makefile.am Sat Jun  5 22:52:30 1999
-+++ rpm-3.0.3/scripts/Makefile.am      Fri Oct 22 15:12:12 1999
+diff -ruN rpm-3.0.3/scripts/Makefile.am rpm-3.0.3.new/scripts/Makefile.am
+--- rpm-3.0.3/scripts/Makefile.am      Sat Jun  5 22:52:30 1999
++++ rpm-3.0.3.new/scripts/Makefile.am  Sat Oct 30 11:24:39 1999
 @@ -4,7 +4,8 @@
  
  EXTRA_DIST = \
@@ -56,8 +48,9 @@
 +      perl.prov perl.req find-perl-requires find-perl-provides \
 +      vpkg-provides.sh
  
---- rpm-3.0.3.perl/scripts/find-perl-provides  Thu Jan  1 01:00:00 1970
-+++ rpm-3.0.3/scripts/find-perl-provides       Fri Oct 22 12:21:39 1999
+diff -ruN rpm-3.0.3/scripts/find-perl-provides rpm-3.0.3.new/scripts/find-perl-provides
+--- rpm-3.0.3/scripts/find-perl-provides       Thu Jan  1 01:00:00 1970
++++ rpm-3.0.3.new/scripts/find-perl-provides   Sat Oct 30 11:24:39 1999
 @@ -0,0 +1,8 @@
 +#!/bin/sh
 +ulimit -c 0
@@ -67,8 +60,9 @@
 +echo $filelist|/usr/lib/rpm/find-provides
 +/usr/lib/rpm/perl.prov $filelist
 +
---- rpm-3.0.3.perl/scripts/find-perl-requires  Thu Jan  1 01:00:00 1970
-+++ rpm-3.0.3/scripts/find-perl-requires       Fri Oct 22 12:21:36 1999
+diff -ruN rpm-3.0.3/scripts/find-perl-requires rpm-3.0.3.new/scripts/find-perl-requires
+--- rpm-3.0.3/scripts/find-perl-requires       Thu Jan  1 01:00:00 1970
++++ rpm-3.0.3.new/scripts/find-perl-requires   Sat Oct 30 11:24:39 1999
 @@ -0,0 +1,11 @@
 +#!/bin/sh
 +ulimit -c 0
 +echo "$requires
 +$requires_perl
 +$requires_mod"|  sort -u
---- rpm-3.0.3.perl/scripts/perl.prov   Sat Jun  5 22:52:31 1999
-+++ rpm-3.0.3/scripts/perl.prov        Fri Oct 22 14:34:50 1999
+diff -ruN rpm-3.0.3/scripts/perl.prov rpm-3.0.3.new/scripts/perl.prov
+--- rpm-3.0.3/scripts/perl.prov        Sat Jun  5 22:52:31 1999
++++ rpm-3.0.3.new/scripts/perl.prov    Sat Oct 30 11:24:39 1999
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!@PERL@
+ # a simple script to print the proper name for perl libraries.
 @@ -30,12 +30,12 @@
    if (length($require{$module}) == 0) {
-    print "perl($module)\n";
+     print "perl($module)\n";
    } else {
 -    print "perl($module)=$require{$module}\n";
 +    print "perl($module) = $require{$module}\n";
    }
  }
  
---- rpm-3.0.3.perl/scripts/perl.req    Sat Jun  5 22:52:31 1999
-+++ rpm-3.0.3/scripts/perl.req Fri Oct 22 12:21:33 1999
-@@ -26,16 +26,22 @@
+diff -ruN rpm-3.0.3/scripts/perl.req rpm-3.0.3.new/scripts/perl.req
+--- rpm-3.0.3/scripts/perl.req Sat Jun  5 22:52:31 1999
++++ rpm-3.0.3.new/scripts/perl.req     Sat Oct 30 11:50:03 1999
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!@PERL@
+ # a simple makedepends like script for perl.
+@@ -12,7 +12,11 @@
+ if ("@ARGV") {
+   foreach (@ARGV) {
+-    process_file($_);
++    if (m=/usr/(bin|lib|share|X11R6/(lib|bin))/=) {
++      if (! m=(/((doc|man|info)|/usr/src)/)\.so$)=) {
++        process_file($_);
++      }
++    }
+   }
+ } else {
+   
+@@ -20,22 +24,30 @@
+   # contents of the file.
+   
+   foreach (<>) {
+-    process_file($_);
++    if (m=/usr/(bin|lib|share|X11R6/(lib|bin))/=) {
++      if (! m=(/((doc|man|info)|/usr/src)/)\.so$)=) {
++        process_file($_);
++      }
++    }
+   }
+ }
  
  
  foreach $module (sort keys %require) {
 +    if ($module =~ /^[0-9._]+$/) {
 +      print "perl >= $module\n";
 +    } else {
-+      if ($module !~ /\.ph$/ && $module !~ /\.pl/) {
-+        print "perl($module)\n";
-+      }
++      print "perl($module)\n";
 +    }
    } else {
  
    }
  }
  
+@@ -54,7 +66,7 @@
+   while (<FILE>) {
+     
+     # skip the documentation
+-    if ( (m/^=(head1|head2|pod)/) .. (m/^=(cut)/) ) {
++    if ( (m/^=(head1|head2|pod|item)/) .. (m/^=(cut)/) ) {
+       next;
+     }
This page took 0.037524 seconds and 4 git commands to generate.