]> git.pld-linux.org Git - packages/rpm.git/commitdiff
fast_python_deps: examine .egg-info files too auto/th/rpm-5.4.15-31
authorJacek Konieczny <jajcus@jajcus.net>
Sun, 29 Nov 2015 09:12:23 +0000 (10:12 +0100)
committerJacek Konieczny <jajcus@jajcus.net>
Sun, 29 Nov 2015 09:12:23 +0000 (10:12 +0100)
python-docutils has an .egg-info file instead of a directory, for some
reason.

Release: 31

fast_python_deps.patch
rpm.spec

index 1decba7f316c9650a33453b6982252b65e44a286..f22e1b0154d949fd50c2393498ebb44f3e91263c 100644 (file)
@@ -1,6 +1,6 @@
 diff -dur -x '*~' -x '*.orig' rpm-5.4.15.orig/lib/rpmfc.c rpm-5.4.15/lib/rpmfc.c
---- rpm-5.4.15.orig/lib/rpmfc.c        2015-11-23 20:38:44.516459734 +0100
-+++ rpm-5.4.15/lib/rpmfc.c     2015-11-23 20:39:56.267070624 +0100
+--- rpm-5.4.15.orig/lib/rpmfc.c        2015-11-29 09:57:16.945204643 +0100
++++ rpm-5.4.15/lib/rpmfc.c     2015-11-29 09:59:24.804768239 +0100
 @@ -604,8 +604,6 @@
    /* XXX "a /usr/bin/python -t script text executable" */
    /* XXX "python 2.3 byte-compiled" */
@@ -20,7 +20,7 @@ diff -dur -x '*~' -x '*.orig' rpm-5.4.15.orig/lib/rpmfc.c rpm-5.4.15/lib/rpmfc.c
  
      miRE mire;
      int skipProv = fc->skipProv;
-@@ -1156,8 +1157,25 @@
+@@ -1156,8 +1157,29 @@
                if ((fn[0] == '3' && fn[1] == '2') || 
                        (fn[0] == '6' && fn[1] == '4'))
                    fn += 2;
@@ -44,11 +44,15 @@ diff -dur -x '*~' -x '*.orig' rpm-5.4.15.orig/lib/rpmfc.c rpm-5.4.15/lib/rpmfc.c
 +                      /* get all PKG-INFO files for egg-info data */
 +                      fc->fcolor->vals[fc->ix] |= RPMFC_PYTHON;
 +                  }
++                  else if (l > 8 && !strcmp(fn + l - 8, "egg-info")) {
++                      /* get all .egg-info files too */
++                      fc->fcolor->vals[fc->ix] |= RPMFC_PYTHON;
++                  }
 +              }
                else if (!strncmp(fn, "/ruby", sizeof("/ruby")-1)) {
                    fc->fcolor->vals[fc->ix] |= RPMFC_RUBY;
                    if ((strstr(fn, ".gemspec") || strstr(fn, "rbconfig.rb"))) {
-@@ -1184,8 +1202,25 @@
+@@ -1184,8 +1206,29 @@
            fn = strstr(fc->fn[fc->ix], "/usr/share");
            if (fn) {
                fn += sizeof("/usr/share")-1;
@@ -72,6 +76,10 @@ diff -dur -x '*~' -x '*.orig' rpm-5.4.15.orig/lib/rpmfc.c rpm-5.4.15/lib/rpmfc.c
 +                      /* get all PKG-INFO files for egg-info data */
 +                      fc->fcolor->vals[fc->ix] |= RPMFC_PYTHON;
 +                  }
++                  else if (l > 8 && !strcmp(fn + l - 8, "egg-info")) {
++                      /* get all .egg-info files too */
++                      fc->fcolor->vals[fc->ix] |= RPMFC_PYTHON;
++                  }
 +              }
                else if (!strncmp(fn, "/ruby", sizeof("/ruby")-1) || !strncmp(fn, "/gems/specifications", sizeof("/gems/specifications")-1)) {
                    fc->fcolor->vals[fc->ix] |= RPMFC_RUBY;
index b1b268af01435f49493b9fe2065b8d949e9a2556..ec43cff2060cb4e294ffeb53133aaedb81d77264 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -51,7 +51,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       5.4.15
-Release:       30
+Release:       31
 License:       LGPL v2.1
 Group:         Base
 # http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.15-0.20140824.src.rpm
This page took 0.049843 seconds and 4 git commands to generate.