]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- it's no longer rh package manager
[packages/rpm.git] / rpm.spec
1 # to build for athlon you need release at least 49
2
3 Summary:        RPM Package Manager
4 Summary(de):    RPM Packet-Manager
5 Summary(es):    Gestor de paquetes RPM
6 Summary(pl):    Aplikacja do zarz±dzania pakietami
7 Summary(pt_BR): Gerenciador de pacotes RPM
8 Name:           rpm
9 Version:        4.0.2
10 Release:        54
11 License:        GPL
12 Group:          Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Patch0:         %{name}-rpmrc.patch
28 Patch1:         %{name}-macros.patch
29 Patch2:         %{name}-arch.patch
30 Patch3:         %{name}-rpmpopt.patch
31 Patch4:         %{name}-perl-macros.patch
32 Patch5:         %{name}-db3.patch
33 Patch6:         %{name}-segv.patch
34 Patch7:         %{name}-am_fix.patch
35 Patch8:         %{name}-perl-req-perlfile.patch
36 Patch9:         %{name}-installplatform.patch
37 Patch10:        %{name}-cache.patch
38 Patch11:        %{name}-suggestions.patch
39 Patch12:        %{name}-rh-lame.patch
40 Patch13:        %{name}-glob.patch
41 Patch14:        %{name}-header_h.patch
42 Patch15:        %{name}-fast-alAddPackage.patch
43 Patch16:        %{name}-byKey.patch
44 Patch17:        %{name}-perlprov.patch
45 Patch18:        %{name}-noperldir.patch
46 Patch19:        popt-cvs20010530.patch
47 Patch20:        %{name}-noexpand.patch
48 Patch21:        %{name}-scripts-closefds.patch
49 Patch22:        %{name}-python-amfix.patch
50 Patch23:        %{name}-non-english-man-pages.patch
51 Patch24:        %{name}-progress-nontty.patch
52 Patch25:        %{name}-am_ac.patch
53 Patch26:        %{name}-python-macros.patch
54 Patch27:        %{name}-hardlink-fixes.patch
55 Patch28:        %{name}-perlprov-regonly.patch
56 Patch29:        %{name}-cxx.patch
57 Patch30:        %{name}-athlon.patch
58 Patch31:        %{name}-athlon-identify.patch
59 Patch32:        %{name}-gettext-in-header.patch
60 Patch33:        %{name}-perlprov-perl5.6.patch
61 Patch37:        %{name}-short_circuit.patch
62 Patch38:        %{name}-section_test.patch
63 URL:            http://www.rpm.org/
64 Icon:           rpm.gif
65 BuildRequires:  autoconf >= 2.50
66 BuildRequires:  automake
67 BuildRequires:  bzip2-devel >= 1.0.1
68 BuildRequires:  db1-devel >= 1.85
69 BuildRequires:  db3-devel >= 3.1.17-9
70 BuildRequires:  gettext-devel >= 0.10.38-3
71 BuildRequires:  python-devel >= 2.2
72 BuildRequires:  python-modules >= 2.2
73 BuildRequires:  zlib-devel
74 BuildRequires:  python-modules >= 2.2.1
75 BuildRequires:  zlib-devel >= 1.1.4
76 %if %{!?_without_static:1}%{?_without_static:0}
77 # Require static library only for static build
78 BuildRequires:  bzip2-static >= 1.0.1
79 BuildRequires:  db1-static >= 1.85
80 BuildRequires:  zlib-static
81 BuildRequires:  glibc-static >= 2.2.0
82 BuildRequires:  zlib-static >= 1.1.4
83 %endif
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85 Obsoletes:      rpm-libs
86 Conflicts:      glibc < 2.2
87
88 %define         __find_provides %{SOURCE4}
89 %define         _binary_payload w9.gzdio
90
91 %define         py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
92 %define         py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
93 %define         py_libdir       %{py_prefix}/lib/python%{py_ver}
94 %define         py_dyndir       %{py_libdir}/lib-dynload
95 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
96
97 %description
98 RPM is a powerful package manager, which can be used to build,
99 install, query, verify, update, and uninstall individual software
100 packages. A package consists of an archive of files, and package
101 information, including name, version, and description.
102
103 %description -l de
104 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
105 Installation, Anfrage, Verifizierung, Aktualisierung und
106 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
107 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
108 Beschreibung.
109
110 %description -l es
111 RPM es un poderoso administrador de paquetes, que puede ser usado para
112 construir, instalar, pesquisar, verificar, actualizar y desinstalar
113 paquetes individuales de software. Un paquete consiste en un
114 almacenaje de archivos, y información sobre el paquete, incluyendo
115 nombre, versión y descripción.
116
117 %description -l pl
118 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
119 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
120 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
121 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
122 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
123 odpytywania programu rpm.
124
125 %description -l pt_BR
126 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
127 construir, instalar, pesquisar, verificar, atualizar e desinstalar
128 pacotes individuais de software. Um pacote consiste de um conjunto de
129 arquivos e informações adicionais, incluindo nome, versão e descrição
130 do pacote, permissões dos arquivos, etc.
131
132 %package devel
133 Summary:        Header files and libraries
134 Summary(de):    Header-Dateien uns Libraries
135 Summary(es):    Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
136 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
137 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
138 Group:          Development/Libraries
139 Requires:       %{name} = %{version}
140 Requires:       popt-devel
141
142 %description devel
143 The RPM packaging system includes a C library that makes it easy to
144 manipulate RPM packages and databases. It is intended to ease the
145 creation of graphical package managers and other tools that need
146 intimate knowledge of RPM packages.
147
148 %description devel -l de
149 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
150 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
151 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
152 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
153
154 %description devel -l es
155 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
156 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
157 facilitar la creación de administradores gráficos de paquetes y otras
158 herramientas que necesiten un conocimiento profundo de paquetes RPM.
159
160 %description devel -l pl
161 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
162 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
163 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
164 szczegó³owej wiedzy na temat pakietów RPM.
165
166 %description devel -l pt_BR
167 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
168 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
169 facilitar a criação de gerenciadores gráficos de pacotes e outras
170 ferramentas que precisem de conhecimento profundo de pacotes RPM.
171
172 %package static
173 Summary:        RPM static libraries
174 Summary(de):    RPMs statische Libraries
175 Summary(pl):    Biblioteki statyczne RPM-a
176 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
177 Group:          Development/Libraries
178 Requires:       %{name}-devel = %{version}
179
180 %description static
181 RPM static libraries.
182
183 %description static -l de
184 RPMs statische Libraries.
185
186 %description static -l pl
187 Biblioteki statyczne RPM-a.
188
189 %description static -l pt_BR
190 Bibliotecas estáticas para desenvolvimento.
191
192 %package utils
193 Summary:        Additional utilities for managing rpm packages and database
194 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
195 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
196 Group:          Applications/File
197 Requires:       %{name} = %{version}
198
199 %description utils
200 Additional utilities for managing rpm packages and database.
201
202 %description utils -l de
203 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
204
205 %description utils -l pl
206 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
207
208 %package perlprov
209 Summary:        Additional utilities for checking perl provides/requires in rpm packages
210 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
211 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
212 Group:          Applications/File
213 Requires:       perl-modules
214 Requires:       findutils
215
216 %description perlprov
217 Additional utilities for checking perl provides/requires in rpm
218 packages.
219
220 %description perlprov -l de
221 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
222
223 %description perlprov -l pl
224 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
225 pakietach rpm.
226
227 %package pythonprov
228 Summary:        Python macros, which simplifies creation of rpm packages with Python software
229 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
230 Group:          Applications/File
231 Requires:       %{name} = %{version}
232 Requires:       python-modules
233
234 %description pythonprov
235 Python macros, which simplifies creation of rpm packages with Python
236 software.
237
238 %description pythonprov -l pl
239 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
240 Pythonie.
241
242 %package -n python-rpm
243 Summary:        Python interface to RPM library
244 Group:          Development/Languages/Python
245 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
246 %requires_eq    python
247 Requires:       %{name} = %{version}
248 %pyrequires_eq  python
249 Obsoletes:      rpm-python
250
251 %description -n python-rpm
252 The rpm-python package contains a module which permits applications
253 written in the Python programming language to use the interface
254 supplied by RPM (RPM Package Manager) libraries.
255
256 This package should be installed if you want to develop Python
257 programs that will manipulate RPM packages and databases.
258
259 %description -n python-rpm -l pl
260 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
261 Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
262
263 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ w
264 Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
265
266 %description -n python-rpm -l pt_BR
267 O pacote rpm-python contém um módulo que permite que aplicações
268 escritas em Python utilizem a interface fornecida pelas bibliotecas
269 RPM (RPM Package Manager).
270
271 Esse pacote deve ser instalado se você quiser desenvolver programas em
272 Python para manipular pacotes e bancos de dados RPM.
273
274 %package build
275 Summary:        Scripts for building binary RPM packages
276 Summary(de):    Scripts fürs Bauen binärer RPM-Pakete
277 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
278 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
279 Group:          Applications/File
280 Requires:       %{name} = %{version}
281 Requires:       /bin/id
282 Requires:       awk
283 Requires:       binutils
284 Requires:       diffutils
285 Requires:       file >= 3.31
286 Requires:       fileutils
287 Requires:       findutils
288 %ifarch athlon
289 Requires:       gcc >= 3.0.3
290 %else
291 Requires:       gcc
292 Requires:       glibc-devel
293 Requires:       grep
294 Requires:       gzip
295 Requires:       make
296 Requires:       patch
297 Requires:       popt >= 1.6.2-2
298 Requires:       sed
299 Requires:       tar
300 Requires:       textutils
301
302 %description build
303 Scripts for building binary RPM packages.
304
305 %description build -l de
306 Scripts fürs Bauen binärer RPM-Pakete.
307
308 %description build -l pl
309 Skrypty pomocnicze do budowania binarnych RPM-ów.
310
311 %description build -l pt_BR
312 Este pacote contém scripts e programas executáveis que são usados para
313 construir pacotes usando o RPM.
314
315 %prep
316 %setup -q -a12
317 %patch0 -p1
318 %patch1 -p1
319 %patch2 -p1
320 %patch3 -p1
321 %patch4 -p1
322 %patch5 -p1
323 %patch6 -p1
324 %patch7 -p1
325 %patch8 -p1
326 %patch9 -p1
327 %patch10 -p1
328 %patch11 -p0
329 %patch12 -p0
330 %patch13 -p1
331 %patch14 -p1
332 %patch15 -p0
333 %patch16 -p0
334 %patch17 -p1
335 %patch18 -p1
336 %patch19 -p1
337 %patch20 -p1
338 %patch21 -p1
339 %patch22 -p1
340 %patch23 -p1
341 %patch24 -p1
342 %patch25 -p1
343 %patch26 -p0
344 %patch27 -p1
345 %patch28 -p1
346 %patch29 -p1
347 %patch30 -p1
348
349 %ifarch athlon
350 %patch31 -p1
351 %endif
352
353 %patch35 -p1
354 %patch36 -p1
355 %patch37 -p1
356 %patch38 -p1
357
358 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
359 cp -f platform.in macros.pld.in
360 install %{SOURCE5} macros.perl.in
361 install %{SOURCE13} macros.python.in
362 install %{SOURCE6} scripts/find-perl-provides
363 install %{SOURCE7} scripts/find-perl-requires
364 install %{SOURCE9} scripts/find-lang.sh
365
366 (cd scripts;
367 mv -f perl.req perl.req.in
368 mv -f perl.prov perl.prov.in)
369 %build
370 # generate Group translations to *.po
371 awk -f %{SOURCE14} %{SOURCE1}
372
373 cd popt
374 autoconf
375 automake -a -c
376 aclocal
377 autoheader
378 automake -a -c -f
379 %{__automake}
380 cd ..
381
382 rm -f missing
383 libtoolize --force --copy
384 autoconf
385 aclocal
386 autoupdate
387 autoheader || :
388 %{__autoconf}
389 automake -a -c
390 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
391         lib/Makefile.am > lib/Makefile.am.new
392 mv -f lib/Makefile.am.new lib/Makefile.am
393 %{__automake}
394 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
395         lib/Makefile.in > lib/Makefile.in.new
396 mv -f lib/Makefile.in.new lib/Makefile.in
397
398 sed -e 's#python1.5#python%{py_ver}#g' \
399         python/Makefile.in > python/Makefile.in.new
400 mv -f python/Makefile.in.new python/Makefile.in
401
402 # config.guess doesn't handle athlon, so we have to change it by hand.
403 # rpm checks for CPU type at runtime, but it looks better
404 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
405         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
406 mv -f macros.tmp macros.in
407
408 %configure \
409         --enable-shared \
410         --enable-v1-packages \
411         --with-python
412
413
414 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
415
416 %install
417 rm -rf $RPM_BUILD_ROOT
418
419 %{__make} install \
420         DESTDIR=$RPM_BUILD_ROOT \
421         pkgbindir="%{_bindir}"
422
423 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
424 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
425
426 install %{SOURCE1} doc/manual/groups
427 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
428 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
429 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
430 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
431 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
432
433 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
434
435 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
436 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
437 # customized rpm macros - global for host
438 #
439 #%%_install_langs pl_PL:en_US
440 %%distribution PLD
441 EOF
442
443 %find_lang %{name}
444
445 # DON'T BREAK BUILD TREE!!!
446 # rm -f doc/manual/Makefile*
447
448 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
449
450 %clean
451 rm -rf $RPM_BUILD_ROOT
452
453 %post   -p /sbin/ldconfig
454 %postun -p /sbin/ldconfig
455
456 %attr(755,root,root) /bin/rpm
457 %attr(755,root,root) %{_bindir}/rpmdb
458 %attr(755,root,root) %{_bindir}/rpmquery
459 %attr(755,root,root) %{_bindir}/rpmsign
460 %attr(755,root,root) %{_bindir}/rpmverify
461 %attr(755,root,root) %{_libdir}/rpm/rpmdb
462 %attr(755,root,root) %{_libdir}/rpm/rpmq
463 %attr(755,root,root) %{_libdir}/rpm/rpmk
464 %attr(755,root,root) %{_libdir}/rpm/rpmv
465 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
466
467 %dir %{_sysconfdir}/rpm
468 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
469
470 %{_mandir}/man8/rpm.8*
471 %lang(fr) %{_mandir}/fr/man8/rpm.8*
472 %lang(ja) %{_mandir}/ja/man8/rpm.8*
473 %lang(ko) %{_mandir}/ko/man8/rpm.8*
474 %lang(pl) %{_mandir}/pl/man8/rpm.8*
475 %lang(ru) %{_mandir}/ru/man8/rpm.8*
476 %lang(sk) %{_mandir}/sk/man8/rpm.8*
477
478 %dir /var/lib/rpm
479 %dir %{_libdir}/rpm
480
481 %{_libdir}/rpm/macros.python
482 %doc %attr(755,root,root) %{_libdir}/rpm/convertrpmrc.sh
483
484 %{_libdir}/rpm/rpmrc
485 %{_libdir}/rpm/rpmpopt*
486 %{_libdir}/rpm/macros
487 %{_libdir}/rpm/noarch-linux
488 %{_libdir}/rpm/noarch-pld-linux
489 %ifarch i386 i486 i586 i686 athlon
490 %{_libdir}/rpm/i?86*
491 %{_libdir}/rpm/athlon*
492 %endif
493 %ifarch sparc sparc64
494 %{_libdir}/rpm/sparc*
495 %endif
496 %ifarch alpha
497 %{_libdir}/rpm/alpha*
498 %endif
499 %ifarch ppc
500 %{_libdir}/rpm/ppc*
501 %defattr(644,root,root,755)
502 %attr(755,root,root) %{_bindir}/rpmbuild
503 %attr(755,root,root) %{_bindir}/rpme
504 %attr(755,root,root) %{_bindir}/rpmi
505 %attr(755,root,root) %{_bindir}/rpmu
506 %attr(755,root,root) %{_libdir}/rpm/find-requires
507 %attr(755,root,root) %{_libdir}/rpm/find-provides
508 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
509 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
510 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
511 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
512 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
513 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
514 %attr(755,root,root) %{_libdir}/rpm/brp-*
515 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
516 %attr(755,root,root) %{_libdir}/rpm/compress-doc
517 %attr(755,root,root) %{_libdir}/rpm/cpanflute
518 %attr(755,root,root) %{_libdir}/rpm/http.req
519 %attr(755,root,root) %{_libdir}/rpm/magic.*
520 %attr(755,root,root) %{_libdir}/rpm/rpmdiff*
521 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
522 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides.sh
523 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides2.sh
524 %attr(755,root,root) %{_libdir}/rpm/rpmb
525 %attr(755,root,root) %{_libdir}/rpm/rpmi
526 %attr(755,root,root) %{_libdir}/rpm/rpmt
527 %attr(755,root,root) %{_libdir}/rpm/rpme
528 %attr(755,root,root) %{_libdir}/rpm/rpmu
529
530 %files devel
531 %defattr(644,root,root,755)
532 %{_includedir}/rpm
533 %attr(755,root,root) %{_libdir}/librpm*.la
534 %attr(755,root,root) %{_libdir}/librpm*.so
535
536 %files static
537 %attr(755,root,root) %{_bindir}/*
538 %files utils
539 %defattr(644,root,root,755)
540 %attr(755,root,root) %{_bindir}/gendiff
541 %attr(755,root,root) %{_bindir}/javadeps
542 %attr(755,root,root) %{_bindir}/rpm2cpio
543
544 %{_mandir}/man8/rpm2cpio.8*
545 %{_mandir}/man1/*
546 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
547 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
548 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
549 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
550
551 %files perlprov
552 %defattr(644,root,root,755)
553 %attr(755,root,root) %{_libdir}/rpm/perl*
554 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
555 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
556 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
557 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
558 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
559
560 %{_libdir}/rpm/macros.perl
561
562 %defattr(644,root,root,755)
563 %defattr(644,root,root,755)
564 %{_libdir}/rpm/macros.python
565
566 %files -n python-rpm
567 %defattr(755,root,root,755)
568 %{py_sitedir}/*.so
This page took 0.086335 seconds and 4 git commands to generate.