]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- check_files patch no work on ppc... /me kick check_files patch
[packages/rpm.git] / rpm.spec
1 # to build for athlon you need release at least 49
2
3 Summary:        RPM Package Manager
4 Summary(de):    RPM Packet-Manager
5 Summary(es):    Gestor de paquetes RPM
6 Summary(pl):    Aplikacja do zarz±dzania pakietami RPM
7 Summary(pt_BR): Gerenciador de pacotes RPM
8 Name:           rpm
9 Version:        4.0.2
10 Release:        77
11 License:        GPL
12 Group:          Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Source14:       %{name}-groups-po.awk
28 Source15:       %{name}-compress-doc
29 Source16:       %{name}-check-files
30 Patch0:         %{name}-rpmrc.patch
31 Patch1:         %{name}-macros.patch
32 Patch2:         %{name}-arch.patch
33 Patch3:         %{name}-rpmpopt.patch
34 Patch4:         %{name}-perl-macros.patch
35 Patch5:         %{name}-db3.patch
36 Patch6:         %{name}-segv.patch
37 Patch7:         %{name}-am_fix.patch
38 Patch8:         %{name}-perl-req-perlfile.patch
39 Patch9:         %{name}-installplatform.patch
40 Patch10:        %{name}-cache.patch
41 Patch11:        %{name}-suggestions.patch
42 Patch12:        %{name}-rh-lame.patch
43 Patch13:        %{name}-glob.patch
44 Patch14:        %{name}-header_h.patch
45 Patch15:        %{name}-fast-alAddPackage.patch
46 Patch16:        %{name}-byKey.patch
47 Patch17:        %{name}-perlprov.patch
48 Patch18:        %{name}-noperldir.patch
49 Patch19:        popt-cvs20010530.patch
50 Patch20:        %{name}-noexpand.patch
51 Patch21:        %{name}-scripts-closefds.patch
52 Patch22:        %{name}-python-amfix.patch
53 Patch23:        %{name}-non-english-man-pages.patch
54 Patch24:        %{name}-progress-nontty.patch
55 Patch25:        %{name}-am_ac.patch
56 Patch26:        %{name}-python-macros.patch
57 Patch27:        %{name}-hardlink-fixes.patch
58 Patch28:        %{name}-perlprov-regonly.patch
59 Patch29:        %{name}-cxx.patch
60 Patch30:        %{name}-athlon.patch
61 Patch31:        %{name}-athlon-identify.patch
62 Patch32:        %{name}-gettext-in-header.patch
63 Patch33:        %{name}-perlprov-perl5.6.patch
64 Patch34:        %{name}-ac25x.patch
65 Patch35:        %{name}-signverify-fix.patch
66 Patch36:        %{name}-compress-doc.patch
67 Patch37:        %{name}-short_circuit.patch
68 Patch38:        %{name}-test_stage.patch
69 Patch39:        %{name}-exclude.patch
70 Patch40:        %{name}-check_files.patch
71 URL:            http://www.rpm.org/
72 Icon:           rpm.gif
73 BuildRequires:  autoconf >= 2.50
74 BuildRequires:  automake
75 BuildRequires:  bzip2-devel >= 1.0.1
76 BuildRequires:  db1-devel >= 1.85
77 BuildRequires:  db3-devel >= 3.1.17-9
78 BuildRequires:  gettext-devel >= 0.10.38-3
79 BuildRequires:  libtool
80 BuildRequires:  patch >= 2.2
81 BuildRequires:  python-devel >= 2.2.1
82 BuildRequires:  python-modules >= 2.2.1
83 BuildRequires:  zlib-devel >= 1.1.4
84 %if %{!?_without_static:1}%{?_without_static:0}
85 # Require static library only for static build
86 BuildRequires:  bzip2-static >= 1.0.1
87 BuildRequires:  db1-static >= 1.85
88 BuildRequires:  db3-static >= 3.1.17-9
89 BuildRequires:  glibc-static >= 2.2.0
90 BuildRequires:  zlib-static >= 1.1.4
91 %endif
92 Requires:       zlib >= 1.1.4
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94 Obsoletes:      rpm-libs
95 Conflicts:      glibc < 2.2
96
97 %define         __find_provides %{SOURCE4}
98 %define         _binary_payload w9.gzdio
99
100 %define         py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
101 %define         py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
102 %define         py_libdir       %{py_prefix}/lib/python%{py_ver}
103 %define         py_sitedir      %{py_libdir}/site-packages
104 %define         py_dyndir       %{py_libdir}/lib-dynload
105 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
106
107 %description
108 RPM is a powerful package manager, which can be used to build,
109 install, query, verify, update, and uninstall individual software
110 packages. A package consists of an archive of files, and package
111 information, including name, version, and description.
112
113 %description -l de
114 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
115 Installation, Anfrage, Verifizierung, Aktualisierung und
116 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
117 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
118 Beschreibung.
119
120 %description -l es
121 RPM es un poderoso administrador de paquetes, que puede ser usado para
122 construir, instalar, pesquisar, verificar, actualizar y desinstalar
123 paquetes individuales de software. Un paquete consiste en un
124 almacenaje de archivos, y información sobre el paquete, incluyendo
125 nombre, versión y descripción.
126
127 %description -l pl
128 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
129 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
130 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
131 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
132 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
133 odpytywania programu rpm.
134
135 %description -l pt_BR
136 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
137 construir, instalar, pesquisar, verificar, atualizar e desinstalar
138 pacotes individuais de software. Um pacote consiste de um conjunto de
139 arquivos e informações adicionais, incluindo nome, versão e descrição
140 do pacote, permissões dos arquivos, etc.
141
142 %package devel
143 Summary:        Header files and libraries
144 Summary(de):    Header-Dateien uns Libraries
145 Summary(es):    Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
146 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
147 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
148 Group:          Development/Libraries
149 Requires:       %{name} = %{version}
150 Requires:       popt-devel
151
152 %description devel
153 The RPM packaging system includes a C library that makes it easy to
154 manipulate RPM packages and databases. It is intended to ease the
155 creation of graphical package managers and other tools that need
156 intimate knowledge of RPM packages.
157
158 %description devel -l de
159 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
160 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
161 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
162 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
163
164 %description devel -l es
165 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
166 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
167 facilitar la creación de administradores gráficos de paquetes y otras
168 herramientas que necesiten un conocimiento profundo de paquetes RPM.
169
170 %description devel -l pl
171 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
172 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
173 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
174 szczegó³owej wiedzy na temat pakietów RPM.
175
176 %description devel -l pt_BR
177 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
178 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
179 facilitar a criação de gerenciadores gráficos de pacotes e outras
180 ferramentas que precisem de conhecimento profundo de pacotes RPM.
181
182 %package static
183 Summary:        RPM static libraries
184 Summary(de):    RPMs statische Libraries
185 Summary(pl):    Biblioteki statyczne RPM-a
186 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
187 Group:          Development/Libraries
188 Requires:       %{name}-devel = %{version}
189
190 %description static
191 RPM static libraries.
192
193 %description static -l de
194 RPMs statische Libraries.
195
196 %description static -l pl
197 Biblioteki statyczne RPM-a.
198
199 %description static -l pt_BR
200 Bibliotecas estáticas para desenvolvimento.
201
202 %package utils
203 Summary:        Additional utilities for managing rpm packages and database
204 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
205 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
206 Group:          Applications/File
207 Requires:       %{name} = %{version}
208
209 %description utils
210 Additional utilities for managing rpm packages and database.
211
212 %description utils -l de
213 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
214
215 %description utils -l pl
216 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
217
218 %package perlprov
219 Summary:        Additional utilities for checking perl provides/requires in rpm packages
220 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
221 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
222 Group:          Applications/File
223 Requires:       %{name} = %{version}
224 Requires:       perl-modules
225 Requires:       findutils
226
227 %description perlprov
228 Additional utilities for checking perl provides/requires in rpm
229 packages.
230
231 %description perlprov -l de
232 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
233
234 %description perlprov -l pl
235 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
236 pakietach rpm.
237
238 %package pythonprov
239 Summary:        Python macros, which simplifies creation of rpm packages with Python software
240 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
241 Group:          Applications/File
242 Requires:       %{name} = %{version}
243 Requires:       python-modules
244
245 %description pythonprov
246 Python macros, which simplifies creation of rpm packages with Python
247 software.
248
249 %description pythonprov -l pl
250 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
251 Pythonie.
252
253 %package -n python-rpm
254 Summary:        Python interface to RPM library
255 Summary(pl):    Pythonowy interfejs do biblioteki RPM-a
256 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
257 Group:          Libraries/Python
258 Requires:       %{name} = %{version}
259 %pyrequires_eq  python
260 Obsoletes:      rpm-python
261
262 %description -n python-rpm
263 The rpm-python package contains a module which permits applications
264 written in the Python programming language to use the interface
265 supplied by RPM (RPM Package Manager) libraries.
266
267 This package should be installed if you want to develop Python
268 programs that will manipulate RPM packages and databases.
269
270 %description -n python-rpm -l pl
271 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
272 Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
273
274 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ w
275 Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
276
277 %description -n python-rpm -l pt_BR
278 O pacote rpm-python contém um módulo que permite que aplicações
279 escritas em Python utilizem a interface fornecida pelas bibliotecas
280 RPM (RPM Package Manager).
281
282 Esse pacote deve ser instalado se você quiser desenvolver programas em
283 Python para manipular pacotes e bancos de dados RPM.
284
285 %package build
286 Summary:        Scripts for building binary RPM packages
287 Summary(de):    Scripts fürs Bauen binärer RPM-Pakete
288 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
289 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
290 Group:          Applications/File
291 Requires:       %{name} = %{version}
292 Requires:       /bin/id
293 Requires:       awk
294 Requires:       binutils
295 Requires:       diffutils
296 Requires:       file >= 3.31
297 Requires:       fileutils
298 Requires:       findutils
299 %ifarch athlon
300 Requires:       gcc >= 3.0.3
301 %else
302 Requires:       gcc
303 %endif
304 Requires:       glibc-devel
305 Requires:       grep
306 Requires:       gzip
307 Requires:       make
308 Requires:       patch
309 Requires:       popt >= 1.6.2-2
310 Requires:       sed
311 Requires:       sh-utils
312 Requires:       tar
313 Requires:       textutils
314
315 %description build
316 Scripts for building binary RPM packages.
317
318 %description build -l de
319 Scripts fürs Bauen binärer RPM-Pakete.
320
321 %description build -l pl
322 Skrypty pomocnicze do budowania binarnych RPM-ów.
323
324 %description build -l pt_BR
325 Este pacote contém scripts e programas executáveis que são usados para
326 construir pacotes usando o RPM.
327
328 %prep
329 %setup -q -a12
330 %patch0 -p1
331 %patch1 -p1
332 %patch2 -p1
333 %patch3 -p1
334 %patch4 -p1
335 %patch5 -p1
336 %patch6 -p1
337 %patch7 -p1
338 %patch8 -p1
339 %patch9 -p1
340 %patch10 -p1
341 %patch11 -p0
342 %patch12 -p0
343 %patch13 -p1
344 %patch14 -p1
345 %patch15 -p0
346 %patch16 -p0
347 %patch17 -p1
348 %patch18 -p1
349 %patch19 -p1
350 %patch20 -p1
351 %patch21 -p1
352 %patch22 -p1
353 %patch23 -p1
354 %patch24 -p1
355 %patch25 -p1
356 %patch26 -p0
357 %patch27 -p1
358 %patch28 -p1
359 %patch29 -p1
360 %patch30 -p1
361
362 %ifarch athlon
363 %patch31 -p1
364 %endif
365
366 %patch32 -p1
367 %patch33 -p1
368 %patch34 -p1
369 %patch35 -p1
370 %patch36 -p1
371 %patch37 -p1
372 %patch38 -p1
373 %patch39 -p1
374 #%patch40 -p1
375
376 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
377 cp -f platform.in macros.pld.in
378 install %{SOURCE5} macros.perl.in
379 install %{SOURCE13} macros.python.in
380 install %{SOURCE6} scripts/find-perl-provides
381 install %{SOURCE7} scripts/find-perl-requires
382 install %{SOURCE9} scripts/find-lang.sh
383
384 (cd scripts;
385 mv -f perl.req perl.req.in
386 mv -f perl.prov perl.prov.in)
387
388 chmod +x %{SOURCE4}
389
390 %build
391 # generate Group translations to *.po
392 awk -f %{SOURCE14} %{SOURCE1}
393
394 cd popt
395 rm -f missing
396 libtoolize --force --copy
397 aclocal
398 autoheader
399 %{__autoconf}
400 %{__automake}
401 cd ..
402
403 rm -f missing
404 libtoolize --force --copy
405 gettextize --copy --force
406 aclocal
407 autoupdate
408 autoheader || :
409 %{__autoconf}
410 # ugly workaround for automake
411 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
412         lib/Makefile.am > lib/Makefile.am.new
413 mv -f lib/Makefile.am.new lib/Makefile.am
414 %{__automake}
415 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
416         lib/Makefile.in > lib/Makefile.in.new
417 mv -f lib/Makefile.in.new lib/Makefile.in
418
419 sed -e 's#python1.5#python%{py_ver}#g' \
420         python/Makefile.in > python/Makefile.in.new
421 mv -f python/Makefile.in.new python/Makefile.in
422
423 # config.guess doesn't handle athlon, so we have to change it by hand.
424 # rpm checks for CPU type at runtime, but it looks better
425 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
426         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
427 mv -f macros.tmp macros.in
428
429 %configure \
430         --enable-shared \
431         --enable-v1-packages \
432         --with-python
433
434
435 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
436
437 %install
438 rm -rf $RPM_BUILD_ROOT
439
440 %{__make} install \
441         DESTDIR=$RPM_BUILD_ROOT \
442         pkgbindir="%{_bindir}"
443
444 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
445 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
446
447 install %{SOURCE1} doc/manual/groups
448 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
449 install %{SOURCE4} $RPM_BUILD_ROOT%{_libdir}/rpm/find-rpm-provides
450 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
451 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
452 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
453 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
454 #install %{SOURCE16} $RPM_BUILD_ROOT%{_libdir}/rpm/check-files
455
456 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
457
458 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
459 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
460 # customized rpm macros - global for host
461 #
462 #%%_install_langs pl_PL:en_US
463 %%distribution PLD
464 EOF
465
466 %find_lang %{name}
467
468 %clean
469 rm -rf $RPM_BUILD_ROOT
470
471 %post   -p /sbin/ldconfig
472 %postun -p /sbin/ldconfig
473
474 %files -f %{name}.lang
475 %defattr(644,root,root,755)
476 %doc RPM-PGP-KEY CHANGES doc/manual/[a-z]*
477
478 %attr(755,root,root) /bin/rpm
479 %attr(755,root,root) %{_bindir}/rpmdb
480 %attr(755,root,root) %{_bindir}/rpmquery
481 %attr(755,root,root) %{_bindir}/rpmsign
482 %attr(755,root,root) %{_bindir}/rpmverify
483 %attr(755,root,root) %{_libdir}/rpm/rpmdb
484 %attr(755,root,root) %{_libdir}/rpm/rpmq
485 %attr(755,root,root) %{_libdir}/rpm/rpmk
486 %attr(755,root,root) %{_libdir}/rpm/rpmv
487 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
488
489 %dir %{_sysconfdir}/rpm
490 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
491
492 %{_mandir}/man8/rpm.8*
493 %lang(fr) %{_mandir}/fr/man8/rpm.8*
494 %lang(ja) %{_mandir}/ja/man8/rpm.8*
495 %lang(ko) %{_mandir}/ko/man8/rpm.8*
496 %lang(pl) %{_mandir}/pl/man8/rpm.8*
497 %lang(ru) %{_mandir}/ru/man8/rpm.8*
498 %lang(sk) %{_mandir}/sk/man8/rpm.8*
499
500 %dir /var/lib/rpm
501 %dir %{_libdir}/rpm
502
503 %doc %attr(755,root,root) %{_libdir}/rpm/convertrpmrc.sh
504
505 %{_libdir}/rpm/rpmrc
506 %{_libdir}/rpm/rpmpopt*
507 %{_libdir}/rpm/macros
508 %{_libdir}/rpm/noarch-linux
509 %{_libdir}/rpm/noarch-pld-linux
510 %ifarch i386 i486 i586 i686 athlon
511 %{_libdir}/rpm/i?86*
512 %{_libdir}/rpm/athlon*
513 %endif
514 %ifarch sparc sparc64
515 %{_libdir}/rpm/sparc*
516 %endif
517 %ifarch alpha
518 %{_libdir}/rpm/alpha*
519 %endif
520 %ifarch ppc
521 %{_libdir}/rpm/ppc*
522 %endif
523
524
525 %files build
526 %defattr(644,root,root,755)
527 %attr(755,root,root) %{_bindir}/rpmbuild
528 %attr(755,root,root) %{_bindir}/rpme
529 %attr(755,root,root) %{_bindir}/rpmi
530 %attr(755,root,root) %{_bindir}/rpmu
531 %attr(755,root,root) %{_libdir}/rpm/find-requires
532 %attr(755,root,root) %{_libdir}/rpm/find-provides
533 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
534 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
535 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
536 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
537 %attr(755,root,root) %{_libdir}/rpm/config.*
538 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
539 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
540 %attr(755,root,root) %{_libdir}/rpm/brp-*
541 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
542 #%attr(755,root,root) %{_libdir}/rpm/check-files
543 %attr(755,root,root) %{_libdir}/rpm/compress-doc
544 %attr(755,root,root) %{_libdir}/rpm/cpanflute
545 %attr(755,root,root) %{_libdir}/rpm/http.req
546 %attr(755,root,root) %{_libdir}/rpm/magic.*
547 %attr(755,root,root) %{_libdir}/rpm/rpmdiff*
548 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
549 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides.sh
550 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides2.sh
551 %attr(755,root,root) %{_libdir}/rpm/rpmb
552 %attr(755,root,root) %{_libdir}/rpm/rpmi
553 %attr(755,root,root) %{_libdir}/rpm/rpmt
554 %attr(755,root,root) %{_libdir}/rpm/rpme
555 %attr(755,root,root) %{_libdir}/rpm/rpmu
556
557 %files devel
558 %defattr(644,root,root,755)
559 %{_includedir}/rpm
560 %attr(755,root,root) %{_libdir}/librpm*.la
561 %attr(755,root,root) %{_libdir}/librpm*.so
562
563 %files static
564 %defattr(644,root,root,755)
565 %{_libdir}/librpm*.a
566
567 %files utils
568 %defattr(644,root,root,755)
569 %attr(755,root,root) %{_bindir}/gendiff
570 %attr(755,root,root) %{_bindir}/javadeps
571 %attr(755,root,root) %{_bindir}/rpm2cpio
572
573 %{_mandir}/man8/rpm2cpio.8*
574 %{_mandir}/man1/*
575 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
576 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
577 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
578 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
579
580 %files perlprov
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{_libdir}/rpm/perl*
583 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
584 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
585 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
586 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
587 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
588
589 %{_libdir}/rpm/macros.perl
590
591 %files pythonprov
592 %defattr(644,root,root,755)
593 %{_libdir}/rpm/macros.python
594
595 %files -n python-rpm
596 %defattr(755,root,root,755)
597 %{py_sitedir}/*.so
This page took 0.118363 seconds and 4 git commands to generate.