]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
fixed internal charest set
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat & PLD Package Manager
2 Summary(pl):    Aplikacja do zarz±dzania pakietami
3 Name:           rpm
4 Version:        2.5.6
5 Release:        4d
6 Group:          Base
7 Group(pl):      Bazowe
8 URL:            ftp://ftp.rpm.org/pub/rpm/dist/rpm-2.5.x
9 Source:         %{name}-%{version}.tar.gz
10 Patch0:         %{name}-config.patch
11 Patch1:         %{name}-rpmrc.patch
12 Patch2:         %{name}-glibc.patch
13 Patch3:         %{name}-groups.patch
14 Patch4:         %{name}-%{version}-i18n.patch
15 Copyright:      GPL
16 BuildRoot:      /tmp/%{name}-%{version}-root
17 Obsoletes:      rpm-libs
18 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
19 RPM is a powerful package manager, which can be used to build, install, 
20 query, verify, update, and uninstall individual software packages. A 
21 package consists of an archive of files, and package information, including 
22 name, version, and description.
23 packages. A package consists of an archive of files, and package
24 nombre, versión y descripción.
25 RPM jest doskona³ym menad¿erem pakietów. Dziêki niemu bêdziesz móg³ przebudowaæ,
26 zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje dotycz±ce ka¿dego 
27 pakietu s± przechowywane w bazie danych i dostêpne tylko dla administratora 
28 systemu.
29 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
30 %package        devel
31 Summary:        Header files and libraries 
32 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne 
33 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
34 Group(pl):      Programowanie/Biblioteki
35 Requires:       %{name} = %{version}
36 Requires:       %{name} = %{version}
37 Requires:       popt-devel
38
39 %description devel
40 The RPM packaging system includes a C library that makes it easy to
41 manipulate RPM packages and databases. It is intended to ease the
42 creation of graphical package managers and other tools that need
43 %description -l pl devel
44 Pliki nag³ówkowe i biblioteki statyczne.
45 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
46 construir pacotes usando o RPM.
47 %setup  -q
48 %patch0 -p1
49 %patch1 -p1
50 %patch2 -p1
51 %patch1 -p1
52 %patch4 -p1
53 install %{SOURCE13} macros.python.in
54 mv -f perl.prov perl.prov.in)
55 autoconf
56 CFLAGS=$RPM_OPT_FLAGS LDFLAGS=-s \
57     ./configure \
58         --prefix=/usr
59 make
60         --with-python
61
62
63 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
64 install -d $RPM_BUILD_ROOT/var/lib/rpm
65 install -d $RPM_BUILD_ROOT/usr/src/rpm/{SOURCES,SPECS,SRPMS,BUILD}
66 install -d $RPM_BUILD_ROOT/usr/src/rpm/RPMS/{$RPM_ARCH,noarch}
67
68 make installprefix="$RPM_BUILD_ROOT" install
69         pkgbindir="%{_bindir}"
70 gzip -9fn  $RPM_BUILD_ROOT/usr/man/man8/*
71 bzip2 -9 RPM-PGP-KEY CHANGES groups docs/*
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post
77 /bin/rpm --initdb
78
79 %files
80
81 %doc {RPM-PGP-KEY,CHANGES,groups}.bz2 docs/*
82 %postun -p /sbin/ldconfig
83
84 %attr(755,root,root) /usr/bin/gendiff
85 %attr(755,root,root) /usr/bin/rpm2cpio
86 %attr(644,root, man) /usr/man/man8/*
87
88 %attr(750,root,root) %dir /var/lib/rpm
89
90 %dir /usr/lib/rpm
91 %attr(755,root,root) /usr/lib/rpm/find-*
92 %attr(755,root,root) /usr/lib/rpm/freshen.sh
93 %attr(755,root,root) /usr/lib/rpm/mkinstalldirs
94
95 /usr/lib/rpm/rpm*
96
97 %dir /usr/src/rpm/RPMS
98 %attr(755,root,root,755) /usr/src/rpm/RPMS/*
99
100 %dir /usr/src/rpm/SRPMS
101 %dir /usr/src/rpm/SPECS
102 %dir /usr/src/rpm/BUILD
103 %dir /usr/src/rpm/SOURCES
104
105 %lang(cs) /usr/share/locale/cs/LC_MESSAGES/rpm.mo
106 %lang(de) /usr/share/locale/de/LC_MESSAGES/rpm.mo
107 %lang(fi) /usr/share/locale/fi/LC_MESSAGES/rpm.mo
108 %lang(fr) /usr/share/locale/fr/LC_MESSAGES/rpm.mo
109 %lang(pt) /usr/share/locale/pt*/LC_MESSAGES/rpm.mo
110 %lang(ru) /usr/share/locale/ru/LC_MESSAGES/rpm.mo
111 %lang(sk) /usr/share/locale/sk/LC_MESSAGES/rpm.mo
112 %lang(sv) /usr/share/locale/sv/LC_MESSAGES/rpm.mo
113 %lang(sr) /usr/share/locale/sr/LC_MESSAGES/rpm.mo
114 %lang(tr) /usr/share/locale/tr/LC_MESSAGES/rpm.mo
115 %lang(ru) %{_mandir}/ru/man8/rpm.8*
116 %attr(755,root,root) %{_libdir}/rpm/rpmi
117 %attr(755,root,root) %{_libdir}/rpm/rpmt
118
119 %dir /usr/include/rpm
120 /usr/include/rpm/*
121
122 /usr/lib/lib*.a
123 %files utils
124 %files -n python-rpm
125 * Fri Feb 19 1999 Marcin Dalecki <dalecki@cs.net.pl>
126   [2.5.6-4d]
127 - fixed ignorance about international character sets.
128
129 * Fri Jan 15 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
130   [2.5.6-1d]
131 - updated to latest stable version,
132 - added URL,
133 - added Group(pl) && changed gropup to Base,
134 - added small patch against GNU libc-2.1.
135
136 * Sun Nov 08 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
137   [2.5.5-1d]
138 - updated to 2.5.5. 
139
140 * Tue Sep 01 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
141   [2.5.2-2d]
142 - translation modified for pl,
143 - compressed man pages && documentation,
144 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
145 - moved /usr/src/redhat to /usr/src/rpm.
146
147 * Sun Aug 30 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
148   [2.5.2-2]
149 - fixed tr.po,
150 - added -q %setup parameter,
151 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
152 - added using %%{name} and %%{version} in Source,
153 - added %lang macros for /usr/share/locale/*/LC_MESSAGES/rpm.mo files,
154 - added %attr and %defattr macros in %files (allow build package from
155   non-root account),
156 - build against GNU libc-2.1.  
157     
158
159 Revision 1.79  2000/02/17 03:42:17  kloczek
160 - release 25,
161 - added "Conflicts: /usr/bin/id" and rebuilded in enviroment with id in
162   /bin.
This page took 0.169441 seconds and 4 git commands to generate.