]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- use standard python macros
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat (and now also PLD) Package Manager
2 Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
3 Summary(pl):    Aplikacja do zarz±dzania pakietami
4 Name:           rpm
5 Version:        4.0.2
6 Release:        45
7 License:        GPL
8 Group:          Base
9 Group(de):      Gründsätzlich
10 Group(es):      Base
11 Group(pl):      Podstawowe
12 Group(pt_BR):   Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Patch0:         %{name}-rpmrc.patch
28 Patch1:         %{name}-macros.patch
29 Patch2:         %{name}-arch.patch
30 Patch3:         %{name}-rpmpopt.patch
31 Patch4:         %{name}-perl-macros.patch
32 Patch5:         %{name}-db3.patch
33 Patch6:         %{name}-segv.patch
34 Patch7:         %{name}-am_fix.patch
35 Patch8:         %{name}-perl-req-perlfile.patch
36 Patch9:         %{name}-installplatform.patch
37 Patch10:        %{name}-cache.patch
38 Patch11:        %{name}-suggestions.patch
39 Patch12:        %{name}-rh-lame.patch
40 Patch13:        %{name}-glob.patch
41 Patch14:        %{name}-header_h.patch
42 Patch15:        %{name}-fast-alAddPackage.patch
43 Patch16:        %{name}-byKey.patch
44 Patch17:        %{name}-perlprov.patch
45 Patch18:        %{name}-noperldir.patch
46 Patch19:        popt-cvs20010530.patch
47 Patch20:        %{name}-noexpand.patch
48 Patch21:        %{name}-scripts-closefds.patch
49 Patch22:        %{name}-python-amfix.patch
50 Patch23:        %{name}-non-english-man-pages.patch
51 Patch24:        %{name}-progress-nontty.patch
52 Patch25:        %{name}-am_ac.patch
53 Patch26:        %{name}-python-macros.patch
54 Patch37:        %{name}-short_circuit.patch
55 Patch38:        %{name}-section_test.patch
56 BuildRequires:  gettext-devel >= 0.10.38-3
57 BuildRequires:  automake
58 BuildRequires:  db3-devel >= 3.1.17-9
59 BuildRequires:  bzip2-devel >= 1.0.1
60 BuildRequires:  zlib-devel
61 BuildRequires:  gettext-devel >= 0.10.38-3
62 BuildRequires:  libtool
63 BuildRequires:  automake
64 BuildRequires:  autoconf >= 2.50
65 BuildRequires:  python-devel
66 BuildRequires:  python-modules >= 2.2.1
67 BuildRequires:  zlib-devel >= 1.1.4
68 # Require static library only for static build
69 BuildRequires:  db3-static >= 3.1.17-9
70 BuildRequires:  bzip2-static >= 1.0.1
71 BuildRequires:  zlib-static
72 BuildRequires:  glibc-static >= 2.2.0
73 %endif
74 BuildRequires:  zlib-static >= 1.1.4
75 Obsoletes:      rpm-libs
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77 Obsoletes:      rpm-libs
78 %define __find_provides %{SOURCE4}
79 %define _binary_payload w9.gzdio
80 %define         __find_provides %{SOURCE4}
81 %include /usr/lib/rpm/macros.python
82 %define         py_dyndir       %{py_libdir}/lib-dynload
83 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
84
85 %description
86 RPM is a powerful package manager, which can be used to build,
87 install, query, verify, update, and uninstall individual software
88 packages. A package consists of an archive of files, and package
89 information, including name, version, and description.
90
91 %description -l de
92 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
93 Installation, Anfrage, Verifizierung, Aktualisierung und
94 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
95 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
96 nombre, versión y descripción.
97
98 %description -l pl
99 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
100 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
101 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
102 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
103 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
104 do pacote, permissões dos arquivos, etc.
105
106 %package devel
107 Summary(de):    Header-Dateien uns Libraries
108 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
109 Group(de):      Entwicklung/Libraries
110 Group(es):      Desarrollo/Bibliotecas
111 Group(fr):      Development/Librairies
112 Group(pl):      Programowanie/Biblioteki
113 Group(pt_BR):   Desenvolvimento/Bibliotecas
114 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
115 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
116 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
117 Group:          Development/Libraries
118 Requires:       %{name} = %{version}
119 Requires:       popt-devel
120
121 %description devel
122 The RPM packaging system includes a C library that makes it easy to
123 manipulate RPM packages and databases. It is intended to ease the
124 creation of graphical package managers and other tools that need
125 intimate knowledge of RPM packages.
126
127 %description devel -l de
128 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
129 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
130 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
131 herramientas que necesiten un conocimiento profundo de paquetes RPM.
132 Pliki nag³ówkowe i biblioteki statyczne.
133 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
134 ferramentas que precisem de conhecimento profundo de pacotes RPM.
135
136 %package static
137 Summary(pl):    Biblioteki statyczne rpm-a
138 Summary(pl):    Biblioteki statyczne RPM-a
139 Group(de):      Entwicklung/Libraries
140 Group(es):      Desarrollo/Bibliotecas
141 Group(fr):      Development/Librairies
142 Group(pl):      Programowanie/Biblioteki
143 Group(pt_BR):   Desenvolvimento/Bibliotecas
144 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
145 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
146 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
147 Group:          Development/Libraries
148 Requires:       %{name}-devel = %{version}
149
150 %description static
151 RPM static libraries.
152
153 %description static -l de
154 RPMs statische Libraries.
155 Biblioteki statyczne rpm-a.
156 %description static -l pl
157 Bibliotecas estáticas para desenvolvimento.
158
159 %package utils
160 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± rpm-a i pakietami
161 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
162 Group(de):      Applikationen/Datei
163 Group(pl):      Aplikacje/Pliki
164 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
165 Group:          Applications/File
166 Requires:       %{name} = %{version}
167
168 %description utils
169 Additional utilities for managing rpm packages and database.
170
171 %description utils -l de
172 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
173 Dodatkowe narzêdzia do zarz±dzania baz± rpm-a i pakietami.
174 %description utils -l pl
175 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
176
177 %package perlprov
178 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w pakietach rpm
179 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
180 Group(de):      Applikationen/Datei
181 Group(pl):      Aplikacje/Pliki
182 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
183 Group:          Applications/File
184 Requires:       perl-modules
185 Requires:       findutils
186
187 %description perlprov
188 Additional utilities for checking perl provides/requires in rpm
189 packages.
190
191 %description perlprov -l de
192 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
193 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w
194 %description perlprov -l pl
195 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
196 pakietach rpm.
197
198 %package pythonprov
199 Summary:        Python macros, which simplifies creation of rpm packages with Python software
200 Group(de):      Applikationen/Datei
201 Group(pl):      Aplikacje/Pliki
202 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
203 Requires:       python
204 Requires:       %{name} = %{version}
205 Requires:       python-modules
206 Python macros, which simplifies creation of rpm packages with Python software.
207 Python macros, which simplifies creation of rpm packages with Python
208 software.
209 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie.
210 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
211 %package python
212
213 Group:          Development/Languages/Python
214 Group(de):      Entwicklung/Sprachen/Python
215 Group(pl):      Programowanie/Jêzyki/Python
216 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
217 %pyrequires_eq  python
218 %description python
219
220 %description -n python-rpm
221 The rpm-python package contains a module which permits applications
222 written in the Python programming language to use the interface
223 supplied by RPM (RPM Package Manager) libraries.
224
225 This package should be installed if you want to develop Python
226 Python para manipular pacotes e bancos de dados RPM.
227
228 %package build
229 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPMów
230 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
231 Group(de):      Applikationen/Datei
232 Group(pl):      Aplikacje/Pliki
233 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
234 Group:          Applications/File
235 Requires:       sh-utils
236 Requires:       binutils
237 Requires:       patch
238 Requires:       file >= 3.31
239 Requires:       binutils
240 Requires:       make
241 Requires:       gcc >= 3.0.3
242 Requires:       gcc
243 Requires:       diffutils
244 Requires:       glibc-devel
245 Requires:       sed
246 Requires:       sed
247 Requires:       popt >= 1.6.2-2
248 Requires:       tar
249 Requires:       textutils
250
251 %description build
252 Scripts for building binary RPM packages.
253
254 %description build -l de
255 Scripts fürs Bauen binärer RPM-Pakete.
256 Skrypty pomocnicze do budowania binarnych RPMów.
257 %description build -l pl
258 construir pacotes usando o RPM.
259
260 %prep
261 %setup -q -a12
262 %patch0 -p1
263 %patch1 -p1
264 %patch2 -p1
265 %patch3 -p1
266 %patch4 -p1
267 %patch5 -p1
268 %patch6 -p1
269 %patch7 -p1
270 %patch8 -p1
271 %patch11 -p0
272 %patch12 -p0
273 %patch11 -p0
274 %patch12 -p0
275 %patch15 -p0
276 %patch16 -p0
277 %patch15 -p0
278 %patch16 -p0
279 %patch17 -p1
280 %patch18 -p1
281 %patch19 -p1
282 %patch22 -p1
283 %patch23 -p1
284 %patch24 -p1
285 %patch25 -p1
286 %patch26 -p0
287 %patch31 -p1
288 %patch36 -p1
289 %patch37 -p1
290 %patch38 -p1
291
292 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
293 cp -f platform.in macros.pld.in
294 install %{SOURCE9} scripts/find-lang.sh
295 install %{SOURCE13} macros.python.in
296 install %{SOURCE6} scripts/find-perl-provides
297 install %{SOURCE7} scripts/find-perl-requires
298 install %{SOURCE9} scripts/find-lang.sh
299
300 (cd scripts;
301 mv -f perl.req perl.req.in
302 mv -f perl.prov perl.prov.in)
303 %build
304 awk -f %{SOURCE14} %{SOURCE1}
305
306 cd popt
307 autoconf
308 automake -a -c
309 aclocal
310 autoheader
311 %{__automake}
312 cd ..
313
314 rm -f missing
315 libtoolize --force --copy
316 autoconf
317 # ugly workaround for automake
318 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
319         lib/Makefile.am > lib/Makefile.am.new
320 mv -f lib/Makefile.am.new lib/Makefile.am
321 automake -a -c
322 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
323         lib/Makefile.in > lib/Makefile.in.new
324 mv -f lib/Makefile.in.new lib/Makefile.in
325
326 sed -e 's#python1.5#python%{py_ver}#g' \
327         python/Makefile.in > python/Makefile.in.new
328 mv -f python/Makefile.in.new python/Makefile.in
329
330 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
331         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
332         --enable-v1-packages \
333         --with-python
334 %configure \
335         --enable-v1-packages \
336         --with-python
337
338
339 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
340
341         DESTDIR="$RPM_BUILD_ROOT" \
342 rm -rf $RPM_BUILD_ROOT
343
344 %{__make} install \
345         DESTDIR=$RPM_BUILD_ROOT \
346         pkgbindir="%{_bindir}"
347
348 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
349 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
350
351 install %{SOURCE1} doc/manual/groups
352 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
353 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
354 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
355 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
356 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
357
358 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
359
360 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
361 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
362 # customized rpm macros - global for host
363 #
364 #%%_install_langs pl_PL:en_US
365 %%distribution PLD
366 EOF
367
368 %find_lang %{name}
369
370 # DON'T BREAK BUILD TREE!!!
371 # rm -f doc/manual/Makefile*
372
373 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
374
375 %clean
376 rm -rf $RPM_BUILD_ROOT
377
378 %post   -p /sbin/ldconfig
379 %postun -p /sbin/ldconfig
380
381 %attr(755,root,root) %{_libdir}/rpm/rpmdb
382 %attr(755,root,root) %{_libdir}/rpm/rpmq
383 %attr(755,root,root) %{_libdir}/rpm/rpmk
384 %attr(755,root,root) %{_libdir}/rpm/rpmv
385 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
386 %attr(755,root,root) %{_libdir}/rpm/rpmdb
387 %attr(755,root,root) %{_libdir}/rpm/rpmq
388 %attr(755,root,root) %{_libdir}/rpm/rpmk
389 %attr(755,root,root) %{_libdir}/rpm/rpmv
390 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
391
392 %dir %{_sysconfdir}/rpm
393 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
394
395 %{_mandir}/man8/rpm.8*
396 %lang(fr) %{_mandir}/fr/man8/rpm.8*
397 %lang(ja) %{_mandir}/ja/man8/rpm.8*
398 %lang(ko) %{_mandir}/ko/man8/rpm.8*
399 %lang(pl) %{_mandir}/pl/man8/rpm.8*
400 %lang(ru) %{_mandir}/ru/man8/rpm.8*
401 %lang(sk) %{_mandir}/sk/man8/rpm.8*
402
403 %dir /var/lib/rpm
404 %dir %{_libdir}/rpm
405
406 %{_libdir}/rpm/macros.python
407 %{_libdir}/rpm/noarch-linux
408 %{_libdir}/rpm/noarch-pld-linux
409 %ifarch i386 i486 i586 i686
410 %{_libdir}/rpm/rpmpopt*
411 %{_libdir}/rpm/noarch-linux
412 %{_libdir}/rpm/noarch-pld-linux
413 %ifarch i386 i486 i586 i686 athlon
414 %{_libdir}/rpm/i?86*
415 %{_libdir}/rpm/athlon*
416 %endif
417 %ifarch sparc sparc64
418 %endif
419 %ifarch ppc
420 %{_libdir}/rpm/ppc*
421 %defattr(644,root,root,755)
422 %attr(755,root,root) %{_bindir}/rpmbuild
423 %attr(755,root,root) %{_bindir}/rpme
424 %attr(755,root,root) %{_bindir}/rpmi
425 %attr(755,root,root) %{_bindir}/rpmu
426 %attr(755,root,root) %{_libdir}/rpm/find-requires
427 %attr(755,root,root) %{_libdir}/rpm/find-provides
428 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
429 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
430 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
431 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
432 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
433 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
434 %attr(755,root,root) %{_libdir}/rpm/brp-*
435 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
436 %attr(755,root,root) %{_libdir}/rpm/compress-doc
437 %attr(755,root,root) %{_libdir}/rpm/cpanflute
438 %attr(755,root,root) %{_libdir}/rpm/http.req
439 %attr(755,root,root) %{_libdir}/rpm/magic.*
440 %attr(755,root,root) %{_libdir}/rpm/rpmi
441 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
442 %attr(755,root,root) %{_libdir}/rpm/rpme
443 %attr(755,root,root) %{_libdir}/rpm/rpmu
444 %attr(755,root,root) %{_libdir}/rpm/rpmb
445 %attr(755,root,root) %{_libdir}/rpm/rpmi
446 %attr(755,root,root) %{_libdir}/rpm/rpmt
447 %attr(755,root,root) %{_libdir}/rpm/rpme
448 %attr(755,root,root) %{_libdir}/librpm*.la
449 %attr(755,root,root) %{_libdir}/librpm*.so
450 %files devel
451 %defattr(644,root,root,755)
452 %{_includedir}/rpm
453 %attr(755,root,root) %{_libdir}/librpm*.la
454 %attr(755,root,root) %{_libdir}/librpm*.so
455
456 %files static
457 %attr(755,root,root) %{_bindir}/*
458 %files utils
459 %defattr(644,root,root,755)
460 %{_mandir}/man1/*
461 %attr(755,root,root) %{_bindir}/javadeps
462 %attr(755,root,root) %{_bindir}/rpm2cpio
463
464 %{_mandir}/man8/rpm2cpio.8*
465 %{_mandir}/man1/*
466 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
467 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
468 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
469 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
470
471 %files perlprov
472 %defattr(644,root,root,755)
473 %attr(755,root,root) %{_libdir}/rpm/perl*
474 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
475 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
476 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
477 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
478 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
479
480 %{_libdir}/rpm/macros.perl
481 %files python
482 %defattr(644,root,root,755)
483 %{py_sitedir}/*.so
484 %{_libdir}/rpm/macros.python
485
486 %files -n python-rpm
487 * %{date} PLD Team <pld-list@pld.org.pl>
488 %{py_sitedir}/*.so
This page took 0.559006 seconds and 4 git commands to generate.