]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- updated to 2.5.5.
[packages/rpm.git] / rpm.spec
1 Summary:     Red Hat Package Manager
2 Summary(pl): Aplikacja do zarz±dzania pakietami
3 Name:        rpm
4 Version:     2.5.5
5 Release:     1
6 Group:       Utilities/System
7 Source:      ftp://ftp.rpm.org/pub/rpm/dist/rpm-2.5.x/%{name}-%{version}.tar.gz
8 Patch0:      rpm.patch
9 Copyright:   GPL
10 BuildRoot:   /tmp/%{name}-%{version}-root
11 Conflicts:   patch < 2.5
12 Obsoletes:      rpm-libs
13 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
14 RPM is a powerful package manager, which can be used to build, install, 
15 query, verify, update, and uninstall individual software packages. A 
16 package consists of an archive of files, and package information, including 
17 name, version, and description.
18 packages. A package consists of an archive of files, and package
19 nombre, versión y descripción.
20
21 RPM jest programem s³u¿±cym do zarz±dzania oprogramowaniem (menad¿erem
22 pakietów). Dziêki niemu bêdziesz móg³ przebudowaæ, zainstalowaæ czy
23 zweryfikowaæ dowolny pakiet. Informacje dotycz±ce ka¿dego pakietu s±
24 przechowywane w bazie danych i dostêpne tylko dla administratora systemu.
25 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
26 %package devel
27 Summary:     Header files and libraries for programs that manipulate rpm packages
28 Summary(pl): Pliki nag³ówkowe i biblioteki statyczne
29 Group:       Development/Libraries
30 Requires:    %{name} = %{version}
31 Requires:       %{name} = %{version}
32 Requires:       popt-devel
33
34 %description devel
35 The RPM packaging system includes a C library that makes it easy to
36 manipulate RPM packages and databases. It is intended to ease the
37 creation of graphical package managers and other tools that need
38 %description -l pl devel
39 RPM to tak¿e 
40 Pliki nag³ówkowe i biblioteki statyczne.
41 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
42 construir pacotes usando o RPM.
43 %setup -q
44 %patch0 -p1
45 install %{SOURCE13} macros.python.in
46 mv -f perl.prov perl.prov.in)
47 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr
48 make
49         --with-python
50
51
52 install -d $RPM_BUILD_ROOT/{var/lib/rpm,usr/src/rpm/{SOURCES,SPECS,RPMS/{$RPM_ARCH,noarch},SRPMS,BUILD}}
53 make installprefix="$RPM_BUILD_ROOT" install
54         pkgbindir="%{_bindir}"
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 /bin/rpm --initdb
60
61 %files
62 %defattr(644, root, root, 755)
63 %doc RPM-PGP-KEY CHANGES groups docs/*
64 %attr(755, root, root) /bin/rpm
65 %attr(755, root, root) /usr/bin/*
66 %dir /usr/lib/rpm
67 %attr(755, root, root) /usr/lib/rpm/find-*
68 %attr(755, root, root) /usr/lib/rpm/freshen.sh
69 %attr(755, root, root) /usr/lib/rpm/mkinstalldirs
70 /usr/lib/rpm/rpmrc
71 /usr/lib/rpm/rpmpopt
72 %attr(644, root,  man) /usr/man/man8/*
73 %attr(700, root, root) %dir /var/lib/rpm
74 /usr/src/rpm
75 %lang(cs) /usr/share/locale/cs/LC_MESSAGES/rpm.mo
76 %lang(de) /usr/share/locale/de/LC_MESSAGES/rpm.mo
77 %lang(fi) /usr/share/locale/fi/LC_MESSAGES/rpm.mo
78 %lang(fr) /usr/share/locale/fr/LC_MESSAGES/rpm.mo
79 %lang(pt) /usr/share/locale/pt*/LC_MESSAGES/rpm.mo
80 %lang(ru) /usr/share/locale/ru/LC_MESSAGES/rpm.mo
81 %lang(sk) /usr/share/locale/sk/LC_MESSAGES/rpm.mo
82 %lang(sr) /usr/share/locale/sr/LC_MESSAGES/rpm.mo
83 %lang(sv) /usr/share/locale/sv/LC_MESSAGES/rpm.mo
84 %lang(tr) /usr/share/locale/tr/LC_MESSAGES/rpm.mo
85 %lang(ru) %{_mandir}/ru/man8/rpm.8*
86 %attr(755,root,root) %{_libdir}/rpm/rpmi
87 %defattr(644, root, root, 755)
88 /usr/include/rpm
89 /usr/lib/lib*.a
90 %files utils
91 %files -n python-rpm
92 * Tue Sep 01 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
93   [2.5.2-3]
94 - added pl translation.
95
96 * Sun Aug 30 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
97   [2.5.2-2]
98 - fixed tr.po,
99 - added -q %setup parameter,
100 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
101 - added using %%{name} and %%{version} in Source,
102 - added %lang macros for /usr/share/locale/*/LC_MESSAGES/rpm.mo files,
103 - added %attr and %defattr macros in %files (allow build package from
104   non-root account).
105 Revision 1.79  2000/02/17 03:42:17  kloczek
106 - release 25,
107 - added "Conflicts: /usr/bin/id" and rebuilded in enviroment with id in
108   /bin.
This page took 0.051063 seconds and 4 git commands to generate.