]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- added translations of groups to .po files (patch)
[packages/rpm.git] / rpm.spec
1 # to build for athlon you need release at least 49
2
3 Summary:        RPM Package Manager
4 Summary(de):    RPM Packet-Manager
5 Summary(es):    Gestor de paquetes RPM
6 Summary(pl):    Aplikacja do zarz±dzania pakietami RPM
7 Summary(pt_BR): Gerenciador de pacotes RPM
8 Name:           rpm
9 Version:        4.0.2
10 Release:        60
11 License:        GPL
12 Group:          Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Patch0:         %{name}-rpmrc.patch
28 Patch1:         %{name}-macros.patch
29 Patch2:         %{name}-arch.patch
30 Patch3:         %{name}-rpmpopt.patch
31 Patch4:         %{name}-perl-macros.patch
32 Patch5:         %{name}-db3.patch
33 Patch6:         %{name}-segv.patch
34 Patch7:         %{name}-am_fix.patch
35 Patch8:         %{name}-perl-req-perlfile.patch
36 Patch9:         %{name}-installplatform.patch
37 Patch10:        %{name}-cache.patch
38 Patch11:        %{name}-suggestions.patch
39 Patch12:        %{name}-rh-lame.patch
40 Patch13:        %{name}-glob.patch
41 Patch14:        %{name}-header_h.patch
42 Patch15:        %{name}-fast-alAddPackage.patch
43 Patch16:        %{name}-byKey.patch
44 Patch17:        %{name}-perlprov.patch
45 Patch18:        %{name}-noperldir.patch
46 Patch19:        popt-cvs20010530.patch
47 Patch20:        %{name}-noexpand.patch
48 Patch21:        %{name}-scripts-closefds.patch
49 Patch22:        %{name}-python-amfix.patch
50 Patch23:        %{name}-non-english-man-pages.patch
51 Patch24:        %{name}-progress-nontty.patch
52 Patch25:        %{name}-am_ac.patch
53 Patch26:        %{name}-python-macros.patch
54 Patch27:        %{name}-hardlink-fixes.patch
55 Patch28:        %{name}-perlprov-regonly.patch
56 Patch29:        %{name}-cxx.patch
57 Patch30:        %{name}-athlon.patch
58 Patch31:        %{name}-athlon-identify.patch
59 Patch32:        %{name}-gettext-in-header.patch
60 Patch33:        %{name}-perlprov-perl5.6.patch
61 Patch34:        %{name}-groups-po.patch
62 Patch37:        %{name}-short_circuit.patch
63 Patch38:        %{name}-section_test.patch
64 URL:            http://www.rpm.org/
65 Icon:           rpm.gif
66 BuildRequires:  autoconf >= 2.50
67 BuildRequires:  automake
68 BuildRequires:  bzip2-devel >= 1.0.1
69 BuildRequires:  db1-devel >= 1.85
70 BuildRequires:  db3-devel >= 3.1.17-9
71 BuildRequires:  gettext-devel >= 0.10.38-3
72 BuildRequires:  python-devel >= 2.2
73 BuildRequires:  python-modules >= 2.2
74 BuildRequires:  python-devel >= 2.2.1
75 BuildRequires:  python-modules >= 2.2.1
76 BuildRequires:  zlib-devel >= 1.1.4
77 %if %{!?_without_static:1}%{?_without_static:0}
78 # Require static library only for static build
79 BuildRequires:  bzip2-static >= 1.0.1
80 BuildRequires:  db1-static >= 1.85
81 BuildRequires:  db3-static >= 3.1.17-9
82 BuildRequires:  glibc-static >= 2.2.0
83 BuildRequires:  zlib-static >= 1.1.4
84 %endif
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86 Obsoletes:      rpm-libs
87 Conflicts:      glibc < 2.2
88
89 %define         __find_provides %{SOURCE4}
90 %define         _binary_payload w9.gzdio
91
92 %define         py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
93 %define         py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
94 %define         py_libdir       %{py_prefix}/lib/python%{py_ver}
95 %define         py_dyndir       %{py_libdir}/lib-dynload
96 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
97
98 %description
99 RPM is a powerful package manager, which can be used to build,
100 install, query, verify, update, and uninstall individual software
101 packages. A package consists of an archive of files, and package
102 information, including name, version, and description.
103
104 %description -l de
105 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
106 Installation, Anfrage, Verifizierung, Aktualisierung und
107 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
108 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
109 Beschreibung.
110
111 %description -l es
112 RPM es un poderoso administrador de paquetes, que puede ser usado para
113 construir, instalar, pesquisar, verificar, actualizar y desinstalar
114 paquetes individuales de software. Un paquete consiste en un
115 almacenaje de archivos, y información sobre el paquete, incluyendo
116 nombre, versión y descripción.
117
118 %description -l pl
119 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
120 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
121 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
122 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
123 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
124 odpytywania programu rpm.
125
126 %description -l pt_BR
127 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
128 construir, instalar, pesquisar, verificar, atualizar e desinstalar
129 pacotes individuais de software. Um pacote consiste de um conjunto de
130 arquivos e informações adicionais, incluindo nome, versão e descrição
131 do pacote, permissões dos arquivos, etc.
132
133 %package devel
134 Summary:        Header files and libraries
135 Summary(de):    Header-Dateien uns Libraries
136 Summary(es):    Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
137 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
138 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
139 Group:          Development/Libraries
140 Requires:       %{name} = %{version}
141 Requires:       popt-devel
142
143 %description devel
144 The RPM packaging system includes a C library that makes it easy to
145 manipulate RPM packages and databases. It is intended to ease the
146 creation of graphical package managers and other tools that need
147 intimate knowledge of RPM packages.
148
149 %description devel -l de
150 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
151 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
152 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
153 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
154
155 %description devel -l es
156 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
157 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
158 facilitar la creación de administradores gráficos de paquetes y otras
159 herramientas que necesiten un conocimiento profundo de paquetes RPM.
160
161 %description devel -l pl
162 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
163 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
164 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
165 szczegó³owej wiedzy na temat pakietów RPM.
166
167 %description devel -l pt_BR
168 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
169 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
170 facilitar a criação de gerenciadores gráficos de pacotes e outras
171 ferramentas que precisem de conhecimento profundo de pacotes RPM.
172
173 %package static
174 Summary:        RPM static libraries
175 Summary(de):    RPMs statische Libraries
176 Summary(pl):    Biblioteki statyczne RPM-a
177 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
178 Group:          Development/Libraries
179 Requires:       %{name}-devel = %{version}
180
181 %description static
182 RPM static libraries.
183
184 %description static -l de
185 RPMs statische Libraries.
186
187 %description static -l pl
188 Biblioteki statyczne RPM-a.
189
190 %description static -l pt_BR
191 Bibliotecas estáticas para desenvolvimento.
192
193 %package utils
194 Summary:        Additional utilities for managing rpm packages and database
195 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
196 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
197 Group:          Applications/File
198 Requires:       %{name} = %{version}
199
200 %description utils
201 Additional utilities for managing rpm packages and database.
202
203 %description utils -l de
204 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
205
206 %description utils -l pl
207 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
208
209 %package perlprov
210 Summary:        Additional utilities for checking perl provides/requires in rpm packages
211 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
212 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
213 Group:          Applications/File
214 Requires:       %{name} = %{version}
215 Requires:       perl-modules
216 Requires:       findutils
217
218 %description perlprov
219 Additional utilities for checking perl provides/requires in rpm
220 packages.
221
222 %description perlprov -l de
223 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
224
225 %description perlprov -l pl
226 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
227 pakietach rpm.
228
229 %package pythonprov
230 Summary:        Python macros, which simplifies creation of rpm packages with Python software
231 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
232 Group:          Applications/File
233 Requires:       %{name} = %{version}
234 Requires:       python-modules
235
236 %description pythonprov
237 Python macros, which simplifies creation of rpm packages with Python
238 software.
239
240 %description pythonprov -l pl
241 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
242 Pythonie.
243
244 %package -n python-rpm
245 Summary:        Python interface to RPM library
246 Summary(pl):    Pythonowy interfejs do biblioteki RPM-a
247 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
248 %requires_eq    python
249 Requires:       %{name} = %{version}
250 %pyrequires_eq  python
251 Obsoletes:      rpm-python
252
253 %description -n python-rpm
254 The rpm-python package contains a module which permits applications
255 written in the Python programming language to use the interface
256 supplied by RPM (RPM Package Manager) libraries.
257
258 This package should be installed if you want to develop Python
259 programs that will manipulate RPM packages and databases.
260
261 %description -n python-rpm -l pl
262 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
263 Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
264
265 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ w
266 Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
267
268 %description -n python-rpm -l pt_BR
269 O pacote rpm-python contém um módulo que permite que aplicações
270 escritas em Python utilizem a interface fornecida pelas bibliotecas
271 RPM (RPM Package Manager).
272
273 Esse pacote deve ser instalado se você quiser desenvolver programas em
274 Python para manipular pacotes e bancos de dados RPM.
275
276 %package build
277 Summary:        Scripts for building binary RPM packages
278 Summary(de):    Scripts fürs Bauen binärer RPM-Pakete
279 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
280 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
281 Group:          Applications/File
282 Requires:       %{name} = %{version}
283 Requires:       /bin/id
284 Requires:       awk
285 Requires:       binutils
286 Requires:       diffutils
287 Requires:       file >= 3.31
288 Requires:       fileutils
289 Requires:       findutils
290 %ifarch athlon
291 Requires:       gcc >= 3.0.3
292 %else
293 Requires:       gcc
294 Requires:       glibc-devel
295 Requires:       grep
296 Requires:       gzip
297 Requires:       make
298 Requires:       patch
299 Requires:       popt >= 1.6.2-2
300 Requires:       sed
301 Requires:       sh-utils
302 Requires:       tar
303 Requires:       textutils
304
305 %description build
306 Scripts for building binary RPM packages.
307
308 %description build -l de
309 Scripts fürs Bauen binärer RPM-Pakete.
310
311 %description build -l pl
312 Skrypty pomocnicze do budowania binarnych RPM-ów.
313
314 %description build -l pt_BR
315 Este pacote contém scripts e programas executáveis que são usados para
316 construir pacotes usando o RPM.
317
318 %prep
319 %setup -q -a12
320 %patch0 -p1
321 %patch1 -p1
322 %patch2 -p1
323 %patch3 -p1
324 %patch4 -p1
325 %patch5 -p1
326 %patch6 -p1
327 %patch7 -p1
328 %patch8 -p1
329 %patch9 -p1
330 %patch10 -p1
331 %patch11 -p0
332 %patch12 -p0
333 %patch13 -p1
334 %patch14 -p1
335 %patch15 -p0
336 %patch16 -p0
337 %patch17 -p1
338 %patch18 -p1
339 %patch19 -p1
340 %patch20 -p1
341 %patch21 -p1
342 %patch22 -p1
343 %patch23 -p1
344 %patch24 -p1
345 %patch25 -p1
346 %patch26 -p0
347 %patch27 -p1
348 %patch28 -p1
349 %patch29 -p1
350 %patch30 -p1
351
352 %ifarch athlon
353 %patch31 -p1
354 %endif
355
356 %patch32 -p1
357 %patch35 -p1
358 %patch36 -p1
359 %patch37 -p1
360 %patch38 -p1
361
362 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
363 cp -f platform.in macros.pld.in
364 install %{SOURCE5} macros.perl.in
365 install %{SOURCE13} macros.python.in
366 install %{SOURCE6} scripts/find-perl-provides
367 install %{SOURCE7} scripts/find-perl-requires
368 install %{SOURCE9} scripts/find-lang.sh
369
370 (cd scripts;
371 mv -f perl.req perl.req.in
372 mv -f perl.prov perl.prov.in)
373 %build
374 # generate Group translations to *.po
375 awk -f %{SOURCE14} %{SOURCE1}
376
377 cd popt
378 autoconf
379 automake -a -c
380 aclocal
381 autoheader
382 automake -a -c -f
383 %{__automake}
384 cd ..
385
386 rm -f missing
387 libtoolize --force --copy
388 autoconf
389 aclocal
390 autoupdate
391 autoheader || :
392 %{__autoconf}
393 automake -a -c
394 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
395         lib/Makefile.am > lib/Makefile.am.new
396 mv -f lib/Makefile.am.new lib/Makefile.am
397 %{__automake}
398 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
399         lib/Makefile.in > lib/Makefile.in.new
400 mv -f lib/Makefile.in.new lib/Makefile.in
401
402 sed -e 's#python1.5#python%{py_ver}#g' \
403         python/Makefile.in > python/Makefile.in.new
404 mv -f python/Makefile.in.new python/Makefile.in
405
406 # config.guess doesn't handle athlon, so we have to change it by hand.
407 # rpm checks for CPU type at runtime, but it looks better
408 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
409         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
410 mv -f macros.tmp macros.in
411
412 %configure \
413         --enable-shared \
414         --enable-v1-packages \
415         --with-python
416
417
418 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
419
420 %install
421 rm -rf $RPM_BUILD_ROOT
422
423 %{__make} install \
424         DESTDIR=$RPM_BUILD_ROOT \
425         pkgbindir="%{_bindir}"
426
427 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
428 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
429
430 install %{SOURCE1} doc/manual/groups
431 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
432 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
433 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
434 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
435 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
436
437 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
438
439 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
440 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
441 # customized rpm macros - global for host
442 #
443 #%%_install_langs pl_PL:en_US
444 %%distribution PLD
445 EOF
446
447 %find_lang %{name}
448
449 # DON'T BREAK BUILD TREE!!!
450 # rm -f doc/manual/Makefile*
451
452 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
453
454 %clean
455 rm -rf $RPM_BUILD_ROOT
456
457 %post   -p /sbin/ldconfig
458 %postun -p /sbin/ldconfig
459
460 %files -f %{name}.lang
461 %defattr(644,root,root,755)
462 %doc RPM-PGP-KEY.gz CHANGES.gz doc/manual/*
463
464 %attr(755,root,root) /bin/rpm
465 %attr(755,root,root) %{_bindir}/rpmdb
466 %attr(755,root,root) %{_bindir}/rpmquery
467 %attr(755,root,root) %{_bindir}/rpmsign
468 %attr(755,root,root) %{_bindir}/rpmverify
469 %attr(755,root,root) %{_libdir}/rpm/rpmdb
470 %attr(755,root,root) %{_libdir}/rpm/rpmq
471 %attr(755,root,root) %{_libdir}/rpm/rpmk
472 %attr(755,root,root) %{_libdir}/rpm/rpmv
473 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
474
475 %dir %{_sysconfdir}/rpm
476 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
477
478 %{_mandir}/man8/rpm.8*
479 %lang(fr) %{_mandir}/fr/man8/rpm.8*
480 %lang(ja) %{_mandir}/ja/man8/rpm.8*
481 %lang(ko) %{_mandir}/ko/man8/rpm.8*
482 %lang(pl) %{_mandir}/pl/man8/rpm.8*
483 %lang(ru) %{_mandir}/ru/man8/rpm.8*
484 %lang(sk) %{_mandir}/sk/man8/rpm.8*
485
486 %dir /var/lib/rpm
487 %dir %{_libdir}/rpm
488
489 %{_libdir}/rpm/macros.python
490 %doc %attr(755,root,root) %{_libdir}/rpm/convertrpmrc.sh
491
492 %{_libdir}/rpm/rpmrc
493 %{_libdir}/rpm/rpmpopt*
494 %{_libdir}/rpm/macros
495 %{_libdir}/rpm/noarch-linux
496 %{_libdir}/rpm/noarch-pld-linux
497 %ifarch i386 i486 i586 i686 athlon
498 %{_libdir}/rpm/i?86*
499 %{_libdir}/rpm/athlon*
500 %endif
501 %ifarch sparc sparc64
502 %{_libdir}/rpm/sparc*
503 %endif
504 %ifarch alpha
505 %{_libdir}/rpm/alpha*
506 %endif
507 %ifarch ppc
508 %{_libdir}/rpm/ppc*
509 %endif
510
511
512 %files build
513 %defattr(644,root,root,755)
514 %attr(755,root,root) %{_bindir}/rpmbuild
515 %attr(755,root,root) %{_bindir}/rpme
516 %attr(755,root,root) %{_bindir}/rpmi
517 %attr(755,root,root) %{_bindir}/rpmu
518 %attr(755,root,root) %{_libdir}/rpm/find-requires
519 %attr(755,root,root) %{_libdir}/rpm/find-provides
520 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
521 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
522 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
523 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
524 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
525 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
526 %attr(755,root,root) %{_libdir}/rpm/brp-*
527 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
528 %attr(755,root,root) %{_libdir}/rpm/compress-doc
529 %attr(755,root,root) %{_libdir}/rpm/cpanflute
530 %attr(755,root,root) %{_libdir}/rpm/http.req
531 %attr(755,root,root) %{_libdir}/rpm/magic.*
532 %attr(755,root,root) %{_libdir}/rpm/rpmdiff*
533 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
534 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides.sh
535 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides2.sh
536 %attr(755,root,root) %{_libdir}/rpm/rpmb
537 %attr(755,root,root) %{_libdir}/rpm/rpmi
538 %attr(755,root,root) %{_libdir}/rpm/rpmt
539 %attr(755,root,root) %{_libdir}/rpm/rpme
540 %attr(755,root,root) %{_libdir}/rpm/rpmu
541
542 %files devel
543 %defattr(644,root,root,755)
544 %{_includedir}/rpm
545 %attr(755,root,root) %{_libdir}/librpm*.la
546 %attr(755,root,root) %{_libdir}/librpm*.so
547
548 %files static
549 %defattr(644,root,root,755)
550 %{_libdir}/librpm*.a
551
552 %files utils
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_bindir}/gendiff
555 %attr(755,root,root) %{_bindir}/javadeps
556 %attr(755,root,root) %{_bindir}/rpm2cpio
557
558 %{_mandir}/man8/rpm2cpio.8*
559 %{_mandir}/man1/*
560 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
561 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
562 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
563 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
564
565 %files perlprov
566 %defattr(644,root,root,755)
567 %attr(755,root,root) %{_libdir}/rpm/perl*
568 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
569 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
570 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
571 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
572 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
573
574 %{_libdir}/rpm/macros.perl
575
576 %files pythonprov
577 %defattr(644,root,root,755)
578 %{_libdir}/rpm/macros.python
579
580 %files -n python-rpm
581 %defattr(755,root,root,755)
582 %{py_sitedir}/*.so
This page took 0.060668 seconds and 4 git commands to generate.