]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- added gzipping pl man pages.
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat & PLD Package Manager
2 Summary(pl):    Aplikacja do zarz±dzania pakietami
3 Name:           rpm
4 Version:        2.95
5 Release:        4
6 Group:          Base
7 Group(pl):      Bazowe
8 Copyright:      GPL
9 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-2.5.x/%{name}-%{version}.tar.gz
10 Source1:        rpm.groups
11 Source2:        rpm.8pl
12 Source3:        rpm.macros
13 Patch0:         rpm-rpmrc.patch
14 Patch1:         rpm-i18n.patch
15 Patch2:         rpm-find-requires.patch
16 Patch3:         rpm-macros.patch
17 Patch4:         rpm-po.patch
18 Patch37:        %{name}-short_circuit.patch
19 Icon:           rpm.gif
20 #BuildPrereq:   bzip2-static
21 #BuildPrereq:   gdbm-static
22 #BuildPrereq:   zlib-static
23 #BuildPrereq:   patch >= 2.2
24 Requires:       glibc >= 2.1
25 BuildRoot:      /tmp/%{name}-%{version}-root
26 Obsoletes:      rpm-libs
27 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
28 RPM is a powerful package manager, which can be used to build, install, 
29 query, verify, update, and uninstall individual software packages. A 
30 package consists of an archive of files, and package information, including 
31 name, version, and description.
32 packages. A package consists of an archive of files, and package
33 nombre, versión y descripción.
34 RPM jest doskona³ym menad¿erem pakietów. Dziêki niemu bêdziesz móg³ przebudowaæ,
35 zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje dotycz±ce ka¿dego 
36 pakietu s± przechowywane w bazie danych i dostêpne tylko dla administratora 
37 systemu.
38 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
39 %package        devel
40 Summary:        Header files and libraries 
41 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne 
42 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
43 Group(pl):      Programowanie/Biblioteki
44 Requires:       %{name} = %{version}
45 Requires:       %{name} = %{version}
46 Requires:       popt-devel
47
48 %description devel
49 The RPM packaging system includes a C library that makes it easy to
50 manipulate RPM packages and databases. It is intended to ease the
51 creation of graphical package managers and other tools that need
52 %description -l pl devel
53 Pliki nag³ówkowe i biblioteki statyczne.
54 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
55 construir pacotes usando o RPM.
56 %setup  -q
57 %patch0 -p1 
58 %patch1 -p1
59 %patch2 -p1
60 %patch3 -p1
61 %patch4 -p1 
62 install %{SOURCE13} macros.python.in
63 mv -f perl.prov perl.prov.in)
64 autoconf
65 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
66 ./configure \
67         --prefix=/usr \
68         --disable-shared
69 make
70         --with-python
71
72
73 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
74 install -d $RPM_BUILD_ROOT/var/lib/rpm \
75         $RPM_BUILD_ROOT/usr/man/{ru,pl}/man8
76
77 make DESTDIR="$RPM_BUILD_ROOT" install
78         pkgbindir="%{_bindir}"
79 install %{SOURCE3} $RPM_BUILD_ROOT/usr/lib/rpm/macros.pld
80
81 install rpm.8ru $RPM_BUILD_ROOT/usr/man/ru/man8/rpm.8
82 install rpm2cpio.8ru $RPM_BUILD_ROOT/usr/man/ru/man8/rpm2cpio.8
83 install %{SOURCE2} $RPM_BUILD_ROOT/usr/man/pl/man8/rpm.8
84
85 install %{SOURCE1} docs/groups
86
87 gzip -9fn $RPM_BUILD_ROOT/usr/man/{{ru,pl}/man8/*,man8/*} \
88         RPM-PGP-KEY CHANGES docs/*
89
90 %post
91 /bin/rpm --initdb
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %files
97
98 %doc RPM-PGP-KEY.gz CHANGES.gz docs/*
99 %postun -p /sbin/ldconfig
100
101 %attr(755,root,root) /usr/bin/gendiff
102 %attr(755,root,root) /usr/bin/rpm2cpio
103 %attr(755,root,root) %{_libdir}/rpm/rpmdb
104 /usr/man/man8/*
105 %lang(ru) /usr/man/ru/man8/*
106 %lang(pl) /usr/man/pl/man8/*
107
108 %lang(cs)    /usr/share/locale/cs/LC_MESSAGES/rpm.mo
109 %lang(de)    /usr/share/locale/de/LC_MESSAGES/rpm.mo
110 %lang(fi)    /usr/share/locale/fi/LC_MESSAGES/rpm.mo
111 %lang(fr)    /usr/share/locale/fr/LC_MESSAGES/rpm.mo
112 %lang(pl)    /usr/share/locale/pl/LC_MESSAGES/rpm.mo
113 %lang(pt_BR) /usr/share/locale/pt_BR/LC_MESSAGES/rpm.mo
114 %lang(ru)    /usr/share/locale/ru/LC_MESSAGES/rpm.mo
115 %lang(sk)    /usr/share/locale/sk/LC_MESSAGES/rpm.mo
116 %lang(sr)    /usr/share/locale/sr/LC_MESSAGES/rpm.mo
117 %lang(sv)    /usr/share/locale/sv/LC_MESSAGES/rpm.mo
118 %lang(tr)    /usr/share/locale/tr/LC_MESSAGES/rpm.mo
119
120 %attr(755,root,root) %dir /var/lib/rpm
121
122 %dir /usr/lib/rpm
123 %attr(755,root,root) /usr/lib/rpm/find-*
124 %attr(755,root,root) /usr/lib/rpm/freshen.sh
125 %attr(755,root,root) /usr/lib/rpm/mkinstalldirs
126 %attr(755,root,root) /usr/lib/rpm/config.*
127 %attr(755,root,root) /usr/lib/rpm/getpo.sh
128
129 /usr/lib/rpm/rpm*
130 /usr/lib/rpm/macros*
131
132 %lang(ru) %{_mandir}/ru/man8/rpm.8*
133 %attr(755,root,root) %{_libdir}/rpm/rpmi
134 %attr(755,root,root) %{_libdir}/rpm/rpmt
135 /usr/include/rpm
136 /usr/lib/librpm*.a
137 %files utils
138 %files -n python-rpm
139 * Wed Mar 10 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
140   [2.5.6-5]
141 - added rpm-find-requires.patch with beter finding list packages containing
142   required shared libraries (Artur Frysiak <wiget@usa.net>),
143 - added ru man pages,
144 - added "Requires: glibc >= 2.1" (rpm is linked statically but it use by
145   dlopen() some shared glibc libraries),
146 - removed man group from man pages.
147
148 * Fri Feb 19 1999 Marcin Dalecki <dalecki@cs.net.pl>
149   [2.5.6-4d]
150 - fixed ignorance about international character sets.
151
152 * Fri Jan 15 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
153   [2.5.6-1d]
154 - updated to latest stable version,
155 - added URL,
156 - added Group(pl) && changed gropup to Base,
157 - added small patch against GNU libc-2.1.
158
159 * Sun Nov 08 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
160   [2.5.5-1d]
161 - updated to 2.5.5. 
162
163 * Tue Sep 01 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
164   [2.5.2-2d]
165 - translation modified for pl,
166 - compressed man pages && documentation,
167 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
168 - moved /usr/src/redhat to /usr/src/rpm.
169
170 * Sun Aug 30 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
171   [2.5.2-2]
172 - fixed tr.po,
173 - added -q %setup parameter,
174 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
175 - added using %%{name} and %%{version} in Source,
176 - added %lang macros for /usr/share/locale/*/LC_MESSAGES/rpm.mo files,
177 - added %attr and %defattr macros in %files (allow build package from
178   non-root account),
179 - build against GNU libc-2.1.
180
181 Revision 1.79  2000/02/17 03:42:17  kloczek
182 - release 25,
183 - added "Conflicts: /usr/bin/id" and rebuilded in enviroment with id in
184   /bin.
This page took 0.041888 seconds and 3 git commands to generate.