]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/rpm.git] / rpm.spec
1 # to build for athlon you need release at least 49
2
3 Summary:        Red Hat (and now also PLD) Package Manager
4 Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
5 Summary(es):    Gestor de paquetes RPM
6 Summary(pl):    Aplikacja do zarz±dzania pakietami
7 Summary(pt_BR): Gerenciador de pacotes RPM
8 Name:           rpm
9 Version:        4.0.2
10 Release:        51
11 License:        GPL
12 Group:          Base
13 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
14 Source1:        %{name}.groups
15 Source2:        %{name}.macros
16 Source3:        %{name}-install-tree
17 Source4:        %{name}-find-rpm-provides
18 Source5:        %{name}-macros.perl
19 Source6:        %{name}-find-perl-provides
20 Source7:        %{name}-find-perl-requires
21 Source8:        %{name}-find-spec-bcond
22 Source9:        %{name}-find-lang
23 Source10:       %{name}-find-provides
24 Source11:       %{name}-find-requires
25 Source12:       %{name}-non-english-man-pages.tar.bz2
26 Source13:       %{name}-macros.python
27 Patch0:         %{name}-rpmrc.patch
28 Patch1:         %{name}-macros.patch
29 Patch2:         %{name}-arch.patch
30 Patch3:         %{name}-rpmpopt.patch
31 Patch4:         %{name}-perl-macros.patch
32 Patch5:         %{name}-db3.patch
33 Patch6:         %{name}-segv.patch
34 Patch7:         %{name}-am_fix.patch
35 Patch8:         %{name}-perl-req-perlfile.patch
36 Patch9:         %{name}-installplatform.patch
37 Patch10:        %{name}-cache.patch
38 Patch11:        %{name}-suggestions.patch
39 Patch12:        %{name}-rh-lame.patch
40 Patch13:        %{name}-glob.patch
41 Patch14:        %{name}-header_h.patch
42 Patch15:        %{name}-fast-alAddPackage.patch
43 Patch16:        %{name}-byKey.patch
44 Patch17:        %{name}-perlprov.patch
45 Patch18:        %{name}-noperldir.patch
46 Patch19:        popt-cvs20010530.patch
47 Patch20:        %{name}-noexpand.patch
48 Patch21:        %{name}-scripts-closefds.patch
49 Patch22:        %{name}-python-amfix.patch
50 Patch23:        %{name}-non-english-man-pages.patch
51 Patch24:        %{name}-progress-nontty.patch
52 Patch25:        %{name}-am_ac.patch
53 Patch26:        %{name}-python-macros.patch
54 Patch27:        %{name}-hardlink-fixes.patch
55 Patch28:        %{name}-perlprov-regonly.patch
56 Patch29:        %{name}-cxx.patch
57 Patch30:        %{name}-athlon.patch
58 Patch31:        %{name}-athlon-identify.patch
59 Patch37:        %{name}-short_circuit.patch
60 Patch38:        %{name}-section_test.patch
61 URL:            http://www.rpm.org/
62 Icon:           rpm.gif
63 BuildRequires:  autoconf >= 2.50
64 BuildRequires:  automake
65 BuildRequires:  bzip2-devel >= 1.0.1
66 BuildRequires:  db1-devel >= 1.85
67 BuildRequires:  db3-devel >= 3.1.17-9
68 BuildRequires:  gettext-devel >= 0.10.38-3
69 BuildRequires:  python-devel >= 2.2
70 BuildRequires:  python-modules >= 2.2
71 BuildRequires:  zlib-devel
72 BuildRequires:  python-modules >= 2.2.1
73 BuildRequires:  zlib-devel >= 1.1.4
74 %if %{!?_without_static:1}%{?_without_static:0}
75 # Require static library only for static build
76 BuildRequires:  bzip2-static >= 1.0.1
77 BuildRequires:  db1-static >= 1.85
78 BuildRequires:  zlib-static
79 BuildRequires:  glibc-static >= 2.2.0
80 BuildRequires:  zlib-static >= 1.1.4
81 %endif
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83 Obsoletes:      rpm-libs
84 Conflicts:      glibc < 2.2
85
86 %define         __find_provides %{SOURCE4}
87 %define         _binary_payload w9.gzdio
88
89 %define         py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
90 %define         py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
91 %define         py_libdir       %{py_prefix}/lib/python%{py_ver}
92 %define         py_dyndir       %{py_libdir}/lib-dynload
93 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
94
95 %description
96 RPM is a powerful package manager, which can be used to build,
97 install, query, verify, update, and uninstall individual software
98 packages. A package consists of an archive of files, and package
99 information, including name, version, and description.
100
101 %description -l de
102 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
103 Installation, Anfrage, Verifizierung, Aktualisierung und
104 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
105 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
106 Beschreibung.
107
108 %description -l es
109 RPM es un poderoso administrador de paquetes, que puede ser usado para
110 construir, instalar, pesquisar, verificar, actualizar y desinstalar
111 paquetes individuales de software. Un paquete consiste en un
112 almacenaje de archivos, y información sobre el paquete, incluyendo
113 nombre, versión y descripción.
114
115 %description -l pl
116 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
117 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
118 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
119 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
120 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
121 odpytywania programu rpm.
122
123 %description -l pt_BR
124 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
125 construir, instalar, pesquisar, verificar, atualizar e desinstalar
126 pacotes individuais de software. Um pacote consiste de um conjunto de
127 arquivos e informações adicionais, incluindo nome, versão e descrição
128 do pacote, permissões dos arquivos, etc.
129
130 %package devel
131 Summary:        Header files and libraries
132 Summary(de):    Header-Dateien uns Libraries
133 Summary(es):    Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
134 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
135 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
136 Group:          Development/Libraries
137 Requires:       %{name} = %{version}
138 Requires:       popt-devel
139
140 %description devel
141 The RPM packaging system includes a C library that makes it easy to
142 manipulate RPM packages and databases. It is intended to ease the
143 creation of graphical package managers and other tools that need
144 intimate knowledge of RPM packages.
145
146 %description devel -l de
147 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
148 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
149 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
150 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
151
152 %description devel -l es
153 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
154 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
155 facilitar la creación de administradores gráficos de paquetes y otras
156 herramientas que necesiten un conocimiento profundo de paquetes RPM.
157
158 %description devel -l pl
159 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
160 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
161 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
162 szczegó³owej wiedzy na temat pakietów RPM.
163
164 %description devel -l pt_BR
165 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
166 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
167 facilitar a criação de gerenciadores gráficos de pacotes e outras
168 ferramentas que precisem de conhecimento profundo de pacotes RPM.
169
170 %package static
171 Summary:        RPM static libraries
172 Summary(de):    RPMs statische Libraries
173 Summary(pl):    Biblioteki statyczne RPM-a
174 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
175 Group:          Development/Libraries
176 Requires:       %{name}-devel = %{version}
177
178 %description static
179 RPM static libraries.
180
181 %description static -l de
182 RPMs statische Libraries.
183
184 %description static -l pl
185 Biblioteki statyczne RPM-a.
186
187 %description static -l pt_BR
188 Bibliotecas estáticas para desenvolvimento.
189
190 %package utils
191 Summary:        Additional utilities for managing rpm packages and database
192 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
193 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
194 Group:          Applications/File
195 Requires:       %{name} = %{version}
196
197 %description utils
198 Additional utilities for managing rpm packages and database.
199
200 %description utils -l de
201 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
202
203 %description utils -l pl
204 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
205
206 %package perlprov
207 Summary:        Additional utilities for checking perl provides/requires in rpm packages
208 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
209 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
210 Group:          Applications/File
211 Requires:       perl-modules
212 Requires:       findutils
213
214 %description perlprov
215 Additional utilities for checking perl provides/requires in rpm
216 packages.
217
218 %description perlprov -l de
219 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
220
221 %description perlprov -l pl
222 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
223 pakietach rpm.
224
225 %package pythonprov
226 Summary:        Python macros, which simplifies creation of rpm packages with Python software
227 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
228 Group:          Applications/File
229 Requires:       %{name} = %{version}
230 Requires:       python-modules
231
232 %description pythonprov
233 Python macros, which simplifies creation of rpm packages with Python
234 software.
235
236 %description pythonprov -l pl
237 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
238 Pythonie.
239
240 %package -n python-rpm
241 Summary:        Python interface to RPM library
242 Group:          Development/Languages/Python
243 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
244 %requires_eq    python
245 Requires:       %{name} = %{version}
246 %pyrequires_eq  python
247 Obsoletes:      rpm-python
248
249 %description -n python-rpm
250 The rpm-python package contains a module which permits applications
251 written in the Python programming language to use the interface
252 supplied by RPM (RPM Package Manager) libraries.
253
254 This package should be installed if you want to develop Python
255 programs that will manipulate RPM packages and databases.
256
257 %description -n python-rpm -l pl
258 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
259 Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
260
261 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ w
262 Pythonie programy manipuluj±ce pakietami i bazami danych rpm.
263
264 %description -n python-rpm -l pt_BR
265 O pacote rpm-python contém um módulo que permite que aplicações
266 escritas em Python utilizem a interface fornecida pelas bibliotecas
267 RPM (RPM Package Manager).
268
269 Esse pacote deve ser instalado se você quiser desenvolver programas em
270 Python para manipular pacotes e bancos de dados RPM.
271
272 %package build
273 Summary:        Scripts for building binary RPM packages
274 Summary(de):    Scripts fürs Bauen binärer RPM-Pakete
275 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
276 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
277 Group:          Applications/File
278 Requires:       %{name} = %{version}
279 Requires:       /bin/id
280 Requires:       awk
281 Requires:       binutils
282 Requires:       diffutils
283 Requires:       file >= 3.31
284 Requires:       fileutils
285 Requires:       findutils
286 %ifarch athlon
287 Requires:       gcc >= 3.0.3
288 %else
289 Requires:       gcc
290 Requires:       glibc-devel
291 Requires:       grep
292 Requires:       gzip
293 Requires:       make
294 Requires:       patch
295 Requires:       popt >= 1.6.2-2
296 Requires:       sed
297 Requires:       tar
298 Requires:       textutils
299
300 %description build
301 Scripts for building binary RPM packages.
302
303 %description build -l de
304 Scripts fürs Bauen binärer RPM-Pakete.
305
306 %description build -l pl
307 Skrypty pomocnicze do budowania binarnych RPM-ów.
308
309 %description build -l pt_BR
310 Este pacote contém scripts e programas executáveis que são usados para
311 construir pacotes usando o RPM.
312
313 %prep
314 %setup -q -a12
315 %patch0 -p1
316 %patch1 -p1
317 %patch2 -p1
318 %patch3 -p1
319 %patch4 -p1
320 %patch5 -p1
321 %patch6 -p1
322 %patch7 -p1
323 %patch8 -p1
324 %patch9 -p1
325 %patch10 -p1
326 %patch11 -p0
327 %patch12 -p0
328 %patch13 -p1
329 %patch14 -p1
330 %patch15 -p0
331 %patch16 -p0
332 %patch17 -p1
333 %patch18 -p1
334 %patch19 -p1
335 %patch20 -p1
336 %patch21 -p1
337 %patch22 -p1
338 %patch23 -p1
339 %patch24 -p1
340 %patch25 -p1
341 %patch26 -p0
342 %patch27 -p1
343 %patch28 -p1
344 %patch29 -p1
345 %patch30 -p1
346
347 %ifarch athlon
348 %patch31 -p1
349 %patch36 -p1
350 %patch37 -p1
351 %patch38 -p1
352
353 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
354 cp -f platform.in macros.pld.in
355 install %{SOURCE5} macros.perl.in
356 install %{SOURCE13} macros.python.in
357 install %{SOURCE6} scripts/find-perl-provides
358 install %{SOURCE7} scripts/find-perl-requires
359 install %{SOURCE9} scripts/find-lang.sh
360
361 (cd scripts;
362 mv -f perl.req perl.req.in
363 mv -f perl.prov perl.prov.in)
364 %build
365 # generate Group translations to *.po
366 awk -f %{SOURCE14} %{SOURCE1}
367
368 cd popt
369 autoconf
370 automake -a -c
371 aclocal
372 autoheader
373 automake -a -c -f
374 %{__automake}
375 cd ..
376
377 rm -f missing
378 libtoolize --force --copy
379 autoconf
380 aclocal
381 autoupdate
382 autoheader || :
383 %{__autoconf}
384 automake -a -c
385 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
386         lib/Makefile.am > lib/Makefile.am.new
387 mv -f lib/Makefile.am.new lib/Makefile.am
388 %{__automake}
389 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
390         lib/Makefile.in > lib/Makefile.in.new
391 mv -f lib/Makefile.in.new lib/Makefile.in
392
393 sed -e 's#python1.5#python%{py_ver}#g' \
394         python/Makefile.in > python/Makefile.in.new
395 mv -f python/Makefile.in.new python/Makefile.in
396
397 # config.guess doesn't handle athlon, so we have to change it by hand.
398 # rpm checks for CPU type at runtime, but it looks better
399 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
400         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
401 mv -f macros.tmp macros.in
402
403 %configure \
404         --enable-shared \
405         --enable-v1-packages \
406         --with-python
407
408
409 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
410
411 %install
412 rm -rf $RPM_BUILD_ROOT
413
414 %{__make} install \
415         DESTDIR=$RPM_BUILD_ROOT \
416         pkgbindir="%{_bindir}"
417
418 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
419 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
420
421 install %{SOURCE1} doc/manual/groups
422 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
423 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
424 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
425 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
426 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
427
428 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
429
430 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
431 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
432 # customized rpm macros - global for host
433 #
434 #%%_install_langs pl_PL:en_US
435 %%distribution PLD
436 EOF
437
438 %find_lang %{name}
439
440 # DON'T BREAK BUILD TREE!!!
441 # rm -f doc/manual/Makefile*
442
443 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
444
445 %clean
446 rm -rf $RPM_BUILD_ROOT
447
448 %post   -p /sbin/ldconfig
449 %postun -p /sbin/ldconfig
450
451 %attr(755,root,root) /bin/rpm
452 %attr(755,root,root) %{_bindir}/rpmdb
453 %attr(755,root,root) %{_bindir}/rpmquery
454 %attr(755,root,root) %{_bindir}/rpmsign
455 %attr(755,root,root) %{_bindir}/rpmverify
456 %attr(755,root,root) %{_libdir}/rpm/rpmdb
457 %attr(755,root,root) %{_libdir}/rpm/rpmq
458 %attr(755,root,root) %{_libdir}/rpm/rpmk
459 %attr(755,root,root) %{_libdir}/rpm/rpmv
460 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
461
462 %dir %{_sysconfdir}/rpm
463 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
464
465 %{_mandir}/man8/rpm.8*
466 %lang(fr) %{_mandir}/fr/man8/rpm.8*
467 %lang(ja) %{_mandir}/ja/man8/rpm.8*
468 %lang(ko) %{_mandir}/ko/man8/rpm.8*
469 %lang(pl) %{_mandir}/pl/man8/rpm.8*
470 %lang(ru) %{_mandir}/ru/man8/rpm.8*
471 %lang(sk) %{_mandir}/sk/man8/rpm.8*
472
473 %dir /var/lib/rpm
474 %dir %{_libdir}/rpm
475
476 %{_libdir}/rpm/macros.python
477 %doc %attr(755,root,root) %{_libdir}/rpm/convertrpmrc.sh
478
479 %{_libdir}/rpm/rpmrc
480 %{_libdir}/rpm/rpmpopt*
481 %{_libdir}/rpm/macros
482 %{_libdir}/rpm/noarch-linux
483 %{_libdir}/rpm/noarch-pld-linux
484 %ifarch i386 i486 i586 i686 athlon
485 %{_libdir}/rpm/i?86*
486 %{_libdir}/rpm/athlon*
487 %endif
488 %ifarch sparc sparc64
489 %{_libdir}/rpm/sparc*
490 %endif
491 %ifarch alpha
492 %{_libdir}/rpm/alpha*
493 %endif
494 %ifarch ppc
495 %{_libdir}/rpm/ppc*
496 %defattr(644,root,root,755)
497 %attr(755,root,root) %{_bindir}/rpmbuild
498 %attr(755,root,root) %{_bindir}/rpme
499 %attr(755,root,root) %{_bindir}/rpmi
500 %attr(755,root,root) %{_bindir}/rpmu
501 %attr(755,root,root) %{_libdir}/rpm/find-requires
502 %attr(755,root,root) %{_libdir}/rpm/find-provides
503 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
504 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
505 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
506 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
507 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
508 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
509 %attr(755,root,root) %{_libdir}/rpm/brp-*
510 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
511 %attr(755,root,root) %{_libdir}/rpm/compress-doc
512 %attr(755,root,root) %{_libdir}/rpm/cpanflute
513 %attr(755,root,root) %{_libdir}/rpm/http.req
514 %attr(755,root,root) %{_libdir}/rpm/magic.*
515 %attr(755,root,root) %{_libdir}/rpm/rpmdiff*
516 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
517 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides.sh
518 %attr(755,root,root) %{_libdir}/rpm/vpkg-provides2.sh
519 %attr(755,root,root) %{_libdir}/rpm/rpmb
520 %attr(755,root,root) %{_libdir}/rpm/rpmi
521 %attr(755,root,root) %{_libdir}/rpm/rpmt
522 %attr(755,root,root) %{_libdir}/rpm/rpme
523 %attr(755,root,root) %{_libdir}/rpm/rpmu
524
525 %files devel
526 %defattr(644,root,root,755)
527 %{_includedir}/rpm
528 %attr(755,root,root) %{_libdir}/librpm*.la
529 %attr(755,root,root) %{_libdir}/librpm*.so
530
531 %files static
532 %attr(755,root,root) %{_bindir}/*
533 %files utils
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{_bindir}/gendiff
536 %attr(755,root,root) %{_bindir}/javadeps
537 %attr(755,root,root) %{_bindir}/rpm2cpio
538
539 %{_mandir}/man8/rpm2cpio.8*
540 %{_mandir}/man1/*
541 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
542 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
543 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
544 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
545
546 %files perlprov
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/rpm/perl*
549 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
550 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
551 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
552 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
553 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
554
555 %{_libdir}/rpm/macros.perl
556
557 %defattr(644,root,root,755)
558 %defattr(644,root,root,755)
559 %{_libdir}/rpm/macros.python
560
561 %files -n python-rpm
562 %defattr(755,root,root,755)
563 %{py_sitedir}/*.so
This page took 0.068207 seconds and 3 git commands to generate.